Bug 281130 - KTorrent crashes after adding new torrents
Summary: KTorrent crashes after adding new torrents
Status: RESOLVED DUPLICATE of bug 251120
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-31 19:05 UTC by Rob V
Modified: 2011-09-02 18:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob V 2011-08-31 19:05:33 UTC
Application: ktorrent (4.0.5)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

Added a few new torrents and they started to download. KTorrent then crashed with no error or warning.

The crash can be reproduced every time.

-- Backtrace:
Application: KTorrent (ktorrent), signal: Aborted
QTextLayout::lineCount (this=0x7f5fda622d30) at text/qtextlayout.cpp:799
	in text/qtextlayout.cpp
[Current thread is 1 (Thread 0x7f5ff1daf780 (LWP 10146))]

Thread 7 (Thread 0x7f5fdd8cc700 (LWP 10149)):
#0  0x00007f5fee281143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f5ff1942524 in dht::RPCServerThread::run (this=0x7d64b0) at ../../src/dht/rpcserver.cpp:107
#2  0x00007f5fef9ed175 in QThreadPrivate::start (arg=0x7d64b0) at thread/qthread_unix.cpp:320
#3  0x00007f5feab3dd8c in start_thread (arg=0x7f5fdd8cc700) at pthread_create.c:304
#4  0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f5fc93ce700 (LWP 10163)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5fef9ec2b3 in QMutexPrivate::wait (this=0x70f150, timeout=-1) at thread/qmutex_unix.cpp:84
#2  0x00007f5fef9e8ce5 in QMutex::lock (this=0x6d60e8) at thread/qmutex.cpp:167
#3  0x00007f5ff18ea2ea in net::DownloadThread::waitForSocketReady (this=0x70f1d0) at ../../src/net/downloadthread.cpp:110
#4  0x00007f5ff18ea536 in net::DownloadThread::update (this=0x70f1d0) at ../../src/net/downloadthread.cpp:48
#5  0x00007f5ff18ea719 in net::NetworkThread::run (this=0x70f1d0) at ../../src/net/networkthread.cpp:48
#6  0x00007f5fef9ed175 in QThreadPrivate::start (arg=0x70f1d0) at thread/qthread_unix.cpp:320
#7  0x00007f5feab3dd8c in start_thread (arg=0x7f5fc93ce700) at pthread_create.c:304
#8  0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f5fc8bcd700 (LWP 10164)):
#0  net::UploadThread::waitForSocketsReady (this=0x70fbd0) at ../../src/net/uploadthread.cpp:122
#1  0x00007f5ff18e9d86 in net::UploadThread::update (this=0x70fbd0) at ../../src/net/uploadthread.cpp:45
#2  0x00007f5ff18ea719 in net::NetworkThread::run (this=0x70fbd0) at ../../src/net/networkthread.cpp:48
#3  0x00007f5fef9ed175 in QThreadPrivate::start (arg=0x70fbd0) at thread/qthread_unix.cpp:320
#4  0x00007f5feab3dd8c in start_thread (arg=0x7f5fc8bcd700) at pthread_create.c:304
#5  0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5fc3fff700 (LWP 10168)):
#0  0x00007f5fee27a35d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f5fee216a78 in _IO_new_file_underflow (fp=0x1b7fcd0) at fileops.c:606
#2  0x00007f5fee217a9e in _IO_default_uflow (fp=0x1b7fcd0) at genops.c:440
#3  0x00007f5fee20bbda in _IO_getline_info (fp=0x1b7fcd0, buf=0x7f5fc3ffe0e0 "-15 Timeout reached\n", n=255, delim=10, extract_delim=1, eof=0x0) at iogetline.c:74
#4  0x00007f5fee20aaaa in _IO_fgets (buf=0x7f5fc3ffe0e0 "-15 Timeout reached\n", n=<value optimized out>, fp=0x1b7fcd0) at iofgets.c:58
#5  0x00007f5fcbbd50d7 in ?? () from /lib/libnss_mdns4.so.2
#6  0x00007f5fcbbd572f in _nss_mdns4_gethostbyaddr_r () from /lib/libnss_mdns4.so.2
#7  0x00007f5fee2a3228 in __gethostbyaddr_r (addr=<value optimized out>, len=4, type=2, resbuf=0x7f5fc3ffeb60, buffer=0x7f5fc3ffe530 "\377\002", buflen=1024, result=0x7f5fc3ffeba0, h_errnop=0x7f5fc3ffebb0) at ../nss/getXXbyYY_r.c:256
#8  0x00007f5fee2a98c5 in getnameinfo (sa=0x18b4de0, addrlen=<value optimized out>, host=0x7f5fc3ffece0 "", hostlen=199, serv=0x7f5fc3ffec10 "", servlen=199, flags=8) at getnameinfo.c:223
#9  0x00007f5ff18ecc2f in net::ReverseResolver::resolve (this=<value optimized out>, addr=...) at ../../src/net/reverseresolver.cpp:64
#10 0x00007f5ff18eccc7 in net::ReverseResolver::run (this=0x1fac290) at ../../src/net/reverseresolver.cpp:73
#11 0x00007f5ff18ed047 in net::ReverseResolverThread::run (this=0x15dcd20) at ../../src/net/reverseresolver.cpp:118
#12 0x00007f5fef9ed175 in QThreadPrivate::start (arg=0x15dcd20) at thread/qthread_unix.cpp:320
#13 0x00007f5feab3dd8c in start_thread (arg=0x7f5fc3fff700) at pthread_create.c:304
#14 0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5fcabd1700 (LWP 10324)):
#0  clock_gettime (clock_id=1, tp=0x7f5fcabd0b30) at ../sysdeps/unix/clock_gettime.c:94
#1  0x00007f5fefa3e304 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00007f5fefaffe3d in QTimerInfoList::updateCurrentTime (this=0x1d27f10) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00007f5fefb001a5 in QTimerInfoList::timerWait (this=0x1d27f10, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00007f5fefafec2c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f5fcabd0c4c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00007f5fefafecd5 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00007f5fe9c2f0a2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f5fe9c2ff9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f5fe9c30639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f5fefaff446 in QEventDispatcherGlib::processEvents (this=0x27d2c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00007f5fefad3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f5fefad3abc in QEventLoop::exec (this=0x7f5fcabd0dd0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00007f5fef9ea924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#14 0x00007f5fefab5c2f in QInotifyFileSystemWatcherEngine::run (this=0x7f5fd8da6710) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00007f5fef9ed175 in QThreadPrivate::start (arg=0x7f5fd8da6710) at thread/qthread_unix.cpp:320
#16 0x00007f5feab3dd8c in start_thread (arg=0x7f5fcabd1700) at pthread_create.c:304
#17 0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5fcd3e0700 (LWP 10342)):
[KCrash Handler]
#6  0x00007f5fee1d6d05 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f5fee1daab6 in abort () at abort.c:92
#8  0x00007f5fe9c38a22 in g_logv () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f5fe9c38aaf in g_log () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f5fe9c2c4e2 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f5fe9c2c88f in g_main_context_new () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f5fefaff1c1 in QEventDispatcherGlibPrivate::QEventDispatcherGlibPrivate (this=0x1b76c30, context=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:310
#13 0x00007f5fefaff2a0 in QEventDispatcherGlib::QEventDispatcherGlib (this=0x287d010, parent=0x0) at kernel/qeventdispatcher_glib.cpp:357
#14 0x00007f5fef9ec587 in QThreadPrivate::createEventDispatcher (data=0x7f5fd8a102b0) at thread/qthread_unix.cpp:261
#15 0x00007f5fef9ed156 in QThreadPrivate::start (arg=0x7f5fd8895220) at thread/qthread_unix.cpp:313
#16 0x00007f5feab3dd8c in start_thread (arg=0x7f5fcd3e0700) at pthread_create.c:304
#17 0x00007f5fee28904d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5ff1daf780 (LWP 10146)):
#0  QTextLayout::lineCount (this=0x7f5fda622d30) at text/qtextlayout.cpp:799
#1  0x00007f5fef12a3ad in QTextDocumentLayoutPrivate::layoutBlock (this=0x1326a00, bl=<value optimized out>, blockPosition=13272, blockFormat=..., layoutStruct=0x7fff6ae4cdf0, layoutFrom=0, layoutTo=0, previousBlockFormat=0x7fff6ae4ccd0) at text/qtextdocumentlayout.cpp:2669
#2  0x00007f5fef13279f in QTextDocumentLayoutPrivate::layoutFlow (this=0x1326a00, it=..., layoutStruct=0x7fff6ae4cdf0, layoutFrom=0, layoutTo=0, width=<value optimized out>) at text/qtextdocumentlayout.cpp:2404
#3  0x00007f5fef130f80 in QTextDocumentLayoutPrivate::layoutFrame (this=0x1326a00, f=0x132b010, layoutFrom=0, layoutTo=0, frameWidth=<value optimized out>, frameHeight=..., parentY=...) at text/qtextdocumentlayout.cpp:2145
#4  0x00007f5fef131783 in QTextDocumentLayoutPrivate::layoutFrame (this=0x1326a00, f=0x132b010, layoutFrom=0, layoutTo=0, parentY=...) at text/qtextdocumentlayout.cpp:2051
#5  0x00007f5fef13462a in QTextDocumentLayout::doLayout (this=0x1327e70, from=0, oldLength=<value optimized out>, length=0) at text/qtextdocumentlayout.cpp:2914
#6  0x00007f5fef135d25 in QTextDocumentLayout::documentChanged (this=0x1327e70, from=0, oldLength=92, length=0) at text/qtextdocumentlayout.cpp:2877
#7  0x00007f5fef10fec6 in QTextDocumentPrivate::finishEdit (this=0x132ed00) at text/qtextdocument_p.cpp:1218
#8  0x00007f5fef110391 in QTextDocumentPrivate::ensureMaximumBlockCount (this=0x132ed00) at text/qtextdocument_p.cpp:1702
#9  0x00007f5fef110071 in QTextDocumentPrivate::finishEdit (this=0x132ed00) at text/qtextdocument_p.cpp:1225
#10 0x00007f5fef0d37c9 in QTextControlPrivate::append (this=<value optimized out>, text=..., format=Qt::AutoText) at text/qtextcontrol.cpp:2822
#11 0x00007f5fef302d41 in QTextEdit::append (this=<value optimized out>, text=...) at widgets/qtextedit.cpp:2620
#12 0x00007f5fd365cd9f in kt::LogViewer::customEvent (this=0x132c350, ev=0x7f5fd9390520) at ../../../plugins/logviewer/logviewer.cpp:103
#13 0x00007f5fefae84fc in QObject::event (this=0x132c350, e=<value optimized out>) at kernel/qobject.cpp:1257
#14 0x00007f5feeee267d in QWidget::event (this=0x132c350, event=0x7f5fd9390520) at kernel/qwidget.cpp:8718
#15 0x00007f5feee919f4 in QApplicationPrivate::notify_helper (this=0x78e990, receiver=0x132c350, e=0x7f5fd9390520) at kernel/qapplication.cpp:4462
#16 0x00007f5feee963ba in QApplication::notify (this=<value optimized out>, receiver=0x132c350, e=0x7f5fd9390520) at kernel/qapplication.cpp:4341
#17 0x0000000000437d91 in kt::App::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../ktorrent/app.cpp:97
#18 0x00007f5fefad449c in QCoreApplication::notifyInternal (this=0x7fff6ae4dfd0, receiver=0x132c350, event=0x7f5fd9390520) at kernel/qcoreapplication.cpp:731
#19 0x00007f5fefad7c25 in sendEvent (receiver=0x0, event_type=0, data=0x706b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x706b60) at kernel/qcoreapplication.cpp:1372
#21 0x00007f5fefaff253 in sendPostedEvents (s=0x78e410) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=0x78e410) at kernel/qeventdispatcher_glib.cpp:277
#23 0x00007f5fe9c2fbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f5fe9c303a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f5fe9c30639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f5fefaff3ef in QEventDispatcherGlib::processEvents (this=0x706340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#27 0x00007f5feef3b4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f5fefad3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f5fefad3abc in QEventLoop::exec (this=0x7fff6ae4df60, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f5fefad7ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#31 0x00000000004271ef in main (argc=5, argv=0x7fff6ae4ed88) at ../../ktorrent/main.cpp:176

Possible duplicates by query: bug 238451, bug 230056.

Reported using DrKonqi
Comment 1 Joris Guisson 2011-09-02 18:31:36 UTC

*** This bug has been marked as a duplicate of bug 251120 ***