Bug 238451 - ferquent crashes
Summary: ferquent crashes
Status: RESOLVED DUPLICATE of bug 230056
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-22 02:19 UTC by Tony Clifton
Modified: 2010-05-22 10:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Clifton 2010-05-22 02:19:23 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.12-115.fc12.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
ktorrent crashes often and randomly, sometimes while running, less often when I quit the application

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Aborted
[Current thread is 1 (Thread 0xb775f7a0 (LWP 2431))]

Thread 7 (Thread 0xb6000b70 (LWP 2434)):
#0  0x009bd424 in __kernel_vsyscall ()
#1  0x02227371 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x001c175c in dht::RPCServerThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/dht/rpcserver.cpp:107
#3  0x04b54cdf in QThreadPrivate::start (arg=0x86ec670) at thread/qthread_unix.cpp:248
#4  0x00979ab5 in start_thread (arg=0xb6000b70) at pthread_create.c:297
#5  0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 6 (Thread 0xac6fbb70 (LWP 2902)):
#0  0x0016af2c in net::DownloadThread::waitForSocketReady (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/downloadthread.cpp:172
#1  0x0016afe0 in net::DownloadThread::update (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/downloadthread.cpp:53
#2  0x0016ba58 in net::NetworkThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#3  0x04b54cdf in QThreadPrivate::start (arg=0x86c4840) at thread/qthread_unix.cpp:248
#4  0x00979ab5 in start_thread (arg=0xac6fbb70) at pthread_create.c:297
#5  0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 5 (Thread 0xabcfab70 (LWP 2903)):
#0  0x009bd424 in __kernel_vsyscall ()
#1  0x0097dc45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x04b55b7f in wait (this=0x86c4bd8, mutex=0x86c4bdc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x86c4bd8, mutex=0x86c4bdc, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x0016a9c9 in net::UploadThread::update (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/uploadthread.cpp:73
#5  0x0016ba58 in net::NetworkThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#6  0x04b54cdf in QThreadPrivate::start (arg=0x86c4ba0) at thread/qthread_unix.cpp:248
#7  0x00979ab5 in start_thread (arg=0xabcfab70) at pthread_create.c:297
#8  0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xab2f9b70 (LWP 2904)):
#0  0x009bd424 in __kernel_vsyscall ()
#1  0x02224396 in __poll (fds=0xab2f7eac, nfds=1, timeout=5000) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x054610b4 in send_dg (statp=0xab2f9df4, buf=0xab2f7f80 "k\276\001", buflen=46, buf2=0x0, buflen2=0, ansp=0xab2f7f60, anssizp=0xab2f7f64, terrno=0xab2f7f2c, ns=0, v_circuit=0xab2f7f28, 
    gotsomewhere=0xab2f7f30, anscp=0xab2f893c, ansp2=0x0, anssizp2=0x0, resplen2=0x0) at res_send.c:1061
#3  0x05462ac0 in __libc_res_nsend (statp=0xab2f9df4, buf=0xab2f7f80 "k\276\001", buflen=46, buf2=0x0, buflen2=0, ans=0xab2f8110 "\331\223\201\200", anssiz=1024, ansp=0xab2f893c, ansp2=0x0, nansp2=
    0x0, resplen2=0x0) at res_send.c:557
#4  0x0545f51e in __libc_res_nquery (statp=0xab2f9df4, name=0xab2f853a "235.203.102.174.in-addr.arpa", class=1, type=12, answer=0xab2f8110 "\331\223\201\200", anslen=1024, answerp=0xab2f893c, 
    answerp2=0x0, nanswerp2=0x0, resplen2=0x0) at res_query.c:225
#5  0x01d3a9d7 in _nss_dns_gethostbyaddr2_r (addr=<value optimized out>, len=<value optimized out>, af=<value optimized out>, result=0xab2f8fb4, buffer=0xab2f9d78 "", buflen=1024, errnop=0xab2f9b28, 
    h_errnop=0xab2f8fe8, ttlp=0x0) at nss_dns/dns-host.c:465
#6  0x01d3b01a in _nss_dns_gethostbyaddr_r (addr=0xb00f7a4, len=4, af=2, result=0xab2f8fb4, buffer=0xab2f89f0 "\177", buflen=1024, errnop=0xab2f9b28, h_errnop=0xab2f8fe8) at nss_dns/dns-host.c:524
#7  0x02248b1b in __gethostbyaddr_r (addr=<value optimized out>, len=4, type=2, resbuf=0xab2f8fb4, buffer=0xab2f89f0 "\177", buflen=1024, result=0xab2f8fe4, h_errnop=0xab2f8fe8)
    at ../nss/getXXbyYY_r.c:253
#8  0x02251f8d in getnameinfo (sa=0xb00f7a0, addrlen=16, host=0xab2f9104 "", hostlen=199, serv=0xab2f903c "", servlen=199, flags=8) at getnameinfo.c:223
#9  0x0016e41c in net::ReverseResolver::resolve (this=<value optimized out>, addr=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/reverseresolver.cpp:64
#10 0x0016e4b4 in net::ReverseResolver::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/reverseresolver.cpp:73
#11 0x0016e5b8 in net::ReverseResolverThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/reverseresolver.cpp:118
#12 0x04b54cdf in QThreadPrivate::start (arg=0x92206d0) at thread/qthread_unix.cpp:248
#13 0x00979ab5 in start_thread (arg=0xab2f9b70) at pthread_create.c:297
#14 0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xadafdb70 (LWP 2931)):
#0  0x009bd424 in __kernel_vsyscall ()
#1  0x0097df72 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S:179
#2  0x04b55b00 in wait (this=0x8a1b0c4, mutex=0x8a1b0c0, time=30000) at thread/qwaitcondition_unix.cpp:85
#3  QWaitCondition::wait (this=0x8a1b0c4, mutex=0x8a1b0c0, time=30000) at thread/qwaitcondition_unix.cpp:159
#4  0x04b4b79b in QThreadPoolThread::run (this=0x91dfa90) at concurrent/qthreadpool.cpp:140
#5  0x04b54cdf in QThreadPrivate::start (arg=0x91dfa90) at thread/qthread_unix.cpp:248
#6  0x00979ab5 in start_thread (arg=0xadafdb70) at pthread_create.c:297
#7  0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xad0fcb70 (LWP 2932)):
[KCrash Handler]
#6  0x009bd424 in __kernel_vsyscall ()
#7  0x0217ea81 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x0218034a in abort () at abort.c:92
#9  0x06f3a316 in IA__g_logv (log_domain=0x6f86366 "GLib", log_level=<value optimized out>, format=0x6f8bcec "Cannot create pipe main loop wake-up: %s\n", args1=0xad0fc15c "s\275(\002")
    at gmessages.c:549
#10 0x06f3a347 in IA__g_log (log_domain=0x6f86366 "GLib", log_level=G_LOG_LEVEL_ERROR, format=0x6f8bcec "Cannot create pipe main loop wake-up: %s\n") at gmessages.c:569
#11 0x06f30ace in g_main_context_init_pipe (context=0xaef04600) at gmain.c:415
#12 0x06f30b65 in IA__g_main_context_new () at gmain.c:510
#13 0x04c735f2 in QEventDispatcherGlibPrivate::QEventDispatcherGlibPrivate (this=0xaef04848, context=0x0) at kernel/qeventdispatcher_glib.cpp:308
#14 0x04c7378c in QEventDispatcherGlib::QEventDispatcherGlib (this=0xaef05fb0, parent=0x0) at kernel/qeventdispatcher_glib.cpp:350
#15 0x04b54b1a in QThreadPrivate::createEventDispatcher (data=0x9363370) at thread/qthread_unix.cpp:200
#16 0x04b54cb6 in QThreadPrivate::start (arg=0x91d2638) at thread/qthread_unix.cpp:241
#17 0x00979ab5 in start_thread (arg=0xad0fcb70) at pthread_create.c:297
#18 0x0222ed8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb775f7a0 (LWP 2431)):
#0  0x009bd424 in __kernel_vsyscall ()
#1  0x0097dc45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x04b55b7f in wait (this=0x8a1b0d4, mutex=0x8a1b0c0, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8a1b0d4, mutex=0x8a1b0c0, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x04b4b99a in QThreadPoolPrivate::waitForDone (this=0x8a1b070) at concurrent/qthreadpool.cpp:295
#5  0x04b4bde1 in QThreadPool::~QThreadPool (this=0x8b334c8, __in_chrg=<value optimized out>) at concurrent/qthreadpool.cpp:428
#6  0x04b4be43 in QThreadPool::~QThreadPool (this=0x8b334c8, __in_chrg=<value optimized out>) at concurrent/qthreadpool.cpp:430
#7  0x04b4c38b in QGlobalStaticDeleter<QThreadPool>::~QGlobalStaticDeleter (this=0x4d5f760, __in_chrg=<value optimized out>) at ../../src/corelib/global/qglobal.h:1799
#8  0x0218208f in __run_exit_handlers (status=1) at exit.c:78
#9  exit (status=1) at exit.c:100
#10 0x0764b091 in gdk_x_io_error (display=0x87082f0) at gdkmain-x11.c:524
#11 0x0075d43b in KApplication::xioErrhandler (this=0xbfbd3074, dpy=0x87082f0) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:408
#12 0x0075d477 in kde_xio_errhandler (dpy=0x87082f0) at /usr/src/debug/kdelibs-4.4.2/kdeui/kernel/kapplication.cpp:125
#13 0x0378aa57 in _XIOError (dpy=<value optimized out>) at XlibInt.c:3138
#14 0x037929d3 in process_responses (dpy=<value optimized out>, wait_for_first_event=<value optimized out>, current_error=<value optimized out>, current_request=<value optimized out>) at xcb_io.c:240
#15 0x03793327 in _XEventsQueued (dpy=<value optimized out>, mode=<value optimized out>) at xcb_io.c:256
#16 0x0377b9ef in XEventsQueued (dpy=<value optimized out>, mode=<value optimized out>) at Pending.c:44
#17 0x0262a71f in x11EventSourcePrepare (s=0x86ef368, timeout=0xbfbd2dcc) at kernel/qguieventdispatcher_glib.cpp:79
#18 0x06f33150 in IA__g_main_context_prepare (context=<value optimized out>, priority=0xbfbd2e4c) at gmain.c:2280
#19 0x06f33509 in g_main_context_iterate (context=0x86edf10, block=1, dispatch=1, self=0x86eb538) at gmain.c:2571
#20 0x06f33a14 in IA__g_main_context_iteration (context=0x86edf10, may_block=1) at gmain.c:2654
#21 0x04c72e7f in QEventDispatcherGlib::processEvents (this=0x86c3640, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#22 0x0262a586 in QGuiEventDispatcherGlib::processEvents (this=0x86c3640, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x04c492da in QEventLoop::processEvents (this=0xbfbd2fe4, flags=...) at kernel/qeventloop.cpp:149
#24 0x04c4961a in QEventLoop::exec (this=0xbfbd2fe4, flags=...) at kernel/qeventloop.cpp:201
#25 0x04c4bce7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#26 0x0257c278 in QApplication::exec () at kernel/qapplication.cpp:3579
#27 0x08065421 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/ktorrent/main.cpp:172

Possible duplicates by query: bug 230056.

Reported using DrKonqi
Comment 1 Joris Guisson 2010-05-22 10:51:32 UTC

*** This bug has been marked as a duplicate of bug 230056 ***