Bug 230056 - Ktorrent crash - no obvious reason
Summary: Ktorrent crash - no obvious reason
Status: RESOLVED UPSTREAM
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 238451 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-09 07:45 UTC by Tony Clifton
Modified: 2010-05-22 10:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Clifton 2010-03-09 07:45:44 UTC
Application: ktorrent (3.3.4)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.9-67.fc12.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
started the programme
opened a torrent file
Ktorrent crashed

 -- Backtrace:
Application: KTorrent (ktorrent), signal: Aborted
[Current thread is 1 (Thread 0xb7817af0 (LWP 10023))]

Thread 6 (Thread 0xb54ffb70 (LWP 10025)):
#0  0x00b5a424 in __kernel_vsyscall ()
#1  0x068fb3b1 in select () at ../sysdeps/unix/syscall-template.S:82
#2  0x00ab575c in dht::RPCServerThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/dht/rpcserver.cpp:107
#3  0x0524fcdf in QThreadPrivate::start (arg=0x9d82170) at thread/qthread_unix.cpp:248
#4  0x0029cab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#5  0x06902dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 5 (Thread 0xad2fdb70 (LWP 10114)):
#0  0x00a5f051 in net::DownloadThread::update (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/downloadthread.cpp:71
#1  0x00a5fa58 in net::NetworkThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#2  0x0524fcdf in QThreadPrivate::start (arg=0x9c0c840) at thread/qthread_unix.cpp:248
#3  0x0029cab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x06902dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 4 (Thread 0xac8fcb70 (LWP 10115)):
#0  0x00b5a424 in __kernel_vsyscall ()
#1  0x002a0c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05250b7f in wait (this=0x9c0cbd8, mutex=0x9c0cbdc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x9c0cbd8, mutex=0x9c0cbdc, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x00a5e9c9 in net::UploadThread::update (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/uploadthread.cpp:73
#5  0x00a5fa58 in net::NetworkThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/networkthread.cpp:48
#6  0x0524fcdf in QThreadPrivate::start (arg=0x9c0cba0) at thread/qthread_unix.cpp:248
#7  0x0029cab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#8  0x06902dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 3 (Thread 0xabefbb70 (LWP 10116)):
#0  0x00b5a424 in __kernel_vsyscall ()
#1  0x002a0c45 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:122
#2  0x05250b7f in wait (this=0xa507eb4, mutex=0xa507eb0, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0xa507eb4, mutex=0xa507eb0, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x00a626a2 in net::ReverseResolverThread::run (this=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/libbtcore/net/reverseresolver.cpp:123
#5  0x0524fcdf in QThreadPrivate::start (arg=0xa507ea8) at thread/qthread_unix.cpp:248
#6  0x0029cab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#7  0x06902dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xae6ffb70 (LWP 12566)):
[KCrash Handler]
#6  0x00b5a424 in __kernel_vsyscall ()
#7  0x06852a91 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x0685435a in abort () at abort.c:92
#9  0x015d22e6 in IA__g_logv (log_domain=<value optimized out>, log_level=<value optimized out>, format=<value optimized out>, args1=<value optimized out>) at gmessages.c:549
#10 0x015d2317 in IA__g_log (log_domain=<value optimized out>, log_level=<value optimized out>, format=<value optimized out>) at gmessages.c:569
#11 0x015c8a9e in g_main_context_init_pipe (context=0xa944520) at gmain.c:415
#12 0x015c8b35 in IA__g_main_context_new () at gmain.c:510
#13 0x0536e5f2 in QEventDispatcherGlibPrivate::QEventDispatcherGlibPrivate (this=0xc4c4880, context=0x0) at kernel/qeventdispatcher_glib.cpp:308
#14 0x0536e78c in QEventDispatcherGlib::QEventDispatcherGlib (this=0xb3b7168, parent=0x0) at kernel/qeventdispatcher_glib.cpp:350
#15 0x0524fb1a in QThreadPrivate::createEventDispatcher (data=0xaa4d230) at thread/qthread_unix.cpp:200
#16 0x0524fcb6 in QThreadPrivate::start (arg=0xbc50a18) at thread/qthread_unix.cpp:241
#17 0x0029cab5 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#18 0x06902dce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7817af0 (LWP 10023)):
#0  0x00b5a424 in __kernel_vsyscall ()
#1  0x068f83d6 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0952e0c0 in ?? () from /usr/lib/libxcb.so.1
#3  0x0952e62b in ?? () from /usr/lib/libxcb.so.1
#4  0x0952e9c8 in xcb_writev () from /usr/lib/libxcb.so.1
#5  0x0872cd59 in _XSend () from /usr/lib/libX11.so.6
#6  0x0872d3aa in _XFlush () from /usr/lib/libX11.so.6
#7  0x00f34ed8 in XRenderFreePicture () from /usr/lib/libXrender.so.1
#8  0x0467eed1 in QX11PixmapData::release (this=0xa7eb940) at image/qpixmap_x11.cpp:1267
#9  0x0467f757 in QX11PixmapData::~QX11PixmapData (this=0xa7eb940, __in_chrg=<value optimized out>) at image/qpixmap_x11.cpp:1238
#10 0x0467f7c3 in QX11PixmapData::~QX11PixmapData (this=0xa7eb940, __in_chrg=<value optimized out>) at image/qpixmap_x11.cpp:1239
#11 0x0466dcd7 in ~QExplicitlySharedDataPointer (this=0xa7eb13c, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qshareddata.h:159
#12 QPixmap::~QPixmap (this=0xa7eb13c, __in_chrg=<value optimized out>) at image/qpixmap.cpp:323
#13 0x01720c4a in QWidget::setUpdatesEnabled(bool) () at kernel/qwidget.cpp:7027
#14 0x01720ec6 in QWidget::setUpdatesEnabled(bool) () at kernel/qwidget.cpp:7027
#15 0x01734a32 in QWidget::setUpdatesEnabled(bool) () at kernel/qwidget.cpp:7027
#16 0x01754316 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#17 0x0177421c in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#18 0x0685609f in __run_exit_handlers (status=<value optimized out>) at exit.c:78
#19 exit (status=<value optimized out>) at exit.c:100
#20 0x039e2081 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#21 0x004a71fb in KApplication::xioErrhandler (this=0xbfebae94, dpy=0x9c8a770) at /usr/src/debug/kdelibs-4.4.0/kdeui/kernel/kapplication.cpp:408
#22 0x004a7237 in kde_xio_errhandler (dpy=0x9c8a770) at /usr/src/debug/kdelibs-4.4.0/kdeui/kernel/kapplication.cpp:125
#23 0x08724a57 in _XIOError () from /usr/lib/libX11.so.6
#24 0x0872c9d3 in ?? () from /usr/lib/libX11.so.6
#25 0x0872d327 in _XEventsQueued () from /usr/lib/libX11.so.6
#26 0x08715978 in XPending () from /usr/lib/libX11.so.6
#27 0x039d5459 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#28 0x039d55d9 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#29 0x015cb120 in IA__g_main_context_prepare (context=<value optimized out>, priority=<value optimized out>) at gmain.c:2280
#30 0x015cb4d9 in g_main_context_iterate (context=0x9c36290, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2571
#31 0x015cb9e4 in IA__g_main_context_iteration (context=0x9c36290, may_block=<value optimized out>) at gmain.c:2654
#32 0x0536de46 in QEventDispatcherGlib::processEvents (this=0x9c0b640, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#33 0x0463b566 in QGuiEventDispatcherGlib::processEvents (this=0x9c0b640, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x053442da in QEventLoop::processEvents (this=0xbfebae04, flags=...) at kernel/qeventloop.cpp:149
#35 0x0534461a in QEventLoop::exec (this=0xbfebae04, flags=...) at kernel/qeventloop.cpp:201
#36 0x05346ce7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#37 0x0458d278 in QApplication::exec () at kernel/qapplication.cpp:3579
#38 0x08065421 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/ktorrent-3.3.4/ktorrent/main.cpp:172

Reported using DrKonqi
Comment 1 Joris Guisson 2010-03-09 18:14:04 UTC
Abort after an XIOError, this is a Qt problem.
Comment 2 Joris Guisson 2010-05-22 10:51:32 UTC
*** Bug 238451 has been marked as a duplicate of this bug. ***