Bug 279785 - Amarok crash during the startup
Summary: Amarok crash during the startup
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-10 07:03 UTC by giggi1999
Modified: 2011-09-26 11:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giggi1999 2011-08-10 07:03:47 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.3
Operating System: Linux 3.0-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

Amarok 2.4.3 crash during the startup:
I launch Amarok it appear the the splash screen and it crashes 

Note:
For building a debug package under ArchLinux we must insert the option 
OPTIONS=(!strip)
 in the PKGBUILD.
Please insert this observation in you Wiki.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f095c3987a0 (LWP 11711))]

Thread 11 (Thread 0x7f093882f700 (LWP 11714)):
#0  0x00007f0958c6cb83 in poll () from /lib/libc.so.6
#1  0x00007f094f7fcfdf in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f094f7eee36 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f094f7ef469 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f094f7ef520 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f094f7fcf8f in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f0948eac2b8 in ?? () from /usr/lib/libpulsecommon-0.9.23.so
#7  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f092b131700 (LWP 11717)):
#0  0x00007f0956e47d9f in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0x00007f09525a5d31 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#2  0x00007f09595a78de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#3  0x00007f095957bdb2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f095957bfb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f095949369f in QThread::exec() () from /usr/lib/libQtCore.so.4
#6  0x00007f095955ed8f in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#9  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#10 0x00007f0958c74e2d in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f0929e2c700 (LWP 11718)):
#0  0x00007f0956e48e3b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095949650e in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f095948aebf in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#5  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#6  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f0929425700 (LWP 11719)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095949659b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0956206144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f09562086eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f09562075af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f095620763b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f09283a8700 (LWP 11721)):
#0  0x00007f0958c817e4 in pthread_mutex_unlock () from /lib/libc.so.6
#1  0x00007f09525a3d83 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#2  0x00007f09525a55f1 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0x00007f09525a5d09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0x00007f09595a78de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f095957bdb2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f095957bfb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f095949369f in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007f095955ed8f in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#11 0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#12 0x00007f0958c74e2d in clone () from /lib/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f0927980700 (LWP 11722)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095949659b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0956206144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f09562086eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f09562075af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f095620763b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f0926f71700 (LWP 11723)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095949659b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0956206144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f09562086eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f09562075af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f095620763b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f0926770700 (LWP 11724)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095949659b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f0956206144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f09562086eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f09562075af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f095620763b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f09594960f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f092591f700 (LWP 11725)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f094eb9e0ea in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f094eb9e1d9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#4  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#5  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f091f5f0700 (LWP 11728)):
#0  0x00007f0956e48ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f095521f2e2 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007f095521f319 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007f094761356c in ?? () from /usr/lib/libGL.so.1
#4  0x00007f0956e44d60 in start_thread () from /lib/libpthread.so.0
#5  0x00007f0958c74e2d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f095c3987a0 (LWP 11711)):
[KCrash Handler]
#6  0x00007f095947ab30 in QAbstractAnimation::state() const () from /usr/lib/libQtCore.so.4
#7  0x00007f095af3a459 in Context::ContextView::addCollapseAnimation (this=0x12b20f0, anim=0x17ae420) at /home/simone/packages/amarok/src/amarok-2.4.3/src/context/ContextView.cpp:240
#8  0x00007f095af34bab in Context::Applet::collapse (this=0x15e0b60, on=false) at /home/simone/packages/amarok/src/amarok-2.4.3/src/context/Applet.cpp:320
#9  0x00007f095af34785 in Context::Applet::setCollapseOff (this=0x15e0b60) at /home/simone/packages/amarok/src/amarok-2.4.3/src/context/Applet.cpp:279
#10 0x00007f092435b160 in Albums::dataUpdated (this=0x15e0b60, name=..., data=...) at /home/simone/packages/amarok/src/amarok-2.4.3/src/context/applets/albums/Albums.cpp:155
#11 0x00007f092435c99e in Albums::qt_metacall (this=0x15e0b60, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffa6a8caf0) at /home/simone/packages/amarok/src/build/src/context/applets/albums/Albums.moc:91
#12 0x00007f095958f7fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0x00007f0955675967 in Plasma::DataContainer::dataUpdated(QString const&, QHash<QString, QVariant> const&) () from /usr/lib/libplasma.so.3
#14 0x00007f0955675e3e in Plasma::DataContainer::checkForUpdate() () from /usr/lib/libplasma.so.3
#15 0x00007f095567775f in Plasma::DataEngine::timerEvent(QTimerEvent*) () from /usr/lib/libplasma.so.3
#16 0x00007f09595930c9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#17 0x00007f0959f44174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f0959f48fe1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x00007f095bdb0226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#20 0x00007f095957cbbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0x00007f09595a9732 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007f09595a6eb4 in ?? () from /usr/lib/libQtCore.so.4
#23 0x00007f09525a529d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0x00007f09525a5a78 in ?? () from /usr/lib/libglib-2.0.so.0
#25 0x00007f09525a5d09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#26 0x00007f09595a7876 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f0959fe71be in ?? () from /usr/lib/libQtGui.so.4
#28 0x00007f095957bdb2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007f095957bfb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0x00007f09595801ab in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#31 0x000000000040cde0 in main (argc=1, argv=0x7fffa6a8f9a8) at /home/simone/packages/amarok/src/amarok-2.4.3/src/main.cpp:289

Possible duplicates by query: bug 279712, bug 279311, bug 269660, bug 258741.

Reported using DrKonqi
Comment 1 giggi1999 2011-08-10 10:32:51 UTC
I've compiled the GIT version:  10 - aug - 2011, 12.00.00, CEST
And the problem don't seems to be solved.


That's the backtrace of the GIT version.

=======================================================
Thread 1 (Thread 0x7fe161d957a0 (LWP 13096)):
[KCrash Handler]
#6  0x00007fe15f1b9b30 in QAbstractAnimation::state() const () from /usr/lib/libQtCore.so.4
#7  0x00007fe160c566cd in Context::ContextView::addCollapseAnimation (this=0x22ac120, anim=0x2bc12c0) at /home/simone/packages/amarok-git/src/amarok/src/context/ContextView.cpp:241
#8  0x00007fe160c51823 in Context::Applet::collapse (this=0x2534bb0, on=<optimized out>) at /home/simone/packages/amarok-git/src/amarok/src/context/Applet.cpp:320
#9  0x00007fe126122cf6 in Albums::dataUpdated (this=0x2534bb0, name=<optimized out>, data=<optimized out>) at /home/simone/packages/amarok-git/src/amarok/src/context/applets/albums/Albums.cpp:155
#10 0x00007fe1261237d6 in Albums::qt_metacall (this=0x2534bb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa24a8b40) at /home/simone/packages/amarok-git/src/build/src/context/applets/albums/Albums.moc:91
#11 0x00007fe15f2ce7fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0x00007fe15b3b4967 in Plasma::DataContainer::dataUpdated(QString const&, QHash<QString, QVariant> const&) () from /usr/lib/libplasma.so.3
#13 0x00007fe15b3b4e3e in Plasma::DataContainer::checkForUpdate() () from /usr/lib/libplasma.so.3
#14 0x00007fe15b3b675f in Plasma::DataEngine::timerEvent(QTimerEvent*) () from /usr/lib/libplasma.so.3
#15 0x00007fe15f2d20c9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x00007fe15fc83174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007fe15fc87fe1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007fe1617ad226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007fe15f2bbbbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x00007fe15f2e8732 in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007fe15f2e5eb4 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007fe1582ee29d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007fe1582eea78 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007fe1582eed09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007fe15f2e6876 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007fe15fd261be in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007fe15f2badb2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007fe15f2bafb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007fe15f2bf1ab in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x0000000000408a1e in main (argc=1, argv=0x7fffa24aba58) at /home/simone/packages/amarok-git/src/amarok/src/main.cpp:291
Comment 2 Myriam Schweingruber 2011-08-13 09:42:52 UTC
I reopened the master bug, please see there.

*** This bug has been marked as a duplicate of bug 258741 ***