Bug 279311 - amarok 2.4.3 crashes when starting playback with Meta+C
Summary: amarok 2.4.3 crashes when starting playback with Meta+C
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-03 18:04 UTC by Serge Ratke
Modified: 2011-09-26 11:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Ratke 2011-08-03 18:04:06 UTC
Application: amarok (2.4.3)
KDE Platform Version: 4.7.00 (4.7.0) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 3.0.0-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

started playback by hitting the global shortcut Meta+C; amarok crashed.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa26c081780 (LWP 2845))]

Thread 8 (Thread 0x7fa22a692700 (LWP 2865)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa2542ae2d0 in LoopRequest (data=0x2470480) at playlist/thread.c:539
#2  Thread (data=0x2470480) at playlist/thread.c:586
#3  0x00007fa26693dd4c in start_thread (arg=0x7fa22a692700) at pthread_create.c:301
#4  0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7fa22970d700 (LWP 2894)):
#0  0x00007fa26694192e in __pthread_mutex_unlock_usercnt (mutex=0x25f5988, decr=<value optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007fa262f044f9 in g_main_context_prepare (context=0x25f5980, priority=0x7fa22970ccac) at gmain.c:2760
#2  0x00007fa262f05419 in g_main_context_iterate (context=0x25f5980, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3072
#3  0x00007fa262f05abd in g_main_context_iteration (context=0x25f5980, may_block=1) at gmain.c:3155
#4  0x00007fa2690dfe96 in QEventDispatcherGlib::processEvents (this=0x2589af0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fa2690b4322 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa2690b4564 in QEventLoop::exec (this=0x7fa22970cdc0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fa268fca6a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007fa269095f08 in QInotifyFileSystemWatcherEngine::run (this=0x25f4db0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fa268fccef5 in QThreadPrivate::start (arg=0x25f4db0) at thread/qthread_unix.cpp:320
#10 0x00007fa26693dd4c in start_thread (arg=0x7fa22970d700) at pthread_create.c:301
#11 0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7fa2229c6700 (LWP 2908)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa268fcd5db in wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa265ce5914 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2c6f5e0, th=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa265ce7fa3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa265ce7fbc in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fa265ce7fbc in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007fa265ce6d8f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa2229c5e10, parent=0x2c6f5e0, th=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:87
#8  0x00007fa265ce6e18 in ThreadWeaver::Thread::run (this=0x2dfa640) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:142
#9  0x00007fa268fccef5 in QThreadPrivate::start (arg=0x2dfa640) at thread/qthread_unix.cpp:320
#10 0x00007fa26693dd4c in start_thread (arg=0x7fa2229c6700) at pthread_create.c:301
#11 0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fa221fba700 (LWP 2909)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa268fcd5db in wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa265ce5914 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2c6f5e0, th=0x2d4e510) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa265ce7fa3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2d4e510) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa265ce6d8f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa221fb9e10, parent=0x2c6f5e0, th=0x2d4e510) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:87
#6  0x00007fa265ce6e18 in ThreadWeaver::Thread::run (this=0x2d4e510) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:142
#7  0x00007fa268fccef5 in QThreadPrivate::start (arg=0x2d4e510) at thread/qthread_unix.cpp:320
#8  0x00007fa26693dd4c in start_thread (arg=0x7fa221fba700) at pthread_create.c:301
#9  0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fa2217b9700 (LWP 2910)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa268fcd5db in wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa265ce5914 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2c6f5e0, th=0x2c92820) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa265ce7fa3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2c92820) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa265ce7fbc in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2c92820) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fa265ce6d8f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa2217b8e10, parent=0x2c6f5e0, th=0x2c92820) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007fa265ce6e18 in ThreadWeaver::Thread::run (this=0x2c92820) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007fa268fccef5 in QThreadPrivate::start (arg=0x2c92820) at thread/qthread_unix.cpp:320
#9  0x00007fa26693dd4c in start_thread (arg=0x7fa2217b9700) at pthread_create.c:301
#10 0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fa220fb8700 (LWP 2911)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa268fcd5db in wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2dfa1b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fa265ce5914 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x2c6f5e0, th=0x2c90380) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fa265ce7fa3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2c90380) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fa265ce7fbc in ThreadWeaver::WorkingHardState::applyForWork (this=0x2df2c30, th=0x2c90380) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007fa265ce6d8f in ThreadWeaver::ThreadRunHelper::run (this=0x7fa220fb7e10, parent=0x2c6f5e0, th=0x2c90380) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007fa265ce6e18 in ThreadWeaver::Thread::run (this=0x2c90380) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007fa268fccef5 in QThreadPrivate::start (arg=0x2c90380) at thread/qthread_unix.cpp:320
#9  0x00007fa26693dd4c in start_thread (arg=0x7fa220fb8700) at pthread_create.c:301
#10 0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fa21b3d9700 (LWP 2915)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa264ce6cf4 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fa264fff180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fa264ce6d29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fa26500d254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fa26693dd4c in start_thread (arg=0x7fa21b3d9700) at pthread_create.c:301
#4  0x00007fa26877fc6d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fa26c081780 (LWP 2845)):
[KCrash Handler]
#6  QAbstractAnimation::state (this=0x7fa200000000) at animation/qabstractanimation.cpp:504
#7  0x00007fa26aa65a01 in Context::ContextView::addCollapseAnimation (this=0x2c59c80, anim=0x3d3d530) at /var/tmp/portage/media-sound/amarok-2.4.3/work/amarok-2.4.3/src/context/ContextView.cpp:240
#8  0x00007fa26aa60f5e in Context::Applet::collapse (this=0x2e208d0, on=<value optimized out>) at /var/tmp/portage/media-sound/amarok-2.4.3/work/amarok-2.4.3/src/context/Applet.cpp:320
#9  0x00007fa21bdf765c in LyricsApplet::dataUpdated (this=0x2e208d0, name=<value optimized out>, data=<value optimized out>) at /var/tmp/portage/media-sound/amarok-2.4.3/work/amarok-2.4.3/src/context/applets/lyrics/LyricsApplet.cpp:612
#10 0x00007fa21bdf8be6 in LyricsApplet::qt_metacall (this=0x2e208d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4404e4c0) at /var/tmp/portage/media-sound/amarok-2.4.3/work/amarok-2.4.3_build/src/context/applets/lyrics/LyricsApplet.moc:102
#11 0x00007fa2690c9637 in QMetaObject::activate (sender=0x2e87b10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff4404e4c0) at kernel/qobject.cpp:3278
#12 0x00007fa265158237 in Plasma::DataContainer::dataUpdated (this=<value optimized out>, _t1=<value optimized out>, _t2=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0_build/plasma/datacontainer.moc:112
#13 0x00007fa2651586f0 in Plasma::DataContainer::checkForUpdate (this=0x2e87b10) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/plasma/datacontainer.cpp:297
#14 0x00007fa26515b52b in Plasma::DataEngine::timerEvent (this=<value optimized out>, event=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/plasma/dataengine.cpp:386
#15 0x00007fa2690c8e69 in QObject::event (this=0x2e894e0, e=<value optimized out>) at kernel/qobject.cpp:1181
#16 0x00007fa269a95b74 in QApplicationPrivate::notify_helper (this=0x20798d0, receiver=0x2e894e0, e=0x7fff4404ec60) at kernel/qapplication.cpp:4462
#17 0x00007fa269a9a6fa in QApplication::notify (this=<value optimized out>, receiver=0x2e894e0, e=0x7fff4404ec60) at kernel/qapplication.cpp:4341
#18 0x00007fa26ba81896 in KApplication::notify (this=0x7fff4404ef90, receiver=0x2e894e0, event=0x7fff4404ec60) at /var/tmp/portage/kde-base/kdelibs-4.7.0/work/kdelibs-4.7.0/kdeui/kernel/kapplication.cpp:311
#19 0x00007fa2690b4f5b in QCoreApplication::notifyInternal (this=0x7fff4404ef90, receiver=0x2e894e0, event=0x7fff4404ec60) at kernel/qcoreapplication.cpp:731
#20 0x00007fa2690e26ee in sendEvent (this=0x20841b0) at kernel/qcoreapplication.h:215
#21 QTimerInfoList::activateTimers (this=0x20841b0) at kernel/qeventdispatcher_unix.cpp:604
#22 0x00007fa2690df744 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#23 0x00007fa262f0503e in g_main_dispatch (context=0x20545f0) at gmain.c:2441
#24 g_main_context_dispatch (context=0x20545f0) at gmain.c:3014
#25 0x00007fa262f05828 in g_main_context_iterate (context=0x20545f0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3092
#26 0x00007fa262f05abd in g_main_context_iteration (context=0x20545f0, may_block=1) at gmain.c:3155
#27 0x00007fa2690dfe3f in QEventDispatcherGlib::processEvents (this=0x1ecd2e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007fa269b3adbe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fa2690b4322 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fa2690b4564 in QEventLoop::exec (this=0x7fff4404eef0, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007fa2690b89cb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#32 0x000000000040e41a in main (argc=3, argv=0x7fff44051598) at /var/tmp/portage/media-sound/amarok-2.4.3/work/amarok-2.4.3/src/main.cpp:289

This bug may be a duplicate of or related to bug 258741.

Possible duplicates by query: bug 269660, bug 258741.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2011-08-05 07:53:54 UTC

*** This bug has been marked as a duplicate of bug 258741 ***