Bug 279712 - Amarok crash during the startup
Summary: Amarok crash during the startup
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: 2.5
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-09 06:03 UTC by giggi1999
Modified: 2012-07-12 17:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (14.33 KB, text/plain)
2011-10-14 18:45 UTC, John Veitch
Details
New crash information added by DrKonqi (14.55 KB, text/plain)
2011-11-16 09:22 UTC, Leonardo La Malfa
Details
New crash information added by DrKonqi (29.26 KB, text/plain)
2012-07-12 14:10 UTC, William W. Ferrell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description giggi1999 2011-08-09 06:03:17 UTC
Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

From some days and independently from the update to the latest version amarok crash during the startup.

I launch amarok, it appear the splash screen and it crash!  


This is the backtrace:
Note: for producing this back-trace I've recompiled amarok with the option -DCMAKE_BUILD_TYPE=Debug and I've removed all code optimization: -O0 

If this back trace is not useful can you send me some suggestion for creating a better backtrace.

=======================================================================
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f58d34e77a0 (LWP 10221))]

Thread 11 (Thread 0x7f58afcd6700 (LWP 10225)):
#0  0x00007f58d00f9b83 in poll () from /lib/libc.so.6
#1  0x00007f58c6c93fdf in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f58c6c85e36 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f58c6c86469 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f58c6c86520 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f58c6c93f8f in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f58c03432b8 in ?? () from /usr/lib/libpulsecommon-0.9.23.so
#7  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f58a2bcd700 (LWP 10228)):
#0  0x00007f58d0a33dc7 in ?? () from /usr/lib/libQtCore.so.4
#1  0x00007f58d0a33e95 in ?? () from /usr/lib/libQtCore.so.4
#2  0x00007f58c9a3b772 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0x00007f58c9a3c66d in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007f58c9a3cd09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007f58d0a348de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f58d0a08db2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f58d0a08fb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x00007f58d092069f in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x00007f58d09ebd8f in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#11 0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#12 0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#13 0x00007f58d0101e2d in clone () from /lib/libc.so.6
#14 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f58a143d700 (LWP 10229)):
#0  0x00007f58ce2d5e3b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58d092350e in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f58d0917ebf in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#5  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#6  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f58a0a36700 (LWP 10230)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58d092359b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f58cd693144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f58cd6956eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f58cd6945af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f58cd69463b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f589f8ba700 (LWP 10231)):
#0  0x00007f58d00f9b83 in poll () from /lib/libc.so.6
#1  0x00007f58c9a3c7d4 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f58c9a3cd09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f58d0a348de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f58d0a08db2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f58d0a08fb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f58d092069f in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f58d09ebd8f in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#10 0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#11 0x00007f58d0101e2d in clone () from /lib/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f589ee97700 (LWP 10232)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58d092359b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f58cd693144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f58cd6956eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f58cd6945af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f58cd69463b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f589e48a700 (LWP 10233)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58d092359b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f58cd693144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f58cd6956eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f58cd6945af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f58cd69463b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f589dc89700 (LWP 10234)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58d092359b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f58cd693144 in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007f58cd6956eb in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f58cd6945af in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f58cd69463b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6  0x00007f58d09230f5 in ?? () from /usr/lib/libQtCore.so.4
#7  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#8  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#9  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f589ce3f700 (LWP 10235)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58c60350ea in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f58c60351d9 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#4  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#5  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5896b5a700 (LWP 10238)):
#0  0x00007f58ce2d5ac4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f58cc6ac2e2 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007f58cc6ac319 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007f58beaaa56c in ?? () from /usr/lib/libGL.so.1
#4  0x00007f58ce2d1d60 in start_thread () from /lib/libpthread.so.0
#5  0x00007f58d0101e2d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f58d34e77a0 (LWP 10221)):
[KCrash Handler]
#6  0x00007f58d0907b30 in QAbstractAnimation::state() const () from /usr/lib/libQtCore.so.4
#7  0x00007f58d23a33dd in Context::ContextView::addCollapseAnimation(QAbstractAnimation*) () from /usr/lib/libamaroklib.so.1
#8  0x00007f58d239e533 in Context::Applet::collapse(bool) () from /usr/lib/libamaroklib.so.1
#9  0x00007f5897796cf6 in ?? () from /usr/lib/kde4/amarok_context_applet_albums.so
#10 0x00007f58977977d6 in ?? () from /usr/lib/kde4/amarok_context_applet_albums.so
#11 0x00007f58d0a1c7fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0x00007f58ccb02967 in Plasma::DataContainer::dataUpdated(QString const&, QHash<QString, QVariant> const&) () from /usr/lib/libplasma.so.3
#13 0x00007f58ccb02e3e in Plasma::DataContainer::checkForUpdate() () from /usr/lib/libplasma.so.3
#14 0x00007f58ccb0475f in Plasma::DataEngine::timerEvent(QTimerEvent*) () from /usr/lib/libplasma.so.3
#15 0x00007f58d0a200c9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x00007f58d13d1174 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f58d13d5fe1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f58d2efb226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007f58d0a09bbc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x00007f58d0a36732 in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f58d0a33eb4 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007f58c9a3c29d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f58c9a3ca78 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f58c9a3cd09 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f58d0a34876 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f58d14741be in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007f58d0a08db2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f58d0a08fb7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007f58d0a0d1ab in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x000000000040890e in ?? ()
#31 0x00007f58d004f17d in __libc_start_main () from /lib/libc.so.6
#32 0x000000000040b53d in _start ()

Reproducible: Always

Steps to Reproduce:
Launch amarok.
Sorry but I've completely forgotten what I've done during the last (working) session with amarok.


Actual Results:  
Crash

Expected Results:  
fix the problem
Comment 1 Myriam Schweingruber 2011-08-09 21:25:51 UTC
You don´t have debugging symbols installed for Amarok. Please install those first and try again.
Also please do not forget to specify which exact version of Amarok you are using in the bug report wizard.
Comment 2 Myriam Schweingruber 2011-09-08 20:23:33 UTC
Closing for lack of feedback. Feel free to reopen this report if you can still reproduce this with current Amarok 2.4.3 or later and provide a valid backtrace.
Comment 3 John Veitch 2011-10-14 18:45:16 UTC
Created attachment 64524 [details]
New crash information added by DrKonqi

amarok (2.4.3) on KDE Platform 4.7.1 (4.7.1) using Qt 4.7.4

- What I was doing when the application crashed:

Amarok crashed on startup. Has been happening for a couple of days now, appeared for no reason I can tell.

Appears to be the same as linked bug report, hopefully my BT will provide enough information.

-- Backtrace (Reduced):
#6  QAbstractAnimation::state (this=0x7fb600000000) at animation/qabstractanimation.cpp:510
#7  0x00007fb64640ef31 in Context::ContextView::addCollapseAnimation(QAbstractAnimation*) () from /usr/lib/libamaroklib.so.1
#8  0x00007fb64640a5b4 in Context::Applet::collapse(bool) () from /usr/lib/libamaroklib.so.1
[...]
#13 0x00007fb6412e6927 in Plasma::DataContainer::dataUpdated (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at ./datacontainer.moc:112
#14 0x00007fb6412e6dfe in Plasma::DataContainer::checkForUpdate (this=0x1899660) at ../../plasma/datacontainer.cpp:297
Comment 4 Myriam Schweingruber 2011-10-14 20:40:31 UTC
John, please install the debugging symbols for Amarok and provide a better backtrace.
Comment 5 Leonardo La Malfa 2011-11-16 09:22:27 UTC
Created attachment 65741 [details]
New crash information added by DrKonqi

amarok (2.4.3) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

I started Amarok this morning, and it crashed.

-- Backtrace (Reduced):
#6  0x00007f8143a29424 in QAbstractAnimation::state (this=0x7f81180c62c0) at animation/qabstractanimation.cpp:510
#7  0x00007f8145514f31 in Context::ContextView::addCollapseAnimation (this=0x7f81180c5ee0, anim=0x1277190) at ../../src/context/ContextView.cpp:240
#8  0x00007f81455105b4 in Context::Applet::collapse (this=0x1e3bc30, on=<optimized out>) at ../../src/context/Applet.cpp:320
#9  0x00007f810fa0e6d2 in Albums::dataUpdated (this=0x1e3bc30, data=<optimized out>, name=<optimized out>) at ../../../../../src/context/applets/albums/Albums.cpp:155
#10 0x00007f810fa0f939 in Albums::dataUpdated (this=0x1e3bc30, name=<optimized out>, data=...) at ../../../../../src/context/applets/albums/Albums.cpp:132
Comment 6 William W. Ferrell 2012-07-12 14:10:38 UTC
Created attachment 72475 [details]
New crash information added by DrKonqi

amarok (2.5.0) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.1

I'm also seeing this issue; full debugging symbols are installed and should be included with this backtrace (the Crash Reporting Assistant claims the backtrace it generated is "useful", so I'm crossing my fingers ;)).

The application crashes every time it's started. Attempting to clear the playback queue by passing "-l file:///dev/null" doesn't appear to help. On the command line, the following messages are printed:

wferrell@stewie:~$ amarok -m
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
Fading to 1 
Transitioning to state "ready" 
QWidget::insertAction: Attempt to insert null action
********************************************************************************************** 
** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: ** 
** amarok --debug                                                                           ** 
********************************************************************************************** 

(the --debug output is excessively lengthy and I figured I'd omit it unless you think it'd be useful; if so, I can regenerate it upon request)

-- Backtrace (Reduced):
#6  QAbstractAnimation::state (this=0x61663d6e00000064) at animation/qabstractanimation.cpp:662
#7  0x00007f8eb68a24aa in Context::ContextView::addCollapseAnimation (this=0x3025960, anim=0x3a713d0) at ../../src/context/ContextView.cpp:245
#8  0x00007f8eb689effe in Context::Applet::collapse (this=0x3185dd0, on=<optimized out>) at ../../src/context/Applet.cpp:321
#9  0x00007f8e845ee180 in WikipediaApplet::dataUpdated (this=0x3185dd0, source=..., data=...) at ../../../../../src/context/applets/wikipedia/WikipediaApplet.cpp:742
#10 0x00007f8e845f1e5d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./WikipediaApplet.moc:91
Comment 7 Myriam Schweingruber 2012-07-12 17:15:13 UTC
Folks, please stop adding debug outputs to a closed bug, All these are the same and are duplicates of a bug already solved in Amarok 2.6 Please everybody, read the backtrace, especially the bottom of it where there are links pointing in the right direction, but adding backtraces to closed bugs is pointless.

*** This bug has been marked as a duplicate of bug 258741 ***
Comment 8 William W. Ferrell 2012-07-12 17:16:48 UTC
Please accept my apologies; I didn't notice the [closed] attribute for this bug in the crash handler when it listed the potentially related bug reports.
Comment 9 Myriam Schweingruber 2012-07-12 17:22:25 UTC
(In reply to comment #8)
> Please accept my apologies; I didn't notice the [closed] attribute for this
> bug in the crash handler when it listed the potentially related bug reports.

Apologies accepted :) The status was set to RESOLVED which means the bug is closed