Bug 277129 - amarok crashes plasma
Summary: amarok crashes plasma
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-05 11:49 UTC by mercatino13
Modified: 2011-07-08 22:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mercatino13 2011-07-05 11:49:03 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I was closing amarok when plasma crashed, but it restarted automatically.

The crash can be reproduced every time.

-- Backtrace:
Application: Powłoka pulpitu Plazmy (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6117720 (LWP 1525))]

Thread 3 (Thread 0xae0e8b70 (LWP 1528)):
#0  0x00a37416 in __kernel_vsyscall ()
#1  0x00b89f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0816b84b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0815b1af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0815b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0848e577 in QEventDispatcherGlib::processEvents (this=0xa3e1498, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x08460289 in QEventLoop::processEvents (this=0xae0e8280, flags=...) at kernel/qeventloop.cpp:149
#7  0x08460522 in QEventLoop::exec (this=0xae0e8280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0836a2a0 in QThread::exec (this=0xa3dde40) at thread/qthread.cpp:492
#9  0x08441fdb in QInotifyFileSystemWatcherEngine::run (this=0xa3dde40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0836cda2 in QThreadPrivate::start (arg=0xa3dde40) at thread/qthread_unix.cpp:320
#11 0x00e8de99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00b9873e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xacaa6b70 (LWP 1529)):
#0  0x00e9036b in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00ba6616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x0815a009 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0815ae63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0815b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0848e577 in QEventDispatcherGlib::processEvents (this=0xa42a608, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x08460289 in QEventLoop::processEvents (this=0xacaa6280, flags=...) at kernel/qeventloop.cpp:149
#7  0x08460522 in QEventLoop::exec (this=0xacaa6280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0836a2a0 in QThread::exec (this=0xa444860) at thread/qthread.cpp:492
#9  0x08441fdb in QInotifyFileSystemWatcherEngine::run (this=0xa444860) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0836cda2 in QThreadPrivate::start (arg=0xa444860) at thread/qthread_unix.cpp:320
#11 0x00e8de99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00b9873e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb6117720 (LWP 1525)):
[KCrash Handler]
#7  0x0114c454 in QString (this=0x9ec0061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x9ec0061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01152352 in KIconLoaderPrivate::makeCacheKey (this=0x9ec004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x01159398 in KIconLoader::loadIcon (this=0xa65b278, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x01150d76 in KIconEngine::pixmap (this=0xa76e680, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x033fcca2 in QIcon::pixmap (this=0xa99d2ec, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x002ff969 in Plasma::IconWidgetPrivate::decoration (this=0xa99d248, option=0x9f07128, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x0030621d in Plasma::IconWidget::paint (this=0xa705dc0, painter=0xbfc8ba7c, option=0x9f07128, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x076a90dd in SystemTray::DBusSystemTrayWidget::paint (this=0xa705dc0, painter=0xbfc8ba7c, option=0x9f07128, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x039a59ec in _q_paintItem (item=<value optimized out>, painter=0xbfc8ba7c, option=0x9f07128, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x039a5cf2 in _q_paintIntoCache (pix=0xbfc8bf4c, item=0xa705dc8, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x9f07128, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0x039b9a00 in QGraphicsScenePrivate::drawItemHelper (this=0x9f06fd8, item=0xa705dc8, painter=0xbfc8d734, option=0x9f07128, widget=0xa4fa090, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0x039ba6c2 in QGraphicsScenePrivate::draw (this=0x9f06fd8, item=0xa705dc8, painter=0xbfc8d734, viewTransform=0xbfc8d51c, transformPtr=0xbfc8c330, exposedRegion=0xa756248, widget=0xa4fa090, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0x039bb402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9f06fd8, item=0xa705dc8, painter=0xbfc8d734, viewTransform=0xbfc8d51c, exposedRegion=0xa756248, widget=0xa4fa090, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0x039ba4ec in QGraphicsScenePrivate::draw (this=0x9f06fd8, item=0x9fd6ca0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, transformPtr=0xbfc8c7d0, exposedRegion=0xa756248, widget=0xa4fa090, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0x039bb402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9f06fd8, item=0x9fd6ca0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, exposedRegion=0xa756248, widget=0xa4fa090, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0x039ba4ec in QGraphicsScenePrivate::draw (this=0x9f06fd8, item=0x9ff33d0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, transformPtr=0xbfc8cc70, exposedRegion=0xa756248, widget=0xa4fa090, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0x039bb402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9f06fd8, item=0x9ff33d0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, exposedRegion=0xa756248, widget=0xa4fa090, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0x039ba4ec in QGraphicsScenePrivate::draw (this=0x9f06fd8, item=0x9f892c0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, transformPtr=0xbfc8d110, exposedRegion=0xa756248, widget=0xa4fa090, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0x039bb402 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x9f06fd8, item=0x9f892c0, painter=0xbfc8d734, viewTransform=0xbfc8d51c, exposedRegion=0xa756248, widget=0xa4fa090, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0x039bbc06 in QGraphicsScenePrivate::drawItems (this=0x9f06fd8, painter=0xbfc8d734, viewTransform=0xbfc8d51c, exposedRegion=0xa756248, widget=0xa4fa090) at graphicsview/qgraphicsscene.cpp:4735
#28 0x039daea1 in QGraphicsView::paintEvent (this=0xa4c5890, event=0xbfc8de44) at graphicsview/qgraphicsview.cpp:3469
#29 0x00c89484 in PanelView::paintEvent (this=0xa4c5890, event=0xbfc8de44) at ../../../../plasma/desktop/shell/panelview.cpp:1593
#30 0x0339f18e in QWidget::event (this=0xa4c5890, event=0xbfc8de44) at kernel/qwidget.cpp:8405
#31 0x03790f63 in QFrame::event (this=0xa4c5890, e=0xbfc8de44) at widgets/qframe.cpp:557
#32 0x0381f5d2 in QAbstractScrollArea::viewportEvent (this=0xa4c5890, e=0xbfc8de44) at widgets/qabstractscrollarea.cpp:1043
#33 0x039dc36f in QGraphicsView::viewportEvent (this=0xa4c5890, event=0xbfc8de44) at graphicsview/qgraphicsview.cpp:2864
#34 0x03821ed5 in viewportEvent (this=0xa3348b0, o=0xa4fa090, e=0xbfc8de44) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0xa3348b0, o=0xa4fa090, e=0xbfc8de44) at widgets/qabstractscrollarea_p.h:116
#36 0x0846125a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9e1b838, receiver=0xa4fa090, event=0xbfc8de44) at kernel/qcoreapplication.cpp:846
#37 0x03346d00 in QApplicationPrivate::notify_helper (this=0x9e1b838, receiver=0xa4fa090, e=0xbfc8de44) at kernel/qapplication.cpp:4458
#38 0x0334b97b in QApplication::notify (this=0x9e126a0, receiver=0xa4fa090, e=0xbfc8de44) at kernel/qapplication.cpp:4427
#39 0x011ab3ca in KApplication::notify (this=0x9e126a0, receiver=0xa4fa090, event=0xbfc8de44) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x084610bb in QCoreApplication::notifyInternal (this=0x9e126a0, receiver=0xa4fa090, event=0xbfc8de44) at kernel/qcoreapplication.cpp:731
#41 0x0339bf0c in sendSpontaneousEvent (this=0xa77ff00, pdev=0xa7198cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa3a8e60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0xa77ff00, pdev=0xa7198cc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa3a8e60) at kernel/qwidget.cpp:5492
#43 0x0339cb7c in QWidgetPrivate::paintSiblingsRecursive (this=0xa755ef8, pdev=0xa7198cc, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xa3a8e60) at kernel/qwidget.cpp:5699
#44 0x0339bc80 in QWidgetPrivate::drawWidget (this=0xa755ef8, pdev=0xa7198cc, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0xa3a8e60) at kernel/qwidget.cpp:5545
#45 0x03577908 in QWidgetBackingStore::sync (this=0xa3a8e60) at painting/qbackingstore.cpp:1333
#46 0x03391843 in QWidgetPrivate::syncBackingStore (this=0xa755ef8) at kernel/qwidget.cpp:1842
#47 0x0339f7e5 in QWidget::event (this=0xa4c5890, event=0xa65b278) at kernel/qwidget.cpp:8552
#48 0x03790f63 in QFrame::event (this=0xa4c5890, e=0xa65b278) at widgets/qframe.cpp:557
#49 0x0382133f in QAbstractScrollArea::event (this=0xa4c5890, e=0xa65b278) at widgets/qabstractscrollarea.cpp:996
#50 0x039cf686 in QGraphicsView::event (this=0xa4c5890, event=0xa65b278) at graphicsview/qgraphicsview.cpp:2741
#51 0x00c897c3 in PanelView::event (this=0xa4c5890, event=0xa65b278) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#52 0x03346d24 in QApplicationPrivate::notify_helper (this=0x9e1b838, receiver=0xa4c5890, e=0xa65b278) at kernel/qapplication.cpp:4462
#53 0x0334b97b in QApplication::notify (this=0x9e126a0, receiver=0xa4c5890, e=0xa65b278) at kernel/qapplication.cpp:4427
#54 0x011ab3ca in KApplication::notify (this=0x9e126a0, receiver=0xa4c5890, event=0xa65b278) at ../../kdeui/kernel/kapplication.cpp:311
#55 0x084610bb in QCoreApplication::notifyInternal (this=0x9e126a0, receiver=0xa4c5890, event=0xa65b278) at kernel/qcoreapplication.cpp:731
#56 0x08464c79 in sendEvent (receiver=0xa4c5890, event_type=77, data=0x9da8f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0xa4c5890, event_type=77, data=0x9da8f50) at kernel/qcoreapplication.cpp:1372
#58 0x08464e0d in QCoreApplication::sendPostedEvents (receiver=0xa4c5890, event_type=77) at kernel/qcoreapplication.cpp:1265
#59 0x039b21b6 in dispatchPendingUpdateRequests (this=0x9f06fd8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x9f06fd8) at graphicsview/qgraphicsscene.cpp:510
#61 0x039b2596 in QGraphicsScene::qt_metacall (this=0x9ee4b78, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa87e590) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#62 0x00242a9a in Plasma::Corona::qt_metacall (this=0x9ee4b78, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa87e590) at ./corona.moc:109
#63 0x00c7c20a in DesktopCorona::qt_metacall (this=0x9ee4b78, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa87e590) at ./desktopcorona.moc:101
#64 0x084676ba in QMetaObject::metacall (object=0x9ee4b78, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0xa87e590) at kernel/qmetaobject.cpp:237
#65 0x08471e16 in QMetaCallEvent::placeMetaCall (this=0xa8e08a0, object=0x9ee4b78) at kernel/qobject.cpp:535
#66 0x084763b7 in QObject::event (this=0x9ee4b78, e=0xa8e08a0) at kernel/qobject.cpp:1226
#67 0x039bf3b4 in QGraphicsScene::event (this=0x9ee4b78, event=0xa8e08a0) at graphicsview/qgraphicsscene.cpp:3544
#68 0x03346d24 in QApplicationPrivate::notify_helper (this=0x9e1b838, receiver=0x9ee4b78, e=0xa8e08a0) at kernel/qapplication.cpp:4462
#69 0x0334b8ce in QApplication::notify (this=0x9e126a0, receiver=0x9ee4b78, e=0xa8e08a0) at kernel/qapplication.cpp:3862
#70 0x011ab3ca in KApplication::notify (this=0x9e126a0, receiver=0x9ee4b78, event=0xa8e08a0) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x084610bb in QCoreApplication::notifyInternal (this=0x9e126a0, receiver=0x9ee4b78, event=0xa8e08a0) at kernel/qcoreapplication.cpp:731
#72 0x08464c79 in sendEvent (receiver=0x0, event_type=0, data=0x9da8f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9da8f50) at kernel/qcoreapplication.cpp:1372
#74 0x08464e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#75 0x0848e3c4 in sendPostedEvents (s=0x9e1d8f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x9e1d8f8) at kernel/qeventdispatcher_glib.cpp:277
#77 0x0815aaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#78 0x0815b270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#79 0x0815b524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#80 0x0848e53c in QEventDispatcherGlib::processEvents (this=0x9da8aa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#81 0x033fa775 in QGuiEventDispatcherGlib::processEvents (this=0x9da8aa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x08460289 in QEventLoop::processEvents (this=0xbfc8f634, flags=...) at kernel/qeventloop.cpp:149
#83 0x08460522 in QEventLoop::exec (this=0xbfc8f634, flags=...) at kernel/qeventloop.cpp:201
#84 0x08464ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#85 0x033448e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#86 0x00c835a5 in kdemain (argc=1, argv=0xbfc8f844) at ../../../../plasma/desktop/shell/main.cpp:118
#87 0x080485cb in main (argc=1, argv=0xbfc8f844) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 277093, bug 276408, bug 276393, bug 276332, bug 276256.

Reported using DrKonqi
Comment 1 Dario Andres 2011-07-08 22:36:32 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***