Bug 276393 - plasma crash on kill hanged amarok
Summary: plasma crash on kill hanged amarok
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-24 15:34 UTC by Belomir
Modified: 2011-09-20 15:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Belomir 2011-06-24 15:34:45 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-30-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

1) paused amarok
2) blocked session (screen saver is blank screen)
3) leaved it for about 1,5 hours
4) returned from screen saver — amarok is hang and eating 50% of CPU
5) killed amarok from KDE utility couse closing didn't do anything
6) plasma crashed

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77e7ad0 (LWP 1921))]

Thread 2 (Thread 0xaebffb70 (LWP 1963)):
#0  0x00271416 in __kernel_vsyscall ()
#1  0x001d1f76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0916da1b in g_poll (fds=0xaec01cc8, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.26.1/glib/gpoll.c:132
#3  0x0916043c in g_main_context_poll (context=0xaec006c8, block=<value optimized out>, dispatch=1, self=0xaec01ca0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:3093
#4  g_main_context_iterate (context=0xaec006c8, block=<value optimized out>, dispatch=1, self=0xaec01ca0) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2775
#5  0x09160848 in g_main_context_iteration (context=0xaec006c8, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#6  0x08e8259f in QEventDispatcherGlib::processEvents (this=0xa1085f8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x08e52609 in QEventLoop::processEvents (this=0xaebff280, flags=) at kernel/qeventloop.cpp:149
#8  0x08e52a8a in QEventLoop::exec (this=0xaebff280, flags=...) at kernel/qeventloop.cpp:201
#9  0x08d4eb7e in QThread::exec (this=0xa107ef8) at thread/qthread.cpp:490
#10 0x08e3135b in QInotifyFileSystemWatcherEngine::run (this=0xa107ef8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x08d51df9 in QThreadPrivate::start (arg=0xa107ef8) at thread/qthread_unix.cpp:266
#12 0x01ca8e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb77e7ad0 (LWP 1921)):
[KCrash Handler]
#7  0x011a1ba7 in QString (this=0xb540061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0xb540061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x011a5ad8 in KIconLoaderPrivate::makeCacheKey (this=0xb54004d, name=..., group=KIconLoader::Desktop, overlays=..., size=22, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x011adf08 in KIconLoader::loadIcon (this=0xb4de958, _name=..., group=KIconLoader::Desktop, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x011a43f6 in KIconEngine::pixmap (this=0xb5f0a38, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x05012626 in QIcon::pixmap (this=0xb2833d4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x00425442 in Plasma::IconWidgetPrivate::decoration (this=0xb283330, option=0x97d7138, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x00427ed7 in Plasma::IconWidget::paint (this=0xb59fb38, painter=0xbff1e9fc, option=0x97d7138, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x02f2d19d in SystemTray::DBusSystemTrayWidget::paint (this=0xb59fb38, painter=0xbff1e9fc, option=0x97d7138, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x0561752c in _q_paintItem (item=<value optimized out>, painter=0xbff1e9fc, option=0x97d7138, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x05619eaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x97d7138, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x05621718 in QGraphicsScenePrivate::drawItemHelper (this=0x97d6fe8, item=0xb59fb40, painter=0xbff206d4, option=0x97d7138, widget=0xa7c3408, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x056257d8 in QGraphicsScenePrivate::draw (this=0x97d6fe8, item=0xb59fb40, painter=0xbff206d4, viewTransform=0xbff204bc, transformPtr=0xbff1f330, exposedRegion=0xa7c7970, widget=0xa7c3408, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x056264a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97d6fe8, item=0xb59fb40, painter=0xbff206d4, viewTransform=0xbff204bc, exposedRegion=0xa7c7970, widget=0xa7c3408, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x05625874 in QGraphicsScenePrivate::draw (this=0x97d6fe8, item=0x9c21cc8, painter=0xbff206d4, viewTransform=0xbff204bc, transformPtr=0xbff1f7a0, exposedRegion=0xa7c7970, widget=0xa7c3408, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x056264a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97d6fe8, item=0x9c21cc8, painter=0xbff206d4, viewTransform=0xbff204bc, exposedRegion=0xa7c7970, widget=0xa7c3408, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x05625874 in QGraphicsScenePrivate::draw (this=0x97d6fe8, item=0x9c03910, painter=0xbff206d4, viewTransform=0xbff204bc, transformPtr=0xbff1fc10, exposedRegion=0xa7c7970, widget=0xa7c3408, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x056264a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97d6fe8, item=0x9c03910, painter=0xbff206d4, viewTransform=0xbff204bc, exposedRegion=0xa7c7970, widget=0xa7c3408, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x05625874 in QGraphicsScenePrivate::draw (this=0x97d6fe8, item=0x9b46a88, painter=0xbff206d4, viewTransform=0xbff204bc, transformPtr=0xbff20080, exposedRegion=0xa7c7970, widget=0xa7c3408, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x056264a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x97d6fe8, item=0x9b46a88, painter=0xbff206d4, viewTransform=0xbff204bc, exposedRegion=0xa7c7970, widget=0xa7c3408, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x05626cce in QGraphicsScenePrivate::drawItems (this=0x97d6fe8, painter=0xbff206d4, viewTransform=0xbff204bc, exposedRegion=0xa7c7970, widget=0xa7c3408) at graphicsview/qgraphicsscene.cpp:4699
#28 0x05652bb9 in QGraphicsView::paintEvent (this=0xa79e3e8, event=0xbff20df4) at graphicsview/qgraphicsview.cpp:3467
#29 0x00fc9904 in PanelView::paintEvent (this=0xa79e3e8, event=0xbff20df4) at ../../../../plasma/desktop/shell/panelview.cpp:1593
#30 0x04fabcc6 in QWidget::event (this=0xa79e3e8, event=0xbff20df4) at kernel/qwidget.cpp:8333
#31 0x053cd763 in QFrame::event (this=0xa79e3e8, e=0xbff20df4) at widgets/qframe.cpp:557
#32 0x0546aa82 in QAbstractScrollArea::viewportEvent (this=0x19005900, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x0564eccb in QGraphicsView::viewportEvent (this=0xa79e3e8, event=0xbff20df4) at graphicsview/qgraphicsview.cpp:2862
#34 0x0546d4d5 in viewportEvent (this=0xa1327c0, o=0xa7c3408, e=0xbff20df4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0xa1327c0, o=0xa7c3408, e=0xbff20df4) at widgets/qabstractscrollarea_p.h:116
#36 0x08e5329a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9786980, receiver=0xa7c3408, event=0xbff20df4) at kernel/qcoreapplication.cpp:847
#37 0x04f4dfb9 in QApplicationPrivate::notify_helper (this=0x9786980, receiver=0xa7c3408, e=0xbff20df4) at kernel/qapplication.cpp:4392
#38 0x04f540e9 in QApplication::notify (this=0x9776af0, receiver=0xa7c3408, e=0xbff20df4) at kernel/qapplication.cpp:4361
#39 0x0120982a in KApplication::notify (this=0x9776af0, receiver=0xa7c3408, event=0xbff20df4) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x08e53b3b in QCoreApplication::notifyInternal (this=0x9776af0, receiver=0xa7c3408, event=0xbff20df4) at kernel/qcoreapplication.cpp:732
#41 0x04fb2ee6 in sendSpontaneousEvent (this=0xa7c3420, pdev=0xa7c6334, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b456a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0xa7c3420, pdev=0xa7c6334, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5420
#43 0x04fb3cff in QWidgetPrivate::paintSiblingsRecursive (this=0xa7c7620, pdev=0xa7c6334, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5627
#44 0x04fb3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0xa7c7620, pdev=0xa7c6334, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5614
#45 0x04fb3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0xa7c7620, pdev=0xa7c6334, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5614
#46 0x04fb3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0xa7c7620, pdev=0xa7c6334, siblings=..., index=7, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5614
#47 0x04fb3b38 in QWidgetPrivate::paintSiblingsRecursive (this=0xa7c7620, pdev=0xa7c6334, siblings=..., index=8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5614
#48 0x04fb2c35 in QWidgetPrivate::drawWidget (this=0xa7c7620, pdev=0xa7c6334, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9b456a8) at kernel/qwidget.cpp:5473
#49 0x051a3c74 in QWidgetBackingStore::sync (this=0x9b456a8) at painting/qbackingstore.cpp:1328
#50 0x04fa52b3 in QWidgetPrivate::syncBackingStore (this=0xa7c7620) at kernel/qwidget.cpp:1805
#51 0x04fac466 in QWidget::event (this=0xa79e3e8, event=0xb4de958) at kernel/qwidget.cpp:8480
#52 0x053cd763 in QFrame::event (this=0xa79e3e8, e=0xb4de958) at widgets/qframe.cpp:557
#53 0x0546b487 in QAbstractScrollArea::event (this=0xa79e3e8, e=0xb4de958) at widgets/qabstractscrollarea.cpp:996
#54 0x05650ea6 in QGraphicsView::event (this=0xa79e3e8, event=0xb4de958) at graphicsview/qgraphicsview.cpp:2739
#55 0x00fccaa3 in PanelView::event (this=0xa79e3e8, event=0xb4de958) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#56 0x04f4dfdc in QApplicationPrivate::notify_helper (this=0x9786980, receiver=0xa79e3e8, e=0xb4de958) at kernel/qapplication.cpp:4396
#57 0x04f540e9 in QApplication::notify (this=0x9776af0, receiver=0xa79e3e8, e=0xb4de958) at kernel/qapplication.cpp:4361
#58 0x0120982a in KApplication::notify (this=0x9776af0, receiver=0xa79e3e8, event=0xb4de958) at ../../kdeui/kernel/kapplication.cpp:311
#59 0x08e53b3b in QCoreApplication::notifyInternal (this=0x9776af0, receiver=0xa79e3e8, event=0xb4de958) at kernel/qcoreapplication.cpp:732
#60 0x08e56d8b in sendEvent (receiver=0xa79e3e8, event_type=77, data=0x9724f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#61 QCoreApplicationPrivate::sendPostedEvents (receiver=0xa79e3e8, event_type=77, data=0x9724f50) at kernel/qcoreapplication.cpp:1373
#62 0x08e56f4d in QCoreApplication::sendPostedEvents (receiver=0xa79e3e8, event_type=77) at kernel/qcoreapplication.cpp:1266
#63 0x05636c3e in dispatchPendingUpdateRequests (this=0x97d6fe8) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#64 QGraphicsScenePrivate::_q_processDirtyItems (this=0x97d6fe8) at graphicsview/qgraphicsscene.cpp:510
#65 0x05637116 in QGraphicsScene::qt_metacall (this=0x97e5a58, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xb5adbf8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#66 0x00351a1a in Plasma::Corona::qt_metacall (this=0x97e5a58, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xb5adbf8) at ./corona.moc:109
#67 0x00fb81ca in DesktopCorona::qt_metacall (this=0x97e5a58, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xb5adbf8) at ./desktopcorona.moc:101
#68 0x08e598ca in QMetaObject::metacall (object=0x97e5a58, cl=419453184, idx=18, argv=0xb5adbf8) at kernel/qmetaobject.cpp:237
#69 0x08e64df6 in QMetaCallEvent::placeMetaCall (this=0xb4dfb08, object=0x97e5a58) at kernel/qobject.cpp:534
#70 0x08e666a2 in QObject::event (this=0x97e5a58, e=0x0) at kernel/qobject.cpp:1219
#71 0x05633374 in QGraphicsScene::event (this=0x97e5a58, event=0xb4dfb08) at graphicsview/qgraphicsscene.cpp:3548
#72 0x04f4dfdc in QApplicationPrivate::notify_helper (this=0x9786980, receiver=0x97e5a58, e=0xb4dfb08) at kernel/qapplication.cpp:4396
#73 0x04f5404e in QApplication::notify (this=0x9776af0, receiver=0x97e5a58, e=0xb4dfb08) at kernel/qapplication.cpp:3798
#74 0x0120982a in KApplication::notify (this=0x9776af0, receiver=0x97e5a58, event=0xb4dfb08) at ../../kdeui/kernel/kapplication.cpp:311
#75 0x08e53b3b in QCoreApplication::notifyInternal (this=0x9776af0, receiver=0x97e5a58, event=0xb4dfb08) at kernel/qcoreapplication.cpp:732
#76 0x08e56d8b in sendEvent (receiver=0x0, event_type=0, data=0x9724f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#77 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9724f50) at kernel/qcoreapplication.cpp:1373
#78 0x08e56f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#79 0x08e82a74 in sendPostedEvents (s=0x978d510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#80 postEventSourceDispatch (s=0x978d510) at kernel/qeventdispatcher_glib.cpp:277
#81 0x0915c855 in g_main_dispatch (context=0x978d490) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2149
#82 g_main_context_dispatch (context=0x978d490) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2702
#83 0x09160668 in g_main_context_iterate (context=0x978d490, block=<value optimized out>, dispatch=1, self=0x9791860) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2780
#84 0x09160848 in g_main_context_iteration (context=0x978d490, may_block=1) at /build/buildd/glib2.0-2.26.1/glib/gmain.c:2843
#85 0x08e82565 in QEventDispatcherGlib::processEvents (this=0x9724a00, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#86 0x0500fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9724a00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#87 0x08e52609 in QEventLoop::processEvents (this=0xbff22bb4, flags=) at kernel/qeventloop.cpp:149
#88 0x08e52a8a in QEventLoop::exec (this=0xbff22bb4, flags=...) at kernel/qeventloop.cpp:201
#89 0x08e5700f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#90 0x04f4ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#91 0x00fc11e7 in kdemain (argc=1, argv=0xbff22dc4) at ../../../../plasma/desktop/shell/main.cpp:118
#92 0x080485bb in main (argc=1, argv=0xbff22dc4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 276332.

Possible duplicates by query: bug 276332, bug 276256, bug 276223, bug 275966, bug 275909.

Reported using DrKonqi
Comment 1 Dario Andres 2011-06-26 14:13:47 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.2.
The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***