Bug 277114 - Plasma crashes when I am clicking on icons in tray area.
Summary: Plasma crashes when I am clicking on icons in tray area.
Status: RESOLVED DUPLICATE of bug 264079
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-05 08:23 UTC by Artem
Modified: 2011-07-08 22:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem 2011-07-05 08:23:04 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.5-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
It`s a regular bug, I am getting plasma crashed when clicking on the icons in the tray (thunderbird, kopete, ktorrent)... It`s not all the time, but regular.

-- Backtrace:
Application: Оболочка Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb584e710 (LWP 3557))]

Thread 2 (Thread 0xa8fbab70 (LWP 3562)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb604203e in poll () from /lib/libc.so.6
#2  0xb5ac80bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5ab7c46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5ab7fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6e367b7 in QEventDispatcherGlib::processEvents (this=0x84cc0f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6e072bd in QEventLoop::processEvents (this=0xa8fba2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6e074e9 in QEventLoop::exec (this=0xa8fba2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6d087b9 in QThread::exec (this=0x840d078) at thread/qthread.cpp:490
#9  0xb6de723d in QInotifyFileSystemWatcherEngine::run (this=0x840d078) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6d0b3aa in QThreadPrivate::start (arg=0x840d078) at thread/qthread_unix.cpp:285
#11 0xb6c8fb05 in start_thread () from /lib/libpthread.so.0
#12 0xb604cd5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb584e710 (LWP 3557)):
[KCrash Handler]
#7  0xae22699b in TaskItemLayout::preferredColumns (this=0x83e3850) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:247
#8  0xae226b2e in TaskItemLayout::gridLayoutSize (this=0x83e3850) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:265
#9  0xae226c0c in TaskItemLayout::layoutItems (this=0x83e3850) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:288
#10 0xae227828 in TaskItemLayout::insert (this=0x83e3850, index=0, item=0x89ec360) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:149
#11 0xae2279b3 in TaskItemLayout::addTaskItem (this=0x83e3850, item=0x89ec360) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:102
#12 0xae235932 in TaskGroupItem::itemAdded (this=0x83eeed8, groupableItem=0x8a9f8a0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:509
#13 0xae235c54 in TaskGroupItem::reload (this=0x83eeed8) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:330
#14 0xae23601d in TaskGroupItem::setGroup (this=0x83eeed8, group=0x83f0a98) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:379
#15 0xae220772 in Tasks::reload (this=0x8374010) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/tasks.cpp:266
#16 0xae22359c in Tasks::qt_metacall (this=0x8374010, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd67f9c) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/desktop/applets/tasks/tasks.moc:99
#17 0xb6e0e8cd in QMetaObject::metacall (object=0x8374010, cl=QMetaObject::InvokeMetaMethod, idx=67, argv=0xbfd67f9c) at kernel/qmetaobject.cpp:237
#18 0xb6e1ea2c in QMetaObject::activate (sender=0x83ed450, m=0xae285bd0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3272
#19 0xae2575d5 in TaskManager::GroupManager::reload (this=0x83ed450) at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/taskmanager/groupmanager.moc:130
#20 0xae25ab62 in TaskManager::GroupManagerPrivate::actuallyReloadTasks (this=0x83ed8c0) at /usr/src/debug/kdebase-workspace-4.6.0/libs/taskmanager/groupmanager.cpp:191
#21 0xae25c0cb in TaskManager::GroupManager::qt_metacall (this=0x83ed450, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfd6812c) at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/taskmanager/groupmanager.moc:117
#22 0xb6e0e8cd in QMetaObject::metacall (object=0x83ed450, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0xbfd6812c) at kernel/qmetaobject.cpp:237
#23 0xb6e1ea2c in QMetaObject::activate (sender=0x83ed8f8, m=0xb6f425a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3272
#24 0xb6e6dfe5 in QTimer::timeout (this=0x83ed8f8) at .moc/release-shared/moc_qtimer.cpp:134
#25 0xb6e25046 in QTimer::timerEvent (this=0x83ed8f8, e=0xbfd6866c) at kernel/qtimer.cpp:271
#26 0xb6e1d3f4 in QObject::event (this=0x83ed8f8, e=0xbfd6866c) at kernel/qobject.cpp:1175
#27 0xb6314414 in QApplicationPrivate::notify_helper (this=0x80dc298, receiver=0x83ed8f8, e=0xbfd6866c) at kernel/qapplication.cpp:4445
#28 0xb631d0c7 in QApplication::notify (this=0x80d5a48, receiver=0x83ed8f8, e=0xbfd6866c) at kernel/qapplication.cpp:3845
#29 0xb74621f1 in KApplication::notify (this=0x80d5a48, receiver=0x83ed8f8, event=0xbfd6866c) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#30 0xb6e07fde in QCoreApplication::notifyInternal (this=0x80d5a48, receiver=0x83ed8f8, event=0xbfd6866c) at kernel/qcoreapplication.cpp:732
#31 0xb6e39379 in sendEvent (this=0x80de634) at kernel/qcoreapplication.h:215
#32 QTimerInfoList::activateTimers (this=0x80de634) at kernel/qeventdispatcher_unix.cpp:618
#33 0xb6e36042 in timerSourceDispatch (source=0x80de600) at kernel/qeventdispatcher_glib.cpp:184
#34 0xb5ab7509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0xb5ab7d10 in ?? () from /lib/libglib-2.0.so.0
#36 0xb5ab7fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0xb6e3676b in QEventDispatcherGlib::processEvents (this=0x80c4a00, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#38 0xb63ca55a in QGuiEventDispatcherGlib::processEvents (this=0x80c4a00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0xb6e072bd in QEventLoop::processEvents (this=0xbfd68914, flags=...) at kernel/qeventloop.cpp:149
#40 0xb6e074e9 in QEventLoop::exec (this=0xbfd68914, flags=...) at kernel/qeventloop.cpp:201
#41 0xb6e0bf90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0xb6312104 in QApplication::exec () at kernel/qapplication.cpp:3719
#43 0xb0d498aa in kdemain (argc=1, argv=0x805cdf8) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#44 0x0804e531 in _start ()

Possible duplicates by query: bug 276595, bug 268295, bug 266400, bug 264167, bug 264079.

Reported using DrKonqi
Comment 1 Dario Andres 2011-07-08 22:46:02 UTC
[Comment from a bug triager]
The bug is fixed in later 4.6.x releases. The issue was being tracked at bug 264079, merging.
Thanks

*** This bug has been marked as a duplicate of bug 264079 ***