Bug 276595 - plasma crash while working with firefox 4
Summary: plasma crash while working with firefox 4
Status: RESOLVED DUPLICATE of bug 264079
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-27 08:40 UTC by Michael Monnerie
Modified: 2011-07-08 22:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2011-06-27 08:40:18 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39.1-zmi x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
I was working with Firefox 4, opening a new window (CTRL+N).

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0bbd09f760 (LWP 3371))]

Thread 2 (Thread 0x7f0ba1756700 (LWP 3373)):
#0  0x00007f0bba799503 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0bb760b114 in g_main_context_poll (context=0x16e0e60, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0x16e0e60, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3086
#3  0x00007f0bb760b650 in g_main_context_iteration (context=0x16e0e60, may_block=1) at gmain.c:3154
#4  0x00007f0bbbd8a976 in QEventDispatcherGlib::processEvents (this=0x16e0130, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f0bbbd5f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f0bbbd5f265 in QEventLoop::exec (this=0x7f0ba1755de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f0bbbc741e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f0bbbd40968 in QInotifyFileSystemWatcherEngine::run (this=0x16adb50) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f0bbbc76a5e in QThreadPrivate::start (arg=0x16adb50) at thread/qthread_unix.cpp:285
#10 0x00007f0bbb9e7a3f in start_thread (arg=0x7f0ba1756700) at pthread_create.c:297
#11 0x00007f0bba7a267d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0bbd09f760 (LWP 3371)):
[KCrash Handler]
#6  0x00007f0ba32ee0bb in TaskItemLayout::preferredColumns (this=0x1d6b780) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:247
#7  0x00007f0ba32ee21d in TaskItemLayout::gridLayoutSize (this=0x1d6b780) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:265
#8  0x00007f0ba32ee2ad in TaskItemLayout::layoutItems (this=0x1d6b780) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:288
#9  0x00007f0ba32eed9a in TaskItemLayout::insert (this=0x1d6b780, index=<value optimized out>, item=0x20f72a0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:149
#10 0x00007f0ba32eeeec in TaskItemLayout::addTaskItem (this=0x1d6b780, item=0x20f72a0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:102
#11 0x00007f0ba32fb478 in TaskGroupItem::itemAdded (this=0x1d67370, groupableItem=0x2097140) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:509
#12 0x00007f0ba32fb781 in TaskGroupItem::reload (this=0x1d67370) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:330
#13 0x00007f0ba32fbb77 in TaskGroupItem::setGroup (this=0x1d67370, group=0x202feb0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:379
#14 0x00007f0ba32eb4ec in Tasks::qt_metacall (this=0x1746620, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa966e9c0) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/desktop/applets/tasks/tasks.moc:99
#15 0x00007f0bbbd74def in QMetaObject::activate (sender=0x1d65540, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#16 0x00007f0ba30a8243 in TaskManager::GroupManagerPrivate::actuallyReloadTasks (this=0x1d66560) at /usr/src/debug/kdebase-workspace-4.6.0/libs/taskmanager/groupmanager.cpp:191
#17 0x00007f0ba30a96f1 in TaskManager::GroupManager::qt_metacall (this=0x1d65540, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fffa966ebb0) at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/taskmanager/groupmanager.moc:117
#18 0x00007f0bbbd74def in QMetaObject::activate (sender=0x1d665b8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#19 0x00007f0bbbd73799 in QObject::event (this=0x1d665b8, e=<value optimized out>) at kernel/qobject.cpp:1175
#20 0x00007f0bbaf0ed14 in QApplicationPrivate::notify_helper (this=0x12403b0, receiver=0x1d665b8, e=0x7fffa966f350) at kernel/qapplication.cpp:4445
#21 0x00007f0bbaf1722a in QApplication::notify (this=<value optimized out>, receiver=0x1d665b8, e=0x7fffa966f350) at kernel/qapplication.cpp:4324
#22 0x00007f0bbca039e6 in KApplication::notify (this=0x12363c0, receiver=0x1d665b8, event=0x7fffa966f350) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#23 0x00007f0bbbd5fbfc in QCoreApplication::notifyInternal (this=0x12363c0, receiver=0x1d665b8, event=0x7fffa966f350) at kernel/qcoreapplication.cpp:732
#24 0x00007f0bbbd8d4d8 in sendEvent (this=0x1243b80) at kernel/qcoreapplication.h:215
#25 QTimerInfoList::activateTimers (this=0x1243b80) at kernel/qeventdispatcher_unix.cpp:618
#26 0x00007f0bbbd8a244 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#27 0x00007f0bb760abd3 in g_main_dispatch (context=0x12429b0) at gmain.c:2440
#28 g_main_context_dispatch (context=0x12429b0) at gmain.c:3013
#29 0x00007f0bb760b3b0 in g_main_context_iterate (context=0x12429b0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3091
#30 0x00007f0bb760b650 in g_main_context_iteration (context=0x12429b0, may_block=1) at gmain.c:3154
#31 0x00007f0bbbd8a91f in QEventDispatcherGlib::processEvents (this=0x1236e20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f0bbafb3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f0bbbd5f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f0bbbd5f265 in QEventLoop::exec (this=0x7fffa966f660, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f0bbbd636ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#36 0x00007f0bac407da8 in kdemain (argc=1, argv=0x1229870) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#37 0x00000000004075e9 in _start ()

This bug may be a duplicate of or related to bug 264079.

Possible duplicates by query: bug 268295, bug 266400, bug 264167, bug 264079, bug 243357.

Reported using DrKonqi
Comment 1 Dario Andres 2011-07-08 22:45:55 UTC
[Comment from a bug triager]
The bug is fixed in later 4.6.x releases. The issue was being tracked at bug 264079, merging.
Thanks

*** This bug has been marked as a duplicate of bug 264079 ***