Bug 266400 - Plasma crashed on changing virtual desktop
Summary: Plasma crashed on changing virtual desktop
Status: RESOLVED DUPLICATE of bug 264079
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 20:35 UTC by Alexey Chernov
Modified: 2011-02-15 20:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2011-02-15 20:35:39 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.36.1 x86_64

-- Information about the crash:
I've tested a plasmoid in a windowed mode (maybe it affected the whole Plasma) and changed the virtual desktop with the hotkey, Plasma suddenly crashed.

-- Backtrace:
Application: Оболочка Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5995e73760 (LWP 2065))]

Thread 2 (Thread 0x7f5961d5a710 (LWP 2080)):
#0  0x00007f598f1eb7b0 in g_main_context_query () from /usr/lib/libglib-2.0.so.0
#1  0x00007f598f1f094c in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0x00007f598f1f0eac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f59947ff1c6 in QEventDispatcherGlib::processEvents (this=0x1902dd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f59947c8f62 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f59947c9345 in QEventLoop::exec (this=0x7f5961d59de0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f59946b1e17 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f59947a3830 in QInotifyFileSystemWatcherEngine::run (this=0x18f7be0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f59946b4e07 in QThreadPrivate::start (arg=0x18f7be0) at thread/qthread_unix.cpp:285
#9  0x00007f5994411aca in start_thread (arg=<value optimized out>) at pthread_create.c:297
#10 0x00007f59928f358d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f5995e73760 (LWP 2065)):
[KCrash Handler]
#6  0x00007f596c4a7cc3 in TaskItemLayout::preferredColumns (this=0x18e6890) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:247
#7  0x00007f596c4a7e4b in TaskItemLayout::gridLayoutSize (this=0x18e6890) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:265
#8  0x00007f596c4a7f04 in TaskItemLayout::layoutItems (this=0x18e6890) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:288
#9  0x00007f596c4a75a5 in TaskItemLayout::insert (this=0x18e6890, index=0, item=0x34d39f0) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:149
#10 0x00007f596c4a7258 in TaskItemLayout::addTaskItem (this=0x18e6890, item=0x34d39f0) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskitemlayout.cpp:102
#11 0x00007f596c4b688a in TaskGroupItem::itemAdded (this=0x18c4870, groupableItem=0x10290f0) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:509
#12 0x00007f596c4b598e in TaskGroupItem::reload (this=0x18c4870) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:330
#13 0x00007f596c4b5e44 in TaskGroupItem::setGroup (this=0x18c4870, group=0x18cb500) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/taskgroupitem.cpp:379
#14 0x00007f596c4a03f2 in Tasks::reload (this=0x1507770) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/tasks.cpp:266
#15 0x00007f596c4a216d in Tasks::qt_metacall (this=0x1507770, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fff33203a80)
    at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/build/plasma/desktop/applets/tasks/tasks.moc:99
#16 0x00007f59947e878f in QMetaObject::activate (sender=0x18c2cd0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x40973c0000000000) at kernel/qobject.cpp:3272
#17 0x00007f596c2423f3 in TaskManager::GroupManager::reload (this=0x18c2cd0) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/build/libs/taskmanager/groupmanager.moc:130
#18 0x00007f596c23ed26 in TaskManager::GroupManagerPrivate::actuallyReloadTasks (this=0x18c34f0) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/libs/taskmanager/groupmanager.cpp:191
#19 0x00007f596c24236e in TaskManager::GroupManager::qt_metacall (this=0x18c2cd0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fff33203cc0)
    at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/build/libs/taskmanager/groupmanager.moc:117
#20 0x00007f59947e878f in QMetaObject::activate (sender=0x18c3548, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x40973c0000000000) at kernel/qobject.cpp:3272
#21 0x00007f59947e0fc9 in QObject::event (this=0x18c3548, e=0x7fff33203308) at kernel/qobject.cpp:1175
#22 0x00007f599378daf0 in QApplicationPrivate::notify_helper (this=0xda7950, receiver=0x18c3548, e=0x7fff33204430) at kernel/qapplication.cpp:4445
#23 0x00007f599379ae89 in QApplication::notify (this=0xd9c630, receiver=<value optimized out>, e=0x7fff33204430) at kernel/qapplication.cpp:4324
#24 0x00007f59958d1c01 in KApplication::notify (this=0xd9c630, receiver=0x18c3548, event=0x7fff33204430) at /usr/src/packages/kde4/4.6.0/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#25 0x00007f59947ca36b in QCoreApplication::notifyInternal (this=0xd9c630, receiver=0x18c3548, event=0x7fff33204430) at kernel/qcoreapplication.cpp:732
#26 0x00007f5994802b6a in QCoreApplication::sendEvent (this=0xdaae90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QTimerInfoList::activateTimers (this=0xdaae90) at kernel/qeventdispatcher_unix.cpp:603
#28 0x00007f59947ff444 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#29 0x00007f598f1f03fc in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00007f598f1f0ce8 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#31 0x00007f598f1f0eac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0x00007f59947ff173 in QEventDispatcherGlib::processEvents (this=0xda76a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#33 0x00007f599385b03e in QGuiEventDispatcherGlib::processEvents (this=0x3512a90, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f59947c8f62 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#35 0x00007f59947c9345 in QEventLoop::exec (this=0x7fff332046f0, flags=) at kernel/qeventloop.cpp:201
#36 0x00007f59947cf6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x00007f5977408b4b in kdemain (argc=1, argv=0xd57f20) at /usr/src/packages/kde4/4.6.0/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#38 0x00000000004071e9 in launch (argc=1, _name=0xd4c678 "/usr/bin/plasma-desktop", args=0xd4c690 "", cwd=0x0, envc=0, envs=0xd4c698 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x40ced5 "0") at /usr/src/packages/kde4/4.6.0/kdelibs-4.6.0/kinit/kinit.cpp:730
#39 0x0000000000408343 in handle_launcher_request (sock=8, who=0x40d16c "launcher") at /usr/src/packages/kde4/4.6.0/kdelibs-4.6.0/kinit/kinit.cpp:1222
#40 0x0000000000408be0 in handle_requests (waitForPid=0) at /usr/src/packages/kde4/4.6.0/kdelibs-4.6.0/kinit/kinit.cpp:1415
#41 0x000000000040a6ab in main (argc=4, argv=0x7fff33205538, envp=0x7fff33205560) at /usr/src/packages/kde4/4.6.0/kdelibs-4.6.0/kinit/kinit.cpp:1903

This bug may be a duplicate of or related to bug 264079.

Possible duplicates by query: bug 264167, bug 264079, bug 243357, bug 232960, bug 231252.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-02-15 20:46:21 UTC

*** This bug has been marked as a duplicate of bug 264079 ***