Bug 277112 - Krusader Crash In Managing Bookmarks
Summary: Krusader Crash In Managing Bookmarks
Status: RESOLVED DUPLICATE of bug 263125
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-05 07:54 UTC by macinville
Modified: 2011-07-11 11:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description macinville 2011-07-05 07:54:04 UTC
Application: keditbookmarks (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Whenever I drag a bookmark in a folder while managing bookmarks, Manage Bookmarks always crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdc566dd780 (LWP 4403))]

Thread 2 (Thread 0x7fdc4ab0c700 (LWP 4404)):
#0  0x00007fdc55ffef03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fdc501f8104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc501f89f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc4b46bc44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fdc5021f3e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fdc506c3d8c in start_thread (arg=0x7fdc4ab0c700) at pthread_create.c:304
#6  0x00007fdc5600c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdc566dd780 (LWP 4403)):
[KCrash Handler]
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x28ce730, source_parent=..., parent_mapping=<value optimized out>, orient=42762064, start=1, end=1, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#7  0x00007fdc54824ba1 in QSortFilterProxyModelPrivate::source_items_removed (this=0x28ce730, source_parent=..., start=1, end=1, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:888
#8  0x00007fdc5482993c in QSortFilterProxyModel::qt_metacall (this=0x28cded0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fffa564fa70) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#9  0x00007fdc538e15f8 in QMetaObject::activate (sender=0x2859590, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffa564fa70) at kernel/qobject.cpp:3287
#10 0x00007fdc53927fd4 in QAbstractItemModel::rowsRemoved (this=<value optimized out>, _t1=<value optimized out>, _t2=1, _t3=1) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#11 0x00007fdc538c7428 in QAbstractItemModel::endRemoveRows (this=0x2859590) at kernel/qabstractitemmodel.cpp:2466
#12 0x00007fdc55d1e63a in KBookmarkModel::removeBookmark (this=0x2859590, bookmark=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:451
#13 0x00007fdc55d19b3b in CreateCommand::undo (this=0x2ab0c90) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:156
#14 0x00007fdc55d1c759 in DeleteCommand::redo (this=0x2a951c0) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:320
#15 0x00007fdc55d1b479 in MoveCommand::redo (this=0x2aaa8d0) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:377
#16 0x00007fdc548e7e89 in QUndoCommand::redo (this=0x2aa5790) at util/qundostack.cpp:208
#17 0x00007fdc548e9433 in QUndoStack::push (this=0x282a758, cmd=0x2aa5790) at util/qundostack.cpp:541
#18 0x00007fdc55d19876 in CommandHistory::addCommand (this=0x2833be0, cmd=0x2aa5790) at ../../../keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#19 0x00007fdc55d1f3e7 in KBookmarkModel::dropMimeData (this=0x2859590, data=0x290dec0, action=<value optimized out>, row=<value optimized out>, column=<value optimized out>, parent=<value optimized out>) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:380
#20 0x00007fdc547a42a1 in QAbstractItemView::dropEvent (this=0x2890ca0, event=0x7fffa5650bb0) at itemviews/qabstractitemview.cpp:1990
#21 0x00007fdc542dd009 in QWidget::event (this=0x2890ca0, event=0x7fffa5650bb0) at kernel/qwidget.cpp:8449
#22 0x00007fdc5468ca66 in QFrame::event (this=0x2890ca0, e=0x7fffa5650bb0) at widgets/qframe.cpp:557
#23 0x00007fdc5479dd7b in QAbstractItemView::viewportEvent (this=0x2890ca0, event=0x7fffa5650bb0) at itemviews/qabstractitemview.cpp:1628
#24 0x00007fdc547e1f85 in QTreeView::viewportEvent (this=0x2890ca0, event=0x7fffa5650bb0) at itemviews/qtreeview.cpp:1256
#25 0x00007fdc538cc627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x28850e0, event=0x7fffa5650bb0) at kernel/qcoreapplication.cpp:846
#26 0x00007fdc5428b9b1 in QApplicationPrivate::notify_helper (this=0x25b6200, receiver=0x28850e0, e=0x7fffa5650bb0) at kernel/qapplication.cpp:4458
#27 0x00007fdc54290611 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=0x7fffa5650bb0) at kernel/qapplication.cpp:4266
#28 0x00007fdc54faa866 in KApplication::notify (this=0x7fffa5653ee0, receiver=0x28850e0, event=0x7fffa5650bb0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fdc538cc49c in QCoreApplication::notifyInternal (this=0x7fffa5653ee0, receiver=0x28850e0, event=0x7fffa5650bb0) at kernel/qcoreapplication.cpp:731
#30 0x00007fdc54316189 in sendEvent (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QX11Data::xdndHandleDrop (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at kernel/qdnd_x11.cpp:1183
#32 0x00007fdc54317233 in QDragManager::drop (this=0x2a947d0) at kernel/qdnd_x11.cpp:1725
#33 0x00007fdc54319d68 in QDragManager::eventFilter (this=0x2a947d0, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1312
#34 0x00007fdc538cc56b in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x25b6200, receiver=0x2aa6760, event=0x7fffa5651480) at kernel/qcoreapplication.cpp:827
#35 0x00007fdc5428b956 in QApplicationPrivate::notify_helper (this=0x25b6200, receiver=0x2aa6760, e=0x7fffa5651480) at kernel/qapplication.cpp:4437
#36 0x00007fdc54290db3 in QApplication::notify (this=<value optimized out>, receiver=0x2aa6760, e=0x7fffa5651480) at kernel/qapplication.cpp:4023
#37 0x00007fdc54faa866 in KApplication::notify (this=0x7fffa5653ee0, receiver=0x2aa6760, event=0x7fffa5651480) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007fdc538cc49c in QCoreApplication::notifyInternal (this=0x7fffa5653ee0, receiver=0x2aa6760, event=0x7fffa5651480) at kernel/qcoreapplication.cpp:731
#39 0x00007fdc5428ca0d in sendEvent (receiver=0x2aa6760, event=0x7fffa5651480, alienWidget=0x0, nativeWidget=0x2aa6760, buttonDown=0x7fdc54d6c218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QApplicationPrivate::sendMouseEvent (receiver=0x2aa6760, event=0x7fffa5651480, alienWidget=0x0, nativeWidget=0x2aa6760, buttonDown=0x7fdc54d6c218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#41 0x00007fdc5430c600 in QETWidget::translateMouseEvent (this=0x2aa6760, event=<value optimized out>) at kernel/qapplication_x11.cpp:4556
#42 0x00007fdc5430b04a in QApplication::x11ProcessEvent (this=0x7fffa5653ee0, event=0x7fffa5651dd0) at kernel/qapplication_x11.cpp:3678
#43 0x00007fdc54333162 in x11EventSourceDispatch (s=0x25ba810, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0x00007fdc501f7bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007fdc501f83a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007fdc501f8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007fdc538f73ef in QEventDispatcherGlib::processEvents (this=0x256b340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007fdc54332dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007fdc538cb882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#50 0x00007fdc538cbabc in QEventLoop::exec (this=0x2a96250, flags=...) at kernel/qeventloop.cpp:201
#51 0x00007fdc54319a84 in QDragManager::drag (this=0x2a947d0, o=<value optimized out>) at kernel/qdnd_x11.cpp:1981
#52 0x00007fdc5429d888 in QDrag::exec (this=0x2a96130, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#53 0x00007fdc547a78bf in QAbstractItemView::startDrag (this=0x2890ca0, supportedActions=...) at itemviews/qabstractitemview.cpp:3448
#54 0x00007fdc547a66d3 in QAbstractItemView::mouseMoveEvent (this=0x2890ca0, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1709
#55 0x00007fdc542dccec in QWidget::event (this=0x2890ca0, event=0x7fffa5653140) at kernel/qwidget.cpp:8244
#56 0x00007fdc5468ca66 in QFrame::event (this=0x2890ca0, e=0x7fffa5653140) at widgets/qframe.cpp:557
#57 0x00007fdc5479dd7b in QAbstractItemView::viewportEvent (this=0x2890ca0, event=0x7fffa5653140) at itemviews/qabstractitemview.cpp:1628
#58 0x00007fdc547e1f85 in QTreeView::viewportEvent (this=0x2890ca0, event=0x7fffa5653140) at itemviews/qtreeview.cpp:1256
#59 0x00007fdc538cc627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x28850e0, event=0x7fffa5653140) at kernel/qcoreapplication.cpp:846
#60 0x00007fdc5428b9b1 in QApplicationPrivate::notify_helper (this=0x25b6200, receiver=0x28850e0, e=0x7fffa5653140) at kernel/qapplication.cpp:4458
#61 0x00007fdc54290db3 in QApplication::notify (this=<value optimized out>, receiver=0x28850e0, e=0x7fffa5653140) at kernel/qapplication.cpp:4023
#62 0x00007fdc54faa866 in KApplication::notify (this=0x7fffa5653ee0, receiver=0x28850e0, event=0x7fffa5653140) at ../../kdeui/kernel/kapplication.cpp:311
#63 0x00007fdc538cc49c in QCoreApplication::notifyInternal (this=0x7fffa5653ee0, receiver=0x28850e0, event=0x7fffa5653140) at kernel/qcoreapplication.cpp:731
#64 0x00007fdc5428ca0d in sendEvent (receiver=0x28850e0, event=0x7fffa5653140, alienWidget=0x28850e0, nativeWidget=0x2826b80, buttonDown=0x7fdc54d6c218, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QApplicationPrivate::sendMouseEvent (receiver=0x28850e0, event=0x7fffa5653140, alienWidget=0x28850e0, nativeWidget=0x2826b80, buttonDown=0x7fdc54d6c218, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#66 0x00007fdc5430c600 in QETWidget::translateMouseEvent (this=0x2826b80, event=<value optimized out>) at kernel/qapplication_x11.cpp:4556
#67 0x00007fdc5430b04a in QApplication::x11ProcessEvent (this=0x7fffa5653ee0, event=0x7fffa5653a90) at kernel/qapplication_x11.cpp:3678
#68 0x00007fdc54333162 in x11EventSourceDispatch (s=0x25ba810, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#69 0x00007fdc501f7bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007fdc501f83a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#71 0x00007fdc501f8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#72 0x00007fdc538f73ef in QEventDispatcherGlib::processEvents (this=0x256b340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#73 0x00007fdc54332dfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#74 0x00007fdc538cb882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#75 0x00007fdc538cbabc in QEventLoop::exec (this=0x7fffa5653d90, flags=...) at kernel/qeventloop.cpp:201
#76 0x00007fdc538cfecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#77 0x00007fdc562d5410 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../keditbookmarks/main.cpp:212
#78 0x00007fdc55f44eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=5, ubp_av=0x7fffa5654b28, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffa5654b18) at libc-start.c:226
#79 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 263125.

Possible duplicates by query: bug 264912, bug 263125.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-07-11 11:35:08 UTC

*** This bug has been marked as a duplicate of bug 263125 ***