Bug 263125 - Konqueror crashed editing bookmarks
Summary: Konqueror crashed editing bookmarks
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 264912 277112 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-14 11:17 UTC by black.beret
Modified: 2013-07-07 18:12 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.65 KB, text/plain)
2011-07-12 21:51 UTC, msulzbach@gmx.net
Details

Note You need to log in before you can comment on or make changes to this bug.
Description black.beret 2011-01-14 11:17:12 UTC
Application: keditbookmarks (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Organising bookmarks by moving large number of links to different folder (possibly including duplicates)

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7762a50 (LWP 2333))]

Thread 2 (Thread 0xb752db70 (LWP 2334)):
#0  0x006eb3c2 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x001edf66 in pthread_mutex_lock () from /lib/libc.so.6
#2  0x03bec6c4 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#3  0x03bf0668 in ?? () from /lib/libglib-2.0.so.0
#4  0x03bf0ba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0x02c8f6b4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0x03c1748f in ?? () from /lib/libglib-2.0.so.0
#7  0x006e8cc9 in start_thread () from /lib/libpthread.so.0
#8  0x001e069e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7762a50 (LWP 2333)):
[KCrash Handler]
#7  iterator (this=0x93591f0, source_parent=..., parent_mapping=0x936b4a8, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#8  insert (this=0x93591f0, source_parent=..., parent_mapping=0x936b4a8, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=true) at ../../include/QtCore/../../src/corelib/tools/qhash.h:765
#9  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x93591f0, source_parent=..., parent_mapping=0x936b4a8, orient=Qt::Vertical, start=0, end=0, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#10 0x05836851 in QSortFilterProxyModelPrivate::source_items_removed (this=0x93591f0, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:888
#11 0x05836a2a in QSortFilterProxyModelPrivate::_q_sourceRowsRemoved (this=0x93591f0, source_parent=..., start=0, end=0) at itemviews/qsortfilterproxymodel.cpp:1295
#12 0x0583b50f in QSortFilterProxyModel::qt_metacall (this=0x9358b40, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbf9240c0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#13 0x00d63462 in BookmarkFolderViewFilterModel::qt_metacall (this=0x9358b40, _c=QMetaObject::InvokeMetaMethod, _id=39, _a=0xbf9240c0) at ./bookmarklistview.moc:172
#14 0x076338ca in QMetaObject::metacall (object=0x9358b40, cl=154505712, idx=39, argv=0xbf9240c0) at kernel/qmetaobject.cpp:237
#15 0x076466ad in QMetaObject::activate (sender=0x9286da8, m=0x7760198, local_signal_index=7, argv=0x929a408) at kernel/qobject.cpp:3280
#16 0x076972ff in QAbstractItemModel::rowsRemoved (this=0x9286da8, _t1=..., _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#17 0x07628c13 in QAbstractItemModel::endRemoveRows (this=0x9286da8) at kernel/qabstractitemmodel.cpp:2467
#18 0x007290f3 in KBookmarkModel::removeBookmark (this=0x9286da8, bookmark=...) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:446
#19 0x00723fe5 in CreateCommand::undo (this=0x94c8f00) at ../../../../apps/keditbookmarks/kbookmarkmodel/commands.cpp:156
#20 0x0072690a in DeleteCommand::redo (this=0x94c8658) at ../../../../apps/keditbookmarks/kbookmarkmodel/commands.cpp:315
#21 0x00724c2e in MoveCommand::redo (this=0x94b8840) at ../../../../apps/keditbookmarks/kbookmarkmodel/commands.cpp:372
#22 0x05914b93 in QUndoCommand::redo (this=0x94061f8) at util/qundostack.cpp:208
#23 0x05916605 in QUndoStack::push (this=0x925dd0c, cmd=0x94061f8) at util/qundostack.cpp:541
#24 0x00723736 in CommandHistory::addCommand (this=0x925dca0, cmd=0x94061f8) at ../../../../apps/keditbookmarks/kbookmarkmodel/commandhistory.cpp:103
#25 0x00729fd8 in KBookmarkModel::dropMimeData (this=0x9286da8, data=0x92d3f00, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:375
#26 0x00d63370 in BookmarkFolderViewFilterModel::dropMimeData (this=0x9358b40, data=0x92d3f00, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../apps/keditbookmarks/bookmarklistview.cpp:187
#27 0x0579acc3 in QAbstractItemView::dropEvent (this=0x9355438, event=0xbf924e40) at itemviews/qabstractitemview.cpp:1981
#28 0x0522cdd0 in QWidget::event (this=0x9355438, event=0xbf924e40) at kernel/qwidget.cpp:8377
#29 0x0564e763 in QFrame::event (this=0x9355438, e=0xbf924e40) at widgets/qframe.cpp:557
#30 0x056eba82 in QAbstractScrollArea::viewportEvent (this=0x93591f0, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#31 0x057a80f7 in QAbstractItemView::viewportEvent (this=0x9355438, event=0xbf924e40) at itemviews/qabstractitemview.cpp:1619
#32 0x057ea883 in QTreeView::viewportEvent (this=0x9355438, event=0xbf924e40) at itemviews/qtreeview.cpp:1256
#33 0x056ee4d5 in viewportEvent (this=0x9356bc8, o=0x9355b10, e=0xbf924e40) at widgets/qabstractscrollarea_p.h:100
#34 QAbstractScrollAreaFilter::eventFilter (this=0x9356bc8, o=0x9355b10, e=0xbf924e40) at widgets/qabstractscrollarea_p.h:116
#35 0x0762d29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9138618, receiver=0x9355b10, event=0xbf924e40) at kernel/qcoreapplication.cpp:847
#36 0x051cefb9 in QApplicationPrivate::notify_helper (this=0x9138618, receiver=0x9355b10, e=0xbf924e40) at kernel/qapplication.cpp:4392
#37 0x051d551f in QApplication::notify (this=0xbf92722c, receiver=0x9355b10, e=0xbf924e40) at kernel/qapplication.cpp:4202
#38 0x00f4768a in KApplication::notify (this=0xbf92722c, receiver=0x9355b10, event=0xbf924e40) at ../../kdeui/kernel/kapplication.cpp:310
#39 0x0762db3b in QCoreApplication::notifyInternal (this=0xbf92722c, receiver=0x9355b10, event=0xbf924e40) at kernel/qcoreapplication.cpp:732
#40 0x05270daa in sendEvent (this=0x913c098, xe=0xbf924f4c, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QX11Data::xdndHandleDrop (this=0x913c098, xe=0xbf924f4c, passive=false) at kernel/qdnd_x11.cpp:1183
#42 0x05275ceb in QDragManager::drop (this=0x9409f00) at kernel/qdnd_x11.cpp:1725
#43 0x05275eea in QDragManager::eventFilter (this=0x9409f00, o=0x94394e0, e=0xbf9254b0) at kernel/qdnd_x11.cpp:1312
#44 0x0762d35c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9138618, receiver=0x94394e0, event=0xbf9254b0) at kernel/qcoreapplication.cpp:828
#45 0x051cef63 in QApplicationPrivate::notify_helper (this=0x9138618, receiver=0x94394e0, e=0xbf9254b0) at kernel/qapplication.cpp:4371
#46 0x051d5c2e in QApplication::notify (this=0xbf92722c, receiver=0x94394e0, e=0xbf9254b0) at kernel/qapplication.cpp:3959
#47 0x00f4768a in KApplication::notify (this=0xbf92722c, receiver=0x94394e0, event=0xbf9254b0) at ../../kdeui/kernel/kapplication.cpp:310
#48 0x0762db3b in QCoreApplication::notifyInternal (this=0xbf92722c, receiver=0x94394e0, event=0xbf9254b0) at kernel/qcoreapplication.cpp:732
#49 0x051d4094 in sendEvent (receiver=0x94394e0, event=0xbf9254b0, alienWidget=0x0, nativeWidget=0x94394e0, buttonDown=0x5b693c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#50 QApplicationPrivate::sendMouseEvent (receiver=0x94394e0, event=0xbf9254b0, alienWidget=0x0, nativeWidget=0x94394e0, buttonDown=0x5b693c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#51 0x05262d10 in QETWidget::translateMouseEvent (this=0x94394e0, event=0xbf9259cc) at kernel/qapplication_x11.cpp:4403
#52 0x05262151 in QApplication::x11ProcessEvent (this=0xbf92722c, event=0xbf9259cc) at kernel/qapplication_x11.cpp:3414
#53 0x0529136a in x11EventSourceDispatch (s=0x913b640, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#54 0x03bec855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#55 0x03bf0668 in ?? () from /lib/libglib-2.0.so.0
#56 0x03bf0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#57 0x0765c565 in QEventDispatcherGlib::processEvents (this=0x9123310, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#58 0x05290be5 in QGuiEventDispatcherGlib::processEvents (this=0x9123310, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#59 0x0762c609 in QEventLoop::processEvents (this=0x942ff78, flags=) at kernel/qeventloop.cpp:149
#60 0x0762ca8a in QEventLoop::exec (this=0x942ff78, flags=...) at kernel/qeventloop.cpp:201
#61 0x052765f7 in QDragManager::drag (this=0x9409f00, o=0x92c39a0) at kernel/qdnd_x11.cpp:1981
#62 0x051e6d4e in QDrag::exec (this=0x92c39a0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#63 0x057a58ac in QAbstractItemView::startDrag (this=0x932a9b8, supportedActions=...) at itemviews/qabstractitemview.cpp:3437
#64 0x057a333a in QAbstractItemView::mouseMoveEvent (this=0x932a9b8, event=0xbf926830) at itemviews/qabstractitemview.cpp:1700
#65 0x057e9f74 in QTreeView::mouseMoveEvent (this=0x932a9b8, event=0xbf926830) at itemviews/qtreeview.cpp:1902
#66 0x0522ccaa in QWidget::event (this=0x932a9b8, event=0xbf926830) at kernel/qwidget.cpp:8172
#67 0x0564e763 in QFrame::event (this=0x932a9b8, e=0xbf926830) at widgets/qframe.cpp:557
#68 0x056eba82 in QAbstractScrollArea::viewportEvent (this=0x93591f0, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#69 0x057a80f7 in QAbstractItemView::viewportEvent (this=0x932a9b8, event=0xbf926830) at itemviews/qabstractitemview.cpp:1619
#70 0x057ea883 in QTreeView::viewportEvent (this=0x932a9b8, event=0xbf926830) at itemviews/qtreeview.cpp:1256
#71 0x056ee4d5 in viewportEvent (this=0x934f390, o=0x934e238, e=0xbf926830) at widgets/qabstractscrollarea_p.h:100
#72 QAbstractScrollAreaFilter::eventFilter (this=0x934f390, o=0x934e238, e=0xbf926830) at widgets/qabstractscrollarea_p.h:116
#73 0x0762d29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9138618, receiver=0x934e238, event=0xbf926830) at kernel/qcoreapplication.cpp:847
#74 0x051cefb9 in QApplicationPrivate::notify_helper (this=0x9138618, receiver=0x934e238, e=0xbf926830) at kernel/qapplication.cpp:4392
#75 0x051d5c2e in QApplication::notify (this=0xbf92722c, receiver=0x934e238, e=0xbf926830) at kernel/qapplication.cpp:3959
#76 0x00f4768a in KApplication::notify (this=0xbf92722c, receiver=0x934e238, event=0xbf926830) at ../../kdeui/kernel/kapplication.cpp:310
#77 0x0762db3b in QCoreApplication::notifyInternal (this=0xbf92722c, receiver=0x934e238, event=0xbf926830) at kernel/qcoreapplication.cpp:732
#78 0x051d4094 in sendEvent (receiver=0x934e238, event=0xbf926830, alienWidget=0x934e238, nativeWidget=0x91380b0, buttonDown=0x5b693c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#79 QApplicationPrivate::sendMouseEvent (receiver=0x934e238, event=0xbf926830, alienWidget=0x934e238, nativeWidget=0x91380b0, buttonDown=0x5b693c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#80 0x05262d10 in QETWidget::translateMouseEvent (this=0x91380b0, event=0xbf926d4c) at kernel/qapplication_x11.cpp:4403
#81 0x05262151 in QApplication::x11ProcessEvent (this=0xbf92722c, event=0xbf926d4c) at kernel/qapplication_x11.cpp:3414
#82 0x0529136a in x11EventSourceDispatch (s=0x913b640, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#83 0x03bec855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#84 0x03bf0668 in ?? () from /lib/libglib-2.0.so.0
#85 0x03bf0848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#86 0x0765c565 in QEventDispatcherGlib::processEvents (this=0x9123310, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#87 0x05290be5 in QGuiEventDispatcherGlib::processEvents (this=0x9123310, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#88 0x0762c609 in QEventLoop::processEvents (this=0xbf927044, flags=) at kernel/qeventloop.cpp:149
#89 0x0762ca8a in QEventLoop::exec (this=0xbf927044, flags=...) at kernel/qeventloop.cpp:201
#90 0x0763100f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#91 0x051cde07 in QApplication::exec () at kernel/qapplication.cpp:3672
#92 0x00d47051 in kdemain (argc=6, argv=0xbf9275c4) at ../../../apps/keditbookmarks/main.cpp:212
#93 0x080485ab in main (argc=6, argv=0xbf9275c4) at keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-07-05 08:06:01 UTC
*** Bug 264912 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2011-07-11 11:35:08 UTC
*** Bug 277112 has been marked as a duplicate of this bug. ***
Comment 3 msulzbach@gmx.net 2011-07-12 21:51:53 UTC
Created attachment 61823 [details]
New crash information added by DrKonqi

keditbookmarks (4.6.2 (4.6.2)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

i tried to copy (via drag and drop) 4 Bookmarks from "unsorted bookmarks" at the right side of kbookmarkeditor-window to the "bookmark-panel" on the left side. i tried it a few times and got always the same result.

-- Backtrace (Reduced):
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x2050730, source_parent=..., parent_mapping=<value optimized out>, orient=32198528, start=0, end=0, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#7  0x00007f3ad5a1bba1 in QSortFilterProxyModelPrivate::source_items_removed (this=0x2050730, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:888
#8  0x00007f3ad5a2093c in QSortFilterProxyModel::qt_metacall (this=0x204fd10, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x7fff4c1679f0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
[...]
#10 0x00007f3ad4b1efd4 in QAbstractItemModel::rowsRemoved (this=<value optimized out>, _t1=<value optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#11 0x00007f3ad4abe428 in QAbstractItemModel::endRemoveRows (this=0x1ed9ad0) at kernel/qabstractitemmodel.cpp:2466
Comment 4 Christoph Feck 2013-07-07 18:12:12 UTC
This should be fixed with KDE 4.10.4, otherwise please reopen.

*** This bug has been marked as a duplicate of bug 287038 ***