Bug 264912 - rekonq bookmark editor crash
Summary: rekonq bookmark editor crash
Status: RESOLVED DUPLICATE of bug 263125
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 07:23 UTC by Blue
Modified: 2011-07-05 08:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Blue 2011-01-31 07:23:29 UTC
Application: keditbookmarks (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I was moving multiple bookmarks at once from one folder to another within the bookmark editor application.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9132b6d760 (LWP 10031))]

Thread 2 (Thread 0x7f91204c4700 (LWP 10032)):
#0  0x00007f9132493203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f912b83f009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f912b83f45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f912fd4d1e6 in QEventDispatcherGlib::processEvents (this=0x1acb9b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f912fd1fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f912fd1fdec in QEventLoop::exec (this=0x7f91204c3db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f912fc2a2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f912fcff5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1acad10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f912fc2d27e in QThreadPrivate::start (arg=0x1acad10) at thread/qthread_unix.cpp:266
#9  0x00007f912e909971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f913249f92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9132b6d760 (LWP 10031)):
[KCrash Handler]
#6  iterator (this=0x196e400, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#7  insert (this=0x196e400, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=true) at ../../include/QtCore/../../src/corelib/tools/qhash.h:765
#8  QSortFilterProxyModelPrivate::updateChildrenMapping (this=0x196e400, source_parent=<value optimized out>, parent_mapping=<value optimized out>, orient=<value optimized out>, start=<value optimized out>, end=<value optimized out>, delta_item_count=1, remove=true) at itemviews/qsortfilterproxymodel.cpp:946
#9  0x00007f9130cb8535 in QSortFilterProxyModelPrivate::source_items_removed (this=0x196e400, source_parent=..., start=0, end=0, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:888
#10 0x00007f9130cbd16c in QSortFilterProxyModel::qt_metacall (this=0x196d920, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc6d32cf0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:137
#11 0x00007f912fd38b27 in QMetaObject::activate (sender=0x18dfa70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1eaea80) at kernel/qobject.cpp:3280
#12 0x00007f912fd84104 in QAbstractItemModel::rowsRemoved (this=0x7f9132737e40, _t1=<value optimized out>, _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:195
#13 0x00007f912fd1c187 in QAbstractItemModel::endRemoveRows (this=0x18dfa70) at kernel/qabstractitemmodel.cpp:2467
#14 0x00007f91321b15de in KBookmarkModel::removeBookmark(KBookmark) () from /usr/lib/libkbookmarkmodel_private.so.4
#15 0x00007f91321acd1a in CreateCommand::undo() () from /usr/lib/libkbookmarkmodel_private.so.4
#16 0x00007f91321af363 in DeleteCommand::redo() () from /usr/lib/libkbookmarkmodel_private.so.4
#17 0x00007f91321ad8ac in ?? () from /usr/lib/libkbookmarkmodel_private.so.4
#18 0x00007f9130d8dba9 in QUndoCommand::redo (this=0x1ef6260) at util/qundostack.cpp:208
#19 0x00007f9130d8f473 in QUndoStack::push (this=0x18df618, cmd=0x30) at util/qundostack.cpp:541
#20 0x00007f91321ac576 in CommandHistory::addCommand(QUndoCommand*) () from /usr/lib/libkbookmarkmodel_private.so.4
#21 0x00007f91321b245d in KBookmarkModel::dropMimeData(QMimeData const*, Qt::DropAction, int, int, QModelIndex const&) () from /usr/lib/libkbookmarkmodel_private.so.4
#22 0x00007f9130c24cad in QAbstractItemView::dropEvent (this=0x1957bc0, event=0x7fffc6d33ed0) at itemviews/qabstractitemview.cpp:1981
#23 0x00007f913072d01c in QWidget::event (this=0x1957bc0, event=0x7fffc6d33ed0) at kernel/qwidget.cpp:8377
#24 0x00007f9130af85e6 in QFrame::event (this=0x1957bc0, e=0x7fffc6d33ed0) at widgets/qframe.cpp:557
#25 0x00007f9130c31a8b in QAbstractItemView::viewportEvent (this=0x1957bc0, event=0x7fffc6d33ed0) at itemviews/qabstractitemview.cpp:1619
#26 0x00007f9130c6fd65 in QTreeView::viewportEvent (this=0x1957bc0, event=0x7fffc6d33ed0) at itemviews/qtreeview.cpp:1256
#27 0x00007f912fd20507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1955f90, event=0x7fffc6d33ed0) at kernel/qcoreapplication.cpp:847
#28 0x00007f91306d6fac in QApplicationPrivate::notify_helper (this=0x179b370, receiver=0x1955f90, e=0x7fffc6d33ed0) at kernel/qapplication.cpp:4392
#29 0x00007f91306dcd82 in QApplication::notify (this=<value optimized out>, receiver=0x1955f90, e=0x7fffc6d33ed0) at kernel/qapplication.cpp:4202
#30 0x00007f9131429156 in KApplication::notify (this=0x7fffc6d37350, receiver=0x1955f90, event=0x7fffc6d33ed0) at ../../kdeui/kernel/kapplication.cpp:310
#31 0x00007f912fd20cdc in QCoreApplication::notifyInternal (this=0x7fffc6d37350, receiver=0x1955f90, event=0x7fffc6d33ed0) at kernel/qcoreapplication.cpp:732
#32 0x00007f913076be8d in sendEvent (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QX11Data::xdndHandleDrop (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>) at kernel/qdnd_x11.cpp:1183
#34 0x00007f9130770763 in QDragManager::drop (this=0x1dbf610) at kernel/qdnd_x11.cpp:1725
#35 0x00007f9130770928 in QDragManager::eventFilter (this=0x1dbf610, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1312
#36 0x00007f912fd205cb in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x179b370, receiver=0x1db4f10, event=0x7fffc6d347d0) at kernel/qcoreapplication.cpp:828
#37 0x00007f91306d6f56 in QApplicationPrivate::notify_helper (this=0x7f9132737e40, receiver=0x30, e=0x196f4a0) at kernel/qapplication.cpp:4371
#38 0x00007f91306dd30e in QApplication::notify (this=0x7fffc6d37350, receiver=0x1db4f10, e=0x7fffc6d347d0) at kernel/qapplication.cpp:3959
#39 0x00007f9131429156 in KApplication::notify (this=0x7fffc6d37350, receiver=0x1db4f10, event=0x7fffc6d347d0) at ../../kdeui/kernel/kapplication.cpp:310
#40 0x00007f912fd20cdc in QCoreApplication::notifyInternal (this=0x7fffc6d37350, receiver=0x1db4f10, event=0x7fffc6d347d0) at kernel/qcoreapplication.cpp:732
#41 0x00007f91306dbdbe in sendEvent (receiver=0x1db4f10, event=0x7fffc6d347d0, alienWidget=0x0, nativeWidget=0x1db4f10, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QApplicationPrivate::sendMouseEvent (receiver=0x1db4f10, event=0x7fffc6d347d0, alienWidget=0x0, nativeWidget=0x1db4f10, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#43 0x00007f913075f345 in QETWidget::translateMouseEvent (this=0x1db4f10, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#44 0x00007f913075dc5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffc6d350f0) at kernel/qapplication_x11.cpp:3536
#45 0x00007f913078a0e2 in x11EventSourceDispatch (s=0x179ef00, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x00007f912b83b342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#47 0x00007f912b83f2a8 in ?? () from /lib/libglib-2.0.so.0
#48 0x00007f912b83f45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#49 0x00007f912fd4d193 in QEventDispatcherGlib::processEvents (this=0x1782c00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#50 0x00007f9130789a4e in QGuiEventDispatcherGlib::processEvents (this=0x7f9132737e40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007f912fd1fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#52 0x00007f912fd1fdec in QEventLoop::exec (this=0x1ed2960, flags=) at kernel/qeventloop.cpp:201
#53 0x00007f913077100b in QDragManager::drag (this=0x1dbf610, o=<value optimized out>) at kernel/qdnd_x11.cpp:1981
#54 0x00007f91306ecf78 in QDrag::exec (this=0x1e57ed0, supportedActions=) at kernel/qdrag.cpp:284
#55 0x00007f9130c2f1d6 in QAbstractItemView::startDrag (this=0x1957bc0, supportedActions=<value optimized out>) at itemviews/qabstractitemview.cpp:3437
#56 0x00007f9130c2cb1e in QAbstractItemView::mouseMoveEvent (this=0x1957bc0, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1700
#57 0x00007f913072ccab in QWidget::event (this=0x1957bc0, event=0x7fffc6d364f0) at kernel/qwidget.cpp:8172
#58 0x00007f9130af85e6 in QFrame::event (this=0x1957bc0, e=0x7fffc6d364f0) at widgets/qframe.cpp:557
#59 0x00007f9130c31a8b in QAbstractItemView::viewportEvent (this=0x1957bc0, event=0x7fffc6d364f0) at itemviews/qabstractitemview.cpp:1619
#60 0x00007f9130c6fd65 in QTreeView::viewportEvent (this=0x1957bc0, event=0x7fffc6d364f0) at itemviews/qtreeview.cpp:1256
#61 0x00007f912fd20507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1955f90, event=0x7fffc6d364f0) at kernel/qcoreapplication.cpp:847
#62 0x00007f91306d6fac in QApplicationPrivate::notify_helper (this=0x179b370, receiver=0x1955f90, e=0x7fffc6d364f0) at kernel/qapplication.cpp:4392
#63 0x00007f91306dd30e in QApplication::notify (this=0x7fffc6d37350, receiver=0x1955f90, e=0x7fffc6d364f0) at kernel/qapplication.cpp:3959
#64 0x00007f9131429156 in KApplication::notify (this=0x7fffc6d37350, receiver=0x1955f90, event=0x7fffc6d364f0) at ../../kdeui/kernel/kapplication.cpp:310
#65 0x00007f912fd20cdc in QCoreApplication::notifyInternal (this=0x7fffc6d37350, receiver=0x1955f90, event=0x7fffc6d364f0) at kernel/qcoreapplication.cpp:732
#66 0x00007f91306dbdbe in sendEvent (receiver=0x1955f90, event=0x7fffc6d364f0, alienWidget=0x1955f90, nativeWidget=0x19851e0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#67 QApplicationPrivate::sendMouseEvent (receiver=0x1955f90, event=0x7fffc6d364f0, alienWidget=0x1955f90, nativeWidget=0x19851e0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#68 0x00007f913075f345 in QETWidget::translateMouseEvent (this=0x19851e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#69 0x00007f913075dc5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffc6d36e10) at kernel/qapplication_x11.cpp:3536
#70 0x00007f913078a0e2 in x11EventSourceDispatch (s=0x179ef00, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#71 0x00007f912b83b342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#72 0x00007f912b83f2a8 in ?? () from /lib/libglib-2.0.so.0
#73 0x00007f912b83f45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#74 0x00007f912fd4d193 in QEventDispatcherGlib::processEvents (this=0x1782c00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#75 0x00007f9130789a4e in QGuiEventDispatcherGlib::processEvents (this=0x7f9132737e40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#76 0x00007f912fd1fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#77 0x00007f912fd1fdec in QEventLoop::exec (this=0x7fffc6d37140, flags=) at kernel/qeventloop.cpp:201
#78 0x00007f912fd23ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#79 0x00007f9132757367 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_keditbookmarks.so
#80 0x00007f91323d7d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc6d37f78) at libc-start.c:226
#81 0x0000000000400669 in _start ()

Possible duplicates by query: bug 263125.

Reported using DrKonqi
Comment 1 Tommi Tervo 2011-07-05 08:06:00 UTC

*** This bug has been marked as a duplicate of bug 263125 ***