Bug 275979 - kwin crash
Summary: kwin crash
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-18 15:00 UTC by stevlowe9
Modified: 2011-06-18 15:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stevlowe9 2011-06-18 15:00:51 UTC
Application: kwin (4.6.4 (4.6.4) "release 8")
KDE Platform Version: 4.6.4 (4.6.4) "release 8" (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.5-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: Screen saver was running and pushed a key to bring it out of that mode and I had the error message that kwin had crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f48e64da760 (LWP 1963))]

Thread 2 (Thread 0x7f48ccffe700 (LWP 1998)):
#0  0x00007f48e1da338c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f48e4ba4004 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f48e4ebd180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f48e4ba4039 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f48e4ecb254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f48e1d9ea3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f48e5d3867d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f48e64da760 (LWP 1963)):
[KCrash Handler]
#6  0x00007f48ce03fad0 in ?? () from /usr/lib64/dri/i965_dri.so
#7  0x00007f48ce0332a4 in ?? () from /usr/lib64/dri/i965_dri.so
#8  0x00007f48ce0357aa in ?? () from /usr/lib64/dri/i965_dri.so
#9  0x00007f48e609d9a5 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/scene_opengl.cpp:921
#10 0x00007f48e6095116 in KWin::Scene::paintGenericScreen (this=0x733e00, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/scene.cpp:188
#11 0x00007f48e609226a in KWin::Scene::finalPaintScreen (this=0x733e00, mask=32, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/scene.cpp:178
#12 0x00007f48e60af70f in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:173
#13 0x00007f48cd76c82b in KWin::StartupFeedbackEffect::paintScreen (this=0x19b6920, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#15 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#16 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#17 0x00007f48cd71354f in KWin::LogoutEffect::paintScreen (this=0x1bbb5b0, mask=32, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/logout/logout.cpp:207
#18 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#19 0x00007f48cd72e182 in KWin::ShadowEffect::paintScreen (this=0x196e910, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/shadow/shadow.cpp:189
#20 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#21 0x00007f48cd740f8e in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/blur/blur.cpp:230
#22 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#23 0x00007f48cd717fd2 in KWin::PresentWindowsEffect::paintScreen (this=0x18dbb70, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#25 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#26 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#27 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#28 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#29 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#30 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#31 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#32 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#33 0x00007f48cd6fe6c3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/desktopgrid/desktopgrid.cpp:156
#34 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#35 0x00007f48cd73495d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/slide/slide.cpp:86
#36 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#37 0x00007f48cd6f7ee2 in KWin::BoxSwitchEffect::paintScreen (this=0x1b17e60, mask=0, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#39 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#40 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#41 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#42 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#43 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#44 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#45 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#46 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#47 0x00007f48e4191f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/lib/kwineffects.cpp:227
#48 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#49 0x00007f48cd73e60f in KWin::ZoomEffect::paintScreen (this=0x1a692e0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects/zoom/zoom.cpp:341
#50 0x00007f48e60af79c in KWin::EffectsHandlerImpl::paintScreen (this=0x18625f0, mask=0, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/effects.cpp:169
#51 0x00007f48e6093325 in KWin::Scene::paintScreen (this=0x733e00, mask=0x7fffe1e457fc, region=0x7fffe1e458f0) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/scene.cpp:137
#52 0x00007f48e60a7869 in KWin::SceneOpenGL::paint (this=0x733e00, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/scene_opengl.cpp:772
#53 0x00007f48e608fa47 in KWin::Workspace::performCompositing (this=0x7f48c8352d40) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/composite.cpp:448
#54 0x00007f48e212c0a9 in QObject::event (this=0x7f48c8352d40, e=<value optimized out>) at kernel/qobject.cpp:1181
#55 0x00007f48e12c3144 in QApplicationPrivate::notify_helper (this=0x6469d0, receiver=0x7f48c8352d40, e=0x7fffe1e46130) at kernel/qapplication.cpp:4462
#56 0x00007f48e12cb6fa in QApplication::notify (this=<value optimized out>, receiver=0x7f48c8352d40, e=0x7fffe1e46130) at kernel/qapplication.cpp:4341
#57 0x00007f48e57b03c6 in KApplication::notify (this=0x7fffe1e46610, receiver=0x7f48c8352d40, event=0x7fffe1e46130) at /usr/src/debug/kdelibs-4.6.4/kdeui/kernel/kapplication.cpp:311
#58 0x00007f48e211847c in QCoreApplication::notifyInternal (this=0x7fffe1e46610, receiver=0x7f48c8352d40, event=0x7fffe1e46130) at kernel/qcoreapplication.cpp:731
#59 0x00007f48e2145df8 in sendEvent (this=0x6478f0) at kernel/qcoreapplication.h:215
#60 QTimerInfoList::activateTimers (this=0x6478f0) at kernel/qeventdispatcher_unix.cpp:619
#61 0x00007f48e2146500 in QEventDispatcherUNIX::processEvents (this=0x612390, flags=...) at kernel/qeventdispatcher_unix.cpp:938
#62 0x00007f48e13699cc in QEventDispatcherX11::processEvents (this=0x612390, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#63 0x00007f48e21178d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007f48e2117ae5 in QEventLoop::exec (this=0x7fffe1e46500, flags=...) at kernel/qeventloop.cpp:201
#65 0x00007f48e211bf2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#66 0x00007f48e602dfb5 in kdemain (argc=<value optimized out>, argv=0x7fffe1e46670) at /usr/src/debug/kdebase-workspace-4.6.4/kwin/main.cpp:533
#67 0x00007f48e5c83bfd in __libc_start_main () from /lib64/libc.so.6
#68 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 275741, bug 275525, bug 275478, bug 275202, bug 275176.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-06-18 15:03:25 UTC
some debug symbols missing, but looks like the fullscreen unredirect driver bug. For workaround see duplicate

*** This bug has been marked as a duplicate of bug 252817 ***