Bug 269147 - Plasma Desktom crashes with no obvious reason
Summary: Plasma Desktom crashes with no obvious reason
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-22 15:35 UTC by underline
Modified: 2011-03-24 13:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description underline 2011-03-22 15:35:30 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Plasma Desktom crashes with no obvious reason. Then it restored.

- Unusual behavior I noticed:
I noticed Amarok to be closed though I didn't do that.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78c3720 (LWP 1750))]

Thread 3 (Thread 0xaeb33b70 (LWP 1751)):
#0  0x050b5e1f in g_thread_self () from /lib/libglib-2.0.so.0
#1  0x0508d5c2 in g_main_context_acquire () from /lib/libglib-2.0.so.0
#2  0x0508f1ee in ?? () from /lib/libglib-2.0.so.0
#3  0x0508f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x07a1559f in QEventDispatcherGlib::processEvents (this=0x88b0870, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x079e5609 in QEventLoop::processEvents (this=0xaeb33280, flags=) at kernel/qeventloop.cpp:149
#6  0x079e5a8a in QEventLoop::exec (this=0xaeb33280, flags=...) at kernel/qeventloop.cpp:201
#7  0x078e1b7e in QThread::exec (this=0x897bbb8) at thread/qthread.cpp:490
#8  0x079c435b in QInotifyFileSystemWatcherEngine::run (this=0x897bbb8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x078e4df9 in QThreadPrivate::start (arg=0x897bbb8) at thread/qthread_unix.cpp:266
#10 0x04ab3cc9 in start_thread () from /lib/libpthread.so.0
#11 0x0049b69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadb31b70 (LWP 1754)):
#0  0x003e1b1f in ?? () from /lib/libc.so.6
#1  0x0508f4f9 in ?? () from /lib/libglib-2.0.so.0
#2  0x0508f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x07a1559f in QEventDispatcherGlib::processEvents (this=0xb53005e8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x079e5609 in QEventLoop::processEvents (this=0xadb31280, flags=) at kernel/qeventloop.cpp:149
#5  0x079e5a8a in QEventLoop::exec (this=0xadb31280, flags=...) at kernel/qeventloop.cpp:201
#6  0x078e1b7e in QThread::exec (this=0x8b60fd8) at thread/qthread.cpp:490
#7  0x079c435b in QInotifyFileSystemWatcherEngine::run (this=0x8b60fd8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x078e4df9 in QThreadPrivate::start (arg=0x8b60fd8) at thread/qthread_unix.cpp:266
#9  0x04ab3cc9 in start_thread () from /lib/libpthread.so.0
#10 0x0049b69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb78c3720 (LWP 1750)):
[KCrash Handler]
#7  0x0113dba7 in QString (this=0x9440061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0x9440061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01141ad8 in KIconLoaderPrivate::makeCacheKey (this=0x944004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x01149f08 in KIconLoader::loadIcon (this=0x92475a0, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x011403f6 in KIconEngine::pixmap (this=0x990e838, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x01584626 in QIcon::pixmap (this=0x947b66c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x00bdc222 in Plasma::IconWidgetPrivate::decoration (this=0x947b5c8, option=0x8444eb0, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x00bdecb7 in Plasma::IconWidget::paint (this=0x95b3c10, painter=0xbff27ffc, option=0x8444eb0, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x0482219d in SystemTray::DBusSystemTrayWidget::paint (this=0x95b3c10, painter=0xbff27ffc, option=0x8444eb0, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x01b8952c in _q_paintItem (item=<value optimized out>, painter=0xbff27ffc, option=0x8444eb0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x01b8beaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8444eb0, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x01b93718 in QGraphicsScenePrivate::drawItemHelper (this=0x8444d60, item=0x95b3c18, painter=0xbff29cd4, option=0x8444eb0, widget=0x8e956f0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x01b977d8 in QGraphicsScenePrivate::draw (this=0x8444d60, item=0x95b3c18, painter=0xbff29cd4, viewTransform=0xbff29abc, transformPtr=0xbff28930, exposedRegion=0x8d9a3b8, widget=0x8e956f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x01b984a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8444d60, item=0x95b3c18, painter=0xbff29cd4, viewTransform=0xbff29abc, exposedRegion=0x8d9a3b8, widget=0x8e956f0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x01b97874 in QGraphicsScenePrivate::draw (this=0x8444d60, item=0x8561808, painter=0xbff29cd4, viewTransform=0xbff29abc, transformPtr=0xbff28da0, exposedRegion=0x8d9a3b8, widget=0x8e956f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x01b984a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8444d60, item=0x8561808, painter=0xbff29cd4, viewTransform=0xbff29abc, exposedRegion=0x8d9a3b8, widget=0x8e956f0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x01b97874 in QGraphicsScenePrivate::draw (this=0x8444d60, item=0x866d7f8, painter=0xbff29cd4, viewTransform=0xbff29abc, transformPtr=0xbff29210, exposedRegion=0x8d9a3b8, widget=0x8e956f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x01b984a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8444d60, item=0x866d7f8, painter=0xbff29cd4, viewTransform=0xbff29abc, exposedRegion=0x8d9a3b8, widget=0x8e956f0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x01b97874 in QGraphicsScenePrivate::draw (this=0x8444d60, item=0x847e168, painter=0xbff29cd4, viewTransform=0xbff29abc, transformPtr=0xbff29680, exposedRegion=0x8d9a3b8, widget=0x8e956f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x01b984a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8444d60, item=0x847e168, painter=0xbff29cd4, viewTransform=0xbff29abc, exposedRegion=0x8d9a3b8, widget=0x8e956f0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x01b98cce in QGraphicsScenePrivate::drawItems (this=0x8444d60, painter=0xbff29cd4, viewTransform=0xbff29abc, exposedRegion=0x8d9a3b8, widget=0x8e956f0) at graphicsview/qgraphicsscene.cpp:4699
#28 0x01bc4bb9 in QGraphicsView::paintEvent (this=0x8d8d3f8, event=0xbff2a3f4) at graphicsview/qgraphicsview.cpp:3467
#29 0x0060e224 in PanelView::paintEvent (this=0x8d8d3f8, event=0xbff2a3f4) at ../../../../plasma/desktop/shell/panelview.cpp:1494
#30 0x0151dcc6 in QWidget::event (this=0x8d8d3f8, event=0xbff2a3f4) at kernel/qwidget.cpp:8333
#31 0x0193f763 in QFrame::event (this=0x8d8d3f8, e=0xbff2a3f4) at widgets/qframe.cpp:557
#32 0x019dca82 in QAbstractScrollArea::viewportEvent (this=0xdf3b645a, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x01bc0ccb in QGraphicsView::viewportEvent (this=0x8d8d3f8, event=0xbff2a3f4) at graphicsview/qgraphicsview.cpp:2862
#34 0x019df4d5 in viewportEvent (this=0x856de50, o=0x8e956f0, e=0xbff2a3f4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x856de50, o=0x8e956f0, e=0xbff2a3f4) at widgets/qabstractscrollarea_p.h:116
#36 0x079e629a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x83c1d98, receiver=0x8e956f0, event=0xbff2a3f4) at kernel/qcoreapplication.cpp:847
#37 0x014bffb9 in QApplicationPrivate::notify_helper (this=0x83c1d98, receiver=0x8e956f0, e=0xbff2a3f4) at kernel/qapplication.cpp:4392
#38 0x014c60e9 in QApplication::notify (this=0x83b5ae0, receiver=0x8e956f0, e=0xbff2a3f4) at kernel/qapplication.cpp:4361
#39 0x011a57da in KApplication::notify (this=0x83b5ae0, receiver=0x8e956f0, event=0xbff2a3f4) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x079e6b3b in QCoreApplication::notifyInternal (this=0x83b5ae0, receiver=0x8e956f0, event=0xbff2a3f4) at kernel/qcoreapplication.cpp:732
#41 0x01524ee6 in sendSpontaneousEvent (this=0x8bbc1a0, pdev=0x8d00084, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x85b6db0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8bbc1a0, pdev=0x8d00084, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x85b6db0) at kernel/qwidget.cpp:5420
#43 0x01525cff in QWidgetPrivate::paintSiblingsRecursive (this=0x8d9a068, pdev=0x8d00084, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x85b6db0) at kernel/qwidget.cpp:5627
#44 0x01525b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x8d9a068, pdev=0x8d00084, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x85b6db0) at kernel/qwidget.cpp:5614
#45 0x01524c35 in QWidgetPrivate::drawWidget (this=0x8d9a068, pdev=0x8d00084, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x85b6db0) at kernel/qwidget.cpp:5473
#46 0x01715c74 in QWidgetBackingStore::sync (this=0x85b6db0) at painting/qbackingstore.cpp:1328
#47 0x015172b3 in QWidgetPrivate::syncBackingStore (this=0x8d9a068) at kernel/qwidget.cpp:1805
#48 0x0151e466 in QWidget::event (this=0x8d8d3f8, event=0x92475a0) at kernel/qwidget.cpp:8480
#49 0x0193f763 in QFrame::event (this=0x8d8d3f8, e=0x92475a0) at widgets/qframe.cpp:557
#50 0x019dd487 in QAbstractScrollArea::event (this=0x8d8d3f8, e=0x92475a0) at widgets/qabstractscrollarea.cpp:996
#51 0x01bc2ea6 in QGraphicsView::event (this=0x8d8d3f8, event=0x92475a0) at graphicsview/qgraphicsview.cpp:2739
#52 0x0060ed13 in PanelView::event (this=0x8d8d3f8, event=0x92475a0) at ../../../../plasma/desktop/shell/panelview.cpp:1505
#53 0x014bffdc in QApplicationPrivate::notify_helper (this=0x83c1d98, receiver=0x8d8d3f8, e=0x92475a0) at kernel/qapplication.cpp:4396
#54 0x014c60e9 in QApplication::notify (this=0x83b5ae0, receiver=0x8d8d3f8, e=0x92475a0) at kernel/qapplication.cpp:4361
#55 0x011a57da in KApplication::notify (this=0x83b5ae0, receiver=0x8d8d3f8, event=0x92475a0) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x079e6b3b in QCoreApplication::notifyInternal (this=0x83b5ae0, receiver=0x8d8d3f8, event=0x92475a0) at kernel/qcoreapplication.cpp:732
#57 0x079e9d8b in sendEvent (receiver=0x8d8d3f8, event_type=77, data=0x83850f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8d8d3f8, event_type=77, data=0x83850f0) at kernel/qcoreapplication.cpp:1373
#59 0x079e9f4d in QCoreApplication::sendPostedEvents (receiver=0x8d8d3f8, event_type=77) at kernel/qcoreapplication.cpp:1266
#60 0x01ba8c3e in dispatchPendingUpdateRequests (this=0x8444d60) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8444d60) at graphicsview/qgraphicsscene.cpp:510
#62 0x01ba9116 in QGraphicsScene::qt_metacall (this=0x8468c68, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x920d370) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0x00b08a4a in Plasma::Corona::qt_metacall (this=0x8468c68, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x920d370) at ./corona.moc:109
#64 0x005fcf7a in DesktopCorona::qt_metacall (this=0x8468c68, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x920d370) at ./desktopcorona.moc:101
#65 0x079ec8ca in QMetaObject::metacall (object=0x8468c68, cl=3745211482, idx=18, argv=0x920d370) at kernel/qmetaobject.cpp:237
#66 0x079f7df6 in QMetaCallEvent::placeMetaCall (this=0x958dcd0, object=0x8468c68) at kernel/qobject.cpp:534
#67 0x079f96a2 in QObject::event (this=0x8468c68, e=0x0) at kernel/qobject.cpp:1219
#68 0x01ba5374 in QGraphicsScene::event (this=0x8468c68, event=0x958dcd0) at graphicsview/qgraphicsscene.cpp:3548
#69 0x014bffdc in QApplicationPrivate::notify_helper (this=0x83c1d98, receiver=0x8468c68, e=0x958dcd0) at kernel/qapplication.cpp:4396
#70 0x014c604e in QApplication::notify (this=0x83b5ae0, receiver=0x8468c68, e=0x958dcd0) at kernel/qapplication.cpp:3798
#71 0x011a57da in KApplication::notify (this=0x83b5ae0, receiver=0x8468c68, event=0x958dcd0) at ../../kdeui/kernel/kapplication.cpp:311
#72 0x079e6b3b in QCoreApplication::notifyInternal (this=0x83b5ae0, receiver=0x8468c68, event=0x958dcd0) at kernel/qcoreapplication.cpp:732
#73 0x079e9d8b in sendEvent (receiver=0x0, event_type=0, data=0x83850f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x83850f0) at kernel/qcoreapplication.cpp:1373
#75 0x079e9f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#76 0x07a15a74 in sendPostedEvents (s=0x83c2fb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x83c2fb0) at kernel/qeventdispatcher_glib.cpp:277
#78 0x0508b855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0x0508f668 in ?? () from /lib/libglib-2.0.so.0
#80 0x0508f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0x07a15565 in QEventDispatcherGlib::processEvents (this=0x8384ba0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#82 0x01581be5 in QGuiEventDispatcherGlib::processEvents (this=0x8384ba0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x079e5609 in QEventLoop::processEvents (this=0xbff2bdc4, flags=) at kernel/qeventloop.cpp:149
#84 0x079e5a8a in QEventLoop::exec (this=0xbff2bdc4, flags=...) at kernel/qeventloop.cpp:201
#85 0x079ea00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#86 0x014bee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#87 0x00605f97 in kdemain (argc=1, argv=0xbff2bfd4) at ../../../../plasma/desktop/shell/main.cpp:118
#88 0x080485bb in main (argc=1, argv=0xbff2bfd4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 266383.

Possible duplicates by query: bug 269118, bug 268955, bug 268886, bug 268874, bug 268858.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-24 13:36:16 UTC

*** This bug has been marked as a duplicate of bug 258706 ***