Bug 268858 - Plasma crashed after closing Kopete
Summary: Plasma crashed after closing Kopete
Status: RESOLVED DUPLICATE of bug 226596
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-19 00:47 UTC by Christian Hartmann
Modified: 2011-05-09 15:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.80 KB, text/plain)
2011-03-29 20:05 UTC, jem
Details
New crash information added by DrKonqi (12.22 KB, text/plain)
2011-05-09 15:55 UTC, lordinfinitus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Hartmann 2011-03-19 00:47:10 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1) "release 390"
Qt Version: 4.7.2
Operating System: Linux 2.6.38-22-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
After closing Kopete, the plasma workspace crashed instantly.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb58b0710 (LWP 1574))]

Thread 3 (Thread 0xaf4adb70 (LWP 1581)):
#0  0xb5bce22b in clock_gettime () from /lib/librt.so.1
#1  0xb6dda0b5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6eacf36 in updateCurrentTime (this=0xaeb00f74, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xaeb00f74, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6eab77b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf4ad11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6eab81d in timerSourcePrepare (source=0xaeb00f40, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5b18a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb5b198e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5b19fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6eabfc7 in QEventDispatcherGlib::processEvents (this=0x8469198, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6e7ca6d in QEventLoop::processEvents (this=0xaf4ad2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6e7cc99 in QEventLoop::exec (this=0xaf4ad2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6d7dd49 in QThread::exec (this=0x8469790) at thread/qthread.cpp:492
#14 0xb6e5c7fd in QInotifyFileSystemWatcherEngine::run (this=0x8469790) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6d80993 in QThreadPrivate::start (arg=0x8469790) at thread/qthread_unix.cpp:320
#16 0xb6d03b05 in start_thread () from /lib/libpthread.so.0
#17 0xb60bdd5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaeaffb70 (LWP 1925)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6d08105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3676ed7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb378d1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb3676f1f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb378d1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb6d03b05 in start_thread () from /lib/libpthread.so.0
#5  0xb60bdd5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb58b0710 (LWP 1574)):
[KCrash Handler]
#7  0xb74bed13 in QString (this=0x90c0061, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x90c0061, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#9  0xb74c0618 in KIconLoaderPrivate::makeCacheKey (this=0x90c004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#10 0xb761784c in KIconLoader::loadIcon (this=0x850b500, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#11 0xb7618b44 in KIconEngine::pixmap (this=0x9987c90, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#12 0xb643e6c4 in QIcon::pixmap (this=0x910853c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb4d2e471 in Plasma::IconWidgetPrivate::decoration (this=0x9108498, option=0x8169c50, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#14 0xb4d35544 in Plasma::IconWidget::paint (this=0x902fc58, painter=0xbff80abc, option=0x8169c50, widget=0x0) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#15 0xaf76829a in SystemTray::DBusSystemTrayWidget::paint (this=0x902fc58, painter=0xbff80abc, option=0x8169c50, widget=0x0) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0xb6a18375 in _q_paintItem (item=<value optimized out>, painter=0xbff80abc, option=0x8169c50, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb6a186ca in _q_paintIntoCache (pix=0xbff80f9c, item=0x902fc60, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb6a2d7d8 in QGraphicsScenePrivate::drawItemHelper (this=0x8169b00, item=0x902fc60, painter=0xbff827d4, option=0x8169c50, widget=0x8886798, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0xb6a2e482 in QGraphicsScenePrivate::draw (this=0x8169b00, item=0x902fc60, painter=0xbff827d4, viewTransform=0xbff825bc, transformPtr=0xbff81390, exposedRegion=0x8c39810, widget=0x8886798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0xb6a2f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8169b00, item=0x902fc60, painter=0xbff827d4, viewTransform=0xbff825bc, exposedRegion=0x8c39810, widget=0x8886798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0xb6a2e2af in QGraphicsScenePrivate::draw (this=0x8169b00, item=0x83f18d8, painter=0xbff827d4, viewTransform=0xbff825bc, transformPtr=0xbff81840, exposedRegion=0x8c39810, widget=0x8886798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0xb6a2f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8169b00, item=0x83f18d8, painter=0xbff827d4, viewTransform=0xbff825bc, exposedRegion=0x8c39810, widget=0x8886798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0xb6a2e2af in QGraphicsScenePrivate::draw (this=0x8169b00, item=0x83ab9c0, painter=0xbff827d4, viewTransform=0xbff825bc, transformPtr=0xbff81cf0, exposedRegion=0x8c39810, widget=0x8886798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0xb6a2f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8169b00, item=0x83ab9c0, painter=0xbff827d4, viewTransform=0xbff825bc, exposedRegion=0x8c39810, widget=0x8886798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0xb6a2e2af in QGraphicsScenePrivate::draw (this=0x8169b00, item=0x8208dd0, painter=0xbff827d4, viewTransform=0xbff825bc, transformPtr=0xbff821a0, exposedRegion=0x8c39810, widget=0x8886798, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0xb6a2f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8169b00, item=0x8208dd0, painter=0xbff827d4, viewTransform=0xbff825bc, exposedRegion=0x8c39810, widget=0x8886798, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0xb6a2fac7 in QGraphicsScenePrivate::drawItems (this=0x8169b00, painter=0xbff827d4, viewTransform=0xbff825bc, exposedRegion=0x8c39810, widget=0x8886798) at graphicsview/qgraphicsscene.cpp:4735
#28 0xb6a509be in QGraphicsView::paintEvent (this=0x8b19cc8, event=0x0) at graphicsview/qgraphicsview.cpp:3469
#29 0xb2554973 in PanelView::paintEvent (this=0x8b19cc8, event=0xbff82eb4) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1494
#30 0xb63e0b4a in QWidget::event (this=0x8b19cc8, event=0xbff82eb4) at kernel/qwidget.cpp:8405
#31 0xb67f00f5 in QFrame::event (this=0x8b19cc8, e=0xbff82eb4) at widgets/qframe.cpp:557
#32 0xb6881b91 in QAbstractScrollArea::viewportEvent (this=0x8b19cc8, e=0xbff82eb4) at widgets/qabstractscrollarea.cpp:1043
#33 0xb6a51ddc in QGraphicsView::viewportEvent (this=0x8b19cc8, event=0xbff82eb4) at graphicsview/qgraphicsview.cpp:2864
#34 0xb6884486 in viewportEvent (this=0x893c0e0, o=0x8886798, e=0xbff82eb4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x893c0e0, o=0x8886798, e=0xbff82eb4) at widgets/qabstractscrollarea_p.h:116
#36 0xb6e7d926 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80e2280, receiver=0x8886798, event=0xbff82eb4) at kernel/qcoreapplication.cpp:846
#37 0xb6385654 in QApplicationPrivate::notify_helper (this=0x80e2280, receiver=0x8886798, e=0xbff82eb4) at kernel/qapplication.cpp:4458
#38 0xb638e4d4 in QApplication::notify (this=0x80d69d0, receiver=0x8886798, e=0xbff82eb4) at kernel/qapplication.cpp:4341
#39 0xb74d9591 in KApplication::notify (this=0x80d69d0, receiver=0x8886798, event=0xbff82eb4) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#40 0xb6e7d78e in QCoreApplication::notifyInternal (this=0x80d69d0, receiver=0x8886798, event=0xbff82eb4) at kernel/qcoreapplication.cpp:731
#41 0xb63dd7e2 in sendSpontaneousEvent (this=0x8c3af30, pdev=0x889132c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x82a4d78) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8c3af30, pdev=0x889132c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x82a4d78) at kernel/qwidget.cpp:5492
#43 0xb63de537 in QWidgetPrivate::paintSiblingsRecursive (this=0x8c394c0, pdev=0x889132c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x82a4d78) at kernel/qwidget.cpp:5699
#44 0xb63de3fd in QWidgetPrivate::paintSiblingsRecursive (this=0x8c394c0, pdev=0x889132c, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x82a4d78) at kernel/qwidget.cpp:5686
#45 0xb63dd538 in QWidgetPrivate::drawWidget (this=0x8c394c0, pdev=0x889132c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x82a4d78) at kernel/qwidget.cpp:5545
#46 0xb65cc198 in QWidgetBackingStore::sync (this=0x82a4d78) at painting/qbackingstore.cpp:1333
#47 0xb63d245b in QWidgetPrivate::syncBackingStore (this=0x8c394c0) at kernel/qwidget.cpp:1842
#48 0xb63e161a in QWidget::event (this=0x8b19cc8, event=0x850b500) at kernel/qwidget.cpp:8552
#49 0xb67f00f5 in QFrame::event (this=0x8b19cc8, e=0x850b500) at widgets/qframe.cpp:557
#50 0xb6883914 in QAbstractScrollArea::event (this=0x8b19cc8, e=0x850b500) at widgets/qabstractscrollarea.cpp:996
#51 0xb6a445c8 in QGraphicsView::event (this=0x8b19cc8, event=0x850b500) at graphicsview/qgraphicsview.cpp:2741
#52 0xb2554b69 in PanelView::event (this=0x8b19cc8, event=0x850b500) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1505
#53 0xb6385684 in QApplicationPrivate::notify_helper (this=0x80e2280, receiver=0x8b19cc8, e=0x850b500) at kernel/qapplication.cpp:4462
#54 0xb638e4d4 in QApplication::notify (this=0x80d69d0, receiver=0x8b19cc8, e=0x850b500) at kernel/qapplication.cpp:4341
#55 0xb74d9591 in KApplication::notify (this=0x80d69d0, receiver=0x8b19cc8, event=0x850b500) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#56 0xb6e7d78e in QCoreApplication::notifyInternal (this=0x80d69d0, receiver=0x8b19cc8, event=0x850b500) at kernel/qcoreapplication.cpp:731
#57 0xb6e8151c in sendEvent (receiver=0x8b19cc8, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8b19cc8, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#59 0xb6e8166c in QCoreApplication::sendPostedEvents (receiver=0x8b19cc8, event_type=77) at kernel/qcoreapplication.cpp:1265
#60 0xb6a2579e in dispatchPendingUpdateRequests (this=0x8169b00) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8169b00) at graphicsview/qgraphicsscene.cpp:510
#62 0xb6a25bb3 in QGraphicsScene::qt_metacall (this=0x8120210, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x90a6dd8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0xb4c6b362 in Plasma::Corona::qt_metacall (this=0x8120210, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x90a6dd8) at /usr/src/debug/kdelibs-4.6.1/build/plasma/corona.moc:109
#64 0xb2546f32 in DesktopCorona::qt_metacall (this=0x8120210, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x90a6dd8) at /usr/src/debug/kdebase-workspace-4.6.1/build/plasma/desktop/shell/desktopcorona.moc:101
#65 0xb6e8407d in QMetaObject::metacall (object=0x8120210, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x90a6dd8) at kernel/qmetaobject.cpp:237
#66 0xb6e8eb55 in QMetaCallEvent::placeMetaCall (this=0x9072130, object=0x8120210) at kernel/qobject.cpp:535
#67 0xb6e92dbf in QObject::event (this=0x8120210, e=0x9072130) at kernel/qobject.cpp:1217
#68 0xb6a337a0 in QGraphicsScene::event (this=0x8120210, event=0x9072130) at graphicsview/qgraphicsscene.cpp:3544
#69 0xb6385684 in QApplicationPrivate::notify_helper (this=0x80e2280, receiver=0x8120210, e=0x9072130) at kernel/qapplication.cpp:4462
#70 0xb638e427 in QApplication::notify (this=0x80d69d0, receiver=0x8120210, e=0x9072130) at kernel/qapplication.cpp:3862
#71 0xb74d9591 in KApplication::notify (this=0x80d69d0, receiver=0x8120210, event=0x9072130) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#72 0xb6e7d78e in QCoreApplication::notifyInternal (this=0x80d69d0, receiver=0x8120210, event=0x9072130) at kernel/qcoreapplication.cpp:731
#73 0xb6e8151c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#75 0xb6e8166c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#76 0xb6eabdf4 in sendPostedEvents (s=0x805cd80) at kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x805cd80) at kernel/qeventdispatcher_glib.cpp:277
#78 0xb5b19509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0xb5b19d10 in ?? () from /lib/libglib-2.0.so.0
#80 0xb5b19fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0xb6eabf7b in QEventDispatcherGlib::processEvents (this=0x80c7d78, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#82 0xb643c1da in QGuiEventDispatcherGlib::processEvents (this=0x80c7d78, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0xb6e7ca6d in QEventLoop::processEvents (this=0xbff84804, flags=...) at kernel/qeventloop.cpp:149
#84 0xb6e7cc99 in QEventLoop::exec (this=0xbff84804, flags=...) at kernel/qeventloop.cpp:201
#85 0xb6e81740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#86 0xb63833d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#87 0xb254e87a in kdemain (argc=1, argv=0x80d3f68) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#88 0x0804e514 in _start ()

This bug may be a duplicate of or related to bug 268518.

Possible duplicates by query: bug 268735, bug 268518, bug 268436, bug 268360, bug 268342.

Reported using DrKonqi
Comment 1 jem 2011-03-29 20:05:49 UTC
Created attachment 58441 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

Closing Kopete triggers this bug every time.

-- Backtrace (Reduced):
#6  0x00007ff4c58ffe36 in QString (this=0x2240075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2240075, group=0, state=0) at /usr/src/debug/kde-base/kdelibs-4.6.1-r2/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#8  0x00007ff4c590597b in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kde-base/kdelibs-4.6.1-r2/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#9  0x00007ff4c590c89d in KIconLoader::loadIcon (this=0x1a38ff0, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kde-base/kdelibs-4.6.1-r2/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#10 0x00007ff4c590465f in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at /usr/src/debug/kde-base/kdelibs-4.6.1-r2/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
Comment 2 Alex Merry 2011-04-07 16:53:23 UTC

*** This bug has been marked as a duplicate of bug 226596 ***
Comment 3 lordinfinitus 2011-05-09 15:55:22 UTC
Created attachment 59803 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

After closing Kopete with Strg+Q Plasma crashed.

-- Backtrace (Reduced):
#7  0x029d6209 in QString (this=0xa9c0061, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0xa9c0061, group=0, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconeffect.cpp:169
#9  0x029dc2f3 in KIconLoaderPrivate::makeCacheKey (this=0xa9c004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:782
#10 0x029e3811 in KIconLoader::loadIcon (this=0xa9b9a08, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:1226
#11 0x029dace7 in KIconEngine::pixmap (this=0xa94b190, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconengine.cpp:93