Bug 268735 - Plasma crash with amarok
Summary: Plasma crash with amarok
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-17 10:47 UTC by chr_braumann
Modified: 2011-03-17 11:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chr_braumann 2011-03-17 10:47:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1) "release 390"
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
I closed amarok after installing a script. Then plasma crashed.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5911710 (LWP 1994))]

Thread 2 (Thread 0xa8ce8b70 (LWP 2002)):
#0  0xb6d67480 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5b7939b in g_main_context_release () from /lib/libglib-2.0.so.0
#2  0xb5b7aade in ?? () from /lib/libglib-2.0.so.0
#3  0xb5b7afce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0xb6f0bfc7 in QEventDispatcherGlib::processEvents (this=0x893d758, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb6edca6d in QEventLoop::processEvents (this=0xa8ce82b0, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6edcc99 in QEventLoop::exec (this=0xa8ce82b0, flags=...) at kernel/qeventloop.cpp:201
#7  0xb6dddd49 in QThread::exec (this=0x8834040) at thread/qthread.cpp:492
#8  0xb6ebc7fd in QInotifyFileSystemWatcherEngine::run (this=0x8834040) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb6de0993 in QThreadPrivate::start (arg=0x8834040) at thread/qthread_unix.cpp:320
#10 0xb6d63b05 in start_thread () from /lib/libpthread.so.0
#11 0xb611dd5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5911710 (LWP 1994)):
[KCrash Handler]
#7  0xb751ed13 in QString (this=0x8bc0061, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x8bc0061, group=0, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconeffect.cpp:169
#9  0xb7520618 in KIconLoaderPrivate::makeCacheKey (this=0x8bc004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:782
#10 0xb767784c in KIconLoader::loadIcon (this=0x81e51b0, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconloader.cpp:1226
#11 0xb7678b44 in KIconEngine::pixmap (this=0x9fbf278, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.1/kdeui/icons/kiconengine.cpp:93
#12 0xb649e6c4 in QIcon::pixmap (this=0x9f545ec, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb4db4471 in Plasma::IconWidgetPrivate::decoration (this=0x9f54548, option=0x8120b18, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:812
#14 0xb4dbb544 in Plasma::IconWidget::paint (this=0xa60bca0, painter=0xbfd22c0c, option=0x8120b18, widget=0x0) at /usr/src/debug/kdelibs-4.6.1/plasma/widgets/iconwidget.cpp:1128
#15 0xafadf29a in SystemTray::DBusSystemTrayWidget::paint (this=0xa60bca0, painter=0xbfd22c0c, option=0x8120b18, widget=0x0) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0xb6a78375 in _q_paintItem (item=<value optimized out>, painter=0xbfd22c0c, option=0x8120b18, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb6a786ca in _q_paintIntoCache (pix=0xbfd230ec, item=0xa60bca8, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb6a8d7d8 in QGraphicsScenePrivate::drawItemHelper (this=0x81209c8, item=0xa60bca8, painter=0xbfd24924, option=0x8120b18, widget=0x88e0c88, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0xb6a8e482 in QGraphicsScenePrivate::draw (this=0x81209c8, item=0xa60bca8, painter=0xbfd24924, viewTransform=0xbfd2470c, transformPtr=0xbfd234e0, exposedRegion=0x8af22a8, widget=0x88e0c88, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0xb6a8f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81209c8, item=0xa60bca8, painter=0xbfd24924, viewTransform=0xbfd2470c, exposedRegion=0x8af22a8, widget=0x88e0c88, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0xb6a8e2af in QGraphicsScenePrivate::draw (this=0x81209c8, item=0x81d1bf8, painter=0xbfd24924, viewTransform=0xbfd2470c, transformPtr=0xbfd23990, exposedRegion=0x8af22a8, widget=0x88e0c88, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0xb6a8f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81209c8, item=0x81d1bf8, painter=0xbfd24924, viewTransform=0xbfd2470c, exposedRegion=0x8af22a8, widget=0x88e0c88, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0xb6a8e2af in QGraphicsScenePrivate::draw (this=0x81209c8, item=0x8361300, painter=0xbfd24924, viewTransform=0xbfd2470c, transformPtr=0xbfd23e40, exposedRegion=0x8af22a8, widget=0x88e0c88, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0xb6a8f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81209c8, item=0x8361300, painter=0xbfd24924, viewTransform=0xbfd2470c, exposedRegion=0x8af22a8, widget=0x88e0c88, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0xb6a8e2af in QGraphicsScenePrivate::draw (this=0x81209c8, item=0x81e2c70, painter=0xbfd24924, viewTransform=0xbfd2470c, transformPtr=0xbfd242f0, exposedRegion=0x8af22a8, widget=0x88e0c88, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0xb6a8f21e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81209c8, item=0x81e2c70, painter=0xbfd24924, viewTransform=0xbfd2470c, exposedRegion=0x8af22a8, widget=0x88e0c88, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0xb6a8fac7 in QGraphicsScenePrivate::drawItems (this=0x81209c8, painter=0xbfd24924, viewTransform=0xbfd2470c, exposedRegion=0x8af22a8, widget=0x88e0c88) at graphicsview/qgraphicsscene.cpp:4735
#28 0xb6ab09be in QGraphicsView::paintEvent (this=0x8af1a50, event=0x0) at graphicsview/qgraphicsview.cpp:3469
#29 0xb258f973 in PanelView::paintEvent (this=0x8af1a50, event=0xbfd25004) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1494
#30 0xb6440b4a in QWidget::event (this=0x8af1a50, event=0xbfd25004) at kernel/qwidget.cpp:8405
#31 0xb68500f5 in QFrame::event (this=0x8af1a50, e=0xbfd25004) at widgets/qframe.cpp:557
#32 0xb68e1b91 in QAbstractScrollArea::viewportEvent (this=0x8af1a50, e=0xbfd25004) at widgets/qabstractscrollarea.cpp:1043
#33 0xb6ab1ddc in QGraphicsView::viewportEvent (this=0x8af1a50, event=0xbfd25004) at graphicsview/qgraphicsview.cpp:2864
#34 0xb68e4486 in viewportEvent (this=0x82764a0, o=0x88e0c88, e=0xbfd25004) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x82764a0, o=0x88e0c88, e=0xbfd25004) at widgets/qabstractscrollarea_p.h:116
#36 0xb6edd926 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80bd4f0, receiver=0x88e0c88, event=0xbfd25004) at kernel/qcoreapplication.cpp:846
#37 0xb63e5654 in QApplicationPrivate::notify_helper (this=0x80bd4f0, receiver=0x88e0c88, e=0xbfd25004) at kernel/qapplication.cpp:4458
#38 0xb63ee4d4 in QApplication::notify (this=0x80b3f78, receiver=0x88e0c88, e=0xbfd25004) at kernel/qapplication.cpp:4341
#39 0xb7539591 in KApplication::notify (this=0x80b3f78, receiver=0x88e0c88, event=0xbfd25004) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#40 0xb6edd78e in QCoreApplication::notifyInternal (this=0x80b3f78, receiver=0x88e0c88, event=0xbfd25004) at kernel/qcoreapplication.cpp:731
#41 0xb643d7e2 in sendSpontaneousEvent (this=0x8a3b738, pdev=0x8f4a0bc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a9bab0) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8a3b738, pdev=0x8f4a0bc, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a9bab0) at kernel/qwidget.cpp:5492
#43 0xb643e537 in QWidgetPrivate::paintSiblingsRecursive (this=0x8af1f58, pdev=0x8f4a0bc, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a9bab0) at kernel/qwidget.cpp:5699
#44 0xb643e3fd in QWidgetPrivate::paintSiblingsRecursive (this=0x8af1f58, pdev=0x8f4a0bc, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a9bab0) at kernel/qwidget.cpp:5686
#45 0xb643d538 in QWidgetPrivate::drawWidget (this=0x8af1f58, pdev=0x8f4a0bc, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8a9bab0) at kernel/qwidget.cpp:5545
#46 0xb662c198 in QWidgetBackingStore::sync (this=0x8a9bab0) at painting/qbackingstore.cpp:1333
#47 0xb643245b in QWidgetPrivate::syncBackingStore (this=0x8af1f58) at kernel/qwidget.cpp:1842
#48 0xb644161a in QWidget::event (this=0x8af1a50, event=0x81e51b0) at kernel/qwidget.cpp:8552
#49 0xb68500f5 in QFrame::event (this=0x8af1a50, e=0x81e51b0) at widgets/qframe.cpp:557
#50 0xb68e3914 in QAbstractScrollArea::event (this=0x8af1a50, e=0x81e51b0) at widgets/qabstractscrollarea.cpp:996
#51 0xb6aa45c8 in QGraphicsView::event (this=0x8af1a50, event=0x81e51b0) at graphicsview/qgraphicsview.cpp:2741
#52 0xb258fb69 in PanelView::event (this=0x8af1a50, event=0x81e51b0) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/panelview.cpp:1505
#53 0xb63e5684 in QApplicationPrivate::notify_helper (this=0x80bd4f0, receiver=0x8af1a50, e=0x81e51b0) at kernel/qapplication.cpp:4462
#54 0xb63ee4d4 in QApplication::notify (this=0x80b3f78, receiver=0x8af1a50, e=0x81e51b0) at kernel/qapplication.cpp:4341
#55 0xb7539591 in KApplication::notify (this=0x80b3f78, receiver=0x8af1a50, event=0x81e51b0) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#56 0xb6edd78e in QCoreApplication::notifyInternal (this=0x80b3f78, receiver=0x8af1a50, event=0x81e51b0) at kernel/qcoreapplication.cpp:731
#57 0xb6ee151c in sendEvent (receiver=0x8af1a50, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8af1a50, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#59 0xb6ee166c in QCoreApplication::sendPostedEvents (receiver=0x8af1a50, event_type=77) at kernel/qcoreapplication.cpp:1265
#60 0xb6a8579e in dispatchPendingUpdateRequests (this=0x81209c8) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x81209c8) at graphicsview/qgraphicsscene.cpp:510
#62 0xb6a85bb3 in QGraphicsScene::qt_metacall (this=0x811e348, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x893acf0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0xb4cf1362 in Plasma::Corona::qt_metacall (this=0x811e348, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x893acf0) at /usr/src/debug/kdelibs-4.6.1/build/plasma/corona.moc:109
#64 0xb2581f32 in DesktopCorona::qt_metacall (this=0x811e348, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x893acf0) at /usr/src/debug/kdebase-workspace-4.6.1/build/plasma/desktop/shell/desktopcorona.moc:101
#65 0xb6ee407d in QMetaObject::metacall (object=0x811e348, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x893acf0) at kernel/qmetaobject.cpp:237
#66 0xb6eeeb55 in QMetaCallEvent::placeMetaCall (this=0xa803138, object=0x811e348) at kernel/qobject.cpp:535
#67 0xb6ef2dbf in QObject::event (this=0x811e348, e=0xa803138) at kernel/qobject.cpp:1217
#68 0xb6a937a0 in QGraphicsScene::event (this=0x811e348, event=0xa803138) at graphicsview/qgraphicsscene.cpp:3544
#69 0xb63e5684 in QApplicationPrivate::notify_helper (this=0x80bd4f0, receiver=0x811e348, e=0xa803138) at kernel/qapplication.cpp:4462
#70 0xb63ee427 in QApplication::notify (this=0x80b3f78, receiver=0x811e348, e=0xa803138) at kernel/qapplication.cpp:3862
#71 0xb7539591 in KApplication::notify (this=0x80b3f78, receiver=0x811e348, event=0xa803138) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#72 0xb6edd78e in QCoreApplication::notifyInternal (this=0x80b3f78, receiver=0x811e348, event=0xa803138) at kernel/qcoreapplication.cpp:731
#73 0xb6ee151c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#75 0xb6ee166c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#76 0xb6f0bdf4 in sendPostedEvents (s=0x80bf890) at kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x80bf890) at kernel/qeventdispatcher_glib.cpp:277
#78 0xb5b7a509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0xb5b7ad10 in ?? () from /lib/libglib-2.0.so.0
#80 0xb5b7afce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0xb6f0bf7b in QEventDispatcherGlib::processEvents (this=0x80a7fd8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#82 0xb649c1da in QGuiEventDispatcherGlib::processEvents (this=0x80a7fd8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0xb6edca6d in QEventLoop::processEvents (this=0xbfd26954, flags=...) at kernel/qeventloop.cpp:149
#84 0xb6edcc99 in QEventLoop::exec (this=0xbfd26954, flags=...) at kernel/qeventloop.cpp:201
#85 0xb6ee1740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#86 0xb63e33d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#87 0xb258987a in kdemain (argc=1, argv=0x80a78d8) at /usr/src/debug/kdebase-workspace-4.6.1/plasma/desktop/shell/main.cpp:118
#88 0x0804e514 in _start ()

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 268518, bug 268436, bug 268360, bug 268342, bug 268254.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-17 11:21:30 UTC

*** This bug has been marked as a duplicate of bug 258706 ***