Bug 268342 - Plasma crash when close amarok
Summary: Plasma crash when close amarok
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-13 04:07 UTC by Cristian M. Barbe
Modified: 2011-03-13 13:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian M. Barbe 2011-03-13 04:07:06 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Internet with Chromium 10
Amsn chat
Listen music with amarok and skype open

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7728720 (LWP 1883))]

Thread 3 (Thread 0xb44b3b70 (LWP 1912)):
#0  0x00226416 in __kernel_vsyscall ()
#1  0x002e8df6 in poll () from /lib/libc.so.6
#2  0x0318ba1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0317e43c in ?? () from /lib/libglib-2.0.so.0
#4  0x0317e848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0747659f in QEventDispatcherGlib::processEvents (this=0x9906000, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x07446609 in QEventLoop::processEvents (this=0xb44b3280, flags=) at kernel/qeventloop.cpp:149
#7  0x07446a8a in QEventLoop::exec (this=0xb44b3280, flags=...) at kernel/qeventloop.cpp:201
#8  0x07342b7e in QThread::exec (this=0x990f478) at thread/qthread.cpp:490
#9  0x0742535b in QInotifyFileSystemWatcherEngine::run (this=0x990f478) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07345df9 in QThreadPrivate::start (arg=0x990f478) at thread/qthread_unix.cpp:266
#11 0x02f83cc9 in start_thread () from /lib/libpthread.so.0
#12 0x002f769e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xad355b70 (LWP 1914)):
#0  0x00226416 in __kernel_vsyscall ()
#1  0x002e8df6 in poll () from /lib/libc.so.6
#2  0x0318ba1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x0317e43c in ?? () from /lib/libglib-2.0.so.0
#4  0x0317e848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0747659f in QEventDispatcherGlib::processEvents (this=0x92df580, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x07446609 in QEventLoop::processEvents (this=0xad355280, flags=) at kernel/qeventloop.cpp:149
#7  0x07446a8a in QEventLoop::exec (this=0xad355280, flags=...) at kernel/qeventloop.cpp:201
#8  0x07342b7e in QThread::exec (this=0x98bb6e8) at thread/qthread.cpp:490
#9  0x0742535b in QInotifyFileSystemWatcherEngine::run (this=0x98bb6e8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07345df9 in QThreadPrivate::start (arg=0x98bb6e8) at thread/qthread_unix.cpp:266
#11 0x02f83cc9 in start_thread () from /lib/libpthread.so.0
#12 0x002f769e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7728720 (LWP 1883)):
[KCrash Handler]
#7  0x00e29ba7 in QString (this=0x9140061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0x9140061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x00e2dad8 in KIconLoaderPrivate::makeCacheKey (this=0x914004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x00e35f08 in KIconLoader::loadIcon (this=0xa33c2f0, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x00e2c3f6 in KIconEngine::pixmap (this=0xa5d2858, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x01270626 in QIcon::pixmap (this=0xa4cfb5c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x00543222 in Plasma::IconWidgetPrivate::decoration (this=0xa4cfab8, option=0x911fcf0, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x00545cb7 in Plasma::IconWidget::paint (this=0xa4fe0d8, painter=0xbf95031c, option=0x911fcf0, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x0902c19d in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0x0187552c in _q_paintItem (item=<value optimized out>, painter=0x911fcf0, option=0x911fcf0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x01877eaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x911fcf0, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x0187f718 in QGraphicsScenePrivate::drawItemHelper (this=0x911fba0, item=0xa4fe0e0, painter=0xbf951ff4, option=0x911fcf0, widget=0x9dfed38, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x018837d8 in QGraphicsScenePrivate::draw (this=0x911fba0, item=0xa4fe0e0, painter=0xbf951ff4, viewTransform=0xbf951ddc, transformPtr=0xbf950c50, exposedRegion=0x9931280, widget=0x9dfed38, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x018844a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x911fba0, item=0xa4fe0e0, painter=0xbf951ff4, viewTransform=0xbf951ddc, exposedRegion=0x9931280, widget=0x9dfed38, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x01883874 in QGraphicsScenePrivate::draw (this=0x911fba0, item=0x94a2cc8, painter=0xbf951ff4, viewTransform=0xbf951ddc, transformPtr=0xbf9510c0, exposedRegion=0x9931280, widget=0x9dfed38, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x018844a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x911fba0, item=0x94a2cc8, painter=0xbf951ff4, viewTransform=0xbf951ddc, exposedRegion=0x9931280, widget=0x9dfed38, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x01883874 in QGraphicsScenePrivate::draw (this=0x911fba0, item=0x94a32f0, painter=0xbf951ff4, viewTransform=0xbf951ddc, transformPtr=0xbf951530, exposedRegion=0x9931280, widget=0x9dfed38, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x018844a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x911fba0, item=0x94a32f0, painter=0xbf951ff4, viewTransform=0xbf951ddc, exposedRegion=0x9931280, widget=0x9dfed38, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x01883874 in QGraphicsScenePrivate::draw (this=0x911fba0, item=0x9399060, painter=0xbf951ff4, viewTransform=0xbf951ddc, transformPtr=0xbf9519a0, exposedRegion=0x9931280, widget=0x9dfed38, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x018844a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x911fba0, item=0x9399060, painter=0xbf951ff4, viewTransform=0xbf951ddc, exposedRegion=0x9931280, widget=0x9dfed38, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x01884cce in QGraphicsScenePrivate::drawItems (this=0x911fba0, painter=0xbf951ff4, viewTransform=0xbf951ddc, exposedRegion=0x9931280, widget=0x9dfed38) at graphicsview/qgraphicsscene.cpp:4699
#28 0x018b0bb9 in QGraphicsView::paintEvent (this=0xa0c5620, event=0xbf952714) at graphicsview/qgraphicsview.cpp:3467
#29 0x008b6224 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#30 0x01209cc6 in QWidget::event (this=0xa0c5620, event=0xbf952714) at kernel/qwidget.cpp:8333
#31 0x0162b763 in QFrame::event (this=0xa0c5620, e=0xbf952714) at widgets/qframe.cpp:557
#32 0x016c8a82 in QAbstractScrollArea::viewportEvent (this=0x1a09146e, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x018acccb in QGraphicsView::viewportEvent (this=0xa0c5620, event=0xbf952714) at graphicsview/qgraphicsview.cpp:2862
#34 0x016cb4d5 in viewportEvent (this=0x99d9e58, o=0x9dfed38, e=0xbf952714) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x99d9e58, o=0x9dfed38, e=0xbf952714) at widgets/qabstractscrollarea_p.h:116
#36 0x0744729a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x90c1960, receiver=0x9dfed38, event=0xbf952714) at kernel/qcoreapplication.cpp:847
#37 0x011abfb9 in QApplicationPrivate::notify_helper (this=0x90c1960, receiver=0x9dfed38, e=0xbf952714) at kernel/qapplication.cpp:4392
#38 0x011b20e9 in QApplication::notify (this=0x90b7a98, receiver=0x9dfed38, e=0xbf952714) at kernel/qapplication.cpp:4361
#39 0x00e917da in KApplication::notify (this=0x90b7a98, receiver=0x9dfed38, event=0xbf952714) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x07447b3b in QCoreApplication::notifyInternal (this=0x90b7a98, receiver=0x9dfed38, event=0xbf952714) at kernel/qcoreapplication.cpp:732
#41 0x01210ee6 in sendSpontaneousEvent (this=0x9c14828, pdev=0x9e119dc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x994dde8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x9c14828, pdev=0x9e119dc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x994dde8) at kernel/qwidget.cpp:5420
#43 0x01211cff in QWidgetPrivate::paintSiblingsRecursive (this=0x9930f30, pdev=0x9e119dc, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x994dde8) at kernel/qwidget.cpp:5627
#44 0x01211b38 in QWidgetPrivate::paintSiblingsRecursive (this=0x9930f30, pdev=0x9e119dc, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x994dde8) at kernel/qwidget.cpp:5614
#45 0x01210c35 in QWidgetPrivate::drawWidget (this=0x9930f30, pdev=0x9e119dc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x994dde8) at kernel/qwidget.cpp:5473
#46 0x01401c74 in QWidgetBackingStore::sync (this=0x994dde8) at painting/qbackingstore.cpp:1328
#47 0x012032b3 in QWidgetPrivate::syncBackingStore (this=0x9930f30) at kernel/qwidget.cpp:1805
#48 0x0120a466 in QWidget::event (this=0xa0c5620, event=0xa33c2f0) at kernel/qwidget.cpp:8480
#49 0x0162b763 in QFrame::event (this=0xa0c5620, e=0xa33c2f0) at widgets/qframe.cpp:557
#50 0x016c9487 in QAbstractScrollArea::event (this=0xa0c5620, e=0xa33c2f0) at widgets/qabstractscrollarea.cpp:996
#51 0x018aeea6 in QGraphicsView::event (this=0xa0c5620, event=0xa33c2f0) at graphicsview/qgraphicsview.cpp:2739
#52 0x008b6d13 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#53 0x011abfdc in QApplicationPrivate::notify_helper (this=0x90c1960, receiver=0xa33c2f0, e=0xa0c5620) at kernel/qapplication.cpp:4396
#54 0x011b20e9 in QApplication::notify (this=0x90b7a98, receiver=0xa0c5620, e=0xa33c2f0) at kernel/qapplication.cpp:4361
#55 0x00e917da in KApplication::notify (this=0x90b7a98, receiver=0xa0c5620, event=0xa33c2f0) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x07447b3b in QCoreApplication::notifyInternal (this=0x90b7a98, receiver=0xa0c5620, event=0xa33c2f0) at kernel/qcoreapplication.cpp:732
#57 0x0744ad8b in sendEvent (receiver=0xa0c5620, event_type=77, data=0x908b108) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0xa0c5620, event_type=77, data=0x908b108) at kernel/qcoreapplication.cpp:1373
#59 0x0744af4d in QCoreApplication::sendPostedEvents (receiver=0xa0c5620, event_type=77) at kernel/qcoreapplication.cpp:1266
#60 0x01894c3e in dispatchPendingUpdateRequests (this=0x911fba0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x911fba0) at graphicsview/qgraphicsscene.cpp:510
#62 0x01895116 in QGraphicsScene::qt_metacall (this=0x916a878, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xa399638) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0x0046fa4a in Plasma::Corona::qt_metacall (this=0x916a878, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0xa399638) at ./corona.moc:109
#64 0x008a4f7a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#65 0x0744d8ca in QMetaObject::metacall (object=0x916a878, cl=436802670, idx=0, argv=0x916a878) at kernel/qmetaobject.cpp:237
#66 0x07458df6 in QMetaCallEvent::placeMetaCall (this=0xa5d0950, object=0x916a878) at kernel/qobject.cpp:534
#67 0x0745a6a2 in QObject::event (this=0x916a878, e=0x0) at kernel/qobject.cpp:1219
#68 0x01891374 in QGraphicsScene::event (this=0x916a878, event=0xa5d0950) at graphicsview/qgraphicsscene.cpp:3548
#69 0x011abfdc in QApplicationPrivate::notify_helper (this=0x90c1960, receiver=0x916a878, e=0xa5d0950) at kernel/qapplication.cpp:4396
#70 0x011b204e in QApplication::notify (this=0x90b7a98, receiver=0x916a878, e=0xa5d0950) at kernel/qapplication.cpp:3798
#71 0x00e917da in KApplication::notify (this=0x90b7a98, receiver=0x916a878, event=0xa5d0950) at ../../kdeui/kernel/kapplication.cpp:311
#72 0x07447b3b in QCoreApplication::notifyInternal (this=0x90b7a98, receiver=0x916a878, event=0xa5d0950) at kernel/qcoreapplication.cpp:732
#73 0x0744ad8b in sendEvent (receiver=0x0, event_type=0, data=0x908b108) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x908b108) at kernel/qcoreapplication.cpp:1373
#75 0x0744af4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#76 0x07476a74 in sendPostedEvents (s=0x90c18e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x90c18e0) at kernel/qeventdispatcher_glib.cpp:277
#78 0x0317a855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#79 0x0317e668 in ?? () from /lib/libglib-2.0.so.0
#80 0x0317e848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#81 0x07476565 in QEventDispatcherGlib::processEvents (this=0x908abb8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#82 0x0126dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x908abb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x07446609 in QEventLoop::processEvents (this=0xbf9540e4, flags=) at kernel/qeventloop.cpp:149
#84 0x07446a8a in QEventLoop::exec (this=0xbf9540e4, flags=...) at kernel/qeventloop.cpp:201
#85 0x0744b00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#86 0x011aae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#87 0x008adf97 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#88 0x080485bb in _start ()

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 268254, bug 268228, bug 268171, bug 268086, bug 268000.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-13 13:43:05 UTC
[Comment from a bug triager]
This issue is being tracked at bug 258706. Merging.
Regards

*** This bug has been marked as a duplicate of bug 258706 ***