Bug 268475 - network-manager applet (and sometimes plasma-desktop) crahes
Summary: network-manager applet (and sometimes plasma-desktop) crahes
Status: RESOLVED DUPLICATE of bug 268473
Alias: None
Product: Network Management
Classification: Unclassified
Component: KDED Module (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 16:15 UTC by Ruszkai Ákos
Modified: 2011-03-14 22:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruszkai Ákos 2011-03-14 16:15:26 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
network-manager applet crashed after I've removed it from panel.
On crash, the window told me the KDE service:

.ar5k

was faulty. I don't know what that is.

- Unusual behavior I noticed:
network-manger applet sometimes fails, and only removing and restarting it helps. It won't refresh networks in  the ner, refuses to connect, misses buttons etc.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE-szolgáltatás (kdeinit4), signal: Illegal instruction
[Current thread is 1 (Thread 0xb7869930 (LWP 1407))]

Thread 3 (Thread 0xb4196b70 (LWP 1452)):
#0  0x00e136d1 in QTimerInfoList::updateCurrentTime (this=0x930a0cc) at kernel/qeventdispatcher_unix.cpp:338
#1  0x00e1372a in QTimerInfoList::timerWait (this=0x930a0cc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#2  0x00e117a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb41960bc) at kernel/qeventdispatcher_glib.cpp:136
#3  0x00e1183d in timerSourcePrepare (source=0xb4195fd8, timeout=0xb4196038) at kernel/qeventdispatcher_glib.cpp:169
#4  0x06f5ee6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#5  0x06f5f279 in ?? () from /lib/libglib-2.0.so.0
#6  0x06f5f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#7  0x00e1159f in QEventDispatcherGlib::processEvents (this=0x92712a8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#8  0x00de1609 in QEventLoop::processEvents (this=0xb4196290, flags=) at kernel/qeventloop.cpp:149
#9  0x00de1a8a in QEventLoop::exec (this=0xb4196290, flags=...) at kernel/qeventloop.cpp:201
#10 0x00cddb7e in QThread::exec (this=0x92ac730) at thread/qthread.cpp:490
#11 0x00dc035b in QInotifyFileSystemWatcherEngine::run (this=0x92ac730) at io/qfilesystemwatcher_inotify.cpp:248
#12 0x00ce0df9 in QThreadPrivate::start (arg=0x92ac730) at thread/qthread_unix.cpp:266
#13 0x0263fcc9 in start_thread () from /lib/libpthread.so.0
#14 0x003e869e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb201eb70 (LWP 1622)):
#0  0x026423eb in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x003f5f66 in pthread_mutex_lock () from /lib/libc.so.6
#2  0x06f5ed0f in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x06f5f279 in ?? () from /lib/libglib-2.0.so.0
#4  0x06f5f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00e1159f in QEventDispatcherGlib::processEvents (this=0x933c090, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00de1609 in QEventLoop::processEvents (this=0xb201e290, flags=) at kernel/qeventloop.cpp:149
#7  0x00de1a8a in QEventLoop::exec (this=0xb201e290, flags=...) at kernel/qeventloop.cpp:201
#8  0x00cddb7e in QThread::exec (this=0x9520bb0) at thread/qthread.cpp:490
#9  0x00dc035b in QInotifyFileSystemWatcherEngine::run (this=0x9520bb0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00ce0df9 in QThreadPrivate::start (arg=0x9520bb0) at thread/qthread_unix.cpp:266
#11 0x0263fcc9 in start_thread () from /lib/libpthread.so.0
#12 0x003e869e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7869930 (LWP 1407)):
[KCrash Handler]
#7  0x00380033 in _IO_file_xsputn () from /lib/libc.so.6
#8  0x0520144e in ?? () from /usr/lib/libknmservice.so.4
#9  0x0520168e in ?? () from /usr/lib/libknmservice.so.4
#10 0x05201645 in ?? () from /usr/lib/libknmservice.so.4
#11 0x05201982 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x051efac3 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x051f0318 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#14 0x051f45c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#15 0x051f1b40 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#16 0x051f09b3 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#17 0x051ea0eb in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#18 0x00de88ca in QMetaObject::metacall (object=0x92ce4c0, cl=154712321, idx=153972512, argv=0x92d8d78) at kernel/qmetaobject.cpp:237
#19 0x00dfb6ad in QMetaObject::activate (sender=0x92d12f8, m=0x37b0580, local_signal_index=1, argv=0x9393ff8) at kernel/qobject.cpp:3280
#20 0x03791883 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x92d12f8, _t1=...) at ./networkmanager.moc:110
#21 0x03792366 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x92d12f8, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:199
#22 0x037923e7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x92d12f8, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff687a8) at ./networkmanager_p.moc:81
#23 0x00de88ca in QMetaObject::metacall (object=0x92d12f8, cl=154712321, idx=11, argv=0xbff687a8) at kernel/qmetaobject.cpp:237
#24 0x00dfb6ad in QMetaObject::activate (sender=0x92c67f0, m=0x3818838, local_signal_index=1, argv=0x9393ff8) at kernel/qobject.cpp:3280
#25 0x03815423 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x92c67f0, _t1=...) at ./networkmanager.moc:118
#26 0x08cd62ea in NMNetworkManager::deviceAdded (this=0x92c67f0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:214
#27 0x08cda595 in NMNetworkManager::qt_metacall (this=0x92c67f0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbff68948) at ./manager.moc:95
#28 0x00de88ca in QMetaObject::metacall (object=0x92c67f0, cl=154712321, idx=16, argv=0xbff68948) at kernel/qmetaobject.cpp:237
#29 0x00dfb6ad in QMetaObject::activate (sender=0x92d4d88, m=0x8cf0a80, local_signal_index=0, argv=0x9393ff8) at kernel/qobject.cpp:3280
#30 0x08ce5be3 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x92d4d88, _t1=...) at ./nm-manager-clientinterface.moc:161
#31 0x08ce60ed in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x92d4d88, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff68bbc) at ./nm-manager-clientinterface.moc:105
#32 0x0369e9dc in QDBusConnectionPrivate::deliverCall (this=0x92bbbf8, object=0x92d4d88, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#33 0x036aa1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x93152d0, object=0x92d4d88) at qdbusintegrator_p.h:103
#34 0x00df56a2 in QObject::event (this=0x92d4d88, e=0x7afd490) at kernel/qobject.cpp:1219
#35 0x01042fdc in QApplicationPrivate::notify_helper (this=0x9202d68, receiver=0x92d4d88, e=0x93152d0) at kernel/qapplication.cpp:4396
#36 0x0104904e in QApplication::notify (this=0xbff69490, receiver=0x92d4d88, e=0x93152d0) at kernel/qapplication.cpp:3798
#37 0x00a907da in KApplication::notify (this=0xbff69490, receiver=0x92d4d88, event=0x93152d0) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00de2b3b in QCoreApplication::notifyInternal (this=0xbff69490, receiver=0x92d4d88, event=0x93152d0) at kernel/qcoreapplication.cpp:732
#39 0x00de5d8b in sendEvent (receiver=0x0, event_type=0, data=0x9171f20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9171f20) at kernel/qcoreapplication.cpp:1373
#41 0x00de5f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#42 0x00e11a74 in sendPostedEvents (s=0x9205110) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x9205110) at kernel/qeventdispatcher_glib.cpp:277
#44 0x06f5b855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x06f5f668 in ?? () from /lib/libglib-2.0.so.0
#46 0x06f5f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0x00e11565 in QEventDispatcherGlib::processEvents (this=0x9173198, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#48 0x01104be5 in QGuiEventDispatcherGlib::processEvents (this=0x9173198, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00de1609 in QEventLoop::processEvents (this=0xbff693e4, flags=) at kernel/qeventloop.cpp:149
#50 0x00de1a8a in QEventLoop::exec (this=0xbff693e4, flags=...) at kernel/qeventloop.cpp:201
#51 0x00de600f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#52 0x01041e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#53 0x048819b7 in kdemain (argc=1, argv=0x91bd898) at ../../kded/kded.cpp:925
#54 0x0804e739 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8051c2b "0") at ../../kinit/kinit.cpp:746
#55 0x08050899 in main (argc=4, argv=0xbff69c64, envp=0xbff69c78) at ../../kinit/kinit.cpp:1861

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 267500, bug 266079.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-14 22:51:15 UTC

*** This bug has been marked as a duplicate of bug 268473 ***