Bug 266079 - Plasma-netbook crash after network-manager has been restarted
Summary: Plasma-netbook crash after network-manager has been restarted
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-11 15:03 UTC by abyss.andrey
Modified: 2011-02-11 18:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abyss.andrey 2011-02-11 15:03:35 UTC
Application: kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

- I entered "sudo service network-manager restart"
- service restarted, connection icon changed to "X"
-After couple seconds it changed to "." and plasma crashed

Plasma-desktop does not crash in same situation.

The crash can be reproduced every time.

-- Backtrace:
Application: Служба KDE (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0xb7803930 (LWP 1533))]

Thread 3 (Thread 0xb4181b70 (LWP 1536)):
#0  0x005e7416 in __kernel_vsyscall ()
#1  0x093860f3 in ?? () from /lib/libc.so.6
#2  0x0931a65f in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0xb3956b70 (LWP 1604)):
#0  0x005e7416 in __kernel_vsyscall ()
#1  0x093860f3 in ?? () from /lib/libc.so.6
#2  0x0931a65f in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb7803930 (LWP 1533)):
[KCrash Handler]
#7  0x005e7416 in __kernel_vsyscall ()
#8  0x092d2941 in raise () from /lib/libc.so.6
#9  0x092d5e42 in abort () from /lib/libc.so.6
#10 0x0930a305 in ?? () from /lib/libc.so.6
#11 0x09314501 in ?? () from /lib/libc.so.6
#12 0x09315d70 in ?? () from /lib/libc.so.6
#13 0x09318e5d in free () from /lib/libc.so.6
#14 0x0079cfed in qFree (ptr=0x9981f60) at global/qmalloc.cpp:60
#15 0x007ee180 in QString::free (d=0x0) at tools/qstring.cpp:1151
#16 0x035fc34b in ?? () from /usr/lib/libknmservice.so.4
#17 0x035fc40c in ?? () from /usr/lib/libknmservice.so.4
#18 0x035fc768 in ?? () from /usr/lib/libknmservice.so.4
#19 0x035fc982 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#20 0x035eaac3 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#21 0x035eb318 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#22 0x035ef5c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#23 0x035ee5c4 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#24 0x035eef71 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) () from /usr/lib/libknmservice.so.4
#25 0x035eba1c in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#26 0x035e50eb in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#27 0x008aa8ca in QMetaObject::metacall (object=0x990d950, cl=1533, idx=160487848, argv=0x984aaa8) at kernel/qmetaobject.cpp:237
#28 0x008bd6ad in QMetaObject::activate (sender=0x990f6a8, m=0x9294580, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3280
#29 0x09275893 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x990f6a8, _t1=...) at ./networkmanager.moc:110
#30 0x09276376 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x990f6a8, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:199
#31 0x092763f7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x990f6a8, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf90a9f8) at ./networkmanager_p.moc:81
#32 0x008aa8ca in QMetaObject::metacall (object=0x990f6a8, cl=1533, idx=11, argv=0xbf90a9f8) at kernel/qmetaobject.cpp:237
#33 0x008bd6ad in QMetaObject::activate (sender=0x98dc230, m=0x4e64838, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3280
#34 0x04e61423 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x98dc230, _t1=...) at ./networkmanager.moc:118
#35 0x072e62ea in NMNetworkManager::deviceAdded (this=0x98dc230, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:214
#36 0x072ea595 in NMNetworkManager::qt_metacall (this=0x98dc230, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbf90ab98) at ./manager.moc:95
#37 0x008aa8ca in QMetaObject::metacall (object=0x98dc230, cl=1533, idx=16, argv=0xbf90ab98) at kernel/qmetaobject.cpp:237
#38 0x008bd6ad in QMetaObject::activate (sender=0x99147b0, m=0x7300a80, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#39 0x072f5be3 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x99147b0, _t1=...) at ./nm-manager-clientinterface.moc:161
#40 0x072f60ed in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x99147b0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf90ae0c) at ./nm-manager-clientinterface.moc:105
#41 0x00b889dc in QDBusConnectionPrivate::deliverCall (this=0x986ffd8, object=0x99147b0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#42 0x00b941f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9850fa0, object=0x99147b0) at qdbusintegrator_p.h:103
#43 0x008b76a2 in QObject::event (this=0x99147b0, e=0x6) at kernel/qobject.cpp:1219
#44 0x00fcafdc in QApplicationPrivate::notify_helper (this=0x97d41a8, receiver=0x99147b0, e=0x9850fa0) at kernel/qapplication.cpp:4396
#45 0x00fd104e in QApplication::notify (this=0xbf90b6e0, receiver=0x99147b0, e=0x9850fa0) at kernel/qapplication.cpp:3798
#46 0x00319f7a in KApplication::notify (this=0xbf90b6e0, receiver=0x99147b0, event=0x9850fa0) at ../../kdeui/kernel/kapplication.cpp:311
#47 0x008a4b3b in QCoreApplication::notifyInternal (this=0xbf90b6e0, receiver=0x99147b0, event=0x9850fa0) at kernel/qcoreapplication.cpp:732
#48 0x008a7d8b in sendEvent (receiver=0x0, event_type=0, data=0x974ff20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x974ff20) at kernel/qcoreapplication.cpp:1373
#50 0x008a7f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#51 0x008d3a74 in sendPostedEvents (s=0x97d50b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#52 postEventSourceDispatch (s=0x97d50b8) at kernel/qeventdispatcher_glib.cpp:277
#53 0x04d73855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#54 0x04d77668 in ?? () from /lib/libglib-2.0.so.0
#55 0x04d77848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#56 0x008d3565 in QEventDispatcherGlib::processEvents (this=0x97be590, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#57 0x0108cbe5 in QGuiEventDispatcherGlib::processEvents (this=0x97be590, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x008a3609 in QEventLoop::processEvents (this=0xbf90b634, flags=) at kernel/qeventloop.cpp:149
#59 0x008a3a8a in QEventLoop::exec (this=0xbf90b634, flags=...) at kernel/qeventloop.cpp:201
#60 0x008a800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#61 0x00fc9e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#62 0x090bf9b7 in kdemain (argc=1, argv=0x979cda0) at ../../kded/kded.cpp:925
#63 0x0804e739 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8051c2b "0") at ../../kinit/kinit.cpp:742
#64 0x08050899 in main (argc=4, argv=0xbf90beb4, envp=0xbf90bec8) at ../../kinit/kinit.cpp:1857

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-02-11 18:08:39 UTC

*** This bug has been marked as a duplicate of bug 210878 ***