Bug 268228 - Plasma crashes every ten minutes or so
Summary: Plasma crashes every ten minutes or so
Status: RESOLVED DUPLICATE of bug 268157
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-11 15:32 UTC by Wonko
Modified: 2011-03-13 13:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wonko 2011-03-11 15:32:43 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.37-ck x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
This seems to be a duplicate, but I am not sure. What seems to be different from other reports I read is that the crashes happen without me doing special things, like logging out or closing Amarok. I have Amarok running, but it does not seem to be affected. I can leave the PC alone for a while, and when I come back plasma sometimes has crashed. Oh, and it did so again while I was typing the last sentence.

I updated to KDE 4.6.1 three days ago, but the crashes started happening yesterday. Well, plasma crashes frequently here, so it may have happened earlier and I forgot, but not that often as it does now. No idea what could have triggered this behaviour. I did not log out of KDE after the first login after the update, I did not install plasmoids or make other changes to the configuration. An hour ago I logged out and in again to see if this would make a difference, but it did not.

If you like me to do so, I could compile plasma-workspace and whatever else you like with debug information.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f869c405760 (LWP 25310))]

Thread 3 (Thread 0x7f8672ada700 (LWP 25320)):
#0  0xffffffffff600136 in ?? ()
#1  0x00007f8672ad9ae0 in ?? ()
#2  0x00007fff91b2b6de in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f866bfff700 (LWP 25937)):
#0  0x00007f869ad2162c in pthread_cond_wait () from /lib/libpthread.so.0
#1  0x00007f868f12cd84 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f868f12cdb9 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f869ad1cd4c in start_thread () from /lib/libpthread.so.0
#4  0x00007f8699b00a7d in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7f869c405760 (LWP 25310)):
[KCrash Handler]
#6  0x00007f869bdc7ded in KIconEffect::fingerprint(int, int) const () from /usr/lib/libkdeui.so.5
#7  0x00007f869bdcd83b in KIconLoaderPrivate::makeCacheKey(QString const&, KIconLoader::Group, QStringList const&, int, int) const () from /usr/lib/libkdeui.so.5
#8  0x00007f869bdd47f1 in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /usr/lib/libkdeui.so.5
#9  0x00007f869bdcc56f in KIconEngine::pixmap(QSize const&, QIcon::Mode, QIcon::State) () from /usr/lib/libkdeui.so.5
#10 0x00007f869a31132e in QIcon::pixmap(QSize const&, QIcon::Mode, QIcon::State) const () from /usr/lib64/qt4/libQtGui.so.4
#11 0x00007f8690d959a1 in Plasma::IconWidgetPrivate::decoration(QStyleOptionGraphicsItem const*, bool, bool) () from /usr/lib64/libplasma.so.3
#12 0x00007f8690d9b81b in Plasma::IconWidget::paint(QPainter*, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib64/libplasma.so.3
#13 0x00007f867f461eb9 in SystemTray::DBusSystemTrayWidget::paint(QPainter*, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib64/kde4/plasma_applet_systemtray.so
#14 0x00007f869a82b3cd in _q_paintItem(QGraphicsItem*, QPainter*, QStyleOptionGraphicsItem const*, QWidget*, bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#15 0x00007f869a82b6d0 in _q_paintIntoCache(QPixmap*, QGraphicsItem*, QRegion const&, QTransform const&, QFlags<QPainter::RenderHint>, QStyleOptionGraphicsItem const*, bool) () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007f869a83f0fd in QGraphicsScenePrivate::drawItemHelper(QGraphicsItem*, QPainter*, QStyleOptionGraphicsItem const*, QWidget*, bool) () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007f869a83fc46 in QGraphicsScenePrivate::draw(QGraphicsItem*, QPainter*, QTransform const*, QTransform const*, QRegion*, QWidget*, double, QTransform const*, bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f869a8408a7 in QGraphicsScenePrivate::drawSubtreeRecursive(QGraphicsItem*, QPainter*, QTransform const*, QRegion*, QWidget*, double, QTransform const*) () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f869a83faa8 in QGraphicsScenePrivate::draw(QGraphicsItem*, QPainter*, QTransform const*, QTransform const*, QRegion*, QWidget*, double, QTransform const*, bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f869a8408a7 in QGraphicsScenePrivate::drawSubtreeRecursive(QGraphicsItem*, QPainter*, QTransform const*, QRegion*, QWidget*, double, QTransform const*) () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007f869a83faa8 in QGraphicsScenePrivate::draw(QGraphicsItem*, QPainter*, QTransform const*, QTransform const*, QRegion*, QWidget*, double, QTransform const*, bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007f869a8408a7 in QGraphicsScenePrivate::drawSubtreeRecursive(QGraphicsItem*, QPainter*, QTransform const*, QRegion*, QWidget*, double, QTransform const*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f869a83faa8 in QGraphicsScenePrivate::draw(QGraphicsItem*, QPainter*, QTransform const*, QTransform const*, QRegion*, QWidget*, double, QTransform const*, bool, bool) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007f869a8408a7 in QGraphicsScenePrivate::drawSubtreeRecursive(QGraphicsItem*, QPainter*, QTransform const*, QRegion*, QWidget*, double, QTransform const*) () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00007f869a84112c in QGraphicsScenePrivate::drawItems(QPainter*, QTransform const*, QRegion*, QWidget*) () from /usr/lib64/qt4/libQtGui.so.4
#26 0x00007f869a85dc7c in QGraphicsView::paintEvent(QPaintEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007f869a2bbbb5 in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00007f869a640446 in QFrame::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007f869a85eeb3 in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#30 0x00007f869b092606 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#31 0x00007f869a26aff1 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00007f869a26fb0a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#33 0x00007f869be21d06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#34 0x00007f869b092483 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007f869a2b8b00 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#36 0x00007f869a2b96af in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#37 0x00007f869a2b956c in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#38 0x00007f869a2b956c in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#39 0x00007f869a2b956c in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#40 0x00007f869a2b8848 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#41 0x00007f869a4777a0 in QWidgetBackingStore::sync() () from /usr/lib64/qt4/libQtGui.so.4
#42 0x00007f869a2aeeb8 in QWidgetPrivate::syncBackingStore() () from /usr/lib64/qt4/libQtGui.so.4
#43 0x00007f869a2bc0b2 in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#44 0x00007f869a640446 in QFrame::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#45 0x00007f869a6bfef3 in QAbstractScrollArea::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#46 0x00007f868bef5b90 in PanelView::event(QEvent*) () from /usr/lib64/libkdeinit4_plasma-desktop.so
#47 0x00007f869a26b024 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#48 0x00007f869a26fb0a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#49 0x00007f869be21d06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#50 0x00007f869b092483 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#51 0x00007f869b095bcc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#52 0x00007f869a837ce2 in QGraphicsScenePrivate::_q_processDirtyItems() () from /usr/lib64/qt4/libQtGui.so.4
#53 0x00007f869a8380d2 in QGraphicsScene::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/qt4/libQtGui.so.4
#54 0x00007f8690ceacc5 in Plasma::Corona::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libplasma.so.3
#55 0x00007f868beea0a5 in DesktopCorona::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkdeinit4_plasma-desktop.so
#56 0x00007f869b0a63a2 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#57 0x00007f869a844a40 in QGraphicsScene::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#58 0x00007f869a26b024 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#59 0x00007f869a26fb0a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#60 0x00007f869be21d06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#61 0x00007f869b092483 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#62 0x00007f869b095bcc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#63 0x00007f869b0bc923 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#64 0x00007f8696b3dbf2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#65 0x00007f8696b3e3a0 in g_main_context_iterate.clone.5 () from /usr/lib/libglib-2.0.so.0
#66 0x00007f8696b3e63d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#67 0x00007f869b0bcaaf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#68 0x00007f869a30f3ee in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#69 0x00007f869b0918a2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#70 0x00007f869b091ae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#71 0x00007f869b095e63 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#72 0x00007f868bef093e in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#73 0x00000000004075f3 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#74 0x0000000000408140 in handle_launcher_request ()
#75 0x0000000000408835 in handle_requests(int) ()
#76 0x000000000040943a in main ()

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 268180, bug 268171, bug 268157, bug 268086, bug 268000.

Reported using DrKonqi
Comment 1 Wonko 2011-03-11 20:32:26 UTC
Related or not? I had another plasma crash, but this time it did not restart automatically. So I started plasma-desktop in a terminal. And get **LOTS** (several per second) of these messages:

QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::setCompositionMode: Painter not active
QPainter::end: Painter not active, aborted

Don't know if this is part of the problem, but I thought I'd mention it.

Oh, and now I just had yet another crash. This time, the crash handler came up - it normally does that only after the first crash - later, plasma just restarts itself automatically. The option to restart the application is greyed out, but plasma also restarted automatically this time.
Comment 2 Dario Andres 2011-03-13 13:49:50 UTC
[Comment from a bug triager]
This issue is particulary related to the SystemTray (and it is not related to Amarok). It is being tracked at bug 268157 . Merging.
Thanks for the information

*** This bug has been marked as a duplicate of bug 268157 ***