Bug 268086 - Plasma crashes after Amarok crashed
Summary: Plasma crashes after Amarok crashed
Status: RESOLVED DUPLICATE of bug 258706
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-09 21:39 UTC by esst
Modified: 2011-03-09 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esst 2011-03-09 21:39:13 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I was listening internet radio with Amarok, and tried to restart it, but then it crashed, after that Plasma crashed too.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb611c720 (LWP 1651))]

Thread 3 (Thread 0xaed71b70 (LWP 1652)):
#0  0x08b677d4 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0x001edfa6 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0x038fb428 in ?? () from /lib/libglib-2.0.so.0
#3  0x038fb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0715759f in QEventDispatcherGlib::processEvents (this=0x9341918, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x07127609 in QEventLoop::processEvents (this=0xaed711d0, flags=) at kernel/qeventloop.cpp:149
#6  0x07127a8a in QEventLoop::exec (this=0xaed711d0, flags=...) at kernel/qeventloop.cpp:201
#7  0x07023b7e in QThread::exec (this=0x93406e0) at thread/qthread.cpp:490
#8  0x0710635b in QInotifyFileSystemWatcherEngine::run (this=0x93406e0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x07026df9 in QThreadPrivate::start (arg=0x93406e0) at thread/qthread_unix.cpp:266
#10 0x0600dba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 2 (Thread 0xaca3ab70 (LWP 1655)):
#0  0x00e0e416 in __kernel_vsyscall ()
#1  0x001d1df6 in poll () from /lib/libc.so.6
#2  0x03908a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x038fb43c in ?? () from /lib/libglib-2.0.so.0
#4  0x038fb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0715759f in QEventDispatcherGlib::processEvents (this=0x956e088, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x07127609 in QEventLoop::processEvents (this=0xaca3a1d0, flags=) at kernel/qeventloop.cpp:149
#7  0x07127a8a in QEventLoop::exec (this=0xaca3a1d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x07023b7e in QThread::exec (this=0x956ddf0) at thread/qthread.cpp:490
#9  0x0710635b in QInotifyFileSystemWatcherEngine::run (this=0x956ddf0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07026df9 in QThreadPrivate::start (arg=0x956ddf0) at thread/qthread_unix.cpp:266
#11 0x0600dba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb611c720 (LWP 1651)):
[KCrash Handler]
#7  0x0115eba7 in QString (this=0x9b40061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:727
#8  KIconEffect::fingerprint (this=0x9b40061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01162ad8 in KIconLoaderPrivate::makeCacheKey (this=0x9b4004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x0116af08 in KIconLoader::loadIcon (this=0x994d5f8, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x011613f6 in KIconEngine::pixmap (this=0x9c9b4b8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x02e5d626 in QIcon::pixmap (this=0x9b5c6d4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x006db222 in Plasma::IconWidgetPrivate::decoration (this=0x9b5c630, option=0x8eb9298, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x006ddcb7 in Plasma::IconWidget::paint (this=0x9b59638, painter=0xbfc2a2dc, option=0x8eb9298, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x0488019d in SystemTray::DBusSystemTrayWidget::paint (this=0x9b59638, painter=0xbfc2a2dc, option=0x8eb9298, widget=0x0) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0x0346252c in _q_paintItem (item=<value optimized out>, painter=0xbfc2a2dc, option=0x8eb9298, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4318
#17 0x03464eaa in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x8eb9298, painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4356
#18 0x0346c718 in QGraphicsScenePrivate::drawItemHelper (this=0x8eb9148, item=0x9b59640, painter=0xbfc2bfb4, option=0x8eb9298, widget=0x983a3d0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4654
#19 0x034707d8 in QGraphicsScenePrivate::draw (this=0x8eb9148, item=0x9b59640, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, transformPtr=0xbfc2ac10, exposedRegion=0x983ef18, widget=0x983a3d0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4895
#20 0x034714a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8eb9148, item=0x9b59640, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, exposedRegion=0x983ef18, widget=0x983a3d0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#21 0x03470874 in QGraphicsScenePrivate::draw (this=0x8eb9148, item=0x9147040, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, transformPtr=0xbfc2b080, exposedRegion=0x983ef18, widget=0x983a3d0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#22 0x034714a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8eb9148, item=0x9147040, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, exposedRegion=0x983ef18, widget=0x983a3d0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#23 0x03470874 in QGraphicsScenePrivate::draw (this=0x8eb9148, item=0x9144c40, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, transformPtr=0xbfc2b4f0, exposedRegion=0x983ef18, widget=0x983a3d0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#24 0x034714a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8eb9148, item=0x9144c40, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, exposedRegion=0x983ef18, widget=0x983a3d0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#25 0x03470874 in QGraphicsScenePrivate::draw (this=0x8eb9148, item=0x90b9700, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, transformPtr=0xbfc2b960, exposedRegion=0x983ef18, widget=0x983a3d0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4909
#26 0x034714a3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8eb9148, item=0x90b9700, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, exposedRegion=0x983ef18, widget=0x983a3d0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4817
#27 0x03471cce in QGraphicsScenePrivate::drawItems (this=0x8eb9148, painter=0xbfc2bfb4, viewTransform=0xbfc2bd9c, exposedRegion=0x983ef18, widget=0x983a3d0) at graphicsview/qgraphicsscene.cpp:4699
#28 0x0349dbb9 in QGraphicsView::paintEvent (this=0x94b7610, event=0xbfc2c6d4) at graphicsview/qgraphicsview.cpp:3467
#29 0x00c4e224 in PanelView::paintEvent (this=0x94b7610, event=0xbfc2c6d4) at ../../../../plasma/desktop/shell/panelview.cpp:1494
#30 0x02df6cc6 in QWidget::event (this=0x94b7610, event=0xbfc2c6d4) at kernel/qwidget.cpp:8333
#31 0x03218763 in QFrame::event (this=0x94b7610, e=0xbfc2c6d4) at widgets/qframe.cpp:557
#32 0x032b5a82 in QAbstractScrollArea::viewportEvent (this=0x2d006500, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#33 0x03499ccb in QGraphicsView::viewportEvent (this=0x94b7610, event=0xbfc2c6d4) at graphicsview/qgraphicsview.cpp:2862
#34 0x032b84d5 in viewportEvent (this=0x9271ab0, o=0x983a3d0, e=0xbfc2c6d4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x9271ab0, o=0x983a3d0, e=0xbfc2c6d4) at widgets/qabstractscrollarea_p.h:116
#36 0x0712829a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8e0b0b0, receiver=0x983a3d0, event=0xbfc2c6d4) at kernel/qcoreapplication.cpp:847
#37 0x02d98fb9 in QApplicationPrivate::notify_helper (this=0x8e0b0b0, receiver=0x983a3d0, e=0xbfc2c6d4) at kernel/qapplication.cpp:4392
#38 0x02d9f0e9 in QApplication::notify (this=0x8e00b68, receiver=0x983a3d0, e=0xbfc2c6d4) at kernel/qapplication.cpp:4361
#39 0x011c67da in KApplication::notify (this=0x8e00b68, receiver=0x983a3d0, event=0xbfc2c6d4) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x07128b3b in QCoreApplication::notifyInternal (this=0x8e00b68, receiver=0x983a3d0, event=0xbfc2c6d4) at kernel/qcoreapplication.cpp:732
#41 0x02dfdee6 in sendSpontaneousEvent (this=0x967d418, pdev=0x93303fc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9517678) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x967d418, pdev=0x93303fc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9517678) at kernel/qwidget.cpp:5420
#43 0x02dfecff in QWidgetPrivate::paintSiblingsRecursive (this=0x983ebc8, pdev=0x93303fc, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9517678) at kernel/qwidget.cpp:5627
#44 0x02dfdc35 in QWidgetPrivate::drawWidget (this=0x983ebc8, pdev=0x93303fc, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9517678) at kernel/qwidget.cpp:5473
#45 0x02feec74 in QWidgetBackingStore::sync (this=0x9517678) at painting/qbackingstore.cpp:1328
#46 0x02df02b3 in QWidgetPrivate::syncBackingStore (this=0x983ebc8) at kernel/qwidget.cpp:1805
#47 0x02df7466 in QWidget::event (this=0x94b7610, event=0x994d5f8) at kernel/qwidget.cpp:8480
#48 0x03218763 in QFrame::event (this=0x94b7610, e=0x994d5f8) at widgets/qframe.cpp:557
#49 0x032b6487 in QAbstractScrollArea::event (this=0x94b7610, e=0x994d5f8) at widgets/qabstractscrollarea.cpp:996
#50 0x0349bea6 in QGraphicsView::event (this=0x94b7610, event=0x994d5f8) at graphicsview/qgraphicsview.cpp:2739
#51 0x00c4ed13 in PanelView::event (this=0x94b7610, event=0x994d5f8) at ../../../../plasma/desktop/shell/panelview.cpp:1505
#52 0x02d98fdc in QApplicationPrivate::notify_helper (this=0x8e0b0b0, receiver=0x94b7610, e=0x994d5f8) at kernel/qapplication.cpp:4396
#53 0x02d9f0e9 in QApplication::notify (this=0x8e00b68, receiver=0x94b7610, e=0x994d5f8) at kernel/qapplication.cpp:4361
#54 0x011c67da in KApplication::notify (this=0x8e00b68, receiver=0x94b7610, event=0x994d5f8) at ../../kdeui/kernel/kapplication.cpp:311
#55 0x07128b3b in QCoreApplication::notifyInternal (this=0x8e00b68, receiver=0x94b7610, event=0x994d5f8) at kernel/qcoreapplication.cpp:732
#56 0x0712bd8b in sendEvent (receiver=0x94b7610, event_type=77, data=0x8d8e108) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x94b7610, event_type=77, data=0x8d8e108) at kernel/qcoreapplication.cpp:1373
#58 0x0712bf4d in QCoreApplication::sendPostedEvents (receiver=0x94b7610, event_type=77) at kernel/qcoreapplication.cpp:1266
#59 0x03481c3e in dispatchPendingUpdateRequests (this=0x8eb9148) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#60 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8eb9148) at graphicsview/qgraphicsscene.cpp:510
#61 0x03482116 in QGraphicsScene::qt_metacall (this=0x8e80588, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x972e350) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#62 0x00607a4a in Plasma::Corona::qt_metacall (this=0x8e80588, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x972e350) at ./corona.moc:109
#63 0x00c3cf7a in DesktopCorona::qt_metacall (this=0x8e80588, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x972e350) at ./desktopcorona.moc:101
#64 0x0712e8ca in QMetaObject::metacall (object=0x8e80588, cl=755000576, idx=18, argv=0x972e350) at kernel/qmetaobject.cpp:237
#65 0x07139df6 in QMetaCallEvent::placeMetaCall (this=0x95aef08, object=0x8e80588) at kernel/qobject.cpp:534
#66 0x0713b6a2 in QObject::event (this=0x8e80588, e=0x0) at kernel/qobject.cpp:1219
#67 0x0347e374 in QGraphicsScene::event (this=0x8e80588, event=0x95aef08) at graphicsview/qgraphicsscene.cpp:3548
#68 0x02d98fdc in QApplicationPrivate::notify_helper (this=0x8e0b0b0, receiver=0x8e80588, e=0x95aef08) at kernel/qapplication.cpp:4396
#69 0x02d9f04e in QApplication::notify (this=0x8e00b68, receiver=0x8e80588, e=0x95aef08) at kernel/qapplication.cpp:3798
#70 0x011c67da in KApplication::notify (this=0x8e00b68, receiver=0x8e80588, event=0x95aef08) at ../../kdeui/kernel/kapplication.cpp:311
#71 0x07128b3b in QCoreApplication::notifyInternal (this=0x8e00b68, receiver=0x8e80588, event=0x95aef08) at kernel/qcoreapplication.cpp:732
#72 0x0712bd8b in sendEvent (receiver=0x0, event_type=0, data=0x8d8e108) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8d8e108) at kernel/qcoreapplication.cpp:1373
#74 0x0712bf4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#75 0x07157a74 in sendPostedEvents (s=0x8e0b030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x8e0b030) at kernel/qeventdispatcher_glib.cpp:277
#77 0x038f7855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#78 0x038fb668 in ?? () from /lib/libglib-2.0.so.0
#79 0x038fb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#80 0x07157565 in QEventDispatcherGlib::processEvents (this=0x8d8dbb8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#81 0x02e5abe5 in QGuiEventDispatcherGlib::processEvents (this=0x8d8dbb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x07127609 in QEventLoop::processEvents (this=0xbfc2df54, flags=) at kernel/qeventloop.cpp:149
#83 0x07127a8a in QEventLoop::exec (this=0xbfc2df54, flags=...) at kernel/qeventloop.cpp:201
#84 0x0712c00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#85 0x02d97e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#86 0x00c45f97 in kdemain (argc=1, argv=0xbfc2e164) at ../../../../plasma/desktop/shell/main.cpp:118
#87 0x080485bb in main (argc=1, argv=0xbfc2e164) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 258706.

Possible duplicates by query: bug 268000, bug 267957, bug 267943, bug 267934, bug 267676.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-09 22:00:01 UTC

*** This bug has been marked as a duplicate of bug 258706 ***