Bug 266727 - filename with hash/pound/octothorpe character ("#") or a percent sign character ("%") can't be played
Summary: filename with hash/pound/octothorpe character ("#") or a percent sign charact...
Status: RESOLVED FIXED
Alias: None
Product: phonon-backend-gstreamer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
: 271284 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-20 14:27 UTC by hamelg
Modified: 2011-04-27 21:19 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.4.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hamelg 2011-02-20 14:27:42 UTC
Amarok doesn't play file when filename contains a hash character (#), ie :

a_file#1.mp3

This bug is appeared in 2.4.0.
Comment 1 Myriam Schweingruber 2011-02-20 23:28:03 UTC
Please check if your system locale is set to UTF instead of ISO.

Also, which Phonon backend do you use?
Comment 2 hamelg 2011-02-21 18:26:47 UTC
$ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

I use the phonon gstreamer backend 4.4.4.
Comment 3 Myriam Schweingruber 2011-02-21 20:01:26 UTC
Thank you for the feedback. Could be related to bug 228145, reassigning.
Comment 4 Harald Sitter 2011-02-21 22:29:34 UTC
Fixed in 8450838f08b4ae402273e73a96466f60cccad309 of phonon-gstreamer.
Comment 5 Harald Sitter 2011-04-21 00:35:03 UTC
*** Bug 271284 has been marked as a duplicate of this bug. ***
Comment 6 Shlomi Fish 2011-04-21 08:02:58 UTC
OK, I changed the bug's title to make it more appropriate. I don't see phonon-gstreamer-4.4.5 here: ftp://ftp.kde.org/pub/kde/stable/phonon/phonon-backend-gstreamer/ . When will it be released? Is there anything I can do to help?

Regards,

-- Shlomi Fish
Comment 7 Myriam Schweingruber 2011-04-27 21:19:31 UTC
reassigning to the new bugzilla product for better bug tracing of the various backends. Sorry for the noise.