Bug 231252 - Crash of Plasma when closing an application (two level in the task bar with ghost windows)
Summary: Crash of Plasma when closing an application (two level in the task bar with g...
Status: RESOLVED DUPLICATE of bug 199325
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 22:22 UTC by Mickaël
Modified: 2010-03-19 00:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mickaël 2010-03-18 22:22:13 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.12-desktop-1mnb i686
Distribution: "Mandriva Linux 2010.0"

 -- Backtrace:
Application: Espace de travail Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb569c6d0 (LWP 1450))]

Thread 3 (Thread 0xa3ff5b70 (LWP 7371)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb751d9e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb7578fb0 in QWaitCondition::wait (this=0x959b8a8, mutex=0x959b8a4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  0xb5cc5194 in QHostInfoAgent::run (this=0x959b898) at kernel/qhostinfo.cpp:260
#4  0xb7577e83 in QThreadPrivate::start (arg=0x959b898) at thread/qthread_unix.cpp:188
#5  0xb7519885 in start_thread () from /lib/i686/libpthread.so.0
#6  0xb5f6a57e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xa3693b70 (LWP 7862)):
#0  0xb5e74016 in clock_gettime (clock_id=1, tp=0xa3693068) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb769c694 in QTimerInfoList::getTime (this=0xa942674, t=@0xa942698) at kernel/qeventdispatcher_unix.cpp:339
#2  0xb769c8d2 in QTimerInfoList::updateCurrentTime (this=0xa942674) at kernel/qeventdispatcher_unix.cpp:297
#3  0xb769caae in QTimerInfoList::timerWait (this=0xa942674, tm=@0xa36930e8) at kernel/qeventdispatcher_unix.cpp:420
#4  0xb769aaeb in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa369315c) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb769ab8d in timerSourcePrepare (source=0x0, timeout=0xb5e78ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb5de6ce8 in IA__g_main_context_prepare (context=0xa8601f0, priority=0xa36931cc) at gmain.c:2280
#7  0xb5de7069 in g_main_context_iterate (context=0xa8601f0, block=<value optimized out>, dispatch=1, self=0x9887da0) at gmain.c:2571
#8  0xb5de758e in IA__g_main_context_iteration (context=0xa8601f0, may_block=1) at gmain.c:2654
#9  0xb769a93f in QEventDispatcherGlib::processEvents (this=0xa8ae0e8, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:408
#10 0xb766d26d in QEventLoop::processEvents (this=0xa36932f4, flags=) at kernel/qeventloop.cpp:149
#11 0xb766d6b9 in QEventLoop::exec (this=0xa36932f4, flags={i = 0}) at kernel/qeventloop.cpp:201
#12 0xb7574b67 in QThread::exec (this=0xa95eb78) at thread/qthread.cpp:487
#13 0xa37a8dde in ?? () from /usr/lib/kde4/plugins/marble/GpsdPositionProviderPlugin.so
#14 0xb7577e83 in QThreadPrivate::start (arg=0xa95eb78) at thread/qthread_unix.cpp:188
#15 0xb7519885 in start_thread () from /lib/i686/libpthread.so.0
#16 0xb5f6a57e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb569c6d0 (LWP 1450)):
[KCrash Handler]
#6  AbstractTaskItem::basicPreferredSize (this=0xb154738) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/tasks.h:92
#7  0xa7cd75ac in TaskItemLayout::preferredColumns (this=0x9595df0) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskitemlayout.cpp:206
#8  0xa7cd84ce in TaskItemLayout::gridLayoutSize (this=0x9595df0) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskitemlayout.cpp:222
#9  0xa7cd85ae in TaskItemLayout::layoutItems (this=0x9595df0) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskitemlayout.cpp:245
#10 0xa7cd9094 in TaskItemLayout::insert (this=0x9595df0, index=4, item=0x913cc48) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskitemlayout.cpp:125
#11 0xa7cd928c in TaskItemLayout::addTaskItem (this=0x9595df0, item=0x913cc48) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskitemlayout.cpp:82
#12 0xa7ce675a in TaskGroupItem::itemAdded (this=0x95cc128, groupableItem=0x9806b98) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/applets/tasks/taskgroupitem.cpp:477
#13 0xa7ce6e15 in TaskGroupItem::qt_metacall (this=0x95cc128, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0xbff9b9b8)
    at /usr/src/debug/kdebase-workspace-4.3.2/build/plasma/applets/tasks/taskgroupitem.moc:113
#14 0xb7685144 in QMetaObject::activate (sender=0x95d1c30, from_signal_index=21, to_signal_index=21, argv=0xbff9b9b8) at kernel/qobject.cpp:3112
#15 0xb7685e65 in QMetaObject::activate (sender=0x95d1c30, m=0xa7cbcbf4, local_signal_index=0, argv=0xbff9b9b8) at kernel/qobject.cpp:3186
#16 0xa7ca7375 in TaskManager::TaskGroup::itemAdded (this=0x95d1c30, _t1=0x9806b98) at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/taskgroup.moc:145
#17 0xa7ca7e65 in TaskManager::TaskGroup::add (this=0x95d1c30, item=0x9806b98) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/taskgroup.cpp:138
#18 0xa7c8b350 in TaskManager::AbstractGroupingStrategy::closeGroup (this=0xac04728, group=0x9720e28) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/abstractgroupingstrategy.cpp:168
#19 0xa7c93174 in TaskManager::ProgramGroupingStrategy::checkGroup (this=0xac04728) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/strategies/programgroupingstrategy.cpp:210
#20 0xa7c941f7 in TaskManager::ProgramGroupingStrategy::qt_metacall (this=0xac04728, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0xbff9bbf8)
    at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/programgroupingstrategy.moc:70
#21 0xb7685144 in QMetaObject::activate (sender=0x9720e28, from_signal_index=22, to_signal_index=22, argv=0xbff9bbf8) at kernel/qobject.cpp:3112
#22 0xb7685e65 in QMetaObject::activate (sender=0x9720e28, m=0xa7cbcbf4, local_signal_index=1, argv=0xbff9bbf8) at kernel/qobject.cpp:3186
#23 0xa7ca7325 in TaskManager::TaskGroup::itemRemoved (this=0x9720e28, _t1=0xadf85f8) at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/taskgroup.moc:152
#24 0xa7ca7bce in TaskManager::TaskGroup::remove (this=0x9720e28, item=0xadf85f8) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/taskgroup.cpp:189
#25 0xa7c8e5b7 in TaskManager::GroupManagerPrivate::removeTask (this=0x9012988, task={d = 0x87c9208}) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/groupmanager.cpp:311
#26 0xa7c9047b in TaskManager::GroupManager::qt_metacall (this=0x906fd20, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff9bda8)
    at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/groupmanager.moc:105
#27 0xb7685144 in QMetaObject::activate (sender=0x9074bb8, from_signal_index=5, to_signal_index=5, argv=0xbff9bda8) at kernel/qobject.cpp:3112
#28 0xb7685e65 in QMetaObject::activate (sender=0x9074bb8, m=0xa7cbcdbc, local_signal_index=1, argv=0xbff9bda8) at kernel/qobject.cpp:3186
#29 0xa7caafa5 in TaskManager::TaskManager::taskRemoved (this=0x9074bb8, _t1={d = 0x87c9208}) at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/taskmanager.moc:162
#30 0xa7cace56 in TaskManager::TaskManager::windowRemoved (this=0x9074bb8, w=81788953) at /usr/src/debug/kdebase-workspace-4.3.2/libs/taskmanager/taskmanager.cpp:278
#31 0xa7cae8c5 in TaskManager::TaskManager::qt_metacall (this=0x9074bb8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbff9bf28)
    at /usr/src/debug/kdebase-workspace-4.3.2/build/libs/taskmanager/taskmanager.moc:110
#32 0xb7685144 in QMetaObject::activate (sender=0x882a820, from_signal_index=6, to_signal_index=6, argv=0xbff9bf28) at kernel/qobject.cpp:3112
#33 0xb7685e65 in QMetaObject::activate (sender=0x882a820, m=0xb6e6126c, local_signal_index=2, argv=0xbff9bf28) at kernel/qobject.cpp:3186
#34 0xb6dac545 in KWindowSystem::windowRemoved (this=0x882a820, _t1=81788953) at /usr/src/debug/kdelibs-4.3.2/build/kdeui/kwindowsystem.moc:127
#35 0xb6dafbba in KWindowSystemPrivate::removeClient (this=0x88bf670, w=81788953) at /usr/src/debug/kdelibs-4.3.2/kdeui/windowmanagement/kwindowsystem_x11.cpp:249
#36 0xb6dbe8ef in NETRootInfo::update (this=0x88bf684, dirty_props=0xbff9c0a8) at /usr/src/debug/kdelibs-4.3.2/kdeui/windowmanagement/netwm.cpp:2183
#37 0xb6dbf595 in NETRootInfo::event (this=0x88bf684, event=<value optimized out>, properties=0xbff9c194, properties_size=5) at /usr/src/debug/kdelibs-4.3.2/kdeui/windowmanagement/netwm.cpp:2058
#38 0xb6dafe8b in KWindowSystemPrivate::x11Event (this=0x88bf670, ev=0xbff9d76c) at /usr/src/debug/kdelibs-4.3.2/kdeui/windowmanagement/kwindowsystem_x11.cpp:136
#39 0xb6c54cc7 in KApplication::x11EventFilter (this=0x87476d8, _event=0xbff9d76c) at /usr/src/debug/kdelibs-4.3.2/kdeui/kernel/kapplication.cpp:900
#40 0xb3dc0953 in PlasmaApp::x11EventFilter (this=0x87476d8, event=0xbff9d76c) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/shells/desktop/plasmaapp.cpp:490
#41 0xb6258951 in qt_x11EventFilter (ev=0xbff9d76c) at kernel/qapplication_x11.cpp:377
#42 0xb626a3ff in QApplication::x11ProcessEvent (this=0x87476d8, event=0xbff9d76c) at kernel/qapplication_x11.cpp:3273
#43 0xb626c89e in QETWidget::translateMouseEvent (this=0x9231a48, event=0xbff9ec8c) at kernel/qapplication_x11.cpp:4143
#44 0xb626baee in QApplication::x11ProcessEvent (this=0x87476d8, event=0xbff9ec8c) at kernel/qapplication_x11.cpp:3430
#45 0xb6296d88 in x11EventSourceDispatch (s=0x87501f8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0xb5de3b92 in IA__g_main_context_dispatch (context=0x874f6a0) at gmain.c:1960
#47 0xb5de7468 in g_main_context_iterate (context=0x874f6a0, block=<value optimized out>, dispatch=1, self=0x874c6a8) at gmain.c:2591
#48 0xb5de758e in IA__g_main_context_iteration (context=0x874f6a0, may_block=1) at gmain.c:2654
#49 0xb769a8f1 in QEventDispatcherGlib::processEvents (this=0x874ab68, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:406
#50 0xb62964ba in QGuiEventDispatcherGlib::processEvents (this=0x874ab68, flags={i = 36}) at kernel/qguieventdispatcher_glib.cpp:202
#51 0xb766d26d in QEventLoop::processEvents (this=0xbff9ef44, flags=) at kernel/qeventloop.cpp:149
#52 0xb766d6b9 in QEventLoop::exec (this=0xbff9ef44, flags={i = 0}) at kernel/qeventloop.cpp:201
#53 0xb766fb50 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#54 0xb61f4504 in QApplication::exec () at kernel/qapplication.cpp:3525
#55 0xb3daabd9 in kdemain (argc=1, argv=0x870d918) at /usr/src/debug/kdebase-workspace-4.3.2/plasma/shells/desktop/main.cpp:50
#56 0x0804da54 in launch (argc=141623400, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x8710068 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8050e85 "0") at /usr/src/debug/kdelibs-4.3.2/kinit/kinit.cpp:677
#57 0x0804e717 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at /usr/src/debug/kdelibs-4.3.2/kinit/kinit.cpp:1169
#58 0x0804eb64 in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.3.2/kinit/kinit.cpp:1362
#59 0x0804f85f in main (argc=2, argv=0xbff9f794, envp=0xbff9f7a0) at /usr/src/debug/kdelibs-4.3.2/kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-19 00:46:36 UTC
Fixed in KDE SC 4.4.0 and later. Regards

*** This bug has been marked as a duplicate of bug 199325 ***