Bug 232960 - Quitting Dia application causing plasma widget crash
Summary: Quitting Dia application causing plasma widget crash
Status: RESOLVED DUPLICATE of bug 199325
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-01 14:40 UTC by Mats Kindahl
Modified: 2010-04-01 14:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mats Kindahl 2010-04-01 14:40:58 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was quitting the Dia application, which caused the Task manager widget to be updated. This caused the crash.

I am running server tests in the background using the memory file system, so memory is scarce.

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb780b700 (LWP 2381))]

Thread 2 (Thread 0xaa8a8b70 (LWP 2382)):
#0  0x0048c422 in __kernel_vsyscall ()
#1  0x00971e15 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0x036d687d in __pthread_cond_wait (cond=0x861fe30, mutex=0x861fe18) at forward.c:139
#3  0x0015fe67 in QWaitConditionPrivate::wait (this=0x85f07f8, mutex=0x85f07f4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x85f07f8, mutex=0x85f07f4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x04ea1922 in QHostInfoAgent::run (this=0x85f07e8) at kernel/qhostinfo.cpp:260
#6  0x0015ee32 in QThreadPrivate::start (arg=0x85f07e8) at thread/qthread_unix.cpp:188
#7  0x0096d80e in start_thread (arg=0xaa8a8b70) at pthread_create.c:300
#8  0x036c98de in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb780b700 (LWP 2381)):
[KCrash Handler]
#6  Tasks::itemTopMargin (this=0x9a8a318) at ../../../../plasma/applets/tasks/tasks.h:92
#7  AbstractTaskItem::basicPreferredSize (this=0x9a8a318) at ../../../../plasma/applets/tasks/abstracttaskitem.cpp:102
#8  0x01ef54eb in TaskItemLayout::preferredColumns (this=0x84fcf60) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:206
#9  0x01ef623a in TaskItemLayout::gridLayoutSize (this=0x84fcf60) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:222
#10 0x01ef62fb in TaskItemLayout::layoutItems (this=0x84fcf60) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:245
#11 0x01ef6c34 in TaskItemLayout::remove (this=0x84fcf60, item=0x8a0b2f0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:136
#12 0x01ef6cec in TaskItemLayout::removeTaskItem (this=0x84fcf60, item=0x8a0b2f0) at ../../../../plasma/applets/tasks/taskitemlayout.cpp:93
#13 0x01f031ce in TaskGroupItem::itemRemoved (this=0x8536270, groupableItem=0x9b687c8) at ../../../../plasma/applets/tasks/taskgroupitem.cpp:521
#14 0x01f04647 in TaskGroupItem::qt_metacall (this=0x8536270, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfc7fcd8) at ./taskgroupitem.moc:114
#15 0x00265263 in QMetaObject::activate (sender=0x84fc8d0, from_signal_index=22, to_signal_index=22, argv=0xbfc7fcd8) at kernel/qobject.cpp:3113
#16 0x00265ec2 in QMetaObject::activate (sender=0x84fc8d0, m=0x6bb5bf4, local_signal_index=1, argv=0xbfc7fcd8) at kernel/qobject.cpp:3187
#17 0x06ba73e3 in TaskManager::TaskGroup::itemRemoved (this=0x84fc8d0, _t1=0x9b687c8) at ./taskgroup.moc:152
#18 0x06ba7c0b in TaskManager::TaskGroup::remove (this=0x84fc8d0, item=0x9b687c8) at ../../../libs/taskmanager/taskgroup.cpp:189
#19 0x06b8f71d in TaskManager::GroupManagerPrivate::removeTask (this=0x8552b98, task=...) at ../../../libs/taskmanager/groupmanager.cpp:311
#20 0x06b9152b in TaskManager::GroupManager::qt_metacall (this=0x84e5e50, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfc7feb8) at ./groupmanager.moc:105
#21 0x00265263 in QMetaObject::activate (sender=0x8501770, from_signal_index=5, to_signal_index=5, argv=0xbfc7feb8) at kernel/qobject.cpp:3113
#22 0x00265ec2 in QMetaObject::activate (sender=0x8501770, m=0x6bb5dbc, local_signal_index=1, argv=0xbfc7feb8) at kernel/qobject.cpp:3187
#23 0x06baae33 in TaskManager::TaskManager::taskRemoved (this=0x8501770, _t1=...) at ./taskmanager.moc:162
#24 0x06bacbb2 in TaskManager::TaskManager::windowRemoved (this=0x8501770, w=98566525) at ../../../libs/taskmanager/taskmanager.cpp:279
#25 0x06bae4ff in TaskManager::TaskManager::qt_metacall (this=0x8501770, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfc80038) at ./taskmanager.moc:110
#26 0x00265263 in QMetaObject::activate (sender=0x8290cd8, from_signal_index=6, to_signal_index=6, argv=0xbfc80038) at kernel/qobject.cpp:3113
#27 0x00265ec2 in QMetaObject::activate (sender=0x8290cd8, m=0xf2b26c, local_signal_index=2, argv=0xbfc80038) at kernel/qobject.cpp:3187
#28 0x00ec2dd3 in KWindowSystem::windowRemoved (this=0x8290cd8, _t1=98566525) at ./kwindowsystem.moc:127
#29 0x00ec6036 in KWindowSystemPrivate::removeClient (this=0x82d7ec8, w=98566525) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:249
#30 0x00ed453f in NETRootInfo::update (this=0x82d7edc, dirty_props=0xbfc801c8) at ../../kdeui/windowmanagement/netwm.cpp:2183
#31 0x00ed50b7 in NETRootInfo::event (this=0x82d7edc, event=<value optimized out>, properties=0xbfc802b4, properties_size=5) at ../../kdeui/windowmanagement/netwm.cpp:2058
#32 0x00ec62d1 in KWindowSystemPrivate::x11Event (this=0x82d7ec8, ev=0xbfc818bc) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:136
#33 0x00d72f86 in KAppX11HackWidget::publicx11Event (this=0x81d9bb0, _event=0xbfc818bc) at ../../kdeui/kernel/kapplication.cpp:911
#34 KApplication::x11EventFilter (this=0x81d9bb0, _event=0xbfc818bc) at ../../kdeui/kernel/kapplication.cpp:961
#35 0x01cc471a in PlasmaApp::x11EventFilter (this=0x81d9bb0, event=0xbfc818bc) at ../../../../plasma/shells/desktop/plasmaapp.cpp:490
#36 0x01110d70 in qt_x11EventFilter (ev=0xbfc818bc) at kernel/qapplication_x11.cpp:375
#37 0x01122375 in QApplication::x11ProcessEvent (this=0x81d9bb0, event=0xbfc818bc) at kernel/qapplication_x11.cpp:3271
#38 0x01150502 in x11EventSourceDispatch (s=0x82030f8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00b1ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x00b20730 in ?? () from /lib/libglib-2.0.so.0
#41 0x00b20863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x0027a02c in QEventDispatcherGlib::processEvents (this=0x82007a0, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#43 0x0114fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x82007a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#44 0x0024dc79 in QEventLoop::processEvents (this=0xbfc81bb4, flags=) at kernel/qeventloop.cpp:149
#45 0x0024e0ca in QEventLoop::exec (this=0xbfc81bb4, flags=...) at kernel/qeventloop.cpp:201
#46 0x0025053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#47 0x010aedd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#48 0x01cae80d in kdemain (argc=1, argv=0x81c2dc8) at ../../../../plasma/shells/desktop/main.cpp:50
#49 0x0804dde1 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x818c9d0 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80511a5 "0") at ../../kinit/kinit.cpp:677
#50 0x0804ea35 in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#51 0x0804eeac in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1362
#52 0x0804fbaf in main (argc=2, argv=0xbfc82414, envp=0xbfc82420) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Beat Wolf 2010-04-01 14:44:39 UTC

*** This bug has been marked as a duplicate of bug 199325 ***