Bug 265640 - digikam 2.0.0 crash on startup
Summary: digikam 2.0.0 crash on startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Bqm-Rotate (show other bugs)
Version: 2.0.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-06 20:26 UTC by terri.bugs
Modified: 2021-12-17 21:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description terri.bugs 2011-02-06 20:26:38 UTC
Application: digikam (2.0.0-beta2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I saw the digiKam splash screen and after few seconds it disappeared and the crash reporting tool appeared. I did change workspaces during the loading of digiKam, but that hasn't been a problem before.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1d694ef9a0 (LWP 2829))]

Thread 9 (Thread 0x7f1d4b8b9700 (LWP 2830)):
#0  0x00007f1d60461203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d5c00b009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f1d5c00b7b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
#3  0x00007f1d562580f4 in ?? () from /usr/lib/libgio-2.0.so.0
#4  0x00007f1d5c0307e4 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f1d3cea8700 (LWP 2831)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1d61c25e3b in wait (this=<value optimized out>, mutex=0x1bebd88, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1bebd88, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000006bb3b8 in Digikam::ScanController::run (this=0x1beba80) at /home/terri/Sources/digikam_20110131/core/digikam/scancontroller.cpp:602
#4  0x00007f1d61c2527e in QThreadPrivate::start (arg=0x1beba80) at thread/qthread_unix.cpp:266
#5  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f1d3c6a7700 (LWP 2899)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1d61c25e3b in wait (this=<value optimized out>, mutex=0x1ddd858, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1ddd858, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f1d65eb0f11 in Digikam::ParkingThread::run (this=0x1ddd840) at /home/terri/Sources/digikam_20110131/core/libs/threads/threadmanager.cpp:119
#4  0x00007f1d61c2527e in QThreadPrivate::start (arg=0x1ddd840) at thread/qthread_unix.cpp:266
#5  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f1d32771700 (LWP 2911)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f1d38b100d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1d31538700 (LWP 2912)):
#0  0x00007f1d604662c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f1d38b39385 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007f1d38b1dd09 in ?? () from /usr/lib/libxine.so.1
#3  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1d30d37700 (LWP 2913)):
#0  0x00007f1d6199dc9d in __pthread_mutex_unlock_usercnt (mutex=0x1faa808) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1faa808) at pthread_mutex_unlock.c:290
#2  0x00007f1d5c00aa05 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x00007f1d5c00ae78 in ?? () from /lib/libglib-2.0.so.0
#4  0x00007f1d5c00b45c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00007f1d61d451e6 in QEventDispatcherGlib::processEvents (this=0x1fdc360, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00007f1d61d17a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#7  0x00007f1d61d17dec in QEventLoop::exec (this=0x7f1d30d36b50, flags=) at kernel/qeventloop.cpp:201
#8  0x00007f1d61c222fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#9  0x00007f1d38d6c2b0 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x00007f1d61c2527e in QThreadPrivate::start (arg=0x1fe37d0) at thread/qthread_unix.cpp:266
#11 0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1d30331700 (LWP 2914)):
#0  0x00007f1d60461203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6017240f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f1d60161d76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f1d601637f9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f1d601638b0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f1d6017220b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f1d57dfbfb8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1d2bb2f700 (LWP 2915)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1d38b20e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f1d6199a971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f1d6046d92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1d694ef9a0 (LWP 2829)):
[KCrash Handler]
#6  deref (this=0x7fff461a3e30, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  QVariant::~QVariant (this=0x7fff461a3e30, __in_chrg=<value optimized out>) at kernel/qvariant.cpp:1407
#8  0x00007f1d294d6d94 in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#9  0x00007f1d294ce2cc in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#10 0x000000000064fa27 in Digikam::DigikamApp::slotKipiPluginPlug (this=0x1c36720) at /home/terri/Sources/digikam_20110131/core/digikam/digikamapp.cpp:2555
#11 0x00000000006360b2 in Digikam::DigikamApp::qt_metacall (this=0x1c36720, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0x7fff461a4580) at /home/terri/Sources/digikam_20110131/build_1/core/digikam/digikamapp.moc:235
#12 0x00007f1d61d30b27 in QMetaObject::activate (sender=0x2ee6c50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff461a3c3f) at kernel/qobject.cpp:3280
#13 0x00007f1d6777493d in KIPI::PluginLoader::replug (this=0x2ee6c50) at /home/terri/Sources/digikam_20110131/build_1/extra/libkipi/libkipi/pluginloader.moc:103
#14 0x00007f1d67775d0c in KIPI::PluginLoader::loadPlugins (this=0x2ee6c50) at /home/terri/Sources/digikam_20110131/extra/libkipi/libkipi/pluginloader.cpp:340
#15 0x000000000064f22a in Digikam::DigikamApp::loadPlugins (this=0x1c36720) at /home/terri/Sources/digikam_20110131/core/digikam/digikamapp.cpp:2495
#16 0x0000000000638a0c in Digikam::DigikamApp::DigikamApp (this=0x1c36720, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /home/terri/Sources/digikam_20110131/core/digikam/digikamapp.cpp:264
#17 0x000000000073d220 in main (argc=1, argv=0x7fff461a50a8) at /home/terri/Sources/digikam_20110131/core/digikam/main.cpp:188

Possible duplicates by query: bug 264603, bug 261177, bug 234021.

Reported using DrKonqi
Comment 1 caulier.gilles 2011-02-06 20:29:46 UTC

*** This bug has been marked as a duplicate of bug 234021 ***
Comment 2 caulier.gilles 2021-12-17 21:33:20 UTC
Fixed with #234021