Bug 264603 - Digikam crashes on startup (KDE 4.6)
Summary: Digikam crashes on startup (KDE 4.6)
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Bqm-Rotate (show other bugs)
Version: 1.8.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-28 10:33 UTC by Phisss
Modified: 2021-12-17 21:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phisss 2011-01-28 10:33:27 UTC
Application: digikam (1.8.0)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
Digikam crashes every time on startup. Can't get it to work at all. I use Kubuntu 64bit with KDE 4.6. The Terminal shows the following error:

KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
Time elapsed: 218 ms
Model: Time elapsed: 0 ms
TextureColorizer::setSeaFileLandFile: Time elapsed: 5 ms
Time elapsed: 2 ms
Model: Time elapsed: 0 ms
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Datei oder Verzeichnis nicht gefunden
QFileSystemWatcher: failed to add paths: /home/wenne/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
TextureColorizer::setSeaFileLandFile: Time elapsed: 8 ms
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/wenne/.kde/socket-kubuntux/kdeinit4__0
QSocketNotifier: Invalid socket 14 and type 'Read', disabling...
QSocketNotifier: Invalid socket 51 and type 'Read', disabling...
QSocketNotifier: Invalid socket 44 and type 'Read', disabling...
QSocketNotifier: Invalid socket 39 and type 'Read', disabling...

[1]+  Angehalten              digikam

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f962d4247c0 (LWP 5600))]

Thread 16 (Thread 0x7f9613940700 (LWP 5601)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9625a65e3b in wait (this=<value optimized out>, mutex=0x281c170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x281c170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000006290fb in Digikam::ScanController::run (this=0x2804bf0) at /build/buildd/digikam-1.8.0/digikam/scancontroller.cpp:571
#4  0x00007f9625a6527e in QThreadPrivate::start (arg=0x2804bf0) at thread/qthread_unix.cpp:266
#5  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 15 (Thread 0x7f961313f700 (LWP 5602)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f961313ea30 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 14 (Thread 0x7f961293e700 (LWP 5614)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f961293da70 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 13 (Thread 0x7f9611829700 (LWP 5615)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9611828a70 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0x7f9610fd2700 (LWP 5616)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9625a65e3b in wait (this=<value optimized out>, mutex=0x2ce5918, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2ce5918, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f962a834ec2 in Digikam::ParkingThread::run (this=0x2ce5900) at /build/buildd/digikam-1.8.0/libs/threads/threadmanager.cpp:119
#4  0x00007f9625a6527e in QThreadPrivate::start (arg=0x2ce5900) at thread/qthread_unix.cpp:266
#5  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f960bfff700 (LWP 5617)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f960bffea70 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 10 (Thread 0x7f960b7fe700 (LWP 5618)):
#0  0x00007f9622d2f66f in __pthread_mutex_lock (mutex=0x2dd7e98) at pthread_mutex_lock.c:62
#1  0x00007f9621f0fa61 in g_main_context_query () from /lib/libglib-2.0.so.0
#2  0x00007f9621f14efc in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f9621f1545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f9625b851e6 in QEventDispatcherGlib::processEvents (this=0x2ddfe60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f9625b57a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f9625b57dec in QEventLoop::exec (this=0x7f960b7fdd90, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f9625a622fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f9625a6527e in QThreadPrivate::start (arg=0x2de1a20) at thread/qthread_unix.cpp:266
#9  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f95ff0c7700 (LWP 5619)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f9608ccf0d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f95fdc8b700 (LWP 5620)):
#0  0x00007f9624a392c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f9608cf8385 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007f9608cdcd09 in ?? () from /usr/lib/libxine.so.1
#3  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f95fd48a700 (LWP 5621)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f95fd489a10 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7f95fca84700 (LWP 5622)):
#0  0x00007f962474542f in ?? () from /usr/lib/libpulse.so.0
#1  0x00007f9624734d76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#2  0x00007f96247367f9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#3  0x00007f96247368b0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#4  0x00007f962474520b in ?? () from /usr/lib/libpulse.so.0
#5  0x00007f961c653fb8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#6  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f95f8282700 (LWP 5623)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9608cdfe83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f95f7a81700 (LWP 5624)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f95f7a80a30 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 3 (Thread 0x7f95f3104700 (LWP 5632)):
#0  idleTimerSourceCheck (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:221
#1  0x00007f9621f1466a in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x00007f9621f15023 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f9621f1545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f9625b851e6 in QEventDispatcherGlib::processEvents (this=0x4b6ca00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f9625b57a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f9625b57dec in QEventLoop::exec (this=0x7f95f3103d50, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f9625a622fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f9625b375f8 in QInotifyFileSystemWatcherEngine::run (this=0x4b6bbd0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f9625a6527e in QThreadPrivate::start (arg=0x4b6bbd0) at thread/qthread_unix.cpp:266
#10 0x00007f9622d2d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f9624a4092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f95f1100700 (LWP 5686)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f95f10ffa30 in ?? ()
#2  0x00007ffff3b0d852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f962d4247c0 (LWP 5600)):
[KCrash Handler]
#6  deref (this=0x7ffff3a10e70, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  QVariant::~QVariant (this=0x7ffff3a10e70, __in_chrg=<value optimized out>) at kernel/qvariant.cpp:1407
#8  0x00007f95e623ad94 in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#9  0x00007f95e62322cc in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#10 0x00000000005c1573 in Digikam::DigikamApp::slotKipiPluginPlug (this=0x7f960c0039b0) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2555
#11 0x00000000005d8b8d in Digikam::DigikamApp::qt_metacall (this=0x7f960c0039b0, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7ffff3a11530) at /build/buildd/digikam-1.8.0/obj-x86_64-linux-gnu/digikam/digikamapp.moc:230
#12 0x00007f9625b70b27 in QMetaObject::activate (sender=0x501f9c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff3a10c7f) at kernel/qobject.cpp:3280
#13 0x00000000005c7666 in Digikam::DigikamApp::loadPlugins (this=0x7f960c0039b0) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2495
#14 0x00000000005d651e in Digikam::DigikamApp::DigikamApp (this=0x7f960c0039b0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:260
#15 0x000000000067b4fd in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/digikam-1.8.0/digikam/main.cpp:177

This bug may be a duplicate of or related to bug 234021.

Possible duplicates by query: bug 261177, bug 234021.

Reported using DrKonqi
Comment 1 caulier.gilles 2011-01-28 10:35:33 UTC

*** This bug has been marked as a duplicate of bug 234021 ***
Comment 2 caulier.gilles 2021-12-17 21:33:20 UTC
Fixed with #234021