Bug 234021 - Crash on loading
Summary: Crash on loading
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Runtime (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-11 10:46 UTC by Zettmaster
Modified: 2018-02-04 11:46 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments
New crash information added by DrKonqi (12.91 KB, text/plain)
2011-01-28 12:25 UTC, zless
Details
New crash information added by DrKonqi (14.95 KB, text/plain)
2011-02-05 13:41 UTC, bikon771
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zettmaster 2010-04-11 10:46:51 UTC
Application: digikam (1.2.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2) "release 238"
Qt Version: 4.6.3
Operating System: Linux 2.6.31.12-0.2-default x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
digikam crash on startup on times. after restart on crashreport button digikam will work on. this crash is everytime when i start digikam. 

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f644d2647c0 (LWP 31899))]

Thread 15 (Thread 0x7f6439bae910 (LWP 31900)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f64478ebb1b in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00000000006ded8b in Digikam::ScanController::run (this=0xbf0580) at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:516
#4  0x00007f64478eaad5 in QThreadPrivate::start (arg=0xbf0580) at thread/qthread_unix.cpp:248
#5  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7f643645f910 (LWP 31902)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f643645ecb0 in ?? ()
#2  0x00007fffd59b7782 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 13 (Thread 0x7f6435ba8910 (LWP 31903)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f6435ba7cb0 in ?? ()
#2  0x00007fffd59b7782 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0x7f6435321910 (LWP 31904)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f64478ebb1b in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f644a72f522 in Digikam::LoadSaveThread::run (this=0xc79ac0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00007f64478eaad5 in QThreadPrivate::start (arg=0xc79ac0) at thread/qthread_unix.cpp:248
#5  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f6434b20910 (LWP 31905)):
#0  0x00007f6446becd03 in poll () from /lib64/libc.so.6
#1  0x00007f644059759c in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f64405978e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6447a03b66 in QEventDispatcherGlib::processEvents (this=0xbf8000, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f64479d8e12 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f64479d91ec in QEventLoop::exec (this=0x7f6434b1ffd0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f64478e7fdb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f64478eaad5 in QThreadPrivate::start (arg=0xc2b920) at thread/qthread_unix.cpp:248
#8  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f642ffff910 (LWP 31906)):
#0  0x00007f6446becd1b in poll () from /lib64/libc.so.6
#1  0x00007f644059759c in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f64405978e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6447a03b66 in QEventDispatcherGlib::processEvents (this=0xea9b50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f64479d8e12 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f64479d91ec in QEventLoop::exec (this=0x7f642fffefd0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f64478e7fdb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f64478eaad5 in QThreadPrivate::start (arg=0xcbe030) at thread/qthread_unix.cpp:248
#8  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f64238dc910 (LWP 31907)):
#0  0x00007f64453082cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6429a59671 in metronom_sync_loop () from /usr/lib64/libxine.so.1
#2  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f64224a0910 (LWP 31908)):
#0  0x00007f64453082cd in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6429a64e69 in interruptable_sleep () from /usr/lib64/libxine.so.1
#2  0x00007f6429a67621 in video_out_loop () from /usr/lib64/libxine.so.1
#3  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f6421c9f910 (LWP 31909)):
#0  0x00007f6440596d95 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f64405974b0 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f64405978e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6447a03b66 in QEventDispatcherGlib::processEvents (this=0xe21de0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f64479d8e12 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f64479d91ec in QEventLoop::exec (this=0x7f6421c9ef70, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f64478e7fdb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f6429cb5286 in Phonon::MediaSource::type() const () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#8  0x00007f64478eaad5 in QThreadPrivate::start (arg=0xe55db0) at thread/qthread_unix.cpp:248
#9  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#10 0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f6421299910 (LWP 31910)):
#0  0x00007f6446becce8 in poll () from /lib64/libc.so.6
#1  0x00007f64469108bf in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f6446900b76 in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f6446901f59 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f6446902010 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f64469107cb in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f643ebd4978 in ?? () from /usr/lib64/libpulsecommon-0.9.21.so
#7  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#8  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f641ca97910 (LWP 31911)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6429a6a713 in ao_loop () from /usr/lib64/libxine.so.1
#2  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f641a803910 (LWP 31912)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f64478ebb1b in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f644a72f522 in Digikam::LoadSaveThread::run (this=0x238ad30) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00007f64478eaad5 in QThreadPrivate::start (arg=0x238ad30) at thread/qthread_unix.cpp:248
#5  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f641a002910 (LWP 31919)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f64478ebb1b in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f644a72f522 in Digikam::LoadSaveThread::run (this=0x2d84fc0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00007f64478eaad5 in QThreadPrivate::start (arg=0x2d84fc0) at thread/qthread_unix.cpp:248
#5  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f64177fd910 (LWP 31920)):
#0  0x00007f6445308049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f64478ebb1b in wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f644a72f522 in Digikam::LoadSaveThread::run (this=0x2e21ad0) at /usr/src/debug/digikam-1.2.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00007f64478eaad5 in QThreadPrivate::start (arg=0x2e21ad0) at thread/qthread_unix.cpp:248
#5  0x00007f644530365d in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6446bf5e1d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f644d2647c0 (LWP 31899)):
[KCrash Handler]
#5  deref (this=<value optimized out>) at ../../src/corelib/arch/qatomic_x86_64.h:133
#6  QVariant::~QVariant (this=<value optimized out>) at kernel/qvariant.cpp:1383
#7  0x00007f64106276d4 in ?? () from /usr/lib64/kde4/kipiplugin_jpeglossless.so
#8  0x00007f641061da42 in ?? () from /usr/lib64/kde4/kipiplugin_jpeglossless.so
#9  0x000000000067a273 in Digikam::DigikamApp::slotKipiPluginPlug (this=0xc47e60) at /usr/src/debug/digikam-1.2.0/digikam/digikamapp.cpp:2354
#10 0x000000000069046d in Digikam::DigikamApp::qt_metacall (this=0xc47e60, _c=InvokeMetaMethod, _id=24, _a=0x7fffd590ed20) at /usr/src/debug/digikam-1.2.0/build/digikam/digikamapp.moc:227
#11 0x00007f64479ed756 in QMetaObject::activate (sender=0x26933a0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffd590e46f) at kernel/qobject.cpp:3287
#12 0x0000000000680416 in Digikam::DigikamApp::loadPlugins (this=0xc47e60) at /usr/src/debug/digikam-1.2.0/digikam/digikamapp.cpp:2297
#13 0x000000000068e96e in Digikam::DigikamApp::DigikamApp (this=0xc47e60, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/digikam-1.2.0/digikam/digikamapp.cpp:252
#14 0x000000000077d0c7 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/digikam-1.2.0/digikam/main.cpp:170

Reported using DrKonqi
Comment 1 Marcel Wiesweg 2010-04-11 16:31:54 UTC
Please ensure that your kipi-plugins and libkipi packages are up to date. This looks like a binary compatibility problem.
Comment 2 Zettmaster 2010-04-11 20:32:55 UTC
(In reply to comment #1)
> Please ensure that your kipi-plugins and libkipi packages are up to date. This
> looks like a binary compatibility problem.

thanks! digiKam work now!
Comment 3 caulier.gilles 2010-12-24 22:53:30 UTC
*** Bug 261177 has been marked as a duplicate of this bug. ***
Comment 4 caulier.gilles 2011-01-28 10:35:33 UTC
*** Bug 264603 has been marked as a duplicate of this bug. ***
Comment 5 zless 2011-01-28 12:25:10 UTC
Created attachment 56564 [details]
New crash information added by DrKonqi

digikam (1.8.0) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:
I just started Digikam for the first time. The wizard detected a previous database in the pictures folder and began scanning. It then crashed.

-- Backtrace (Reduced):
#6  deref (this=0x7fffd05b7c20, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  QVariant::~QVariant (this=0x7fffd05b7c20, __in_chrg=<value optimized out>) at kernel/qvariant.cpp:1407
[...]
#10 0x00000000005c1573 in Digikam::DigikamApp::slotKipiPluginPlug (this=0x18d0f00) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2555
#11 0x00000000005d8b8d in Digikam::DigikamApp::qt_metacall (this=0x18d0f00, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7fffd05b82e0) at /build/buildd/digikam-1.8.0/obj-x86_64-linux-gnu/digikam/digikamapp.moc:230
[...]
#13 0x00000000005c7666 in Digikam::DigikamApp::loadPlugins (this=0x18d0f00) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2495
Comment 6 Telmo Xtra 2011-01-29 18:58:01 UTC
Same issue for me:

Digikam 1.8 just crashes at startup: KDE 4.6 on Kubuntu 10.10 64 bit. Can't do anything, not even printing... :-( 

System is fully updated.

Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3ea55187c0 (LWP 27844))]

Thread 16 (Thread 0x7f3e8bf29700 (LWP 27845)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3e9e398e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x000000000062887b in ?? ()
#3  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 15 (Thread 0x7f3e8b728700 (LWP 27846)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e46a5f8 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7f3e8af27700 (LWP 27848)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7f3e89ef8700 (LWP 27849)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7f3e896f7700 (LWP 27850)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3e9e398e3b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f3ea2933e62 in ?? () from /usr/lib/libdigikamcore.so.1
#3  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f3e88ef6700 (LWP 27851)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f3e83fff700 (LWP 27852)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f3e73b8c700 (LWP 27853)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f3e812c20d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f3e72750700 (LWP 27854)):
#0  0x00007f3e9cbd92c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f3e812eb385 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007f3e812cfd09 in ?? () from /usr/lib/libxine.so.1
#3  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f3e71f4f700 (LWP 27855)):
#0  __pthread_getspecific (key=1) at pthread_getspecific.c:32
#1  0x00007f3e9e397ba1 in ?? () from /usr/lib/libQtCore.so.4
#2  0x00007f3e9e4b8689 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f3e9a095a11 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#4  0x00007f3e9a095e78 in ?? () from /lib/libglib-2.0.so.0
#5  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#10 0x00007f3e8151d830 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#11 0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#12 0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#13 0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f3e71549700 (LWP 27856)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9c6a940f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007f3e9c698d76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007f3e9c69a7f9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007f3e9c69a8b0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007f3e9c6a920b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007f3e947d4fb8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f3e6cd47700 (LWP 27857)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f3e812d2e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f3e6c546700 (LWP 27858)):
#0  __pthread_mutex_lock (mutex=0x3183a88) at pthread_mutex_lock.c:127
#1  0x00007f3e9a095697 in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a096023 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e46a5f8 in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3e67eec700 (LWP 27865)):
#0  __pthread_mutex_unlock_usercnt (mutex=0x362d798) at pthread_mutex_unlock.c:49
#1  __pthread_mutex_unlock (mutex=0x362d798) at pthread_mutex_unlock.c:290
#2  0x00007f3e9a095661 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x00007f3e9a096023 in ?? () from /lib/libglib-2.0.so.0
#4  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x00007f3e9e46a5f8 in ?? () from /usr/lib/libQtCore.so.4
#10 0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#11 0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3e656e7700 (LWP 27878)):
#0  0x00007f3e9cbd4203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3e9a096009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f3e9a09645c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f3e9e4b81e6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f3e9e48aa02 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f3e9e48adec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f3e9e3952fd in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f3e9e46a5f8 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f3e9e39827e in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f3e9e10d971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f3e9cbe092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3ea55187c0 (LWP 27844)):
[KCrash Handler]
#6  0x00007f3ea1926426 in ?? () from /usr/lib/libmarblewidget.so.10
#7  0x00007f3ea192da98 in ?? () from /usr/lib/libmarblewidget.so.10
#8  0x00007f3ea1917df7 in ?? () from /usr/lib/libmarblewidget.so.10
#9  0x00007f3ea191819b in ?? () from /usr/lib/libmarblewidget.so.10
#10 0x00007f3ea191a7b9 in ?? () from /usr/lib/libmarblewidget.so.10
#11 0x00007f3ea189205e in Marble::MarbleModel::setupTextureMapper(Marble::Projection) () from /usr/lib/libmarblewidget.so.10
#12 0x00007f3ea1897672 in Marble::MarbleModel::setMapTheme(Marble::GeoSceneDocument*, Marble::Projection) () from /usr/lib/libmarblewidget.so.10
#13 0x00007f3ea189e299 in Marble::MarbleMap::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#14 0x00007f3ea188fc05 in Marble::MarbleWidget::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#15 0x00007f3ea29dadaa in Digikam::WorldMapWidget::setMapTheme(Digikam::WorldMapWidget::MapTheme) () from /usr/lib/libdigikamcore.so.1
#16 0x00007f3ea29de328 in Digikam::WorldMapWidget::readConfig(KConfigGroup&) () from /usr/lib/libdigikamcore.so.1
#17 0x0000000000546810 in _start ()
Comment 7 Andrew Coles 2011-01-29 19:37:57 UTC
Telmo - remove the package libmarblewidget10 and try again.

(Digikam 1.8 from the Kubuntu Backports PPA was compiled to use
libmarblewidget.so.11, but looking at your backtrace it's loading
libmarblewidget.so.10.)
Comment 8 Telmo Xtra 2011-01-30 14:30:09 UTC
Ok. Solved. The issue was that I had Digikam installed from Philip5's PPA (http://ppa.launchpad.net/philip5/extra/ubuntu) and had both versions of libmarblewidget10/11 installed. If I removed libmarblewidget11 Digikam worked, but if I tried to remove libmarblewidget10, dpkg also tried to remove digikam and showphoto.

Anyaway, after removing Philips5 PPA, and removing Digikam, Showphoto and kipi-plugins and allowing Digikam to be installed from Kubuntu backports it works fine and I have only libmarblewidget11 installed now. So no issue now.

Thanks for the tip.
Comment 9 bikon771 2011-02-05 13:41:20 UTC
Created attachment 56893 [details]
New crash information added by DrKonqi

digikam (1.8.0) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

digiKam crashes on start up(Kubuntu10.10)

-- Backtrace (Reduced):
#6  deref (this=0x7fff7abde5c0, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  QVariant::~QVariant (this=0x7fff7abde5c0, __in_chrg=<value optimized out>) at kernel/qvariant.cpp:1407
[...]
#10 0x00000000005c1573 in Digikam::DigikamApp::slotKipiPluginPlug (this=0x7f3f80015c10) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2555
#11 0x00000000005d8b8d in Digikam::DigikamApp::qt_metacall (this=0x7f3f80015c10, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7fff7abdec90) at /build/buildd/digikam-1.8.0/obj-x86_64-linux-gnu/digikam/digikamapp.moc:230
[...]
#13 0x00000000005c7666 in Digikam::DigikamApp::loadPlugins (this=0x7f3f80015c10) at /build/buildd/digikam-1.8.0/digikam/digikamapp.cpp:2495
Comment 10 caulier.gilles 2011-02-06 20:29:46 UTC
*** Bug 265640 has been marked as a duplicate of this bug. ***
Comment 11 caulier.gilles 2018-02-04 11:46:52 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core