Bug 265116 - KWin froze and lag a lot afterwards when using ALT TAB with the perspective effect
Summary: KWin froze and lag a lot afterwards when using ALT TAB with the perspective e...
Status: RESOLVED DUPLICATE of bug 261323
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 19:26 UTC by courteville
Modified: 2011-02-01 21:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description courteville 2011-02-01 19:26:03 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-ARCH x86_64
Distribution (Platform): Debian stable

-- Information about the crash:
- What I was doing when the application crashed:
Any time I use Alt+Tab with the perspective effect, KWin bugs as soon as I released the touchs to select a window : the window is then displayed but the cursor is frozen

- Unusual behavior I noticed:
Afterwards, Kde is kind of laggy

- Custom settings of the application:
Perspective presentation for the alt tab information, no problem with the box switch

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
[Current thread is 1 (Thread 0x7f9128d317a0 (LWP 2038))]

Thread 2 (Thread 0x7f910c47d700 (LWP 2054)):
#0  0x00007f912455241c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f91273f5794 in ?? () from /usr/lib/libQtScript.so.4
#2  0x00007f91273f57c9 in ?? () from /usr/lib/libQtScript.so.4
#3  0x00007f9125df0ae3 in ?? () from /usr/lib/libGL.so.1
#4  0x00007f912454dcb0 in start_thread () from /lib/libpthread.so.0
#5  0x00007f91285b5aed in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9128d317a0 (LWP 2038)):
[KCrash Handler]
#6  0x00007f9128514675 in raise () from /lib/libc.so.6
#7  0x00007f9128515af6 in abort () from /lib/libc.so.6
#8  0x00007f9123669f7d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#9  0x00007f9123668196 in ?? () from /usr/lib/libstdc++.so.6
#10 0x00007f91236681c3 in std::terminate() () from /usr/lib/libstdc++.so.6
#11 0x00007f9123668316 in __cxa_rethrow () from /usr/lib/libstdc++.so.6
#12 0x00007f91248be572 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#13 0x00007f91248c297b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#14 0x00007f912889c09a in kdemain () from /usr/lib/libkdeinit4_kwin.so
#15 0x00007f9128500dcd in __libc_start_main () from /lib/libc.so.6
#16 0x00000000004005c9 in _start ()

This bug may be a duplicate of or related to bug 253079.

Possible duplicates by query: bug 265068, bug 265057, bug 265044, bug 265043, bug 265031.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-02-01 21:54:12 UTC
backtrace is an unrelated terminate, no sigsev

*** This bug has been marked as a duplicate of bug 261323 ***