Bug 263264 - Konqueror crash when java applet is loadet (tested with sun-java6-plugin)
Summary: Konqueror crash when java applet is loadet (tested with sun-java6-plugin)
Status: RESOLVED DUPLICATE of bug 258452
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 22:58 UTC by Fabian B.
Modified: 2011-01-16 00:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian B. 2011-01-15 22:58:42 UTC
Application: konqueror (4.5.95 (4.6 RC2))
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-020637-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Open Konqueror and visit "http://knuddelz.de". Konqueror starts to load and crash.
i use sun-java6-plugin

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4e83710 (LWP 5664))]

Thread 2 (Thread 0xb0abeb70 (LWP 5683)):
#0  0xb558ce36 in clock_gettime (clock_id=-1252454412, tp=0xb0abdf90) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb67f250b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb68c96e5 in QTimerInfoList::updateCurrentTime (this=0x9545884) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb68c972a in QTimerInfoList::timerWait (this=0x9545884, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb68c77a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb0abe0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb68c783d in timerSourcePrepare (source=0x0, timeout=0xb5590ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb54f9e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb54fa279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb54fa848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb68c759f in QEventDispatcherGlib::processEvents (this=0x9439540, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb6897609 in QEventLoop::processEvents (this=0xb0abe290, flags=) at kernel/qeventloop.cpp:149
#12 0xb6897a8a in QEventLoop::exec (this=0xb0abe290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6793b7e in QThread::exec (this=0x9424610) at thread/qthread.cpp:490
#14 0xb687635b in QInotifyFileSystemWatcherEngine::run (this=0x9424610) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6796df9 in QThreadPrivate::start (arg=0x9424610) at thread/qthread_unix.cpp:266
#16 0xb559ccc9 in start_thread (arg=0xb0abeb70) at pthread_create.c:304
#17 0xb768d69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb4e83710 (LWP 5664)):
[KCrash Handler]
#7  deref (this=0xa3cc6dc, other=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:132
#8  QString::operator= (this=0xa3cc6dc, other=...) at tools/qstring.cpp:1324
#9  0xac84284e in transform<QList<QVariant>::const_iterator, QList<QString>::iterator, QString (*)(QVariant const&)> (this=0xa3b6838, wparent=0x9a06038, parent=0xa9579d8, args=...) at /usr/include/c++/4.4/bits/stl_algo.h:4703
#10 KJavaAppletViewerFactory::create (this=0xa3b6838, wparent=0x9a06038, parent=0xa9579d8, args=...) at ../../../khtml/java/kjavaappletviewer.cpp:73
#11 0xafb93839 in create<KParts::ReadOnlyPart> (this=0xa9579d8, parentWidget=0x9a06038, parent=0xa9579d8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../kdecore/util/kpluginfactory.h:527
#12 KHTMLPart::createPart (this=0xa9579d8, parentWidget=0x9a06038, parent=0xa9579d8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../khtml/khtml_part.cpp:4623
#13 0xafb8568a in KHTMLPart::processObjectRequest (this=0xa9579d8, child=0xa13fd48, _url=..., mimetype=...) at ../../khtml/khtml_part.cpp:4388
#14 0xafb8692d in KHTMLPart::requestObject (this=0xa9579d8, child=0xa13fd48, url=..., _args=..., browserArgs=...) at ../../khtml/khtml_part.cpp:4277
#15 0xafb8782b in KHTMLPart::loadObjectElement (this=0xa9579d8, frame=0x9896340, url=..., serviceType=..., params=...) at ../../khtml/khtml_part.cpp:4198
#16 0xafc99193 in DOM::HTMLObjectBaseElementImpl::computeContent (this=0x9896340) at ../../khtml/html/html_objectimpl.cpp:538
#17 0xafc9a47f in DOM::HTMLAppletElementImpl::computeContent (this=0x9896340) at ../../khtml/html/html_objectimpl.cpp:677
#18 0xafc93934 in DOM::HTMLPartContainerElementImpl::computeContentIfNeeded (this=0x250040) at ../../khtml/html/html_objectimpl.cpp:89
#19 0xafc4ef52 in khtml::KHTMLParser::popOneBlock (this=0x99db890, delBlock=true) at ../../khtml/html/htmlparser.cpp:1865
#20 0xafc502a6 in khtml::KHTMLParser::popBlock (this=0x99db890, _id=5) at ../../khtml/html/htmlparser.cpp:1806
#21 0xafc532d4 in khtml::KHTMLParser::parseToken (this=0x99db890, t=0xa27d544) at ../../khtml/html/htmlparser.cpp:253
#22 0xafc53b73 in khtml::HTMLTokenizer::processToken (this=0xa27d530) at ../../khtml/html/htmltokenizer.cpp:2040
#23 0xafc5b606 in khtml::HTMLTokenizer::parseTag (this=0xa27d530, src=...) at ../../khtml/html/htmltokenizer.cpp:1501
#24 0xafc5d1e1 in khtml::HTMLTokenizer::write (this=0xa27d530, str=..., appendData=false) at ../../khtml/html/htmltokenizer.cpp:1798
#25 0xafc59427 in khtml::HTMLTokenizer::notifyFinished (this=0xa27d530, finishedObj=0x9ae4d08) at ../../khtml/html/htmltokenizer.cpp:2136
#26 0xafd8bb15 in khtml::CachedScript::checkNotify (this=0x9ae4d08) at ../../khtml/misc/loader.cpp:397
#27 0xafd8feac in khtml::CachedScript::data (this=0x9ae4d08, buffer=..., eof=true) at ../../khtml/misc/loader.cpp:389
#28 0xafd8f98d in khtml::Loader::slotFinished (this=0x97628f0, job=0x9ae5248) at ../../khtml/misc/loader.cpp:1262
#29 0xafd8fcdf in khtml::Loader::qt_metacall (this=0x97628f0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbff93fc8) at ./loader.moc:141
#30 0xb689e8ca in QMetaObject::metacall (object=0x97628f0, cl=3220779720, idx=7, argv=0xbff93fc8) at kernel/qmetaobject.cpp:237
#31 0xb68b16ad in QMetaObject::activate (sender=0x9ae5248, m=0xb6c6b548, local_signal_index=3, argv=0x250040) at kernel/qobject.cpp:3280
#32 0xb6ae9d83 in KJob::result (this=0x9ae5248, _t1=0x9ae5248) at ./kjob.moc:194
#33 0xb6aea0e8 in KJob::emitResult (this=0x9ae5248) at ../../kdecore/jobs/kjob.cpp:312
#34 0xb7175a40 in KIO::SimpleJob::slotFinished (this=0x9ae5248) at ../../kio/kio/job.cpp:525
#35 0xb717639c in KIO::TransferJob::slotFinished (this=0x9ae5248) at ../../kio/kio/job.cpp:1118
#36 0xb7173c43 in KIO::TransferJob::qt_metacall (this=0x9ae5248, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbff9427c) at ./jobclasses.moc:367
#37 0xb689e8ca in QMetaObject::metacall (object=0x9ae5248, cl=3220779720, idx=47, argv=0xbff9427c) at kernel/qmetaobject.cpp:237
#38 0xb68b16ad in QMetaObject::activate (sender=0xa959720, m=0xb732a6c4, local_signal_index=4, argv=0x250040) at kernel/qobject.cpp:3280
#39 0xb7231327 in KIO::SlaveInterface::finished (this=0xa959720) at ./slaveinterface.moc:171
#40 0xb7234ac8 in KIO::SlaveInterface::dispatch (this=0xa959720, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:173
#41 0xb72317e3 in KIO::SlaveInterface::dispatch (this=0xa959720) at ../../kio/kio/slaveinterface.cpp:89
#42 0xb7224138 in KIO::Slave::gotInput (this=0xa959720) at ../../kio/kio/slave.cpp:348
#43 0xb7224343 in KIO::Slave::qt_metacall (this=0xa959720, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbff945ac) at ./slave.moc:82
#44 0xb689e8ca in QMetaObject::metacall (object=0xa959720, cl=3220779720, idx=30, argv=0xbff945ac) at kernel/qmetaobject.cpp:237
#45 0xb68b16ad in QMetaObject::activate (sender=0xa9f3668, m=0xb73274a0, local_signal_index=0, argv=0x250040) at kernel/qobject.cpp:3280
#46 0xb713b847 in KIO::Connection::readyRead (this=0xa9f3668) at ./connection.moc:92
#47 0xb713dbae in KIO::ConnectionPrivate::dequeue (this=0x9960948) at ../../kio/kio/connection.cpp:82
#48 0xb713dcde in KIO::Connection::qt_metacall (this=0xa9f3668, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x97d3230) at ./connection.moc:79
#49 0xb689e8ca in QMetaObject::metacall (object=0xa9f3668, cl=3220779720, idx=5, argv=0x97d3230) at kernel/qmetaobject.cpp:237
#50 0xb68a9df6 in QMetaCallEvent::placeMetaCall (this=0xa592f38, object=0xa9f3668) at kernel/qobject.cpp:534
#51 0xb68ab6a2 in QObject::event (this=0xa9f3668, e=0xa98d501) at kernel/qobject.cpp:1219
#52 0xb5d1bfdc in QApplicationPrivate::notify_helper (this=0x92fdc90, receiver=0xa9f3668, e=0xa592f38) at kernel/qapplication.cpp:4396
#53 0xb5d2204e in QApplication::notify (this=0xbff95024, receiver=0xa9f3668, e=0xa592f38) at kernel/qapplication.cpp:3798
#54 0xb6e7df8a in KApplication::notify (this=0xbff95024, receiver=0xa9f3668, event=0xa592f38) at ../../kdeui/kernel/kapplication.cpp:311
#55 0xb6898b3b in QCoreApplication::notifyInternal (this=0xbff95024, receiver=0xa9f3668, event=0xa592f38) at kernel/qcoreapplication.cpp:732
#56 0xb689bd8b in sendEvent (receiver=0x0, event_type=0, data=0x92e4000) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x92e4000) at kernel/qcoreapplication.cpp:1373
#58 0xb689bf4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#59 0xb68c7a74 in sendPostedEvents (s=0x9300120) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#60 postEventSourceDispatch (s=0x9300120) at kernel/qeventdispatcher_glib.cpp:277
#61 0xb54f6855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#62 0xb54fa668 in ?? () from /lib/libglib-2.0.so.0
#63 0xb54fa848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#64 0xb68c7565 in QEventDispatcherGlib::processEvents (this=0x92fdc70, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#65 0xb5dddbe5 in QGuiEventDispatcherGlib::processEvents (this=0x92fdc70, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#66 0xb6897609 in QEventLoop::processEvents (this=0xbff94e64, flags=) at kernel/qeventloop.cpp:149
#67 0xb6897a8a in QEventLoop::exec (this=0xbff94e64, flags=...) at kernel/qeventloop.cpp:201
#68 0xb689c00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#69 0xb5d1ae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#70 0xb77e9e42 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_konqueror.so
#71 0x080485ab in _start ()

This bug may be a duplicate of or related to bug 258452.

Possible duplicates by query: bug 258847, bug 258832, bug 258452.

Reported using DrKonqi
Comment 1 Pino Toscano 2011-01-16 00:37:22 UTC

*** This bug has been marked as a duplicate of bug 258452 ***