Bug 258832 - Konqui crashed when calling fritz.nas from Dolphin
Summary: Konqui crashed when calling fritz.nas from Dolphin
Status: RESOLVED DUPLICATE of bug 258452
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-04 20:08 UTC by m.wege
Modified: 2010-12-11 23:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2010-12-04 20:08:07 UTC
Application: konqueror (4.5.80 (4.6 Beta1))
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-7-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: I type fritz.nas in Dolphin, which then called Konqueror to open it -> crash.
-> calling the same site via Konqueror directly -> no crash

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#7  deref (this=0x95749dc, other=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:132
#8  QString::operator= (this=0x95749dc, other=...) at tools/qstring.cpp:1324
#9  0xade1984e in transform<QList<QVariant>::const_iterator, QList<QString>::iterator, QString (*)(QVariant const&)> (this=0x94f5f40, wparent=0x8b68758, parent=0x8b2b9f8, args=...) at /usr/include/c++/4.4/bits/stl_algo.h:4703
#10 KJavaAppletViewerFactory::create (this=0x94f5f40, wparent=0x8b68758, parent=0x8b2b9f8, args=...) at ../../../khtml/java/kjavaappletviewer.cpp:73
#11 0xb153f279 in create<KParts::ReadOnlyPart> (this=0x8b2b9f8, parentWidget=0x8b68758, parent=0x8b2b9f8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../kdecore/util/kpluginfactory.h:527
#12 KHTMLPart::createPart (this=0x8b2b9f8, parentWidget=0x8b68758, parent=0x8b2b9f8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../khtml/khtml_part.cpp:4625
#13 0xb15310ca in KHTMLPart::processObjectRequest (this=0x8b2b9f8, child=0x9571648, _url=..., mimetype=...) at ../../khtml/khtml_part.cpp:4388
#14 0xb153236d in KHTMLPart::requestObject (this=0x8b2b9f8, child=0x9571648, url=..., _args=..., browserArgs=...) at ../../khtml/khtml_part.cpp:4277
#15 0xb153326b in KHTMLPart::loadObjectElement (this=0x8b2b9f8, frame=0x9571af0, url=..., serviceType=..., params=...) at ../../khtml/khtml_part.cpp:4198
#16 0xb1644293 in DOM::HTMLObjectBaseElementImpl::computeContent (this=0x9571af0) at ../../khtml/html/html_objectimpl.cpp:538
#17 0xb164557f in DOM::HTMLAppletElementImpl::computeContent (this=0x9571af0) at ../../khtml/html/html_objectimpl.cpp:677
#18 0xb163ea34 in DOM::HTMLPartContainerElementImpl::computeContentIfNeeded (this=0x726538d1) at ../../khtml/html/html_objectimpl.cpp:89
#19 0xb163ec75 in DOM::HTMLPartContainerElementImpl::recalcStyle (this=0x9571af0, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_objectimpl.cpp:72
#20 0xb15c456f in DOM::ElementImpl::recalcStyle (this=0x9501d88, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#21 0xb1617a39 in DOM::HTMLElementImpl::recalcStyle (this=0x9501d88, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#22 0xb15c456f in DOM::ElementImpl::recalcStyle (this=0x94ffad0, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#23 0xb1617a39 in DOM::HTMLElementImpl::recalcStyle (this=0x94ffad0, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#24 0xb15c456f in DOM::ElementImpl::recalcStyle (this=0x94a9ba0, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#25 0xb1617a39 in DOM::HTMLElementImpl::recalcStyle (this=0x94a9ba0, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#26 0xb15c456f in DOM::ElementImpl::recalcStyle (this=0x94a6b78, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#27 0xb1617a39 in DOM::HTMLElementImpl::recalcStyle (this=0x94a6b78, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#28 0xb15c456f in DOM::ElementImpl::recalcStyle (this=0x940a268, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#29 0xb1617a39 in DOM::HTMLElementImpl::recalcStyle (this=0x940a268, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#30 0xb15b28ef in DOM::DocumentImpl::recalcStyle (this=0x9429538, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_docimpl.cpp:1439
#31 0xb159e978 in DOM::DocumentImpl::updateRendering (this=0x726538d1) at ../../khtml/xml/dom_docimpl.cpp:1468
#32 0xb15ab5ea in DOM::DocumentImpl::updateDocumentsRendering () at ../../khtml/xml/dom_docimpl.cpp:1481
#33 0xb17b054c in KJS::Window::afterScriptExecution (this=0xadec0000) at ../../khtml/ecma/kjs_window.cpp:1323
#34 0xb17c9e89 in KJSProxy::evaluate (this=0x940a3f0, filename=..., baseLine=139, str=..., n=..., completion=0xbff6d33c) at ../../khtml/ecma/kjs_proxy.cpp:138
#35 0xb151c9fb in KHTMLPart::executeScript (this=0x8b2b9f8, filename=..., baseLine=139, n=..., script=...) at ../../khtml/khtml_part.cpp:1279
#36 0xb15ffc63 in khtml::HTMLTokenizer::scriptExecution (this=0x9423798, str=..., scriptURL=..., baseLine=139) at ../../khtml/html/htmltokenizer.cpp:517
#37 0xb16054d5 in khtml::HTMLTokenizer::scriptHandler (this=0x9423798) at ../../khtml/html/htmltokenizer.cpp:470
#38 0xb16068d5 in khtml::HTMLTokenizer::parseRawContent (this=0x9423798, src=...) at ../../khtml/html/htmltokenizer.cpp:379
#39 0xb16085ab in khtml::HTMLTokenizer::parseTag (this=0x9423798, src=...) at ../../khtml/html/htmltokenizer.cpp:1527
#40 0xb1608c11 in khtml::HTMLTokenizer::write (this=0x9423798, str=..., appendData=false) at ../../khtml/html/htmltokenizer.cpp:1798
#41 0xb1604e57 in khtml::HTMLTokenizer::notifyFinished (this=0x9423798, finishedObj=0x95519c0) at ../../khtml/html/htmltokenizer.cpp:2136
#42 0xb17365d5 in khtml::CachedScript::checkNotify (this=0x95519c0) at ../../khtml/misc/loader.cpp:397
#43 0xb173a96c in khtml::CachedScript::data (this=0x95519c0, buffer=..., eof=true) at ../../khtml/misc/loader.cpp:389
#44 0xb173a44d in khtml::Loader::slotFinished (this=0x8b4b340, job=0x9553a98) at ../../khtml/misc/loader.cpp:1262
#45 0xb173a79f in khtml::Loader::qt_metacall (this=0x8b4b340, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbff6daf8) at ./loader.moc:141
#46 0xb68378ca in QMetaObject::metacall (object=0x8b4b340, cl=3220621288, idx=7, argv=0xbff6daf8) at kernel/qmetaobject.cpp:237
#47 0xb684a6ad in QMetaObject::activate (sender=0x9553a98, m=0xb6c03568, local_signal_index=3, argv=0x726538d1) at kernel/qobject.cpp:3280
#48 0xb6a83183 in KJob::result (this=0x9553a98, _t1=0x9553a98) at ./kjob.moc:194
#49 0xb6a834e8 in KJob::emitResult (this=0x9553a98) at ../../kdecore/jobs/kjob.cpp:312
#50 0xb71078c0 in KIO::SimpleJob::slotFinished (this=0x9553a98) at ../../kio/kio/job.cpp:525
#51 0xb710821c in KIO::TransferJob::slotFinished (this=0x9553a98) at ../../kio/kio/job.cpp:1118
#52 0xb7105ac3 in KIO::TransferJob::qt_metacall (this=0x9553a98, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbff6ddac) at ./jobclasses.moc:367
#53 0xb68378ca in QMetaObject::metacall (object=0x9553a98, cl=3220621288, idx=47, argv=0xbff6ddac) at kernel/qmetaobject.cpp:237
#54 0xb684a6ad in QMetaObject::activate (sender=0x93f7a08, m=0xb72bb6c4, local_signal_index=4, argv=0x726538d1) at kernel/qobject.cpp:3280
#55 0xb71c2797 in KIO::SlaveInterface::finished (this=0x93f7a08) at ./slaveinterface.moc:171
#56 0xb71c5f38 in KIO::SlaveInterface::dispatch (this=0x93f7a08, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:173
#57 0xb71c2c53 in KIO::SlaveInterface::dispatch (this=0x93f7a08) at ../../kio/kio/slaveinterface.cpp:89
#58 0xb71b55a8 in KIO::Slave::gotInput (this=0x93f7a08) at ../../kio/kio/slave.cpp:348
#59 0xb71b57b3 in KIO::Slave::qt_metacall (this=0x93f7a08, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbff6e0dc) at ./slave.moc:82
#60 0xb68378ca in QMetaObject::metacall (object=0x93f7a08, cl=3220621288, idx=30, argv=0xbff6e0dc) at kernel/qmetaobject.cpp:237
#61 0xb684a6ad in QMetaObject::activate (sender=0x94897c8, m=0xb72b84a0, local_signal_index=0, argv=0x726538d1) at kernel/qobject.cpp:3280
#62 0xb70cd717 in KIO::Connection::readyRead (this=0x94897c8) at ./connection.moc:92
#63 0xb70cfa7e in KIO::ConnectionPrivate::dequeue (this=0x9488d90) at ../../kio/kio/connection.cpp:82
#64 0xb70cfbae in KIO::Connection::qt_metacall (this=0x94897c8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x95380f8) at ./connection.moc:79
#65 0xb68378ca in QMetaObject::metacall (object=0x94897c8, cl=3220621288, idx=5, argv=0x95380f8) at kernel/qmetaobject.cpp:237
#66 0xb6842df6 in QMetaCallEvent::placeMetaCall (this=0x8b25b38, object=0x94897c8) at kernel/qobject.cpp:534
#67 0xb68446a2 in QObject::event (this=0x94897c8, e=0x8b95201) at kernel/qobject.cpp:1219
#68 0xb5cb4fdc in QApplicationPrivate::notify_helper (this=0x8509850, receiver=0x94897c8, e=0x8b25b38) at kernel/qapplication.cpp:4396
#69 0xb5cbb04e in QApplication::notify (this=0xbff6eb54, receiver=0x94897c8, e=0x8b25b38) at kernel/qapplication.cpp:3798
#70 0xb6e0fe6a in KApplication::notify (this=0xbff6eb54, receiver=0x94897c8, event=0x8b25b38) at ../../kdeui/kernel/kapplication.cpp:311
#71 0xb6831b3b in QCoreApplication::notifyInternal (this=0xbff6eb54, receiver=0x94897c8, event=0x8b25b38) at kernel/qcoreapplication.cpp:732
#72 0xb6834d8b in sendEvent (receiver=0x0, event_type=0, data=0x84effe8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84effe8) at kernel/qcoreapplication.cpp:1373
#74 0xb6834f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#75 0xb6860a74 in sendPostedEvents (s=0x850bd20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x850bd20) at kernel/qeventdispatcher_glib.cpp:277
#77 0xb54a2855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#78 0xb54a6668 in ?? () from /lib/libglib-2.0.so.0
#79 0xb54a6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#80 0xb6860565 in QEventDispatcherGlib::processEvents (this=0x8509830, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#81 0xb5d76be5 in QGuiEventDispatcherGlib::processEvents (this=0x8509830, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb6830609 in QEventLoop::processEvents (this=0xbff6e994, flags=) at kernel/qeventloop.cpp:149
#83 0xb6830a8a in QEventLoop::exec (this=0xbff6e994, flags=...) at kernel/qeventloop.cpp:201
#84 0xb683500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#85 0xb5cb3e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#86 0xb7789ce2 in kdemain (argc=2, argv=0xbff6ee34) at ../../../../apps/konqueror/src/konqmain.cpp:234
#87 0x080485ab in main (argc=2, argv=0xbff6ee34) at konqueror_dummy.cpp:3

This bug may be a duplicate of or related to bug 258452.

Possible duplicates by query: bug 258452.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-11 23:35:42 UTC
[Comment from a bug triager]
This issue is being tracked at bug 258452. Merging. Thanks

*** This bug has been marked as a duplicate of bug 258452 ***