Bug 258847 - crash on session restauration
Summary: crash on session restauration
Status: RESOLVED DUPLICATE of bug 258452
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-04 21:56 UTC by m.wege
Modified: 2010-12-11 23:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2010-12-04 21:56:22 UTC
Application: konqueror (4.5.80 (4.6 Beta1))
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-7-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I am not sure, if it is the same crash as reported before, but most likely it is. The crash happened on session restauration.

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[KCrash Handler]
#7  deref (this=0x95b5fe4, other=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:132
#8  QString::operator= (this=0x95b5fe4, other=...) at tools/qstring.cpp:1324
#9  0xae5c984e in transform<QList<QVariant>::const_iterator, QList<QString>::iterator, QString (*)(QVariant const&)> (this=0x9590e40, wparent=0x8c4cb10, parent=0x8c0f9e8, args=...) at /usr/include/c++/4.4/bits/stl_algo.h:4703
#10 KJavaAppletViewerFactory::create (this=0x9590e40, wparent=0x8c4cb10, parent=0x8c0f9e8, args=...) at ../../../khtml/java/kjavaappletviewer.cpp:73
#11 0xb14e3279 in create<KParts::ReadOnlyPart> (this=0x8c0f9e8, parentWidget=0x8c4cb10, parent=0x8c0f9e8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../kdecore/util/kpluginfactory.h:527
#12 KHTMLPart::createPart (this=0x8c0f9e8, parentWidget=0x8c4cb10, parent=0x8c0f9e8, mimetype=..., serviceName=..., serviceTypes=..., params=...) at ../../khtml/khtml_part.cpp:4625
#13 0xb14d50ca in KHTMLPart::processObjectRequest (this=0x8c0f9e8, child=0x95a9938, _url=..., mimetype=...) at ../../khtml/khtml_part.cpp:4388
#14 0xb14d636d in KHTMLPart::requestObject (this=0x8c0f9e8, child=0x95a9938, url=..., _args=..., browserArgs=...) at ../../khtml/khtml_part.cpp:4277
#15 0xb14d726b in KHTMLPart::loadObjectElement (this=0x8c0f9e8, frame=0x95a9e88, url=..., serviceType=..., params=...) at ../../khtml/khtml_part.cpp:4198
#16 0xb15e8293 in DOM::HTMLObjectBaseElementImpl::computeContent (this=0x95a9e88) at ../../khtml/html/html_objectimpl.cpp:538
#17 0xb15e957f in DOM::HTMLAppletElementImpl::computeContent (this=0x95a9e88) at ../../khtml/html/html_objectimpl.cpp:677
#18 0xb15e2a34 in DOM::HTMLPartContainerElementImpl::computeContentIfNeeded (this=0x250092) at ../../khtml/html/html_objectimpl.cpp:89
#19 0xb15e2c75 in DOM::HTMLPartContainerElementImpl::recalcStyle (this=0x95a9e88, ch=DOM::NodeImpl::Force) at ../../khtml/html/html_objectimpl.cpp:72
#20 0xb156856f in DOM::ElementImpl::recalcStyle (this=0x953a800, change=DOM::NodeImpl::Force) at ../../khtml/xml/dom_elementimpl.cpp:1018
#21 0xb15bba39 in DOM::HTMLElementImpl::recalcStyle (this=0x953a800, ch=DOM::NodeImpl::Force) at ../../khtml/html/html_elementimpl.cpp:235
#22 0xb156856f in DOM::ElementImpl::recalcStyle (this=0x953a840, change=DOM::NodeImpl::Force) at ../../khtml/xml/dom_elementimpl.cpp:1018
#23 0xb15bba39 in DOM::HTMLElementImpl::recalcStyle (this=0x953a840, ch=DOM::NodeImpl::Force) at ../../khtml/html/html_elementimpl.cpp:235
#24 0xb156856f in DOM::ElementImpl::recalcStyle (this=0x94daea8, change=DOM::NodeImpl::Force) at ../../khtml/xml/dom_elementimpl.cpp:1018
#25 0xb15bba39 in DOM::HTMLElementImpl::recalcStyle (this=0x94daea8, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#26 0xb156856f in DOM::ElementImpl::recalcStyle (this=0x94dae60, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#27 0xb15bba39 in DOM::HTMLElementImpl::recalcStyle (this=0x94dae60, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#28 0xb156856f in DOM::ElementImpl::recalcStyle (this=0x9454b08, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_elementimpl.cpp:1018
#29 0xb15bba39 in DOM::HTMLElementImpl::recalcStyle (this=0x9454b08, ch=DOM::NodeImpl::NoChange) at ../../khtml/html/html_elementimpl.cpp:235
#30 0xb15568ef in DOM::DocumentImpl::recalcStyle (this=0x943b7f0, change=DOM::NodeImpl::NoChange) at ../../khtml/xml/dom_docimpl.cpp:1439
#31 0xb1542978 in DOM::DocumentImpl::updateRendering (this=0x250092) at ../../khtml/xml/dom_docimpl.cpp:1468
#32 0xb154f5ea in DOM::DocumentImpl::updateDocumentsRendering () at ../../khtml/xml/dom_docimpl.cpp:1481
#33 0xb175454c in KJS::Window::afterScriptExecution (this=0xae670000) at ../../khtml/ecma/kjs_window.cpp:1323
#34 0xb176de89 in KJSProxy::evaluate (this=0x9461da0, filename=..., baseLine=139, str=..., n=..., completion=0xbfabb7ac) at ../../khtml/ecma/kjs_proxy.cpp:138
#35 0xb14c09fb in KHTMLPart::executeScript (this=0x8c0f9e8, filename=..., baseLine=139, n=..., script=...) at ../../khtml/khtml_part.cpp:1279
#36 0xb15a3c63 in khtml::HTMLTokenizer::scriptExecution (this=0x9436730, str=..., scriptURL=..., baseLine=139) at ../../khtml/html/htmltokenizer.cpp:517
#37 0xb15a94d5 in khtml::HTMLTokenizer::scriptHandler (this=0x9436730) at ../../khtml/html/htmltokenizer.cpp:470
#38 0xb15aa8d5 in khtml::HTMLTokenizer::parseRawContent (this=0x9436730, src=...) at ../../khtml/html/htmltokenizer.cpp:379
#39 0xb15ac5ab in khtml::HTMLTokenizer::parseTag (this=0x9436730, src=...) at ../../khtml/html/htmltokenizer.cpp:1527
#40 0xb15acc11 in khtml::HTMLTokenizer::write (this=0x9436730, str=..., appendData=false) at ../../khtml/html/htmltokenizer.cpp:1798
#41 0xb15a8e57 in khtml::HTMLTokenizer::notifyFinished (this=0x9436730, finishedObj=0x9596110) at ../../khtml/html/htmltokenizer.cpp:2136
#42 0xb16da5d5 in khtml::CachedScript::checkNotify (this=0x9596110) at ../../khtml/misc/loader.cpp:397
#43 0xb16de96c in khtml::CachedScript::data (this=0x9596110, buffer=..., eof=true) at ../../khtml/misc/loader.cpp:389
#44 0xb16de44d in khtml::Loader::slotFinished (this=0x8c1d850, job=0x954e128) at ../../khtml/misc/loader.cpp:1262
#45 0xb16de79f in khtml::Loader::qt_metacall (this=0x8c1d850, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfabbf68) at ./loader.moc:141
#46 0xb68278ca in QMetaObject::metacall (object=0x8c1d850, cl=3215699032, idx=7, argv=0xbfabbf68) at kernel/qmetaobject.cpp:237
#47 0xb683a6ad in QMetaObject::activate (sender=0x954e128, m=0xb6bf3568, local_signal_index=3, argv=0x250092) at kernel/qobject.cpp:3280
#48 0xb6a73183 in KJob::result (this=0x954e128, _t1=0x954e128) at ./kjob.moc:194
#49 0xb6a734e8 in KJob::emitResult (this=0x954e128) at ../../kdecore/jobs/kjob.cpp:312
#50 0xb70f78c0 in KIO::SimpleJob::slotFinished (this=0x954e128) at ../../kio/kio/job.cpp:525
#51 0xb70f821c in KIO::TransferJob::slotFinished (this=0x954e128) at ../../kio/kio/job.cpp:1118
#52 0xb70f5ac3 in KIO::TransferJob::qt_metacall (this=0x954e128, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfabc21c) at ./jobclasses.moc:367
#53 0xb68278ca in QMetaObject::metacall (object=0x954e128, cl=3215699032, idx=47, argv=0xbfabc21c) at kernel/qmetaobject.cpp:237
#54 0xb683a6ad in QMetaObject::activate (sender=0x944a3f0, m=0xb72ab6c4, local_signal_index=4, argv=0x250092) at kernel/qobject.cpp:3280
#55 0xb71b2797 in KIO::SlaveInterface::finished (this=0x944a3f0) at ./slaveinterface.moc:171
#56 0xb71b5f38 in KIO::SlaveInterface::dispatch (this=0x944a3f0, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:173
#57 0xb71b2c53 in KIO::SlaveInterface::dispatch (this=0x944a3f0) at ../../kio/kio/slaveinterface.cpp:89
#58 0xb71a55a8 in KIO::Slave::gotInput (this=0x944a3f0) at ../../kio/kio/slave.cpp:348
#59 0xb71a57b3 in KIO::Slave::qt_metacall (this=0x944a3f0, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfabc54c) at ./slave.moc:82
#60 0xb68278ca in QMetaObject::metacall (object=0x944a3f0, cl=3215699032, idx=30, argv=0xbfabc54c) at kernel/qmetaobject.cpp:237
#61 0xb683a6ad in QMetaObject::activate (sender=0x94c93e0, m=0xb72a84a0, local_signal_index=0, argv=0x250092) at kernel/qobject.cpp:3280
#62 0xb70bd717 in KIO::Connection::readyRead (this=0x94c93e0) at ./connection.moc:92
#63 0xb70bfa7e in KIO::ConnectionPrivate::dequeue (this=0x94c8e20) at ../../kio/kio/connection.cpp:82
#64 0xb70bfbae in KIO::Connection::qt_metacall (this=0x94c93e0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x8c7cec8) at ./connection.moc:79
#65 0xb68278ca in QMetaObject::metacall (object=0x94c93e0, cl=3215699032, idx=5, argv=0x8c7cec8) at kernel/qmetaobject.cpp:237
#66 0xb6832df6 in QMetaCallEvent::placeMetaCall (this=0x9597a40, object=0x94c93e0) at kernel/qobject.cpp:534
#67 0xb68346a2 in QObject::event (this=0x94c93e0, e=0x93cc501) at kernel/qobject.cpp:1219
#68 0xb5ca4fdc in QApplicationPrivate::notify_helper (this=0x85f0848, receiver=0x94c93e0, e=0x9597a40) at kernel/qapplication.cpp:4396
#69 0xb5cab04e in QApplication::notify (this=0xbfabcfc4, receiver=0x94c93e0, e=0x9597a40) at kernel/qapplication.cpp:3798
#70 0xb6dffe6a in KApplication::notify (this=0xbfabcfc4, receiver=0x94c93e0, event=0x9597a40) at ../../kdeui/kernel/kapplication.cpp:311
#71 0xb6821b3b in QCoreApplication::notifyInternal (this=0xbfabcfc4, receiver=0x94c93e0, event=0x9597a40) at kernel/qcoreapplication.cpp:732
#72 0xb6824d8b in sendEvent (receiver=0x0, event_type=0, data=0x85d6fe8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#73 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x85d6fe8) at kernel/qcoreapplication.cpp:1373
#74 0xb6824f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#75 0xb6850a74 in sendPostedEvents (s=0x85f2d20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=0x85f2d20) at kernel/qeventdispatcher_glib.cpp:277
#77 0xb5492855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#78 0xb5496668 in ?? () from /lib/libglib-2.0.so.0
#79 0xb5496848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#80 0xb6850565 in QEventDispatcherGlib::processEvents (this=0x85f0828, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#81 0xb5d66be5 in QGuiEventDispatcherGlib::processEvents (this=0x85f0828, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#82 0xb6820609 in QEventLoop::processEvents (this=0xbfabce04, flags=) at kernel/qeventloop.cpp:149
#83 0xb6820a8a in QEventLoop::exec (this=0xbfabce04, flags=...) at kernel/qeventloop.cpp:201
#84 0xb682500f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#85 0xb5ca3e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#86 0xb7779ce2 in kdemain (argc=2, argv=0xbfabd2a4) at ../../../../apps/konqueror/src/konqmain.cpp:234
#87 0x080485ab in main (argc=2, argv=0xbfabd2a4) at konqueror_dummy.cpp:3

This bug may be a duplicate of or related to bug 258832.

Possible duplicates by query: bug 258832, bug 258452.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-11 23:35:46 UTC
[Comment from a bug triager]
- Do you remember which web page was going to be restored ?
This issue is being tracked at bug 258452. Merging. Thanks

*** This bug has been marked as a duplicate of bug 258452 ***