Bug 262707 - Unable to select any of the "Category" options from the drop down menu when entering or editing a transaction.
Summary: Unable to select any of the "Category" options from the drop down menu when e...
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.5.2
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 277431 277977 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-09 23:08 UTC by Rob W
Modified: 2011-07-18 15:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob W 2011-01-09 23:08:37 UTC
Version:           4.5.2 (using KDE 4.5.2) 
OS:                MS Windows

When mousing over any of the options in the list(s) and trying to select one it closes the list and no option is selected.  If I type in the first few letters of the option I want I am able to use the arrow keys to select the appropriate one and can press enter on the keyboard to enter it into the ledger.

Reproducible: Always

Steps to Reproduce:
Reproducible 100% of the time.
Enter a new transaction under any account in Assets or Liabilities.
Click the drop down arrow and attempt to select the appropriate category option.
 

Actual Results:  
It selects nothing and closes the drop down menu.

Expected Results:  
It should select the option that was "clicked".
In order to get the correct option entered you must type into the box the first few letters, arrow down, and press enter.

OS: WindowsNT (i686) release Windows 7
Compiler: cl.exe

Windows 7 Ultimate x64
Most recent updates from Microsoft installed.
Problem happens 100% of the time on my Dell Laptop (Vostro 1500) and whitebox desktop.
Comment 1 Cristian Oneț 2011-05-31 22:15:10 UTC
SVN commit 1234361 by conet:

BUG: 262707
On Windows when clicking the popup it seems that it is made the active window which causes a FocusOutEvent with the proper reason. So, on Windows, if the focus is lost due to a application window activation don't hide the completer.

Also on all version if the focus out reason is window activation don't trigger the category creation code this enables the user to switch windows while typing a category name.

This bug is yet another reason to port the account combobox to the QCombobox-QCompleter mechanism.

 M  +5 -0      kmymoneycombo.cpp  
 M  +5 -0      kmymoneycompletion.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1234361
Comment 2 Cristian Oneț 2011-05-31 22:33:23 UTC
SVN commit 1234362 by conet:

BUG: 262707
When returning from a window switch also don't select the edit text.

 M  +1 -1      kmymoneylineedit.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1234362
Comment 3 Cristian Oneț 2011-07-14 16:28:24 UTC
*** Bug 277431 has been marked as a duplicate of this bug. ***
Comment 4 Cristian Oneț 2011-07-18 15:16:04 UTC
*** Bug 277977 has been marked as a duplicate of this bug. ***