Bug 277977 - Crash editing Leger unassigned categories
Summary: Crash editing Leger unassigned categories
Status: RESOLVED DUPLICATE of bug 262707
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: 4.5.3
Platform: Microsoft Windows Microsoft Windows
: NOR crash (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-17 21:58 UTC by ross.mgr
Modified: 2011-07-18 15:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ross.mgr 2011-07-17 21:58:15 UTC
Version:           4.5.3 (using Devel) 
OS:                MS Windows

Imported transactions from my bank.  Editing the records, to change unassigned category.    

Editing one record, the check to accept the change is not enabled.  So edited multiple records.  The check was enabled so clicked it to save category change, then KMyMoney crashed.  

Selecting the category requires typing the entire name rather than providing nearest match, which is the one wanted.

Restarted then tried to edit category for one record, the check button was never enabled to save it.

Tried to change status to cleared, or even reconciled, still crashes.


Reproducible: Always

Steps to Reproduce:
Imported transaction from my bank ofx file.  Then to eliminate unassigned categories, edited records.  

Actual Results:  
Crash - data never saved

Expected Results:  
Enable the check button.  Store the record(s) then update the category or other change with the entered data. 

Also expected to begin typing a category, then as the match occurs, select the matched category, either by enter key or clicking on the list. 

When editing one record, enable the check to save it.  When editing multiple records, save the data, update the categories in the leger list.  

Computer is XP with default setup.  

Just installed the KMyMoney application for Windows.

Use the default .4 category list.

Tried to use the Education heading for category, and not books, etc.
Comment 1 allan 2011-07-17 23:18:57 UTC
(In reply to comment #0)
> Version:           4.5.3 (using Devel) 
> OS:                MS Windows
> 
> Imported transactions from my bank.  Editing the records, to change unassigned
> category.    
> 
> Editing one record, the check to accept the change is not enabled.  

If you mean that the 'Enter' button was not enabled, and as you say
later that this is a new installation, what might prevent saving the
edit is that the date of the transaction is earlier than the opening
date of the account.  Select Accounts on the left, then right click on
the account in question to edit it and check/ensure that the opening
date is before the oldest transaction.
> So edited
> multiple records.  The check was enabled so clicked it to save category change,
> then KMyMoney crashed.  
> 

The above should not have a bearing on the crash, but if you get
another crash, do you get a backtrace printed out?  If so, please attach it here.

> Selecting the category requires typing the entire name rather than providing
> nearest match, which is the one wanted.
> 
> Restarted then tried to edit category for one record, the check button was
> never enabled to save it.
> 
> Tried to change status to cleared, or even reconciled, still crashes.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> Imported transaction from my bank ofx file.  Then to eliminate unassigned
> categories, edited records.  
> 
> Actual Results:  
> Crash - data never saved
> 
> Expected Results:  
> Enable the check button.  Store the record(s) then update the category or other
> change with the entered data. 
> 
> Also expected to begin typing a category, then as the match occurs, select the
> matched category, either by enter key or clicking on the list. 
> 
> When editing one record, enable the check to save it.  When editing multiple
> records, save the data, update the categories in the leger list.  
> 
> Computer is XP with default setup.  
> 
> Just installed the KMyMoney application for Windows.
> 
> Use the default .4 category list.
> 
> Tried to use the Education heading for category, and not books, etc.
Comment 2 ross.mgr 2011-07-18 03:46:10 UTC
I changed the date; the enable button problem was corrected.

However, if editing the transaction record, change the category to something
valid, as seen in the list.  The application closes.  There is no displayed
error information.    

Played with the selection box on the left, "pay to" or "from", if the wrong
one is selected, which happened automatically on the edit open, the crash
occurs when the enter button is clicked.  I made one edit successfully, by
changing that selection to "from" rather than the default display of the pay
to.  However, when opening again, all data was as it was before the edit.  I
tried it again just like I did when it worked, the crash happened again.
Just doing a single record.

Opened again, tried the edit for the category on single record.  Purposely
changed the from/to selection on the left of edit screen, the edit worked
again.  Did a save from file menu, the change was saved when app opened
again.  




-----Original Message-----
From: bugzilla_noreply@kde.org [mailto:bugzilla_noreply@kde.org] On Behalf
Of allan
Sent: Sunday, July 17, 2011 5:19 PM
To: ross.mgr@gmail.com
Subject: [Bug 277977] Crash editing Leger unassigned categories

https://bugs.kde.org/show_bug.cgi?id=277977


allan <agander93@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |agander93@gmail.com




--- Comment #1 from allan <agander93 gmail com>  2011-07-17 23:18:57 ---
(In reply to comment #0)
> Version:           4.5.3 (using Devel) 
> OS:                MS Windows
> 
> Imported transactions from my bank.  Editing the records, to change
unassigned
> category.    
> 
> Editing one record, the check to accept the change is not enabled.  

If you mean that the 'Enter' button was not enabled, and as you say
later that this is a new installation, what might prevent saving the
edit is that the date of the transaction is earlier than the opening
date of the account.  Select Accounts on the left, then right click on
the account in question to edit it and check/ensure that the opening
date is before the oldest transaction.
> So edited
> multiple records.  The check was enabled so clicked it to save category
change,
> then KMyMoney crashed.  
> 

The above should not have a bearing on the crash, but if you get
another crash, do you get a backtrace printed out?  If so, please attach it
here.

> Selecting the category requires typing the entire name rather than
providing
> nearest match, which is the one wanted.
> 
> Restarted then tried to edit category for one record, the check button was
> never enabled to save it.
> 
> Tried to change status to cleared, or even reconciled, still crashes.
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> Imported transaction from my bank ofx file.  Then to eliminate unassigned
> categories, edited records.  
> 
> Actual Results:  
> Crash - data never saved
> 
> Expected Results:  
> Enable the check button.  Store the record(s) then update the category or
other
> change with the entered data. 
> 
> Also expected to begin typing a category, then as the match occurs, select
the
> matched category, either by enter key or clicking on the list. 
> 
> When editing one record, enable the check to save it.  When editing
multiple
> records, save the data, update the categories in the leger list.  
> 
> Computer is XP with default setup.  
> 
> Just installed the KMyMoney application for Windows.
> 
> Use the default .4 category list.
> 
> Tried to use the Education heading for category, and not books, etc.
Comment 3 Cristian Oneț 2011-07-18 15:16:04 UTC
Part of this is duplicate of BUG 262707 part of it is duplicate of another bug that caused the selection in the ledger to be invalid thus disabling the 'Enter' button.

*** This bug has been marked as a duplicate of bug 262707 ***