Bug 261342 - Kate crashes if the directory the Filesystem Browser plug-in is showing is moved
Summary: Kate crashes if the directory the Filesystem Browser plug-in is showing is m...
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-27 03:36 UTC by Alberto Paderno
Modified: 2010-12-27 11:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Paderno 2010-12-27 03:36:43 UTC
Application: kate (3.5.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I moved (by mistake) the directory the "Filesystem Browser" plug-in was showing, and Kate crashed.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7855930 (LWP 2544))]

Thread 2 (Thread 0xb4630b70 (LWP 2545)):
#0  0x0044c416 in __kernel_vsyscall ()
#1  0x00c10df6 in __poll (fds=0xca7ff4, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x00cfaa1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x00ced43c in ?? () from /lib/libglib-2.0.so.0
#4  0x00ced848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0474359f in QEventDispatcherGlib::processEvents (this=0x99da4e8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x04713609 in QEventLoop::processEvents (this=0xb4630290, flags=) at kernel/qeventloop.cpp:149
#7  0x04713a8a in QEventLoop::exec (this=0xb4630290, flags=...) at kernel/qeventloop.cpp:201
#8  0x0460fb7e in QThread::exec (this=0x965a888) at thread/qthread.cpp:490
#9  0x046f235b in QInotifyFileSystemWatcherEngine::run (this=0x965a888) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x04612df9 in QThreadPrivate::start (arg=0x965a888) at thread/qthread_unix.cpp:266
#11 0x004ddcc9 in start_thread (arg=0xb4630b70) at pthread_create.c:304
#12 0x00c1f69e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7855930 (LWP 2544)):
[KCrash Handler]
#7  0x03d19d08 in KFileItem::isDir (this=0x9a233d8) at ../../kio/kio/kfileitem.cpp:1000
#8  0x03d139c2 in KDirModelPrivate::removeFromNodeHash (this=0x9a23250, node=0x9a233d8, url=...) at ../../kio/kio/kdirmodel.cpp:204
#9  0x03d14910 in KDirModelPrivate::_k_slotDeleteItems (this=0x9a23250, items=...) at ../../kio/kio/kdirmodel.cpp:494
#10 0x03d15008 in KDirModel::qt_metacall (this=0x9a23b58, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfc3d578) at ./kdirmodel.moc:91
#11 0x0471a8ca in QMetaObject::metacall (object=0x9a23b58, cl=3217282072, idx=27, argv=0xbfc3d578) at kernel/qmetaobject.cpp:237
#12 0x0472d6ad in QMetaObject::activate (sender=0x9a23af0, m=0x3e89b9c, local_signal_index=13, argv=0x0) at kernel/qobject.cpp:3280
#13 0x03cf41c3 in KDirLister::itemsDeleted (this=0x9a23af0, _t1=...) at ./kdirlister.moc:295
#14 0x03cf5049 in KDirLister::Private::emitItemsDeleted (this=0x9a21ef0, _items=...) at ../../kio/kio/kdirlister.cpp:2417
#15 0x03d00e46 in KDirListerCache::itemsDeleted (this=0x9a19968, listers=..., deletedItems=...) at ../../kio/kio/kdirlister.cpp:1765
#16 0x03d02952 in KDirListerCache::slotFilesRemoved (this=0x9a19968, fileList=...) at ../../kio/kio/kdirlister.cpp:833
#17 0x03d02da8 in KDirListerCache::slotFilesRemoved (this=0x9a19968, fileList=...) at ../../kio/kio/kdirlister.cpp:788
#18 0x03d09b05 in KDirListerCache::qt_metacall (this=0x9a19968, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfc3d8b8) at ./kdirlister_p.moc:98
#19 0x0471a8ca in QMetaObject::metacall (object=0x9a19968, cl=3217282072, idx=5, argv=0xbfc3d8b8) at kernel/qmetaobject.cpp:237
#20 0x0472d6ad in QMetaObject::activate (sender=0x9a19b80, m=0x3e89df4, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3280
#21 0x03d15bb3 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x9a19b80, _t1=...) at ./kdirnotify.moc:131
#22 0x03d15db5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9a19b80, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfc3da1c) at ./kdirnotify.moc:89
#23 0x0012f9dc in QDBusConnectionPrivate::deliverCall (this=0x95c3218, object=0x9a19b80, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:919
#24 0x0013b1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa24c638, object=0x9a19b80) at qdbusintegrator_p.h:103
#25 0x047276a2 in QObject::event (this=0x9a19b80, e=0x1) at kernel/qobject.cpp:1219
#26 0x00ec3fdc in QApplicationPrivate::notify_helper (this=0x95c7630, receiver=0x9a19b80, e=0xa24c638) at kernel/qapplication.cpp:4396
#27 0x00eca04e in QApplication::notify (this=0xbfc3f11c, receiver=0x9a19b80, e=0xa24c638) at kernel/qapplication.cpp:3798
#28 0x008cf68a in KApplication::notify (this=0xbfc3f11c, receiver=0x9a19b80, event=0xa24c638) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x04714b3b in QCoreApplication::notifyInternal (this=0xbfc3f11c, receiver=0x9a19b80, event=0xa24c638) at kernel/qcoreapplication.cpp:732
#30 0x04717d8b in sendEvent (receiver=0x0, event_type=0, data=0x95aae98) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95aae98) at kernel/qcoreapplication.cpp:1373
#32 0x04717f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#33 0x04743a74 in sendPostedEvents (s=0x95cb688) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x95cb688) at kernel/qeventdispatcher_glib.cpp:277
#35 0x00ce9855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00ced668 in ?? () from /lib/libglib-2.0.so.0
#37 0x00ced848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x04743565 in QEventDispatcherGlib::processEvents (this=0x95aab58, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#39 0x00f85be5 in QGuiEventDispatcherGlib::processEvents (this=0x95aab58, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x04713609 in QEventLoop::processEvents (this=0xbfc3e240, flags=) at kernel/qeventloop.cpp:149
#41 0x04713a8a in QEventLoop::exec (this=0xbfc3e240, flags=...) at kernel/qeventloop.cpp:201
#42 0x0142e873 in QDialog::exec (this=0xa1d06a8) at dialogs/qdialog.cpp:552
#43 0x00489d08 in ?? () from /usr/lib/libkateinterfaces.so.4
#44 0x0047f31c in ?? () from /usr/lib/libkateinterfaces.so.4
#45 0x0047f63a in ?? () from /usr/lib/libkateinterfaces.so.4
#46 0x004810a2 in ?? () from /usr/lib/libkateinterfaces.so.4
#47 0x0471a8ca in QMetaObject::metacall (object=0x9646360, cl=3217282072, idx=159002040, argv=0xbfc3e298) at kernel/qmetaobject.cpp:237
#48 0x0472d6ad in QMetaObject::activate (sender=0xa38d1a8, m=0x8dd8a08, local_signal_index=15, argv=0x0) at kernel/qobject.cpp:3280
#49 0x08c40755 in KateDocument::modifiedOnDisk (this=0xa38d1a8, _t1=0xa38d1a8, _t2=true, _t3=KTextEditor::ModificationInterface::OnDiskDeleted) at ./katedocument.moc:502
#50 0x08c3eedf in KateDocument::slotModOnHdDeleted (this=0xa38d1a8, path=...) at ../../kate/document/katedocument.cpp:4441
#51 0x08c65f49 in KateDocument::qt_metacall (this=0xa38d1a8, _c=QMetaObject::InvokeMetaMethod, _id=68, _a=0xbfc3e778) at ./katedocument.moc:375
#52 0x0471a8ca in QMetaObject::metacall (object=0xa38d1a8, cl=3217282072, idx=104, argv=0xbfc3e778) at kernel/qmetaobject.cpp:237
#53 0x0472d6ad in QMetaObject::activate (sender=0x967d9a0, m=0x410644, local_signal_index=2, argv=0x0) at kernel/qobject.cpp:3280
#54 0x002746e3 in KDirWatch::deleted (this=0x967d9a0, _t1=...) at ./kdirwatch.moc:113
#55 0x00274e94 in KDirWatch::setDeleted (this=0x967d9a0, _file=...) at ../../kdecore/io/kdirwatch.cpp:1867
#56 0x0027518d in KDirWatch::qt_metacall (this=0x967d9a0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xa27bba0) at ./kdirwatch.moc:87
#57 0x0471a8ca in QMetaObject::metacall (object=0x967d9a0, cl=3217282072, idx=9, argv=0xa27bba0) at kernel/qmetaobject.cpp:237
#58 0x04725df6 in QMetaCallEvent::placeMetaCall (this=0xa1d05f0, object=0x967d9a0) at kernel/qobject.cpp:534
#59 0x047276a2 in QObject::event (this=0x967d9a0, e=0x1) at kernel/qobject.cpp:1219
#60 0x00ec3fdc in QApplicationPrivate::notify_helper (this=0x95c7630, receiver=0x967d9a0, e=0xa1d05f0) at kernel/qapplication.cpp:4396
#61 0x00eca04e in QApplication::notify (this=0xbfc3f11c, receiver=0x967d9a0, e=0xa1d05f0) at kernel/qapplication.cpp:3798
#62 0x008cf68a in KApplication::notify (this=0xbfc3f11c, receiver=0x967d9a0, event=0xa1d05f0) at ../../kdeui/kernel/kapplication.cpp:310
#63 0x04714b3b in QCoreApplication::notifyInternal (this=0xbfc3f11c, receiver=0x967d9a0, event=0xa1d05f0) at kernel/qcoreapplication.cpp:732
#64 0x04717d8b in sendEvent (receiver=0x0, event_type=0, data=0x95aae98) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x95aae98) at kernel/qcoreapplication.cpp:1373
#66 0x04717f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#67 0x04743a74 in sendPostedEvents (s=0x95cb688) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#68 postEventSourceDispatch (s=0x95cb688) at kernel/qeventdispatcher_glib.cpp:277
#69 0x00ce9855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#70 0x00ced668 in ?? () from /lib/libglib-2.0.so.0
#71 0x00ced848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#72 0x04743565 in QEventDispatcherGlib::processEvents (this=0x95aab58, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#73 0x00f85be5 in QGuiEventDispatcherGlib::processEvents (this=0x95aab58, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#74 0x04713609 in QEventLoop::processEvents (this=0xbfc3f014, flags=) at kernel/qeventloop.cpp:149
#75 0x04713a8a in QEventLoop::exec (this=0xbfc3f014, flags=...) at kernel/qeventloop.cpp:201
#76 0x0471800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#77 0x00ec2e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#78 0x00d927b7 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kate.so
#79 0x0804859b in _start ()

Possible duplicates by query: bug 224858, bug 223186, bug 220983.

Reported using DrKonqi
Comment 1 Dominik Haumann 2010-12-27 11:39:33 UTC
I is a known issue and unfortunately not fixed yet. See bug #196695.

*** This bug has been marked as a duplicate of bug 196695 ***