Bug 220983 - workspace Plasma kdeinit4 Segmentation fault
Summary: workspace Plasma kdeinit4 Segmentation fault
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-02 16:06 UTC by omega
Modified: 2010-01-02 18:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omega 2010-01-02 16:06:26 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
plasma crashed when i move folder

 -- Backtrace:
Application: Spazio di lavoro di Plasma (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f72378eb750 (LWP 2124))]

Thread 2 (Thread 0x7f7215474910 (LWP 2127)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f72373304fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x1b4d9e8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b4d9e8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f723376378c in QHostInfoAgent::run (this=0x1b4d9d0) at kernel/qhostinfo.cpp:260
#4  0x00007f723732f445 in QThreadPrivate::start (arg=0x1b4d9d0) at thread/qthread_unix.cpp:188
#5  0x00007f72340a1a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f7234c817bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f72378eb750 (LWP 2124)):
[KCrash Handler]
#5  0x00007f7236534d03 in KFileItem::isDir (this=0x2092190) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007f7236524198 in KDirModelPrivate::removeFromNodeHash (this=0x2726ce0, node=0x2092190, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007f72365250ab in KDirModelPrivate::_k_slotDeleteItems (this=0x2726ce0, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007f7236526b82 in KDirModel::qt_metacall (this=0x26c6e00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff416671e0) at ./kdirmodel.moc:83
#9  0x00007f723742addc in QMetaObject::activate (sender=0x269f440, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007f723650a895 in KDirLister::itemsDeleted (this=0x2092190, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007f723650b5d1 in KDirLister::Private::emitItemsDeleted (this=0x26ef5f0, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007f723651a57e in KDirListerCache::itemsDeleted (this=0x18cd550, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007f723651bfca in KDirListerCache::slotFilesRemoved (this=0x18cd550, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007f723651c454 in KDirListerCache::slotFilesRemoved (this=0x18cd550, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007f723651cdb0 in KDirListerCache::qt_metacall (this=0x18cd550, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff41667660) at ./kdirlister_p.moc:92
#16 0x00007f723742addc in QMetaObject::activate (sender=0x18ce5a0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f7236528115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x2092190, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007f7236528290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x18ce5a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff41667920) at ./kdirnotify.moc:83
#19 0x00007f7233494ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007f723349bdef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007f72374250f9 in QObject::event (this=0x18ce5a0, e=0x27448a0) at kernel/qobject.cpp:1111
#22 0x00007f72353c1efc in QApplicationPrivate::notify_helper (this=0x12512b0, receiver=0x18ce5a0, e=0x27448a0) at kernel/qapplication.cpp:4056
#23 0x00007f72353c91ce in QApplication::notify (this=0x12480d0, receiver=0x18ce5a0, e=0x27448a0) at kernel/qapplication.cpp:4021
#24 0x00007f7235ff8e56 in KApplication::notify (this=0x12480d0, receiver=0x18ce5a0, event=0x27448a0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007f7237415c2c in QCoreApplication::notifyInternal (this=0x12480d0, receiver=0x18ce5a0, event=0x27448a0) at kernel/qcoreapplication.cpp:610
#26 0x00007f723741680a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x11bf4d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x11bf4d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007f723743e533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007f72342f2bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007f72342f6598 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007f72342f66c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007f723743e1a6 in QEventDispatcherGlib::processEvents (this=0x11c2040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f72354564be in QGuiEventDispatcherGlib::processEvents (this=0x2092190, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f7237414532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f7237414904 in QEventLoop::exec (this=0x7fff41668210, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f7237416ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x00007f722ae3b4cf in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#39 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#40 0x0000000000407aa0 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#41 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#42 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

Reported using DrKonqi
Comment 1 Marco Martin 2010-01-02 18:03:26 UTC
this looks like a problem in KFileModel?
Comment 2 Beat Wolf 2010-01-02 18:40:58 UTC

*** This bug has been marked as a duplicate of bug 196695 ***