Bug 224858 - dolphin crashed while accessing a previously created directory
Summary: dolphin crashed while accessing a previously created directory
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.3
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-30 12:03 UTC by Toralf Förster
Modified: 2010-01-30 15:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster 2010-01-30 12:03:22 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.32.7 i686

What I was doing when the application crashed:
munted a Sony MemoryStick Pro via card reader onto my ThinkPad (vFAT), used a split view in dolphin, moved a full directory from the cared to my hard disk and switched to the dolphin tab which showed the (old) content of the moved directory. Clicking at an icon crashed it.


 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb7768ac8 in KFileItem::isDir (this=0x9c01640) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kfileitem.cpp:969
#7  0xb7755353 in KDirModelPrivate::removeFromNodeHash (this=0x9becba0, node=0x9c01640, url=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirmodel.cpp:200
#8  0xb775643e in KDirModelPrivate::_k_slotDeleteItems (this=0x9becba0, items=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirmodel.cpp:487
#9  0xb7757dd5 in KDirModel::qt_metacall (this=0x9bc8860, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfe488ac)
    at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3_build/kio/kdirmodel.moc:83
#10 0xb6aaf3cb in QMetaObject::activate (sender=0x9bc8850, from_signal_index=<value optimized out>, to_signal_index=17, argv=0x0) at kernel/qobject.cpp:3101
#11 0xb6aaf973 in QMetaObject::activate (sender=0x9bc8850, m=0x80b9410, local_signal_index=13, argv=0xbfe488ac) at kernel/qobject.cpp:3178
#12 0xb773a524 in KDirLister::itemsDeleted (this=0x9bc8850, _t1=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3_build/kio/kdirlister.moc:289
#13 0xb773b479 in KDirLister::Private::emitItemsDeleted (this=0x9bf8320, _items=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirlister.cpp:2351
#14 0xb7745cb1 in KDirListerCache::itemsDeleted (this=0x9b3b5c0, listers=..., deletedItems=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirlister.cpp:1697
#15 0xb77464d7 in KDirListerCache::slotFilesRemoved (this=0x9b3b5c0, fileList=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirlister.cpp:808
#16 0xb7746909 in KDirListerCache::slotFilesRemoved (this=0x9b3b5c0, fileList=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kio/kio/kdirlister.cpp:763
#17 0xb774dd72 in KDirListerCache::qt_metacall (this=0x9b3b5c0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfe48bdc)
    at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3_build/kio/kdirlister_p.moc:92
#18 0xb6aaf3cb in QMetaObject::activate (sender=0x9b49e48, from_signal_index=<value optimized out>, to_signal_index=9, argv=0x0) at kernel/qobject.cpp:3101
#19 0xb6aaf973 in QMetaObject::activate (sender=0x9b49e48, m=0xb78c8234, local_signal_index=4, argv=0xbfe48bdc) at kernel/qobject.cpp:3178
#20 0xb7759984 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x9b49e48, _t1=...) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3_build/kio/kdirnotify.moc:125
#21 0xb7759b82 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9b49e48, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe48cd0)
    at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3_build/kio/kdirnotify.moc:83
#22 0xb6b68c47 in QDBusConnectionPrivate::deliverCall (this=0x9ac8358, object=0x9b49e48, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:891
#23 0xb6b6f527 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/qt4/libQtDBus.so.4
#24 0xb6aac4c0 in QObject::event (this=0x9b49e48, e=0x9e56cd0) at kernel/qobject.cpp:1099
#25 0xb628ffac in QApplicationPrivate::notify_helper (this=0x9ad9f98, receiver=0x9b49e48, e=0x9e56cd0) at kernel/qapplication.cpp:4065
#26 0xb62988f3 in QApplication::notify (this=0xbfe49454, receiver=0x9b49e48, e=0x9e56cd0) at kernel/qapplication.cpp:3605
#27 0xb6fe6fae in KApplication::notify (this=0xbfe49454, receiver=0x9b49e48, event=0x9e56cd0) at /var/tmp/portage/kde-base/kdelibs-4.3.3-r1/work/kdelibs-4.3.3/kdeui/kernel/kapplication.cpp:302
#28 0xb6a9cf02 in QCoreApplication::notifyInternal (this=0xbfe49454, receiver=0x9b49e48, event=0x9e56cd0) at kernel/qcoreapplication.cpp:606
#29 0xb6a9d84b in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9ab2810) at kernel/qcoreapplication.h:213
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9ab2810) at kernel/qcoreapplication.cpp:1244
#31 0xb6a9d9de in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#32 0xb6ac4a90 in QCoreApplication::sendPostedEvents (s=0x9ad1fd8) at kernel/qcoreapplication.h:218
#33 postEventSourceDispatch (s=0x9ad1fd8) at kernel/qeventdispatcher_glib.cpp:210
#34 0xb5b164fb in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0x09ad1c04 in ?? ()
#36 0x09ad2320 in ?? ()
#37 0xb5bb43b8 in ?? () from /usr/lib/libglib-2.0.so.0
#38 0xb5bb43e0 in ?? () from /usr/lib/libglib-2.0.so.0
#39 0xb6ac4a60 in ?? () at kernel/qeventdispatcher_glib.cpp:99 from /usr/lib/qt4/libQtCore.so.4
#40 0x00000000 in ?? ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-01-30 15:01:09 UTC
Thanks for the bug report! This crash has been reported already.

*** This bug has been marked as a duplicate of bug 196695 ***