Bug 259862 - Amarok does not inhibit suspend while playing
Summary: Amarok does not inhibit suspend while playing
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.6.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: later
Assignee: Amarok Developers
URL:
Keywords:
: 279808 301512 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-14 17:17 UTC by niburu1
Modified: 2013-04-06 16:21 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description niburu1 2010-12-14 17:17:47 UTC
Version:           2.3.90 (2.4 beta 1) (using KDE 4.5.85) 
OS:                Linux

When playing audio, suspend and like power management features should be inhibited by Amarok. Solid supports this: see http://api.kde.org/4.x-api/kdelibs-apidocs/solid/html/namespaceSolid_1_1PowerManagement.html#a992cfe4520fe1fa8955d971e7c7cd446. Also see bug 227099 for some relevant discussion.

Reproducible: Always
Comment 1 niburu1 2011-05-05 17:58:24 UTC
This really should be considered a BUG. Any hopes of this "feature" being implemented any time soon if at all?
Comment 2 Mayank Madan 2012-11-29 18:18:45 UTC
Bug is reproducible in 2.6-git
Comment 3 Oliver Henshaw 2013-03-04 18:12:55 UTC
See also bug #279808.
Comment 4 Myriam Schweingruber 2013-03-04 18:45:06 UTC
*** Bug 279808 has been marked as a duplicate of this bug. ***
Comment 5 Anmol Ahuja 2013-04-03 20:35:57 UTC
https://git.reviewboard.kde.org/r/109846
Comment 6 Matěj Laitl 2013-04-03 22:46:33 UTC
*** Bug 301512 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Laitl 2013-04-03 23:05:12 UTC
[copying my comment from bug 222571]:
I think we should have 3 mutually exclusive radio buttons in Amarok Playback config:

When Amarok is playing:
 (a) Prevent system from going to sleep
 (b) Allow system to go to sleep, but pause playing
(c) Allow system to go to sleep, resume playing on resum

 [question is what should be default and if other devs are happy with this - I'm going to bring this to amarok-devel@kde.org - please watch it]
Comment 8 Matěj Laitl 2013-04-06 16:21:56 UTC
Removing bug 315438 from dependencies - it is a related bug, but I want to mark this one as fixed and the dependency prevents me from doing so. It also prevented the commit hook from posting to this bug, which is kinda unfortunate. (I didn't know about the dependency, next time you add a dependency, Jamie, please accompany it with a comment please)

Git commit 71e55e7bdd9b31642d09145a5801777c0e120454 by Matěj Laitl, on behalf of Anmol Ahuja.
Committed on 06/04/2013 at 18:07.
Pushed by laitl into branch 'master'.

Implement power management: suspend inhibition and pause on resume

FEATURES:
  * Added options to pause playback on system suspend and to inhibit automatic suspend
    if playing a track (enabled by default); patch by Anmol Ahuja. (BR 259862, 222571)

Related: 222571
FIXED-IN: 2.8
REVIEW: 109846
DIGEST: Amarok is now power-management aware: it can inhibit automatic system suspend
and pause on resume (configurable)

M  +2    -0    ChangeLog
M  +1    -0    src/CMakeLists.txt
M  +2    -0    src/EngineController.cpp
M  +8    -0    src/amarokconfig.kcfg
M  +36   -1    src/configdialog/dialogs/PlaybackConfig.ui
A  +90   -0    src/playback/PowerManager.cpp     [License: GPL (v2+)]
A  +48   -0    src/playback/PowerManager.h     [License: GPL (v2+)]
M  +3    -1    tests/core-impl/meta/multi/CMakeLists.txt
M  +2    -0    tests/playlist/CMakeLists.txt

http://commits.kde.org/amarok/71e55e7bdd9b31642d09145a5801777c0e120454