Bug 259861 - One-click "Download New Items"
Summary: One-click "Download New Items"
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Import-History (show other bugs)
Version: 1.6.0
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 222828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-14 17:15 UTC by Todd
Modified: 2017-08-16 09:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2010-12-14 17:15:45 UTC
Version:           1.6.0 (using KDE 4.5.85) 
OS:                Linux

At least for me, and I imagine many other people, the most common thing to do when downloading pictures off a removable device is to download pictures that have not already been download.  However, in digikam this requires two steps in two different menus.  First, you have to use the edit menu to select the new pictures, then you have to use the Download menu and Download Selected.  

Considering how common this use-case is, there should be a "Download New Items" entry in the download menu, so someone can click that once and download the pictures immediately.

I would further say that it is such a common use-case that it should be in the import images toolbar by default so someone can use it without navigating a menu.

Reproducible: Always

Steps to Reproduce:
Open one of the import tools

Actual Results:  
1. Click the "Edit" menu
2. Click "Select New Items"
3. Click the "Image" menu
4. Click "Download Selected"

Expected Results:  
1. Click the "Download New Items" toolbar button
Comment 1 Todd 2010-12-15 15:37:02 UTC
This isn't just for cameras, it is also for removable devices.
Comment 2 caulier.gilles 2011-08-05 08:52:28 UTC
*** Bug 224603 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2011-08-05 08:52:40 UTC
*** Bug 222828 has been marked as a duplicate of this bug. ***
Comment 4 Dotan Cohen 2011-08-05 09:00:09 UTC
Digikam has a "Download All" button and even a "Download and Erase All" button that you can add to the toolbar. Does that not fit your use case?
Comment 5 caulier.gilles 2011-08-05 09:14:29 UTC
*** Bug 224603 has been marked as a duplicate of this bug. ***
Comment 6 caulier.gilles 2011-08-10 13:53:41 UTC
Git commit fe9a2d0b16b6793756e8230e83a6a31f7c4925cb by Gilles Caulier.
Committed on 10/08/2011 at 15:49.
Pushed by cgilles into branch 'master'.

Fast one click button to Download New items from Camera interface is implemented.
BUGS: 259861

M  +8    -2    utilities/cameragui/main/cameraui_p.h
M  +8    -1    utilities/cameragui/main/cameraui.h
M  +5    -2    utilities/cameragui/main/cameraui.rc
M  +61   -7    utilities/cameragui/main/cameraui.cpp

http://commits.kde.org/digikam/fe9a2d0b16b6793756e8230e83a6a31f7c4925cb