Bug 257918 - text alongside is gone for some toolbar icons in Dolphin
Summary: text alongside is gone for some toolbar icons in Dolphin
Status: RESOLVED NOT A BUG
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 262298 264422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-25 23:00 UTC by Andreas Kuhl
Modified: 2011-02-26 21:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
text alongside icons (32.91 KB, image/png)
2010-11-25 23:00 UTC, Andreas Kuhl
Details
text under icons (36.53 KB, image/png)
2010-11-25 23:01 UTC, Andreas Kuhl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kuhl 2010-11-25 23:00:40 UTC
Created attachment 53740 [details]
text alongside icons

Version:           unspecified (using KDE 4.5.80) 
OS:                Linux

When I select "text alongside icons" for toolbars in dolphin, the text besides some icons (navigation arrows and viewmode switchers) is gone. The missing text appears again with "text under icons" setting.

I attached a screenshot with text alongside icons and text under icons.

Reproducible: Always




OS: Linux (x86_64) release 2.6.35-2-desktop
Compiler: gcc
Comment 1 Andreas Kuhl 2010-11-25 23:01:00 UTC
Created attachment 53741 [details]
text under icons
Comment 2 Christoph Feck 2010-11-26 00:11:00 UTC
You can change that. Go to "Configure Toolbars...", select the action, then "Edit Text...". There is a checkbox that allows you to toggle visibility. I agree that the UI for that is not nice, but better than manually editing the rc file.
Comment 3 Andreas Kuhl 2010-11-26 08:31:09 UTC
Ok, you are right. Seems that this behaviour changed between KDE SC 4.5 and 4.6 beta 1. Unfortunally it is hidden und not quite obvious so that I have mistaken this for an bug, instead it's a feature! ;)
Comment 4 Peter Penz 2010-11-26 08:55:33 UTC
I think we'll need to improve the UI for 4.7, I guess that more users might complain about this. But let's wait for more feedback in the meantime...
Comment 5 Christoph Feck 2011-01-06 16:49:50 UTC
*** Bug 262298 has been marked as a duplicate of this bug. ***
Comment 6 Peter Penz 2011-01-27 11:00:34 UTC
*** Bug 264422 has been marked as a duplicate of this bug. ***
Comment 7 Peter Penz 2011-02-26 21:04:40 UTC
Git commit 6b7aeec96ffbb37aad0805c51654d1d70a3b4b04 by Peter Penz.
Committed on 26/02/2011 at 21:01.
Pushed by ppenz into branch 'master'.

Toolbar-buttons: Allow easier configuration of text-visibility

When "Text Alongside Icons" is selected it is possible already to configure for each toolbar-button whether the text should be shown. However the configuration setting is quite hidden under Configure Toolbars... -> Change Text... -> [x] "Hide text when toolbar shows text alongside icons" and some users where not aware about such a setting at all (see bug 257918 and duplicates).

The patch provides an additional entry in the context-menu that allows to switch the text-visibility of a button by one click.

CCBUG: 257918

M  +61   -4    kdeui/widgets/ktoolbar.cpp     
M  +1    -0    kdeui/widgets/ktoolbar.h     

http://commits.kde.org/kdelibs/6b7aeec96ffbb37aad0805c51654d1d70a3b4b04