Bug 255368 - knetworkmanager crashes when restarting the service from the command line
Summary: knetworkmanager crashes when restarting the service from the command line
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-27 03:49 UTC by Dan F. Monzon
Modified: 2010-11-08 23:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.26 KB, text/plain)
2010-11-02 00:11 UTC, Mathieu Jobin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan F. Monzon 2010-10-27 03:49:22 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
issued command: service network restart and application crashes at which point it asks if I would like to start it back up, I say ok and it starts again.  

The crash can be reproduced every time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0xb70f4e5d in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0xb70bd99b in ?? () from /usr/lib/libknmservice.so.4
#8  0xb70bdcd2 in ?? () from /usr/lib/libknmservice.so.4
#9  0xb70be795 in ?? () from /usr/lib/libknmservice.so.4
#10 0xb70be5f3 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0xb70ad1d4 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0xb70ad253 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0xb70b1748 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0xb70b0222 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
#15 0xb70b0b42 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider(ConnectionList*, ActivatableList*, Solid::Control::WirelessNetworkInterface*, QObject*) ()
   from /usr/lib/libknmservice.so.4
#16 0xb70add2e in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#17 0xb70a8b65 in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#18 0xb6e8befd in QMetaObject::metacall (object=0x815c080, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbf8e25d8) at kernel/qmetaobject.cpp:237
#19 0xb6e9afe8 in QMetaObject::activate (sender=0x8168bc8, m=0xb7051560, local_signal_index=1, argv=0xbf8e25d8) at kernel/qobject.cpp:3295
#20 0xb7032195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x8168bc8, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#21 0xb70327cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x8168bc8, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#22 0xb703284e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x8168bc8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf8e2738)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#23 0xb6e8befd in QMetaObject::metacall (object=0x8168bc8, cl=QMetaObject::InvokeMetaMethod, idx=10, argv=0xbf8e2738) at kernel/qmetaobject.cpp:237
#24 0xb6e9afe8 in QMetaObject::activate (sender=0x814ed00, m=0xb36e4618, local_signal_index=1, argv=0xbf8e2738) at kernel/qobject.cpp:3295
#25 0xb36ca135 in NMNetworkManager::networkInterfaceAdded (this=0x814ed00, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#26 0xb36cf72a in NMNetworkManager::deviceAdded (this=0x814ed00, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#27 0xb36d9f73 in NMNetworkManager::qt_metacall (this=0x814ed00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf8e28b8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#28 0xb6e8befd in QMetaObject::metacall (object=0x814ed00, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbf8e28b8) at kernel/qmetaobject.cpp:237
#29 0xb6e9afe8 in QMetaObject::activate (sender=0x80d5ba8, m=0xb36e4678, local_signal_index=0, argv=0xbf8e28b8) at kernel/qobject.cpp:3295
#30 0xb36cb745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x80d5ba8, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#31 0xb36d4b7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x80d5ba8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8e2aec)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#32 0xb6fc0a37 in QDBusConnectionPrivate::deliverCall (this=0x814e468, object=0x80d5ba8, msg=..., metaTypes=..., slotIdx=-1081204664) at qdbusintegrator.cpp:904
#33 0xb6fce536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x81db168, object=0x80d5ba8) at qdbusintegrator_p.h:101
#34 0xb6e9893f in QObject::event (this=0x80d5ba8, e=0x81db168) at kernel/qobject.cpp:1248
#35 0xb63dac64 in QApplicationPrivate::notify_helper (this=0x8095468, receiver=0x80d5ba8, e=0x81db168) at kernel/qapplication.cpp:4302
#36 0xb63e2bf7 in QApplication::notify (this=0xbf8e3350, receiver=0x80d5ba8, e=0x81db168) at kernel/qapplication.cpp:3706
#37 0xb734f9d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#38 0xb6e85e0e in QCoreApplication::notifyInternal (this=0xbf8e3350, receiver=0x80d5ba8, event=0x81db168) at kernel/qcoreapplication.cpp:726
#39 0xb6e899b4 in sendEvent (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8074e10) at kernel/qcoreapplication.cpp:1367
#41 0xb6e89b9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#42 0xb6eb183d in sendPostedEvents (s=0x8097910) at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x8097910) at kernel/qeventdispatcher_glib.cpp:276
#44 0xb5b79b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb5b7a350 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb5b7a60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb6eb1d4b in QEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#48 0xb648b19a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb6e8511d in QEventLoop::processEvents (this=0xbf8e32b4, flags=...) at kernel/qeventloop.cpp:149
#50 0xb6e85319 in QEventLoop::exec (this=0xbf8e32b4, flags=...) at kernel/qeventloop.cpp:201
#51 0xb6e89c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#52 0xb63d8164 in QApplication::exec () at kernel/qapplication.cpp:3581
#53 0x08053e59 in _start ()

This bug may be a duplicate of or related to bug 210878.

Possible duplicates by query: bug 254993, bug 254337, bug 253885, bug 250798, bug 249299.

Reported using DrKonqi
Comment 1 Mathieu Jobin 2010-11-02 00:11:45 UTC
Created attachment 53058 [details]
New crash information added by DrKonqi

knetworkmanager (v0.9) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:

I had to update these two files,

 /etc/NetworkManager/nm-system-settings.conf
 /var/lib/NetworkManager/NetworkManager.state

then, did

sudo restart network-manager

on kubuntu

and knetwork-manager crashed.

happens like 70% of the time....

-- Backtrace (Reduced):
#11 0x00337b52 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x00325c03 in ActivatableList::notifyOnAddActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x00326458 in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#14 0x0032abad in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#15 0x00329704 in WirelessNetworkInterfaceActivatableProvider::networkAppeared(QString const&) () from /usr/lib/libknmservice.so.4
Comment 2 Christoph Feck 2010-11-08 23:32:32 UTC

*** This bug has been marked as a duplicate of bug 210878 ***