Bug 255203 - PLasma crashing after nvidia driver update
Summary: PLasma crashing after nvidia driver update
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-25 13:09 UTC by mniasfreemag
Modified: 2010-10-25 19:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mniasfreemag 2010-10-25 13:09:04 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Updated Nvidia Driver to latest version from yast , relogged in and plasma crashes. happens every time.

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb592e710 (LWP 3582))]

Thread 2 (Thread 0xa9a81b70 (LWP 3588)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6cca452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6d4190c in wait (this=0x887bd6c, mutex=0x887bd68, time=30000) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x887bd6c, mutex=0x887bd68, time=30000) at thread/qwaitcondition_unix.cpp:160
#4  0xb6d36cd4 in QThreadPoolThread::run (this=0x883dec0) at concurrent/qthreadpool.cpp:140
#5  0xb6d4127a in QThreadPrivate::start (arg=0x883dec0) at thread/qthread_unix.cpp:266
#6  0xb326ac38 in ?? () from /usr/X11R6/lib/libGL.so.1

Thread 1 (Thread 0xb592e710 (LWP 3582)):
[KCrash Handler]
#7  0xb777610a in enter.8103 () from /lib/ld-linux.so.2
#8  0xb7776771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb7776b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb777845b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb777f82e in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb777b50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb777f2e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5da7bdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb777b50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5da8342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5da7ca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6e303e5 in QLibraryPrivate::load_sys (this=0x88fe850) at plugin/qlibrary_unix.cpp:205
#19 0xb6e2a864 in QLibraryPrivate::load (this=0x88fe850) at plugin/qlibrary.cpp:484
#20 0xb6e2a948 in QLibraryPrivate::loadPlugin (this=0x88fe850) at plugin/qlibrary.cpp:516
#21 0xb6e24883 in QPluginLoader::load (this=0xbffe550c) at plugin/qpluginloader.cpp:227
#22 0xb70f592f in KPluginLoader::load() () from /usr/lib/libkdecore.so.5
#23 0xb70f5df5 in KPluginLoader::KPluginLoader(KService const&, KComponentData const&, QObject*) () from /usr/lib/libkdecore.so.5
#24 0xb4e00a5a in Plasma::DataEngineManager::loadEngine (this=0x83b5218, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/dataenginemanager.cpp:137
#25 0xb4e37c55 in Plasma::DataEngineConsumer::dataEngine (this=0x82bcc30, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/private/dataengineconsumer.cpp:100
#26 0xb4dbcd97 in Plasma::Applet::dataEngine (this=0x83e5818, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:663
#27 0xa9c86f62 in ClockApplet::init() () from /usr/lib/libplasmaclock.so.4
#28 0xa9cc1a3e in ?? () from /usr/lib/kde4/plasma_applet_dig_clock.so
#29 0xb4de492f in Plasma::ContainmentPrivate::initApplets (this=0x81b1900) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:474
#30 0xb4df6e46 in Plasma::CoronaPrivate::importLayout (this=0x8135d08, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:525
#31 0xb4df7b95 in Plasma::Corona::loadLayout (this=0x812d590, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:460
#32 0xb4df7c74 in Plasma::Corona::initializeLayout (this=0x812d590, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:363
#33 0xb16f619a in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#34 0xb16f985e in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#35 0xb1702409 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#36 0xb6e4696d in QMetaObject::metacall (object=0x80da610, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x81722d8) at kernel/qmetaobject.cpp:237
#37 0xb6e51465 in QMetaCallEvent::placeMetaCall (this=0x81710d0, object=0x80da610) at kernel/qobject.cpp:534
#38 0xb6e5569f in QObject::event (this=0x80da610, e=0x81710d0) at kernel/qobject.cpp:1211
#39 0xb6e4071a in QCoreApplication::event (this=0x80da610, e=0x81710d0) at kernel/qcoreapplication.cpp:1561
#40 0xb63428dd in QApplication::event (this=0x80da610, e=0x81710d0) at kernel/qapplication.cpp:2439
#41 0xb63401a4 in QApplicationPrivate::notify_helper (this=0x80e08a8, receiver=0x80da610, e=0x81710d0) at kernel/qapplication.cpp:4396
#42 0xb6348dd7 in QApplication::notify (this=0x80da610, receiver=0x80da610, e=0x81710d0) at kernel/qapplication.cpp:3798
#43 0xb74869c1 in KApplication::notify (this=0x80da610, receiver=0x80da610, event=0x81710d0) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#44 0xb6e4012e in QCoreApplication::notifyInternal (this=0x80da610, receiver=0x80da610, event=0x81710d0) at kernel/qcoreapplication.cpp:732
#45 0xb6e43e6c in sendEvent (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.cpp:1373
#47 0xb6e43fbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#48 0xb6e6e6d4 in sendPostedEvents (s=0x80e2aa0) at kernel/qcoreapplication.h:220
#49 postEventSourceDispatch (s=0x80e2aa0) at kernel/qeventdispatcher_glib.cpp:277
#50 0xb5b7cb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0xb5b7d350 in ?? () from /usr/lib/libglib-2.0.so.0
#52 0xb5b7d60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0xb6e6e85b in QEventDispatcherGlib::processEvents (this=0x80e0258, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0xb63f519a in QGuiEventDispatcherGlib::processEvents (this=0x80e0258, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0xb6e3f40d in QEventLoop::processEvents (this=0xbffe6484, flags=...) at kernel/qeventloop.cpp:149
#56 0xb6e3f639 in QEventLoop::exec (this=0xbffe6484, flags=...) at kernel/qeventloop.cpp:201
#57 0xb6e44090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0xb633ded4 in QApplication::exec () at kernel/qapplication.cpp:3672
#59 0xb16ef06d in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#60 0x0804e441 in _start ()

This bug may be a duplicate of or related to bug 251719.

Possible duplicates by query: bug 255090, bug 255062, bug 251719.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-25 19:09:08 UTC

*** This bug has been marked as a duplicate of bug 251719 ***