Bug 255062 - Plasma crash with NVIDIA drivers
Summary: Plasma crash with NVIDIA drivers
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-23 21:15 UTC by mail.zausa.giulio
Modified: 2010-10-24 10:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (5.98 KB, text/plain)
2010-10-24 09:57 UTC, hs1718
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail.zausa.giulio 2010-10-23 21:15:31 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.4-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Plasma crash when started if you have an NVIDIA GT 200 Series driver.

The crash can be reproduced every time.

-- Backtrace:
Application: Spazio di lavoro di Plasma (kdeinit4), signal: Floating point exception
[Current thread is 1 (Thread 0xb5a71710 (LWP 11195))]

Thread 2 (Thread 0xa9c94b70 (LWP 11196)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6e12125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3905457 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb3a241a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb390549f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb3a241a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb33acc38 in ?? () from /usr/X11R6/lib/libGL.so.1

Thread 1 (Thread 0xb5a71710 (LWP 11195)):
[KCrash Handler]
#7  0xb78c910a in enter.8103 () from /lib/ld-linux.so.2
#8  0xb78c9771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb78c9b49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb78cb45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb78d282e in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb78ce50f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb78d22e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5eefbdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb78ce50f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5ef0342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5eefca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6f783e5 in QLibraryPrivate::load_sys (this=0x87fdd10) at plugin/qlibrary_unix.cpp:205
#19 0xb6f72864 in QLibraryPrivate::load (this=0x87fdd10) at plugin/qlibrary.cpp:484
#20 0xb6f72948 in QLibraryPrivate::loadPlugin (this=0x87fdd10) at plugin/qlibrary.cpp:516
#21 0xb6f6c883 in QPluginLoader::load (this=0xbfcb399c) at plugin/qpluginloader.cpp:227
#22 0xb723d92f in KPluginLoader::load (this=0xbfcb399c) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:222
#23 0xb723ddf5 in KPluginLoader::KPluginLoader (this=0xbfcb399c, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:180
#24 0xb4f42a5a in Plasma::DataEngineManager::loadEngine (this=0x86632b8, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/dataenginemanager.cpp:137
#25 0xb4f79c55 in Plasma::DataEngineConsumer::dataEngine (this=0x871c230, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/private/dataengineconsumer.cpp:100
#26 0xb4efed97 in Plasma::Applet::dataEngine (this=0x871b810, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:663
#27 0xa8bc9f62 in ClockApplet::init (this=0x871b810) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmaclock/clockapplet.cpp:570
#28 0xa8c0fa3e in Clock::init (this=0x871b810) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/generic/applets/digital-clock/clock.cpp:72
#29 0xb4f258dd in Plasma::Containment::addApplet (this=0x82b73a8, applet=0x871b810, pos=..., delayInit=false) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:996
#30 0xb4f25c62 in Plasma::ContainmentPrivate::addApplet (this=0x81f2528, name=..., args=..., appletGeometry=..., id=0, delayInit=false) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:2379
#31 0xb4f25f7a in Plasma::Containment::addApplet (this=0x82b73a8, name=..., args=..., appletGeometry=...) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:926
#32 0xb17231b2 in WorkspaceScripting::Containment::addWidget (context=0xa8f5c200, engine=0xbfcb4914) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/containment.cpp:207
#33 0xb397be5a in QScript::FunctionWrapper::proxyCall (exec=0xbfcb31a0, callee=0xa8f04f80, thisObject=..., args=...) at bridge/qscriptfunction.cpp:82
#34 0xb386e8e3 in QTJSC::NativeFuncWrapper::operator() (this=0xbfcb3f18, exec=0xa8f5c200, jsobj=0xa8f04f80, thisValue=..., argList=...)
    at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#35 0xb383a1d9 in QTJSC::cti_op_call_NotJSFunction (args=0xa938fd38) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1771
#36 0xa935e363 in ?? ()
#37 0xb37e175c in execute (this=0xa938e360, eval=0xa93a89d8, callFrame=0xa8f5c0a8, thisObj=0xa8f00000, globalRegisterOffset=31, scopeChain=0xa9388768, exception=0xbfcb40e0)
    at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITCode.h:79
#38 QTJSC::Interpreter::execute (this=0xa938e360, eval=0xa93a89d8, callFrame=0xa8f5c0a8, thisObj=0xa8f00000, globalRegisterOffset=31, scopeChain=0xa9388768, exception=0xbfcb40e0)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:886
#39 0xb37e1a35 in QTJSC::Interpreter::execute (this=0xa938e360, eval=0xa93a89d8, callFrame=0xa8f5c0a8, thisObj=0xa8f00000, scopeChain=0xa9388768, exception=0xbfcb40e0)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:803
#40 0xb394e8a6 in QScriptEnginePrivate::evaluateHelper (this=0x82c1138, exec=0xa8f5c0a8, sourceId=-1455913064, executable=0xa93a89d8, compile=@0xbfcb41af) at api/qscriptengine.cpp:1359
#41 0xb3955b39 in QScriptEngine::evaluate (this=0xa1c618f9, program=..., fileName=..., lineNumber=1) at api/qscriptengine.cpp:2606
#42 0xb171e28d in WorkspaceScripting::ScriptEngine::evaluateScript (this=0xbfcb4914, script=..., path=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:350
#43 0xb172a900 in WorkspaceScripting::ScriptEngine::loadTemplate (context=0xa8f5c0a8, engine=0xbfcb4914)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:304
#44 0xb397be5a in QScript::FunctionWrapper::proxyCall (exec=0xbfcb31a0, callee=0xa8f04200, thisObject=..., args=...) at bridge/qscriptfunction.cpp:82
#45 0xb386e8e3 in QTJSC::NativeFuncWrapper::operator() (this=0xbfcb4538, exec=0xa8f5c0a8, jsobj=0xa8f04200, thisValue=..., argList=...)
    at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#46 0xb383a1d9 in QTJSC::cti_op_call_NotJSFunction (args=0xa938fe28) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1771
#47 0xa935d844 in ?? ()
#48 0xb37e175c in execute (this=0xa938e360, eval=0xa93a0038, callFrame=0x8438fdc, thisObj=0xa8f00000, globalRegisterOffset=9, scopeChain=0xa93882b8, exception=0xbfcb4700)
    at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITCode.h:79
#49 QTJSC::Interpreter::execute (this=0xa938e360, eval=0xa93a0038, callFrame=0x8438fdc, thisObj=0xa8f00000, globalRegisterOffset=9, scopeChain=0xa93882b8, exception=0xbfcb4700)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:886
#50 0xb37e1a35 in QTJSC::Interpreter::execute (this=0xa938e360, eval=0xa93a0038, callFrame=0x8438fdc, thisObj=0xa8f00000, scopeChain=0xa93882b8, exception=0xbfcb4700)
    at ../3rdparty/javascriptcore/JavaScriptCore/interpreter/Interpreter.cpp:803
#51 0xb394e8a6 in QScriptEnginePrivate::evaluateHelper (this=0x82c1138, exec=0x8438fdc, sourceId=-1455912944, executable=0xa93a0038, compile=@0xbfcb47cf) at api/qscriptengine.cpp:1359
#52 0xb3955b39 in QScriptEngine::evaluate (this=0xa1c618f9, program=..., fileName=..., lineNumber=1) at api/qscriptengine.cpp:2606
#53 0xb171e28d in WorkspaceScripting::ScriptEngine::evaluateScript (this=0xbfcb4914, script=..., path=...)
    at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmagenericshell/scripting/scriptengine.cpp:350
#54 0xb1832f65 in DesktopCorona::evaluateScripts (this=0x815caf0, scripts=...) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/desktopcorona.cpp:320
#55 0xb18331f3 in DesktopCorona::loadDefaultLayout (this=0x815caf0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/desktopcorona.cpp:337
#56 0xb4f39ed3 in Plasma::Corona::initializeLayout (this=0x815caf0, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:366
#57 0xb183919a in PlasmaApp::corona (this=0x80d4588) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#58 0xb183c85e in PlasmaApp::setupDesktop (this=0x80d4588) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#59 0xb1845409 in PlasmaApp::qt_metacall (this=0x80d4588, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x8150d78)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#60 0xb6f8e96d in QMetaObject::metacall (object=0x80d4588, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0x8150d78) at kernel/qmetaobject.cpp:237
#61 0xb6f99465 in QMetaCallEvent::placeMetaCall (this=0x81528b8, object=0x80d4588) at kernel/qobject.cpp:534
#62 0xb6f9d69f in QObject::event (this=0x80d4588, e=0x81528b8) at kernel/qobject.cpp:1211
#63 0xb6f8871a in QCoreApplication::event (this=0x80d4588, e=0x81528b8) at kernel/qcoreapplication.cpp:1561
#64 0xb648a8dd in QApplication::event (this=0x80d4588, e=0x81528b8) at kernel/qapplication.cpp:2439
#65 0xb64881a4 in QApplicationPrivate::notify_helper (this=0x80ddf88, receiver=0x80d4588, e=0x81528b8) at kernel/qapplication.cpp:4396
#66 0xb6490dd7 in QApplication::notify (this=0x80d4588, receiver=0x80d4588, e=0x81528b8) at kernel/qapplication.cpp:3798
#67 0xb75ce9c1 in KApplication::notify (this=0x80d4588, receiver=0x80d4588, event=0x81528b8) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#68 0xb6f8812e in QCoreApplication::notifyInternal (this=0x80d4588, receiver=0x80d4588, event=0x81528b8) at kernel/qcoreapplication.cpp:732
#69 0xb6f8be6c in sendEvent (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80572a0) at kernel/qcoreapplication.cpp:1373
#71 0xb6f8bfbc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#72 0xb6fb66d4 in sendPostedEvents (s=0x80e0bb8) at kernel/qcoreapplication.h:220
#73 postEventSourceDispatch (s=0x80e0bb8) at kernel/qeventdispatcher_glib.cpp:277
#74 0xb5cc4b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#75 0xb5cc5350 in ?? () from /usr/lib/libglib-2.0.so.0
#76 0xb5cc560e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#77 0xb6fb685b in QEventDispatcherGlib::processEvents (this=0x80da7d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#78 0xb653d19a in QGuiEventDispatcherGlib::processEvents (this=0x80da7d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#79 0xb6f8740d in QEventLoop::processEvents (this=0xbfcb5474, flags=...) at kernel/qeventloop.cpp:149
#80 0xb6f87639 in QEventLoop::exec (this=0xbfcb5474, flags=...) at kernel/qeventloop.cpp:201
#81 0xb6f8c090 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#82 0xb6485ed4 in QApplication::exec () at kernel/qapplication.cpp:3672
#83 0xb183206d in kdemain (argc=1, argv=0x80d2898) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#84 0x0804e441 in _start ()

This bug may be a duplicate of or related to bug 251719.

Possible duplicates by query: bug 251719.

Reported using DrKonqi
Comment 1 hs1718 2010-10-24 09:57:01 UTC
Created attachment 52816 [details]
New crash information added by DrKonqi

plasma-desktop (0.3) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

Floitingpoint-Exception when starting KDE after updating

-- Backtrace (Reduced):
#7  0xb783d10a in enter.8103 () from /lib/ld-linux.so.2
#8  0xb783d771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb783db49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb783f45b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb784682e in dl_open_worker () from /lib/ld-linux.so.2
Comment 2 Beat Wolf 2010-10-24 10:34:17 UTC

*** This bug has been marked as a duplicate of bug 251719 ***