Bug 255090 - Plasma crash after login
Summary: Plasma crash after login
Status: RESOLVED DUPLICATE of bug 251719
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-24 09:55 UTC by i.kneup
Modified: 2010-10-26 13:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description i.kneup 2010-10-24 09:55:08 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2) "release 10"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.4-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
Plasma crashes immediately after the login screen

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma-Arbeitsfläche (kdeinit4), signal: Floating point exception
[KCrash Handler]
#7  0xb77ae10a in enter.8103 () from /lib/ld-linux.so.2
#8  0xb77ae771 in do_lookup_x () from /lib/ld-linux.so.2
#9  0xb77aeb49 in _dl_lookup_symbol_x () from /lib/ld-linux.so.2
#10 0xb77b045b in _dl_relocate_object () from /lib/ld-linux.so.2
#11 0xb77b782e in dl_open_worker () from /lib/ld-linux.so.2
#12 0xb77b350f in _dl_catch_error () from /lib/ld-linux.so.2
#13 0xb77b72e6 in _dl_open () from /lib/ld-linux.so.2
#14 0xb5e4dbdd in dlopen_doit () from /lib/libdl.so.2
#15 0xb77b350f in _dl_catch_error () from /lib/ld-linux.so.2
#16 0xb5e4e342 in _dlerror_run () from /lib/libdl.so.2
#17 0xb5e4dca7 in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#18 0xb6e8a469 in QLibraryPrivate::load_sys (this=0x85da5e0) at plugin/qlibrary_unix.cpp:205
#19 0xb6e849c4 in QLibraryPrivate::load (this=0x85da5e0) at plugin/qlibrary.cpp:484
#20 0xb6e84aa8 in QLibraryPrivate::loadPlugin (this=0x85da5e0) at plugin/qlibrary.cpp:516
#21 0xb6e7f223 in QPluginLoader::load (this=0xbfd53d4c) at plugin/qpluginloader.cpp:227
#22 0xb713136f in KPluginLoader::load (this=0xbfd53d4c) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:222
#23 0xb7131835 in KPluginLoader::KPluginLoader (this=0xbfd53d4c, service=..., componentdata=..., parent=0x0) at /usr/src/debug/kdelibs-4.5.2/kdecore/util/kpluginloader.cpp:180
#24 0xb4ead04a in Plasma::DataEngineManager::loadEngine (this=0x82fa398, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/dataenginemanager.cpp:137
#25 0xb4ee3b65 in Plasma::DataEngineConsumer::dataEngine (this=0x8253cf8, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/private/dataengineconsumer.cpp:100
#26 0xb4e6b957 in Plasma::Applet::dataEngine (this=0x822f0f8, name=...) at /usr/src/debug/kdelibs-4.5.2/plasma/applet.cpp:663
#27 0xa9860c12 in ClockApplet::init (this=0x822f0f8) at /usr/src/debug/kdebase-workspace-4.5.2/libs/plasmaclock/clockapplet.cpp:570
#28 0xa9940a3e in Clock::init (this=0x822f0f8) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/generic/applets/digital-clock/clock.cpp:72
#29 0xb4e8ef2f in Plasma::ContainmentPrivate::initApplets (this=0x8217c38) at /usr/src/debug/kdelibs-4.5.2/plasma/containment.cpp:474
#30 0xb4ea3ef6 in Plasma::CoronaPrivate::importLayout (this=0x812df40, conf=..., mergeConfig=false) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:525
#31 0xb4ea4c45 in Plasma::Corona::loadLayout (this=0x811d000, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:460
#32 0xb4ea4d24 in Plasma::Corona::initializeLayout (this=0x811d000, configName=...) at /usr/src/debug/kdelibs-4.5.2/plasma/corona.cpp:363
#33 0xb16b7f52 in PlasmaApp::corona (this=0x80e0f78) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:806
#34 0xb16b88de in PlasmaApp::setupDesktop (this=0x80e0f78) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/plasmaapp.cpp:286
#35 0xb16c28c9 in PlasmaApp::qt_metacall (this=0x80e0f78, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0xbfd5452c)
    at /usr/src/debug/kdebase-workspace-4.5.2/build/plasma/desktop/shell/plasmaapp.moc:149
#36 0xb6e9fefd in QMetaObject::metacall (object=0x80e0f78, cl=QMetaObject::InvokeMetaMethod, idx=42, argv=0xbfd5452c) at kernel/qmetaobject.cpp:237
#37 0xb6eaefe8 in QMetaObject::activate (sender=0x816dc58, m=0xb6fb5188, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#38 0xb6eb49d5 in QSingleShotTimer::timeout (this=0x816dc58) at .moc/release-shared/qtimer.moc:82
#39 0xb6eb4a8c in QSingleShotTimer::timerEvent (this=0x816dc58) at kernel/qtimer.cpp:308
#40 0xb6eac774 in QObject::event (this=0x816dc58, e=0xbfd54a60) at kernel/qobject.cpp:1212
#41 0xb63d2c64 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#42 0xb63dabf7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#43 0xb74b8941 in KApplication::notify (this=0x80e0f78, receiver=0x816dc58, event=0xbfd54a60) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#44 0xb6e99e0e in QCoreApplication::notifyInternal (this=0x80e0f78, receiver=0x816dc58, event=0xbfd54a60) at kernel/qcoreapplication.cpp:726
#45 0xb6ec870e in sendEvent (this=0x80eaa84) at kernel/qcoreapplication.h:215
#46 QTimerInfoList::activateTimers (this=0x80eaa84) at kernel/qeventdispatcher_unix.cpp:618
#47 0xb6ec5642 in timerSourceDispatch (source=0x80eaa50) at kernel/qeventdispatcher_glib.cpp:184
#48 0xb5c20b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#49 0xb5c21350 in ?? () from /usr/lib/libglib-2.0.so.0
#50 0xb5c2160e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#51 0xb6ec5d4b in QEventDispatcherGlib::processEvents (this=0x80e7980, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#52 0xb648319a in ?? () from /usr/lib/libQtGui.so.4
#53 0xb6e9911d in QEventLoop::processEvents (this=0xbfd54d24, flags=...) at kernel/qeventloop.cpp:149
#54 0xb6e99319 in QEventLoop::exec (this=0xbfd54d24, flags=...) at kernel/qeventloop.cpp:201
#55 0xb6e9dc70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#56 0xb63d0164 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#57 0xb16ab5ed in kdemain (argc=1, argv=0x80e1cf0) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#58 0x0804e3f1 in _start ()

This bug may be a duplicate of or related to bug 251719.

Possible duplicates by query: bug 255062, bug 251719.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-10-24 11:52:29 UTC

*** This bug has been marked as a duplicate of bug 251719 ***
Comment 2 Sandipan Mohanty 2010-10-25 14:34:55 UTC
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 251719 ***

I confirm the crash reported in 255090. The crash happens also for a newly created user, and also when I start KDE through an NX session. The bug 251719 seems to involve the 269.19.06 beta driver from NVidia, which I don't have. The details, including the backtrace, are as in the original post by  i.kneup@gmx.de. What can I do to help trace the bug ?
Comment 3 Sandipan Mohanty 2010-10-26 13:49:14 UTC
Another piece of possibly useful information: plasma runs without problems if one deletes the digital clock from the configuration files in .kde4/share/config, using a text editor. I removed references to digital-clock in plasmarc, plasma-desktoprc and plasma-desktop-appletrc. So, the temporary work around mentioned with bug 251719 works for me after all.

(In reply to comment #2)
> (In reply to comment #1)
> > 
> > *** This bug has been marked as a duplicate of bug 251719 ***
> 
> I confirm the crash reported in 255090. The crash happens also for a newly
> created user, and also when I start KDE through an NX session. The bug 251719
> seems to involve the 269.19.06 beta driver from NVidia, which I don't have. The
> details, including the backtrace, are as in the original post by 
> i.kneup@gmx.de. What can I do to help trace the bug ?