Bug 254984 - Entering new payee in ledger doesn't work when payee with same first characters already exists
Summary: Entering new payee in ledger doesn't work when payee with same first characte...
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: 4.5
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 257039 258063 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-22 19:44 UTC by Markus
Modified: 2011-07-06 08:55 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus 2010-10-22 19:44:38 UTC
Version:           4.5 (using KDE 4.5.1) 
OS:                Linux

When editing a payment in the ledger I cannot enter a new (not existing) payee, if there is already any existing payee with same first characters. Example: there exists an payee "Lebensmittel". I cannot enter "Leben". The autocompletion feature always choose "Lebensmittel", even if I close the popup result list.

Reproducible: Always

Steps to Reproduce:
Enter a new (not existing) payee with the first characters of any existing payee.

Actual Results:  
KMM always selects the first existing payee, it's impossible to create a new one in the ledgers editor mode, when the first characters are the same as an existing payee

Expected Results:  
If I close the autocompletion window, kmm should accept the new payee name and should create a new one.
Comment 1 Thomas Baumgart 2010-10-23 18:51:49 UTC
A quick workaround would be to add a few spaces so that the new name does not match an existing one. Those blanks (as of now) have to be removed manually from the payee's name in the payee view afterwards.
Comment 2 Jack 2010-10-23 23:02:08 UTC
Enter the new payee and click the mouse in the next field you want to enter.  If the dropdown is in the way, hit ESC.  I just tried this and it offered to add the new payee.  Maybe it can't be done with the keyboard alone, but with the mouse, it seems it is possible.
Comment 3 Cristian Oneț 2010-10-28 20:01:27 UTC
Since this bug is a result of implementing BUG 235618 I'm changing this into a wish with the following description.
It would be nice if the KMyMoney editable combo would allow adding items by changing 
setInsertPolicy(QComboBox::NoInsert);
into 
setInsertPolicy(QComboBox::InsertAlphabetically);
while correctly handling object creation.
Comment 4 Cristian Oneț 2010-10-28 20:02:46 UTC
And I forgot to add that until then the simple workaround posted by Jack is there to create a payee which is a substring of another payee.
Comment 5 Alvaro Soliverez 2010-11-27 13:12:16 UTC
*** Bug 258063 has been marked as a duplicate of this bug. ***
Comment 6 John Wheaton 2010-11-27 13:42:14 UTC
I would like to petition for an upgrade from "wishlist" status.  While this isn't critical-path functionality, it is highly annoying when entering a lot of information.
Comment 7 Thomas Baumgart 2010-11-27 16:30:47 UTC
*** Bug 257039 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Baumgart 2011-07-06 08:55:19 UTC
SVN commit 1239969 by tbaumgart:

Only copy the complete text from the completion box to the edit widget if the completion box is visible.

BUG: 254984

 M  +4 -2      kmymoneymvccombo.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1239969