Bug 258063 - When Payee is a substring of another payee, the wrong Payee is used
Summary: When Payee is a substring of another payee, the wrong Payee is used
Status: RESOLVED DUPLICATE of bug 254984
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: 4.5
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 12:48 UTC by John Wheaton
Modified: 2010-11-27 13:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Wheaton 2010-11-27 12:48:51 UTC
Version:           4.5 (using KDE 4.5.3) 
OS:                Linux

KMyMoney version:  4.5.1
^^^ need to update selection in Bugzilla, btw.

This is hard to explain in a summary.

I have the following payees:
THE HOME DEPOT #2623
THE HOME DEPOT 2623
The Home Depot

I have progressively been weeding out duplicates from my original Quicken import (a while ago).  This is one I apparently didn't get to.

What I want to use is "The Home Depot".  If I type that in, press 'enter' or 'tab' to move another field, all looks well.  When I press 'enter' to commit the entry, it changes to the first matching entry "THE HOME DEPOT #2623".

I have to actually click on what I want with the mouse.  That may seem petty, but when one is trying to cruise through a stack of entries, having to use the mouse for only this is very annoying... and it just should work that way anyway.



Reproducible: Always




OS: Linux (x86_64) release 2.6.32-25-generic
Compiler: cc
Comment 1 Alvaro Soliverez 2010-11-27 13:12:16 UTC

*** This bug has been marked as a duplicate of bug 254984 ***