Bug 257039 - In Ledger Payee field, first payee is always selected if shorter name existing is selected.
Summary: In Ledger Payee field, first payee is always selected if shorter name existin...
Status: RESOLVED DUPLICATE of bug 254984
Alias: None
Product: kmymoney
Classification: Applications
Component: general (show other bugs)
Version: 4.5
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-16 05:32 UTC by thatonefilmguy
Modified: 2010-11-27 16:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thatonefilmguy 2010-11-16 05:32:14 UTC
Version:           4.5 (using KDE 4.5.1) 
OS:                Linux

After typing a few characters and then selecting a payee from a dropdown list, if the selected payee name also matches other (longer) payee names, then the first payee name in the list will be selected, regardless of the shorter name being highlighted in the list.

For example, if I type "ExxonMobil" a list like the following is displayed:

EXXONMOBIL 10005122
EXXONMOBIL 13104895
EXXONMOBIL 14425098
ExxonMobil

Now first, by typing 'ExxonMobil' fully, it does not require a new payee to be created because one already exists so this is not the same as Bug 254984.  However, if I press Tab or Enter after typing the full name, or even if I scroll down to the 'ExxonMobil' entry in the list and then press Enter or Tab, it will instead fill the field with the first entry in the list, "EXXONMOBIL 10005122".

This is a fairly common problem because for many payees there end up being multiple entries in the Payee list of a similar name for essentially the same company because I do not always change the payee to the desired one after downloading a whole load of transactions from the web.

One workaround is to click the desired payee instead of using the keyboard, but this is extremely annoying when trying to get through a lot of transactions and having to use the mouse every time to select the desired payee from the list without using the keyboard.

I suspect this is the result of the fix for Bug 235618

Reproducible: Always

Steps to Reproduce:
1. Create a payee named 'ExxonMobil'
2. Create one or more longer named payees which also match the first payee name, such as 'EXXONMOBIL 10005122'
3. In Ledger view, create a new withdrawal transaction. In the Pay To field, type 'ExxonMobil'.
4. The autocomplete list will populate with payees created in steps 1 & 2.
5. Click [Tab].
6. The field will match the first 'EXXONMOBIL 10005122' entry instead of 'ExxonMobil', even though it matches the latter exactly.
7. Return to the Pay To field, clear it and then begin to type 'Exxon' again.
8. Using the arrow keys, scroll down to the 'ExxonMobil' entry and press [Tab] or [Enter].
9. The cursor will move to the next field; however, the 'EXXONMOBIL 10005122' payee will be automatically selected even though 'ExxonMobil' was explicitly selected in the dropdown list.

Actual Results:  
The incorrect payee is selected rather than the explicitly selected one, or the one which matches the text entered in the Pay To field exactly.

Expected Results:  
1. Match the payee from the list which is identical to the text entered in the pay to field first rather than automatching an entry which is not identical.
2. Use the selected payee from the list, do not try to autocomplete the payee name after the user explicitly selects one from the list.

OS: Linux (i686) release 2.6.35-22-generic
Compiler: cc
Comment 1 Thomas Baumgart 2010-11-27 16:30:47 UTC

*** This bug has been marked as a duplicate of bug 254984 ***