Bug 251440 - run command crash
Summary: run command crash
Status: RESOLVED DUPLICATE of bug 241531
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-16 13:43 UTC by mr.kryptos
Modified: 2010-09-27 14:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mr.kryptos 2010-09-16 13:43:24 UTC
Application: krunner (0.1)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.6-54.fc13.x86_64 x86_64

-- Information about the crash:
after opening the run terminal with ALT+F2, i typed  su-c 'mount /dev/sda2 /media/Files' and clicked the run command at the top of the list. this caused the crash.

 -- Backtrace:
Application: Run Command Interface (krunner), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f1188ae4820 (LWP 1965))]

Thread 5 (Thread 0x7f11713d0710 (LWP 2828)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003e7b87212b in wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003e79009f96 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10dd050, th=0x1374920) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003e7900c4bb in ThreadWeaver::WorkingHardState::applyForWork (this=0x10896f0, th=0x1374920) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003e7900ae7f in ThreadWeaver::ThreadRunHelper::run (this=0x7f11713cfd40, parent=0x10dd050, th=0x1374920) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003e7900b368 in ThreadWeaver::Thread::run (this=0x1374920) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003e7b8711a5 in QThreadPrivate::start (arg=0x1374920) at thread/qthread_unix.cpp:248
#8  0x0000003ddee07761 in start_thread (arg=0x7f11713d0710) at pthread_create.c:301
#9  0x0000003dde6e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f116bfff710 (LWP 2829)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003e7b87212b in wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003e79009f96 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10dd050, th=0x13aa410) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003e7900c4bb in ThreadWeaver::WorkingHardState::applyForWork (this=0x10896f0, th=0x13aa410) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003e7900ae7f in ThreadWeaver::ThreadRunHelper::run (this=0x7f116bffed40, parent=0x10dd050, th=0x13aa410) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003e7900b368 in ThreadWeaver::Thread::run (this=0x13aa410) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003e7b8711a5 in QThreadPrivate::start (arg=0x13aa410) at thread/qthread_unix.cpp:248
#8  0x0000003ddee07761 in start_thread (arg=0x7f116bfff710) at pthread_create.c:301
#9  0x0000003dde6e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f116b5fe710 (LWP 2830)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003e7b87212b in wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003e79009f96 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10dd050, th=0x10778b0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003e7900c4bb in ThreadWeaver::WorkingHardState::applyForWork (this=0x10896f0, th=0x10778b0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003e7900ae7f in ThreadWeaver::ThreadRunHelper::run (this=0x7f116b5fdd40, parent=0x10dd050, th=0x10778b0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003e7900b368 in ThreadWeaver::Thread::run (this=0x10778b0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003e7b8711a5 in QThreadPrivate::start (arg=0x10778b0) at thread/qthread_unix.cpp:248
#8  0x0000003ddee07761 in start_thread (arg=0x7f116b5fe710) at pthread_create.c:301
#9  0x0000003dde6e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f116abfd710 (LWP 2831)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003e7b87212b in wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1099980, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003e79009f96 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x10dd050, th=0x1271ce0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x0000003e7900c4bb in ThreadWeaver::WorkingHardState::applyForWork (this=0x10896f0, th=0x1271ce0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x0000003e7900ae7f in ThreadWeaver::ThreadRunHelper::run (this=0x7f116abfcd40, parent=0x10dd050, th=0x1271ce0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:87
#6  0x0000003e7900b368 in ThreadWeaver::Thread::run (this=0x1271ce0) at /usr/src/debug/kdelibs-4.4.5/threadweaver/Weaver/Thread.cpp:142
#7  0x0000003e7b8711a5 in QThreadPrivate::start (arg=0x1271ce0) at thread/qthread_unix.cpp:248
#8  0x0000003ddee07761 in start_thread (arg=0x7f116abfd710) at pthread_create.c:301
#9  0x0000003dde6e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f1188ae4820 (LWP 1965)):
[KCrash Handler]
#5  ref (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qatomic_x86_64.h:121
#6  QString (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qstring.h:715
#7  KRun::runCommand (cmd=..., window=0x0, workingDirectory=...) at /usr/src/debug/kdelibs-4.4.5/kio/kio/krun.cpp:1019
#8  0x0000003e7ff60da0 in KRun::runCommand (cmd=<value optimized out>, window=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kio/kio/krun.cpp:1010
#9  0x00007f117221e1d5 in ShellRunner::run (this=0x1351500, context=..., match=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.4.5/plasma/generic/runners/shell/shellrunner.cpp:86
#10 0x0000003e789853c5 in Plasma::RunnerContext::run (this=0x108f8c0, match=...) at /usr/src/debug/kdelibs-4.4.5/plasma/runnercontext.cpp:544
#11 0x0000003e78988bc9 in Plasma::RunnerManager::run (this=0xf4d920, match=...) at /usr/src/debug/kdelibs-4.4.5/plasma/runnermanager.cpp:528
#12 0x0000003df602d756 in Interface::run (this=0x10a9020, item=0x1458c90) at /usr/src/debug/kdebase-workspace-4.4.5/krunner/interfaces/default/interface.cpp:523
#13 0x0000003df602dd74 in Interface::qt_metacall (this=0x10a9020, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8e6b3f90)
    at /usr/src/debug/kdebase-workspace-4.4.5/x86_64-redhat-linux-gnu/krunner/interface.moc:105
#14 0x0000003e7b966a36 in QMetaObject::activate (sender=0x10dfdc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#15 0x0000003e826ab848 in KComboBox::qt_metacall (this=0x10dfdc0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff8e6b40e0)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kdeui/kcombobox.moc:111
#16 0x0000003e826bbe00 in KHistoryComboBox::qt_metacall (this=0x10dfdc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8e6b40e0)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kdeui/khistorycombobox.moc:83
#17 0x0000003e7b966a36 in QMetaObject::activate (sender=0x10fe8b0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#18 0x0000003e7dd822f8 in QLineEdit::qt_metacall (this=0x10fe8b0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff8e6b42b0) at .moc/release-shared/moc_qlineedit.cpp:159
#19 0x0000003e826caaa5 in KLineEdit::qt_metacall (this=0x10fe8b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8e6b42b0)
    at /usr/src/debug/kdelibs-4.4.5/x86_64-redhat-linux-gnu/kdeui/klineedit.moc:134
#20 0x0000003e7b966a36 in QMetaObject::activate (sender=0x1112680, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3295
#21 0x0000003e7dd89bcc in QLineControl::processKeyEvent (this=0x1112680, event=0x7fff8e6b5410) at widgets/qlinecontrol.cpp:1528
#22 0x0000003e7dd7f2f1 in QLineEdit::keyPressEvent (this=<value optimized out>, event=0x7fff8e6b5410) at widgets/qlineedit.cpp:1667
#23 0x0000003e826c6c7d in KLineEdit::keyPressEvent (this=0x10fe8b0, e=0x7fff8e6b5410) at /usr/src/debug/kdelibs-4.4.5/kdeui/widgets/klineedit.cpp:1025
#24 0x0000003e7d9f6136 in QWidget::event (this=0x10fe8b0, event=0x7fff8e6b5410) at kernel/qwidget.cpp:8079
#25 0x0000003e7dd80441 in QLineEdit::event (this=0x10fe8b0, e=0x7fff8e6b5410) at widgets/qlineedit.cpp:1480
#26 0x0000003e826c8617 in KLineEdit::event (this=0x10fe8b0, ev=0x7fff8e6b5410) at /usr/src/debug/kdelibs-4.4.5/kdeui/widgets/klineedit.cpp:1329
#27 0x0000003e7dd4b6fd in QComboBox::keyPressEvent (this=0x10dfdc0, e=0x7fff8e6b5410) at widgets/qcombobox.cpp:3000
#28 0x0000003e826bbb84 in KHistoryComboBox::keyPressEvent (this=0x10dfdc0, e=<value optimized out>) at /usr/src/debug/kdelibs-4.4.5/kdeui/widgets/khistorycombobox.cpp:344
#29 0x0000003e7d9f6136 in QWidget::event (this=0x10dfdc0, event=0x7fff8e6b5410) at kernel/qwidget.cpp:8079
#30 0x0000003e7d9ab39c in QApplicationPrivate::notify_helper (this=0xf3afe0, receiver=0x10dfdc0, e=0x7fff8e6b5410) at kernel/qapplication.cpp:4306
#31 0x0000003e7d9b2e13 in QApplication::notify (this=<value optimized out>, receiver=0x10dfdc0, e=0x7fff8e6b5410) at kernel/qapplication.cpp:3769
#32 0x0000003e82607016 in KApplication::notify (this=0xf32630, receiver=0x10dfdc0, event=0x7fff8e6b5410) at /usr/src/debug/kdelibs-4.4.5/kdeui/kernel/kapplication.cpp:302
#33 0x0000003e7b953ddc in QCoreApplication::notifyInternal (this=0xf32630, receiver=0x10dfdc0, event=0x7fff8e6b5410) at kernel/qcoreapplication.cpp:726
#34 0x0000003e7da455ea in QKeyMapper::sendKeyEvent (keyWidget=0x10dfdc0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777220, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=36, nativeVirtualKey=65293, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1875
#35 0x0000003e7da47a20 in QKeyMapperPrivate::translateKeyEvent (this=<value optimized out>, keyWidget=0x10dfdc0, event=<value optimized out>, grab=false) at kernel/qkeymapper_x11.cpp:1845
#36 0x0000003e7da21b24 in QApplication::x11ProcessEvent (this=0xf32630, event=0x7fff8e6b5fe0) at kernel/qapplication_x11.cpp:3406
#37 0x0000003e7da4ab92 in x11EventSourceDispatch (s=0xf3ebe0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x0000003de063bd02 in g_main_dispatch (context=0xf3d520) at gmain.c:1960
#39 IA__g_main_context_dispatch (context=0xf3d520) at gmain.c:2513
#40 0x0000003de063fae8 in g_main_context_iterate (context=0xf3d520, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#41 0x0000003de063fc9c in IA__g_main_context_iteration (context=0xf3d520, may_block=1) at gmain.c:2654
#42 0x0000003e7b979863 in QEventDispatcherGlib::processEvents (this=0xf0fa60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#43 0x0000003e7da4a84e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x0000003e7b952822 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x0000003e7b952aec in QEventLoop::exec (this=0x7fff8e6b6310, flags=...) at kernel/qeventloop.cpp:201
#46 0x0000003e7b9561bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#47 0x0000003df602a3b4 in kdemain (argc=1, argv=0x7fff8e6b65e8) at /usr/src/debug/kdebase-workspace-4.4.5/krunner/main.cpp:65
#48 0x0000003dde61ec5d in __libc_start_main (main=0x4008d0 <main(int, char**)>, argc=1, ubp_av=0x7fff8e6b65e8, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff8e6b65d8) at libc-start.c:226
#49 0x0000000000400809 in _start ()

This bug may be a duplicate of or related to bug 241531.

Possible duplicates by query: bug 248525, bug 248414, bug 243835, bug 241531.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-09-27 14:17:16 UTC

*** This bug has been marked as a duplicate of bug 241531 ***