Bug 248525 - Krunner crashed while typing "kdesu konqueror /"
Summary: Krunner crashed while typing "kdesu konqueror /"
Status: RESOLVED DUPLICATE of bug 241531
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-20 16:12 UTC by Shekhar
Modified: 2010-08-20 18:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shekhar 2010-08-20 16:12:06 UTC
Application: krunner (0.1)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
It happens sometimes, but due to different reasons. I was typing "kdesu konqueror /" and it showed me the previously entered entry for that command, so in order to auto complete, I pressed the right arrow key to the end and pressed enter, but it did nothing , and was unresponsive. After sometime, it crashed and the crash handler asked me for bug report.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Run Command Interface (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb54f5710 (LWP 2530))]

Thread 5 (Thread 0xa785fb70 (LWP 4497)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6aed125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6b62710 in wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f0124a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81d13a0, th=0x81e0070) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f04307 in waitForAvailableJob (this=0x81c1d58, th=0x81e0070) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x81c1d58, th=0x81e0070) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f00b43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81d13a0, th=0x81e0070, previous=0x8220dc0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f01744 in ThreadWeaver::ThreadRunHelper::run (this=0xa785f314, parent=0x81d13a0, th=0x81e0070) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f017fa in ThreadWeaver::Thread::run (this=0x81e0070) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6b6204f in QThreadPrivate::start (arg=0x81e0070) at thread/qthread_unix.cpp:248
#11 0xb6ae8b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5ed546e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa6f9fb70 (LWP 4498)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6aed125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6b62710 in wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f0124a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81d13a0, th=0x8122648) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f04307 in waitForAvailableJob (this=0x81c1d58, th=0x8122648) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x81c1d58, th=0x8122648) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f00b43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81d13a0, th=0x8122648, previous=0x81d3f48) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f01744 in ThreadWeaver::ThreadRunHelper::run (this=0xa6f9f314, parent=0x81d13a0, th=0x8122648) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f017fa in ThreadWeaver::Thread::run (this=0x8122648) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6b6204f in QThreadPrivate::start (arg=0x8122648) at thread/qthread_unix.cpp:248
#11 0xb6ae8b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5ed546e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa679eb70 (LWP 4499)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6aed125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6b62710 in wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f0124a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81d13a0, th=0x8264408) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f04307 in waitForAvailableJob (this=0x81c1d58, th=0x8264408) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x81c1d58, th=0x8264408) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f00b43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81d13a0, th=0x8264408, previous=0x827dd80) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f01744 in ThreadWeaver::ThreadRunHelper::run (this=0xa679e314, parent=0x81d13a0, th=0x8264408) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f017fa in ThreadWeaver::Thread::run (this=0x8264408) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6b6204f in QThreadPrivate::start (arg=0x8264408) at thread/qthread_unix.cpp:248
#11 0xb6ae8b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5ed546e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa5f9db70 (LWP 4500)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6aed125 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6b62710 in wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x81d13b8, mutex=0x81c1570, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0xb3f0124a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x81d13a0, th=0x8185db0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb3f04307 in waitForAvailableJob (this=0x81c1d58, th=0x8185db0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x81c1d58, th=0x8185db0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3f00b43 in ThreadWeaver::WeaverImpl::applyForWork (this=0x81d13a0, th=0x8185db0, previous=0x827aae0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb3f01744 in ThreadWeaver::ThreadRunHelper::run (this=0xa5f9d314, parent=0x81d13a0, th=0x8185db0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:87
#9  0xb3f017fa in ThreadWeaver::Thread::run (this=0x8185db0) at /usr/src/debug/kdelibs-4.4.4/threadweaver/Weaver/Thread.cpp:142
#10 0xb6b6204f in QThreadPrivate::start (arg=0x8185db0) at thread/qthread_unix.cpp:248
#11 0xb6ae8b25 in start_thread () from /lib/libpthread.so.0
#12 0xb5ed546e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb54f5710 (LWP 2530)):
[KCrash Handler]
#6  ref (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (cmd=..., window=0x0, workingDirectory=...) at /usr/include/QtCore/qstring.h:715
#8  KRun::runCommand (cmd=..., window=0x0, workingDirectory=...) at /usr/src/debug/kdelibs-4.4.4/kio/kio/krun.cpp:1022
#9  0xb722f966 in KRun::runCommand (cmd=..., window=0x0) at /usr/src/debug/kdelibs-4.4.4/kio/kio/krun.cpp:1013
#10 0xa705a243 in ShellRunner::run (this=0x8282c48, context=..., match=...) at /usr/src/debug/kdebase-workspace-4.4.4/plasma/generic/runners/shell/shellrunner.cpp:86
#11 0xb523b5df in Plasma::QueryMatch::run (this=0x8257ff0, context=...) at /usr/src/debug/kdelibs-4.4.4/plasma/querymatch.cpp:224
#12 0xb5247837 in Plasma::RunnerContext::run (this=0x8111dd0, match=...) at /usr/src/debug/kdelibs-4.4.4/plasma/runnercontext.cpp:544
#13 0xb524adc4 in Plasma::RunnerManager::run (this=0x8111c88, match=...) at /usr/src/debug/kdelibs-4.4.4/plasma/runnermanager.cpp:528
#14 0xb33d461d in run (this=0x8296380, item=0x8257fd8) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/resultitem.cpp:308
#15 ResultScene::run (this=0x8296380, item=0x8257fd8) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/resultscene.cpp:423
#16 0xb33d46e1 in Interface::run (this=0x81ed0e8, item=0x8257fd8) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/interface.cpp:523
#17 0xb33d4a6c in Interface::runDefaultResultItem (this=0x81ed0e8) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/interface.cpp:543
#18 0xb33e27b8 in Interface::matchCountChanged (this=0x81ed0e8, count=1) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/interface.cpp:581
#19 0xb33e7e35 in Interface::qt_metacall (this=0x81ed0e8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf910ad8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/krunner/interface.moc:107
#20 0xb6c61efd in QMetaObject::metacall (object=0x81ed0e8, cl=QMetaObject::InvokeMetaMethod, idx=91, argv=0xbf910ad8) at kernel/qmetaobject.cpp:237
#21 0xb6c70fe8 in QMetaObject::activate (sender=0x8296380, m=0xb34012a0, local_signal_index=3, argv=0xbf910ad8) at kernel/qobject.cpp:3295
#22 0xb33d4c25 in ResultScene::matchCountChanged (this=0x8296380, _t1=1) at /usr/src/debug/kdebase-workspace-4.4.4/build/krunner/resultscene.moc:143
#23 0xb33e6fea in ResultScene::setQueryMatches (this=0x8296380, m=...) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/interfaces/default/resultscene.cpp:203
#24 0xb33e8063 in ResultScene::qt_metacall (this=0x8296380, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf910c88) at /usr/src/debug/kdebase-workspace-4.4.4/build/krunner/resultscene.moc:101
#25 0xb6c61efd in QMetaObject::metacall (object=0x8296380, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbf910c88) at kernel/qmetaobject.cpp:237
#26 0xb6c70fe8 in QMetaObject::activate (sender=0x8111c88, m=0xb53908e4, local_signal_index=0, argv=0xbf910c88) at kernel/qobject.cpp:3295
#27 0xb5249bd5 in Plasma::RunnerManager::matchesChanged (this=0x8111c88, _t1=...) at /usr/src/debug/kdelibs-4.4.4/build/plasma/runnermanager.moc:118
#28 0xb524c8bb in matchesChanged (this=0x8111c88, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbf910dec) at /usr/src/debug/kdelibs-4.4.4/plasma/runnermanager.cpp:90
#29 Plasma::RunnerManager::qt_metacall (this=0x8111c88, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbf910dec) at /usr/src/debug/kdelibs-4.4.4/build/plasma/runnermanager.moc:104
#30 0xb6c61efd in QMetaObject::metacall (object=0x8111c88, cl=QMetaObject::InvokeMetaMethod, idx=13, argv=0xbf910dec) at kernel/qmetaobject.cpp:237
#31 0xb6c70fe8 in QMetaObject::activate (sender=0x8111ddc, m=0xb6d785a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#32 0xb6cbda35 in QTimer::timeout (this=0x8111ddc) at .moc/release-shared/moc_qtimer.cpp:134
#33 0xb6c768e6 in QTimer::timerEvent (this=0x8111ddc, e=0xbf911320) at kernel/qtimer.cpp:271
#34 0xb6c6e774 in QObject::event (this=0x8111ddc, e=0xbf911320) at kernel/qobject.cpp:1212
#35 0xb6195c64 in QApplicationPrivate::notify_helper (this=0x80a2058, receiver=0x8111ddc, e=0xbf911320) at kernel/qapplication.cpp:4302
#36 0xb619dbf7 in QApplication::notify (this=0x809f8f8, receiver=0x8111ddc, e=0xbf911320) at kernel/qapplication.cpp:3706
#37 0xb6e9f9d1 in KApplication::notify (this=0x809f8f8, receiver=0x8111ddc, event=0xbf911320) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#38 0xb6c5be0e in QCoreApplication::notifyInternal (this=0x809f8f8, receiver=0x8111ddc, event=0xbf911320) at kernel/qcoreapplication.cpp:726
#39 0xb6c8a70e in sendEvent (this=0x80a5134) at kernel/qcoreapplication.h:215
#40 QTimerInfoList::activateTimers (this=0x80a5134) at kernel/qeventdispatcher_unix.cpp:618
#41 0xb6c87675 in timerSourceDispatch (source=0x80a5168) at kernel/qeventdispatcher_glib.cpp:184
#42 idleTimerSourceDispatch (source=0x80a5168) at kernel/qeventdispatcher_glib.cpp:231
#43 0xb58deb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#44 0xb58df350 in ?? () from /usr/lib/libglib-2.0.so.0
#45 0xb58df60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#46 0xb6c87d4b in QEventDispatcherGlib::processEvents (this=0x805ee10, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#47 0xb624619a in QGuiEventDispatcherGlib::processEvents (this=0x805ee10, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0xb6c5b11d in QEventLoop::processEvents (this=0xbf9115e4, flags=...) at kernel/qeventloop.cpp:149
#49 0xb6c5b319 in QEventLoop::exec (this=0xbf9115e4, flags=...) at kernel/qeventloop.cpp:201
#50 0xb6c5fc70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#51 0xb6193164 in QApplication::exec () at kernel/qapplication.cpp:3581
#52 0xb33e619d in kdemain (argc=1, argv=0x8096340) at /usr/src/debug/kdebase-workspace-4.4.4/krunner/main.cpp:65
#53 0x0804e5b1 in _start ()

Possible duplicates by query: bug 248414, bug 243835, bug 241531.

Reported using DrKonqi
Comment 1 Nicolas L. 2010-08-20 18:47:31 UTC

*** This bug has been marked as a duplicate of bug 241531 ***